Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Riena » error in an example on live.eclipse.org
error in an example on live.eclipse.org [message #27251] Tue, 30 June 2009 09:31 Go to next message
hans-georg Mising name is currently offline hans-georg Mising name
Messages: 79
Registered: July 2009
Member
I watched the following video/webinar: http://live.eclipse.org/node/612
When I try it under eclipse 3.5, I get on the client side the following
error:

********************
osgi> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
{org.osgi.service.log.LogReaderService,
org.eclipse.equinox.log.ExtendedLogReaderService}={service.i d=40} ServiceEvent
REGISTERED
Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
{org.osgi.service.log.LogService,
org.eclipse.equinox.log.ExtendedLogService}={service.id=42} ServiceEvent
REGISTERED
Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher]
org.eclipse.riena.internal.core.StartupsSafeRunnable Startup:
'org.eclipse.equinox.log' succesful.
Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
FrameworkEvent INFO
Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
FrameworkEvent INFO
Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
BundleEvent STARTED
Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
BundleEvent STARTED
Tue Jun 30 15:28:38 CEST 2009 INFO [DeferredLoggingForwarder]
org.eclipse.riena.internal.core.Activator DeferredLogEvent on Tue Jun 30
15:28:38 CEST 2009 (1246368518150 ms) in thread [Start Level Event
Dispatcher]:
LogLevel(INFO), Message(No stage information set.)
Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
BundleEvent STARTED
Tue Jun 30 15:28:38 CEST 2009 INFO [Start Level Event Dispatcher] null
{org.eclipse.riena.communication.core.IRemoteServiceRegistry }={service.ranking=-100,
service.id=43} ServiceEvent REGISTERED
Tue Jun 30 15:28:38 CEST 2009 INFO [Start Level Event Dispatcher]
org.eclipse.riena.internal.communication.core.ssl.SSLConfigu ration No
configuration given!.
Tue Jun 30 15:28:38 CEST 2009 INFO [Start Level Event Dispatcher] null
{org.eclipse.riena.communication.core.progressmonitor.IRemot eProgressMonitorRegistry}={service.id=44}
ServiceEvent REGISTERED
Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
BundleEvent STARTED
Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
BundleEvent STARTED
Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
BundleEvent STARTED
Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
BundleEvent STARTED
Tue Jun 30 15:28:38 CEST 2009 INFO [Start Level Event Dispatcher]
org.eclipse.riena.communication.core.factory.RemoteServiceFa ctory found
protocol [hessian]
org.eclipse.riena.internal.communication.factory.hessian.Rem oteServiceFactoryHessian @8a4916
Tue Jun 30 15:28:38 CEST 2009 INFO [Start Level Event Dispatcher] null
{org.abram.common.ICustomerService}={service.url=http://localhost:8080/hessian/CusotmerWS,
service.protocol=hessian, service.id=45} ServiceEvent REGISTERED
Tue Jun 30 15:28:38 CEST 2009 DEBUG [Start Level Event Dispatcher]
org.eclipse.riena.internal.communication.core.registry.Remot eServiceRegistry
OSGi NEW service registered id: org.abram.common.ICustomerService
Tue Jun 30 15:28:38 CEST 2009 INFO [Start Level Event Dispatcher] null
{org.abram.common.ICustomerService}={service.url=http://localhost:8080/hessian/CusotmerWS,
service.protocol=hessian, service.id=45} ServiceEvent UNREGISTERING
Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
BundleEvent STOPPED
Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
BundleEvent STARTED
Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
BundleEvent STARTED
Tue Jun 30 15:28:38 CEST 2009 ERROR [Framework Event Dispatcher] null
FrameworkEvent ERROR
org.osgi.framework.BundleException: Exception in
org.abram.client.Activator.start() of bundle org.abram.client.
**************************

please test the example on http://live.eclipse.org/node/612, because this
is very important to understand what riena is.
Re: error in an example on live.eclipse.org [message #27290 is a reply to message #27251] Tue, 30 June 2009 10:03 Go to previous messageGo to next message
Eclipse User
Originally posted by: ekkehard.gentz-software.de

hans-georg,
how does your installation look like ?

Eclipse 3.5 as IDE
Riena SDK 1.1.0 and Riena Examples 1.1. as Target Platform ?
Equinox SDK and RCP SDK should also be there
(or another way described here
http://ekkescorner.wordpress.com/2009/06/29/galileo-howto-de fine-a-simple-target-platform/
)
or you follow the wiki getting started
http://wiki.eclipse.org/Riena_Getting_started

please give some informations

ekke
hans-georg schrieb:
> I watched the following video/webinar: http://live.eclipse.org/node/612
> When I try it under eclipse 3.5, I get on the client side the following
> error:
>
> ********************
> osgi> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher]
> null {org.osgi.service.log.LogReaderService,
> org.eclipse.equinox.log.ExtendedLogReaderService}={service.i d=40}
> ServiceEvent REGISTERED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> {org.osgi.service.log.LogService,
> org.eclipse.equinox.log.ExtendedLogService}={service.id=42} ServiceEvent
> REGISTERED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher]
> org.eclipse.riena.internal.core.StartupsSafeRunnable Startup:
> 'org.eclipse.equinox.log' succesful.
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> FrameworkEvent INFO
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> FrameworkEvent INFO
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> BundleEvent STARTED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> BundleEvent STARTED
> Tue Jun 30 15:28:38 CEST 2009 INFO [DeferredLoggingForwarder]
> org.eclipse.riena.internal.core.Activator DeferredLogEvent on Tue Jun 30
> 15:28:38 CEST 2009 (1246368518150 ms) in thread [Start Level Event
> Dispatcher]:
> LogLevel(INFO), Message(No stage information set.)
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> BundleEvent STARTED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Start Level Event Dispatcher] null
> {org.eclipse.riena.communication.core.IRemoteServiceRegistry }={service.ranking=-100,
> service.id=43} ServiceEvent REGISTERED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Start Level Event Dispatcher]
> org.eclipse.riena.internal.communication.core.ssl.SSLConfigu ration No
> configuration given!.
> Tue Jun 30 15:28:38 CEST 2009 INFO [Start Level Event Dispatcher] null
> {org.eclipse.riena.communication.core.progressmonitor.IRemot eProgressMonitorRegistry}={service.id=44}
> ServiceEvent REGISTERED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> BundleEvent STARTED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> BundleEvent STARTED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> BundleEvent STARTED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> BundleEvent STARTED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Start Level Event Dispatcher]
> org.eclipse.riena.communication.core.factory.RemoteServiceFa ctory found
> protocol [hessian]
> org.eclipse.riena.internal.communication.factory.hessian.Rem oteServiceFactoryHessian @8a4916
>
> Tue Jun 30 15:28:38 CEST 2009 INFO [Start Level Event Dispatcher] null
> {org.abram.common.ICustomerService}={service.url=http://localhost:8080/hessian/CusotmerWS,
> service.protocol=hessian, service.id=45} ServiceEvent REGISTERED
> Tue Jun 30 15:28:38 CEST 2009 DEBUG [Start Level Event Dispatcher]
> org.eclipse.riena.internal.communication.core.registry.Remot eServiceRegistry
> OSGi NEW service registered id: org.abram.common.ICustomerService
> Tue Jun 30 15:28:38 CEST 2009 INFO [Start Level Event Dispatcher] null
> {org.abram.common.ICustomerService}={service.url=http://localhost:8080/hessian/CusotmerWS,
> service.protocol=hessian, service.id=45} ServiceEvent UNREGISTERING
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> BundleEvent STOPPED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> BundleEvent STARTED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> BundleEvent STARTED
> Tue Jun 30 15:28:38 CEST 2009 ERROR [Framework Event Dispatcher] null
> FrameworkEvent ERROR
> org.osgi.framework.BundleException: Exception in
> org.abram.client.Activator.start() of bundle org.abram.client.
> **************************
>
> please test the example on http://live.eclipse.org/node/612, because
> this is very important to understand what riena is.
>
Re: error in an example on live.eclipse.org [message #27324 is a reply to message #27290] Tue, 30 June 2009 10:15 Go to previous messageGo to next message
hans-georg Mising name is currently offline hans-georg Mising name
Messages: 79
Registered: July 2009
Member
I createt my own target plattform in this way
- I downloades eclipse 3.5
- I downloaded riena-1.1.0-platform-win32.win32.x86.zip
from this two files I made a new targetplattform

I work with Mac OSX 10.5

In the example, the server is running very good. No problems.
Re: error in an example on live.eclipse.org [message #27349 is a reply to message #27324] Tue, 30 June 2009 14:47 Go to previous messageGo to next message
Christian Campo is currently offline Christian Campo
Messages: 590
Registered: July 2009
Senior Member
hans-georg schrieb:
> I createt my own target plattform in this way
> - I downloades eclipse 3.5
> - I downloaded riena-1.1.0-platform-win32.win32.x86.zip
> from this two files I made a new targetplattform
>
> I work with Mac OSX 10.5
>
> In the example, the server is running very good. No problems.
>
You seem to have a typo in the URL. You specify http://localhost:8080/hessian/CusotmerWS while the correct one is
http://localhost:8080/hessian/CustomerWS

maybe that helps.....

if it doesnt we need to see the exception that happens here:
org.osgi.framework.BundleException: Exception in org.abram.client.Activator.start() of bundle org.abram.client.

write some code to catch the exception and write it to the console with stacktrace....

christian
Re: error in an example on live.eclipse.org [message #27764 is a reply to message #27349] Tue, 30 June 2009 16:06 Go to previous messageGo to next message
Eclipse User
Originally posted by: ekkehard.gentz-software.de

Christian Campo schrieb:
> hans-georg schrieb:
>> I createt my own target plattform in this way
>> - I downloades eclipse 3.5
>> - I downloaded riena-1.1.0-platform-win32.win32.x86.zip
>> from this two files I made a new targetplattform
>>
>> I work with Mac OSX 10.5
>>
>> In the example, the server is running very good. No problems.
>>
> You seem to have a typo in the URL. You specify
> http://localhost:8080/hessian/CusotmerWS while the correct one is
> http://localhost:8080/hessian/CustomerWS
>
Christian,

seems your eyes are better then mine ;-)

I looked at the stacktrace and didn't notice this

ekke
Re: error in an example on live.eclipse.org [message #27808 is a reply to message #27764] Wed, 01 July 2009 06:00 Go to previous messageGo to next message
Christian Campo is currently offline Christian Campo
Messages: 590
Registered: July 2009
Senior Member
ekke schrieb:
> Christian Campo schrieb:
>> hans-georg schrieb:
>>> I createt my own target plattform in this way
>>> - I downloades eclipse 3.5
>>> - I downloaded riena-1.1.0-platform-win32.win32.x86.zip
>>> from this two files I made a new targetplattform
>>>
>>> I work with Mac OSX 10.5
>>>
>>> In the example, the server is running very good. No problems.
>>>
>> You seem to have a typo in the URL. You specify
>> http://localhost:8080/hessian/CusotmerWS while the correct one is
>> http://localhost:8080/hessian/CustomerWS
>>
> Christian,
>
> seems your eyes are better then mine ;-)
>
> I looked at the stacktrace and didn't notice this
>
> ekke
thats really the only trick I can. Find typos on a large screen of characters in milliseconds.....

christian
Thanks [message #27848 is a reply to message #27808] Wed, 01 July 2009 07:54 Go to previous message
hans-georg Mising name is currently offline hans-georg Mising name
Messages: 79
Registered: July 2009
Member
Thanks, now it's working
Re: error in an example on live.eclipse.org [message #582951 is a reply to message #27251] Tue, 30 June 2009 10:03 Go to previous message
Eclipse User
Originally posted by: ekkehard.gentz-software.de

hans-georg,
how does your installation look like ?

Eclipse 3.5 as IDE
Riena SDK 1.1.0 and Riena Examples 1.1. as Target Platform ?
Equinox SDK and RCP SDK should also be there
(or another way described here
http://ekkescorner.wordpress.com/2009/06/29/galileo-howto-de fine-a-simple-target-platform/
)
or you follow the wiki getting started
http://wiki.eclipse.org/Riena_Getting_started

please give some informations

ekke
hans-georg schrieb:
> I watched the following video/webinar: http://live.eclipse.org/node/612
> When I try it under eclipse 3.5, I get on the client side the following
> error:
>
> ********************
> osgi> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher]
> null {org.osgi.service.log.LogReaderService,
> org.eclipse.equinox.log.ExtendedLogReaderService}={service.i d=40}
> ServiceEvent REGISTERED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> {org.osgi.service.log.LogService,
> org.eclipse.equinox.log.ExtendedLogService}={service.id=42} ServiceEvent
> REGISTERED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher]
> org.eclipse.riena.internal.core.StartupsSafeRunnable Startup:
> 'org.eclipse.equinox.log' succesful.
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> FrameworkEvent INFO
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> FrameworkEvent INFO
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> BundleEvent STARTED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> BundleEvent STARTED
> Tue Jun 30 15:28:38 CEST 2009 INFO [DeferredLoggingForwarder]
> org.eclipse.riena.internal.core.Activator DeferredLogEvent on Tue Jun 30
> 15:28:38 CEST 2009 (1246368518150 ms) in thread [Start Level Event
> Dispatcher]:
> LogLevel(INFO), Message(No stage information set.)
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> BundleEvent STARTED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Start Level Event Dispatcher] null
> {org.eclipse.riena.communication.core.IRemoteServiceRegistry }={service.ranking=-100,
> service.id=43} ServiceEvent REGISTERED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Start Level Event Dispatcher]
> org.eclipse.riena.internal.communication.core.ssl.SSLConfigu ration No
> configuration given!.
> Tue Jun 30 15:28:38 CEST 2009 INFO [Start Level Event Dispatcher] null
> {org.eclipse.riena.communication.core.progressmonitor.IRemot eProgressMonitorRegistry}={service.id=44}
> ServiceEvent REGISTERED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> BundleEvent STARTED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> BundleEvent STARTED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> BundleEvent STARTED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> BundleEvent STARTED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Start Level Event Dispatcher]
> org.eclipse.riena.communication.core.factory.RemoteServiceFa ctory found
> protocol [hessian]
> org.eclipse.riena.internal.communication.factory.hessian.Rem oteServiceFactoryHessian @8a4916
>
> Tue Jun 30 15:28:38 CEST 2009 INFO [Start Level Event Dispatcher] null
> {org.abram.common.ICustomerService}={service.url=http://localhost:8080/hessian/CusotmerWS,
> service.protocol=hessian, service.id=45} ServiceEvent REGISTERED
> Tue Jun 30 15:28:38 CEST 2009 DEBUG [Start Level Event Dispatcher]
> org.eclipse.riena.internal.communication.core.registry.Remot eServiceRegistry
> OSGi NEW service registered id: org.abram.common.ICustomerService
> Tue Jun 30 15:28:38 CEST 2009 INFO [Start Level Event Dispatcher] null
> {org.abram.common.ICustomerService}={service.url=http://localhost:8080/hessian/CusotmerWS,
> service.protocol=hessian, service.id=45} ServiceEvent UNREGISTERING
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> BundleEvent STOPPED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> BundleEvent STARTED
> Tue Jun 30 15:28:38 CEST 2009 INFO [Framework Event Dispatcher] null
> BundleEvent STARTED
> Tue Jun 30 15:28:38 CEST 2009 ERROR [Framework Event Dispatcher] null
> FrameworkEvent ERROR
> org.osgi.framework.BundleException: Exception in
> org.abram.client.Activator.start() of bundle org.abram.client.
> **************************
>
> please test the example on http://live.eclipse.org/node/612, because
> this is very important to understand what riena is.
>
Re: error in an example on live.eclipse.org [message #582959 is a reply to message #27290] Tue, 30 June 2009 10:15 Go to previous message
hans-georg Mising name is currently offline hans-georg Mising name
Messages: 79
Registered: July 2009
Member
I createt my own target plattform in this way
- I downloades eclipse 3.5
- I downloaded riena-1.1.0-platform-win32.win32.x86.zip
from this two files I made a new targetplattform

I work with Mac OSX 10.5

In the example, the server is running very good. No problems.
Re: error in an example on live.eclipse.org [message #582971 is a reply to message #27324] Tue, 30 June 2009 14:47 Go to previous message
Christian Campo is currently offline Christian Campo
Messages: 590
Registered: July 2009
Senior Member
hans-georg schrieb:
> I createt my own target plattform in this way
> - I downloades eclipse 3.5
> - I downloaded riena-1.1.0-platform-win32.win32.x86.zip
> from this two files I made a new targetplattform
>
> I work with Mac OSX 10.5
>
> In the example, the server is running very good. No problems.
>
You seem to have a typo in the URL. You specify http://localhost:8080/hessian/CusotmerWS while the correct one is
http://localhost:8080/hessian/CustomerWS

maybe that helps.....

if it doesnt we need to see the exception that happens here:
org.osgi.framework.BundleException: Exception in org.abram.client.Activator.start() of bundle org.abram.client.

write some code to catch the exception and write it to the console with stacktrace....

christian
Re: error in an example on live.eclipse.org [message #582988 is a reply to message #27349] Tue, 30 June 2009 16:06 Go to previous message
Eclipse User
Originally posted by: ekkehard.gentz-software.de

Christian Campo schrieb:
> hans-georg schrieb:
>> I createt my own target plattform in this way
>> - I downloades eclipse 3.5
>> - I downloaded riena-1.1.0-platform-win32.win32.x86.zip
>> from this two files I made a new targetplattform
>>
>> I work with Mac OSX 10.5
>>
>> In the example, the server is running very good. No problems.
>>
> You seem to have a typo in the URL. You specify
> http://localhost:8080/hessian/CusotmerWS while the correct one is
> http://localhost:8080/hessian/CustomerWS
>
Christian,

seems your eyes are better then mine ;-)

I looked at the stacktrace and didn't notice this

ekke
Re: error in an example on live.eclipse.org [message #583004 is a reply to message #27764] Wed, 01 July 2009 06:00 Go to previous message
Christian Campo is currently offline Christian Campo
Messages: 590
Registered: July 2009
Senior Member
ekke schrieb:
> Christian Campo schrieb:
>> hans-georg schrieb:
>>> I createt my own target plattform in this way
>>> - I downloades eclipse 3.5
>>> - I downloaded riena-1.1.0-platform-win32.win32.x86.zip
>>> from this two files I made a new targetplattform
>>>
>>> I work with Mac OSX 10.5
>>>
>>> In the example, the server is running very good. No problems.
>>>
>> You seem to have a typo in the URL. You specify
>> http://localhost:8080/hessian/CusotmerWS while the correct one is
>> http://localhost:8080/hessian/CustomerWS
>>
> Christian,
>
> seems your eyes are better then mine ;-)
>
> I looked at the stacktrace and didn't notice this
>
> ekke
thats really the only trick I can. Find typos on a large screen of characters in milliseconds.....

christian
Thanks [message #583011 is a reply to message #27808] Wed, 01 July 2009 07:54 Go to previous message
hans-georg Mising name is currently offline hans-georg Mising name
Messages: 79
Registered: July 2009
Member
Thanks, now it's working
Previous Topic:error in an example on live.eclipse.org
Next Topic:Where to see the apis provided by Riena?
Goto Forum:
  


Current Time: Fri Jul 25 01:27:15 EDT 2014

Powered by FUDForum. Page generated in 0.16255 seconds