Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IMP » Build lpgparser in org.eclipse.imp.lpg.runtime failed
Build lpgparser in org.eclipse.imp.lpg.runtime failed [message #27127] Tue, 10 March 2009 13:12 Go to next message
Defert Philippe is currently offline Defert Philippe
Messages: 62
Registered: July 2009
Member
Hello,

I have install the lastest version of IMP with lpg.runtime 2.0.16 on
eclipse ganymede SR2
The build (incremental or full) of lpgParser in
org.eclipse.imp.lpg.runtime failed in LPGKWLexer due his depencies

i try to build it in commandline. The result is :

lpg-win32_x86.exe -include-directory='.
;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse/plu gins/lpg.generator_2
..0.16/templates/java/;/C:/Downloads/eclipse-jee-ganymede-SR 2-win32/eclipse/plugi
ns/lpg.generator_2.0.16/include/java/' LPGParser.g

Options in effect for LPGKWLexer.gi:

ACTION-BLOCK=("","/.","./")

AST-DIRECTORY="" AST-TYPE="Ast" NOATTRIBUTES NOAUTOMATIC-AST
NOBACKTRACK

BYTE CONFLICTS DAT-DIRECTORY="" DAT-FILE="LPGKWLexerdcl.data"
DCL-FILE="LPGKWLexerdcl.xml" NODEBUG DEF-FILE="LPGKWLexerdef.xml"
NOEDIT
NOERROR-MAPS ESCAPE='%' EXPORT-TERMINALS=("LPGParsersym.xml","","")
EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGKWLexer" NOFIRST
NOFOLLOW NOGLR NOGOTO-DEFAULT GRM-FILE="LPGKWLexer.gi"
IMP-FILE="LPGKWLexerimp.xml"

INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
/plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
-SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
LALR=1 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
PACKAGE="org.eclipse.imp.lpg.parser" NOPARENT-SAVE
NOPARSETABLE-INTERFACES

PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
PRS-FILE="LPGKWLexerprs.xml"
NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
NOSHIFT-DEFAULT SINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
SUFFIX=""
SYM-FILE="LPGKWLexersym.xml" TAB-FILE="LPGKWLexer.t" NOTABLE
TEMPLATE="KeywordTemplateF.gi" TRACE=CONFLICTS NOVARIABLES NOVERBOSE
NOVISITOR VISITOR-TYPE="Visitor" WARNINGS NOXREF

LPGKWLexer.gi:0:0:0:0:0:0: Error: The template file KeywordTemplateF.gi
could no
t be read.
LPGKWLexer.gi:12:5:12:28:358:381: Error: The include file
KWLexerFoldedCaseMapF.
gi could not be read.

Options in effect for LPGLexer.gi:

ACTION-BLOCK=("","/.","./")

AST-DIRECTORY="" AST-TYPE="Ast" NOATTRIBUTES NOAUTOMATIC-AST
NOBACKTRACK

BYTE CONFLICTS DAT-DIRECTORY="" DAT-FILE="LPGLexerdcl.data"
DCL-FILE="LPGLexerdcl.xml" NODEBUG DEF-FILE="LPGLexerdef.xml" NOEDIT
NOERROR-MAPS ESCAPE='%' EXPORT-TERMINALS=("LPGParsersym.xml","","")
EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGLexer"
FILTER="LPGKWLexer.gi" NOFIRST NOFOLLOW NOGLR NOGOTO-DEFAULT
GRM-FILE="LPGLexer.gi" IMP-FILE="LPGLexerimp.xml"

INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
/plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
-SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
LALR=15 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
PACKAGE="org.eclipse.imp.lpg.parser" NOPARENT-SAVE
NOPARSETABLE-INTERFACES

PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
PRS-FILE="LPGLexerprs.xml"
NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
NOSHIFT-DEFAULT SINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
SUFFIX=""
SYM-FILE="LPGLexersym.xml" TAB-FILE="LPGLexer.t" NOTABLE
TEMPLATE="LexerTemplateF.gi" TRACE=CONFLICTS NOVARIABLES NOVERBOSE
NOVISITOR VISITOR-TYPE="Visitor" WARNINGS NOXREF


Options in effect for LPGParser.g:

ACTION-BLOCK=("","/.","./")

AST-DIRECTORY="" AST-TYPE="ASTNode" NOATTRIBUTES AUTOMATIC-AST=NESTED
NOBACKTRACK BYTE CONFLICTS DAT-DIRECTORY=""
DAT-FILE="LPGParserdcl.data"

DCL-FILE="LPGParserdcl.xml" NODEBUG DEF-FILE="LPGParserdef.xml"
NOEDIT
NOERROR-MAPS ESCAPE='%' EXPORT-TERMINALS=("LPGParserexp.xml","","")
EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGParser" NOFIRST
NOFOLLOW NOGLR NOGOTO-DEFAULT GRM-FILE="LPGParser.g"
IMP-FILE="LPGParserimp.xml" IMPORT-TERMINALS="LPGLexer.gi"

INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
/plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
-SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
LALR=6 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
PACKAGE="org.eclipse.imp.lpg.parser" PARENT-SAVED
NOPARSETABLE-INTERFACES
PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
PRS-FILE="LPGParserprs.xml"
NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
NOSHIFT-DEFAULT NOSINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
SUFFIX=""
SYM-FILE="LPGParsersym.xml" TAB-FILE="LPGParser.t" NOTABLE
TEMPLATE="dtParserTemplateF.gi" TRACE=CONFLICTS VARIABLES NOVERBOSE
VISITOR=PREORDER VISITOR-TYPE="Visitor" WARNINGS NOXREF



the size of lpg-win32_X86.exe is 1224 Ko
My include directory is the default param.

Thanks

Philippe
Re: Build lpgparser in org.eclipse.imp.lpg.runtime failed [message #27168 is a reply to message #27127] Tue, 10 March 2009 13:20 Go to previous messageGo to next message
Defert Philippe is currently offline Defert Philippe
Messages: 62
Registered: July 2009
Member
hi,

I download the latest lpg runtime from his project website
(lpg-win32_x86-2_0_16.exe) and the lpg command line version is : Version
2.0.15 (Feb 3 2009).

it may be a start point ?

Philippe

Defert Philippe a écrit :
> Hello,
>
> I have install the lastest version of IMP with lpg.runtime 2.0.16 on
> eclipse ganymede SR2
> The build (incremental or full) of lpgParser in
> org.eclipse.imp.lpg.runtime failed in LPGKWLexer due his depencies
>
> i try to build it in commandline. The result is :
>
> lpg-win32_x86.exe -include-directory='.
> ;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse/plu gins/lpg.generator_2
> .0.16/templates/java/;/C:/Downloads/eclipse-jee-ganymede-SR2 -win32/eclipse/plugi
> ns/lpg.generator_2.0.16/include/java/' LPGParser.g
>
> Options in effect for LPGKWLexer.gi:
>
> ACTION-BLOCK=("","/.","./")
>
> AST-DIRECTORY="" AST-TYPE="Ast" NOATTRIBUTES NOAUTOMATIC-AST
> NOBACKTRACK
>
> BYTE CONFLICTS DAT-DIRECTORY="" DAT-FILE="LPGKWLexerdcl.data"
> DCL-FILE="LPGKWLexerdcl.xml" NODEBUG DEF-FILE="LPGKWLexerdef.xml"
> NOEDIT
> NOERROR-MAPS ESCAPE='%' EXPORT-TERMINALS=("LPGParsersym.xml","","")
> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGKWLexer" NOFIRST
> NOFOLLOW NOGLR NOGOTO-DEFAULT GRM-FILE="LPGKWLexer.gi"
> IMP-FILE="LPGKWLexerimp.xml"
>
> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
> LALR=1 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
> PACKAGE="org.eclipse.imp.lpg.parser" NOPARENT-SAVE
> NOPARSETABLE-INTERFACES
>
> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
> PRS-FILE="LPGKWLexerprs.xml"
> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
> NOSHIFT-DEFAULT SINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
> SUFFIX=""
> SYM-FILE="LPGKWLexersym.xml" TAB-FILE="LPGKWLexer.t" NOTABLE
> TEMPLATE="KeywordTemplateF.gi" TRACE=CONFLICTS NOVARIABLES NOVERBOSE
> NOVISITOR VISITOR-TYPE="Visitor" WARNINGS NOXREF
>
> LPGKWLexer.gi:0:0:0:0:0:0: Error: The template file KeywordTemplateF.gi
> could no
> t be read.
> LPGKWLexer.gi:12:5:12:28:358:381: Error: The include file
> KWLexerFoldedCaseMapF.
> gi could not be read.
>
> Options in effect for LPGLexer.gi:
>
> ACTION-BLOCK=("","/.","./")
>
> AST-DIRECTORY="" AST-TYPE="Ast" NOATTRIBUTES NOAUTOMATIC-AST
> NOBACKTRACK
>
> BYTE CONFLICTS DAT-DIRECTORY="" DAT-FILE="LPGLexerdcl.data"
> DCL-FILE="LPGLexerdcl.xml" NODEBUG DEF-FILE="LPGLexerdef.xml" NOEDIT
> NOERROR-MAPS ESCAPE='%' EXPORT-TERMINALS=("LPGParsersym.xml","","")
> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGLexer"
> FILTER="LPGKWLexer.gi" NOFIRST NOFOLLOW NOGLR NOGOTO-DEFAULT
> GRM-FILE="LPGLexer.gi" IMP-FILE="LPGLexerimp.xml"
>
> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
> LALR=15 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
> PACKAGE="org.eclipse.imp.lpg.parser" NOPARENT-SAVE
> NOPARSETABLE-INTERFACES
>
> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
> PRS-FILE="LPGLexerprs.xml"
> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
> NOSHIFT-DEFAULT SINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
> SUFFIX=""
> SYM-FILE="LPGLexersym.xml" TAB-FILE="LPGLexer.t" NOTABLE
> TEMPLATE="LexerTemplateF.gi" TRACE=CONFLICTS NOVARIABLES NOVERBOSE
> NOVISITOR VISITOR-TYPE="Visitor" WARNINGS NOXREF
>
>
> Options in effect for LPGParser.g:
>
> ACTION-BLOCK=("","/.","./")
>
> AST-DIRECTORY="" AST-TYPE="ASTNode" NOATTRIBUTES AUTOMATIC-AST=NESTED
> NOBACKTRACK BYTE CONFLICTS DAT-DIRECTORY=""
> DAT-FILE="LPGParserdcl.data"
>
> DCL-FILE="LPGParserdcl.xml" NODEBUG DEF-FILE="LPGParserdef.xml"
> NOEDIT
> NOERROR-MAPS ESCAPE='%' EXPORT-TERMINALS=("LPGParserexp.xml","","")
> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGParser" NOFIRST
> NOFOLLOW NOGLR NOGOTO-DEFAULT GRM-FILE="LPGParser.g"
> IMP-FILE="LPGParserimp.xml" IMPORT-TERMINALS="LPGLexer.gi"
>
> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
> LALR=6 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
> PACKAGE="org.eclipse.imp.lpg.parser" PARENT-SAVED
> NOPARSETABLE-INTERFACES
> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
> PRS-FILE="LPGParserprs.xml"
> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
> NOSHIFT-DEFAULT NOSINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
> SUFFIX=""
> SYM-FILE="LPGParsersym.xml" TAB-FILE="LPGParser.t" NOTABLE
> TEMPLATE="dtParserTemplateF.gi" TRACE=CONFLICTS VARIABLES NOVERBOSE
> VISITOR=PREORDER VISITOR-TYPE="Visitor" WARNINGS NOXREF
>
>
>
> the size of lpg-win32_X86.exe is 1224 Ko
> My include directory is the default param.
>
> Thanks
>
> Philippe
>
Re: Build lpgparser in org.eclipse.imp.lpg.runtime failed [message #27206 is a reply to message #27168] Tue, 10 March 2009 22:40 Go to previous messageGo to next message
Jin Missing name is currently offline Jin Missing name
Messages: 100
Registered: July 2009
Senior Member
right, command line version is 2.0.15 (Feb 3 2009). Because the lpg
generator run in "external tools". command line or running in eclipse are
very much the same, if the settings are the same. How about your error log?

"Defert Philippe" <defert@bayesia.com>
??????:gp67hn$7hn$1@build.eclipse.org...
> hi,
>
> I download the latest lpg runtime from his project website
> (lpg-win32_x86-2_0_16.exe) and the lpg command line version is : Version
> 2.0.15 (Feb 3 2009).
>
> it may be a start point ?
>
> Philippe
>
> Defert Philippe a
Re: Build lpgparser in org.eclipse.imp.lpg.runtime failed [message #27245 is a reply to message #27206] Wed, 11 March 2009 05:18 Go to previous messageGo to next message
Defert Philippe is currently offline Defert Philippe
Messages: 62
Registered: July 2009
Member
I have no error in eclipse in errorLog, the problem seems to come in lpg
runtime.

Eclipse shows 2 problems in lpg code;
The include file KWLexerFoldedCaseMapF.gi could not be read. LPGKWLexer.gi
The template file KeywordTemplateF.gi could not be read. LPGKWLexer.gi

Philippe

jin.phd@gmail.com a écrit :
> right, command line version is 2.0.15 (Feb 3 2009). Because the lpg
> generator run in "external tools". command line or running in eclipse are
> very much the same, if the settings are the same. How about your error log?
>
> "Defert Philippe" <defert@bayesia.com>
> ??????:gp67hn$7hn$1@build.eclipse.org...
>> hi,
>>
>> I download the latest lpg runtime from his project website
>> (lpg-win32_x86-2_0_16.exe) and the lpg command line version is : Version
>> 2.0.15 (Feb 3 2009).
>>
>> it may be a start point ?
>>
>> Philippe
>>
>> Defert Philippe a écrit :
>>> Hello,
>>>
>>> I have install the lastest version of IMP with lpg.runtime 2.0.16 on
>>> eclipse ganymede SR2
>>> The build (incremental or full) of lpgParser in
>>> org.eclipse.imp.lpg.runtime failed in LPGKWLexer due his depencies
>>>
>>> i try to build it in commandline. The result is :
>>>
>>> lpg-win32_x86.exe -include-directory='.
>>> ;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse/plu gins/lpg.generator_2
>>> .0.16/templates/java/;/C:/Downloads/eclipse-jee-ganymede-SR2 -win32/eclipse/plugi
>>> ns/lpg.generator_2.0.16/include/java/' LPGParser.g
>>>
>>> Options in effect for LPGKWLexer.gi:
>>>
>>> ACTION-BLOCK=("","/.","./")
>>>
>>> AST-DIRECTORY="" AST-TYPE="Ast" NOATTRIBUTES NOAUTOMATIC-AST
>>> NOBACKTRACK
>>>
>>> BYTE CONFLICTS DAT-DIRECTORY="" DAT-FILE="LPGKWLexerdcl.data"
>>> DCL-FILE="LPGKWLexerdcl.xml" NODEBUG DEF-FILE="LPGKWLexerdef.xml"
>>> NOEDIT
>>> NOERROR-MAPS ESCAPE='%' EXPORT-TERMINALS=("LPGParsersym.xml","","")
>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGKWLexer" NOFIRST
>>> NOFOLLOW NOGLR NOGOTO-DEFAULT GRM-FILE="LPGKWLexer.gi"
>>> IMP-FILE="LPGKWLexerimp.xml"
>>>
>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>> LALR=1 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>> PACKAGE="org.eclipse.imp.lpg.parser" NOPARENT-SAVE
>>> NOPARSETABLE-INTERFACES
>>>
>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>> PRS-FILE="LPGKWLexerprs.xml"
>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>> NOSHIFT-DEFAULT SINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>> SUFFIX=""
>>> SYM-FILE="LPGKWLexersym.xml" TAB-FILE="LPGKWLexer.t" NOTABLE
>>> TEMPLATE="KeywordTemplateF.gi" TRACE=CONFLICTS NOVARIABLES
>>> NOVERBOSE
>>> NOVISITOR VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>
>>> LPGKWLexer.gi:0:0:0:0:0:0: Error: The template file KeywordTemplateF.gi
>>> could no
>>> t be read.
>>> LPGKWLexer.gi:12:5:12:28:358:381: Error: The include file
>>> KWLexerFoldedCaseMapF.
>>> gi could not be read.
>>>
>>> Options in effect for LPGLexer.gi:
>>>
>>> ACTION-BLOCK=("","/.","./")
>>>
>>> AST-DIRECTORY="" AST-TYPE="Ast" NOATTRIBUTES NOAUTOMATIC-AST
>>> NOBACKTRACK
>>>
>>> BYTE CONFLICTS DAT-DIRECTORY="" DAT-FILE="LPGLexerdcl.data"
>>> DCL-FILE="LPGLexerdcl.xml" NODEBUG DEF-FILE="LPGLexerdef.xml"
>>> NOEDIT
>>> NOERROR-MAPS ESCAPE='%' EXPORT-TERMINALS=("LPGParsersym.xml","","")
>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGLexer"
>>> FILTER="LPGKWLexer.gi" NOFIRST NOFOLLOW NOGLR NOGOTO-DEFAULT
>>> GRM-FILE="LPGLexer.gi" IMP-FILE="LPGLexerimp.xml"
>>>
>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>> LALR=15 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>> PACKAGE="org.eclipse.imp.lpg.parser" NOPARENT-SAVE
>>> NOPARSETABLE-INTERFACES
>>>
>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>> PRS-FILE="LPGLexerprs.xml"
>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>> NOSHIFT-DEFAULT SINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>> SUFFIX=""
>>> SYM-FILE="LPGLexersym.xml" TAB-FILE="LPGLexer.t" NOTABLE
>>> TEMPLATE="LexerTemplateF.gi" TRACE=CONFLICTS NOVARIABLES NOVERBOSE
>>> NOVISITOR VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>
>>>
>>> Options in effect for LPGParser.g:
>>>
>>> ACTION-BLOCK=("","/.","./")
>>>
>>> AST-DIRECTORY="" AST-TYPE="ASTNode" NOATTRIBUTES
>>> AUTOMATIC-AST=NESTED
>>> NOBACKTRACK BYTE CONFLICTS DAT-DIRECTORY=""
>>> DAT-FILE="LPGParserdcl.data"
>>>
>>> DCL-FILE="LPGParserdcl.xml" NODEBUG DEF-FILE="LPGParserdef.xml"
>>> NOEDIT
>>> NOERROR-MAPS ESCAPE='%' EXPORT-TERMINALS=("LPGParserexp.xml","","")
>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGParser" NOFIRST
>>> NOFOLLOW NOGLR NOGOTO-DEFAULT GRM-FILE="LPGParser.g"
>>> IMP-FILE="LPGParserimp.xml" IMPORT-TERMINALS="LPGLexer.gi"
>>>
>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>> LALR=6 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>> PACKAGE="org.eclipse.imp.lpg.parser" PARENT-SAVED
>>> NOPARSETABLE-INTERFACES
>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>> PRS-FILE="LPGParserprs.xml"
>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>> NOSHIFT-DEFAULT NOSINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>> SUFFIX=""
>>> SYM-FILE="LPGParsersym.xml" TAB-FILE="LPGParser.t" NOTABLE
>>> TEMPLATE="dtParserTemplateF.gi" TRACE=CONFLICTS VARIABLES
>>> NOVERBOSE
>>> VISITOR=PREORDER VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>
>>>
>>>
>>> the size of lpg-win32_X86.exe is 1224 Ko
>>> My include directory is the default param.
>>>
>>> Thanks
>>>
>>> Philippe
>>>
>
>
Re: Build lpgparser in org.eclipse.imp.lpg.runtime failed [message #27281 is a reply to message #27245] Thu, 12 March 2009 10:12 Go to previous messageGo to next message
Jin Missing name is currently offline Jin Missing name
Messages: 100
Registered: July 2009
Senior Member
The files as mentioned works for me. it is possible that the lpg editor can
not provide the outline for some grammar files(maybe due to uncompleted
parsing), but should read them successfully. so your problem seems odd...)

"Defert Philippe" <defert@bayesia.com>
??????:gp7vkf$jqi$1@build.eclipse.org...
>I have no error in eclipse in errorLog, the problem seems to come in lpg
> runtime.
>
> Eclipse shows 2 problems in lpg code;
> The include file KWLexerFoldedCaseMapF.gi could not be read. LPGKWLexer.gi
> The template file KeywordTemplateF.gi could not be read. LPGKWLexer.gi
>
> Philippe
>
> jin.phd@gmail.com a
Re: Build lpgparser in org.eclipse.imp.lpg.runtime failed [message #27317 is a reply to message #27281] Thu, 12 March 2009 13:01 Go to previous messageGo to next message
Defert Philippe is currently offline Defert Philippe
Messages: 62
Registered: July 2009
Member
it doesn't work for me,
if i delete "lpgparser.java" and rebuild "lpgparser.g"
the errors were generated and lpgparser.java wasn't generated and there
occurs many errors in eclipse

can you send me your lpg's includepath from your lpg's preference.
mine is :
..;..;${pluginResource:lpg.generator/templates/java};${plugi nResource:lpg.generator/include/java}

Philippe

jin.phd@gmail.com a écrit :
> The files as mentioned works for me. it is possible that the lpg editor can
> not provide the outline for some grammar files(maybe due to uncompleted
> parsing), but should read them successfully. so your problem seems odd...)
>
> "Defert Philippe" <defert@bayesia.com>
> ??????:gp7vkf$jqi$1@build.eclipse.org...
>> I have no error in eclipse in errorLog, the problem seems to come in lpg
>> runtime.
>>
>> Eclipse shows 2 problems in lpg code;
>> The include file KWLexerFoldedCaseMapF.gi could not be read. LPGKWLexer.gi
>> The template file KeywordTemplateF.gi could not be read. LPGKWLexer.gi
>>
>> Philippe
>>
>> jin.phd@gmail.com a écrit :
>>> right, command line version is 2.0.15 (Feb 3 2009). Because the lpg
>>> generator run in "external tools". command line or running in eclipse are
>>> very much the same, if the settings are the same. How about your error
>>> log?
>>>
>>> "Defert Philippe" <defert@bayesia.com>
>>> ??????:gp67hn$7hn$1@build.eclipse.org...
>>>> hi,
>>>>
>>>> I download the latest lpg runtime from his project website
>>>> (lpg-win32_x86-2_0_16.exe) and the lpg command line version is : Version
>>>> 2.0.15 (Feb 3 2009).
>>>>
>>>> it may be a start point ?
>>>>
>>>> Philippe
>>>>
>>>> Defert Philippe a écrit :
>>>>> Hello,
>>>>>
>>>>> I have install the lastest version of IMP with lpg.runtime 2.0.16 on
>>>>> eclipse ganymede SR2
>>>>> The build (incremental or full) of lpgParser in
>>>>> org.eclipse.imp.lpg.runtime failed in LPGKWLexer due his depencies
>>>>>
>>>>> i try to build it in commandline. The result is :
>>>>>
>>>>> lpg-win32_x86.exe -include-directory='.
>>>>> ;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse/plu gins/lpg.generator_2
>>>>> .0.16/templates/java/;/C:/Downloads/eclipse-jee-ganymede-SR2 -win32/eclipse/plugi
>>>>> ns/lpg.generator_2.0.16/include/java/' LPGParser.g
>>>>>
>>>>> Options in effect for LPGKWLexer.gi:
>>>>>
>>>>> ACTION-BLOCK=("","/.","./")
>>>>>
>>>>> AST-DIRECTORY="" AST-TYPE="Ast" NOATTRIBUTES NOAUTOMATIC-AST
>>>>> NOBACKTRACK
>>>>>
>>>>> BYTE CONFLICTS DAT-DIRECTORY="" DAT-FILE="LPGKWLexerdcl.data"
>>>>> DCL-FILE="LPGKWLexerdcl.xml" NODEBUG DEF-FILE="LPGKWLexerdef.xml"
>>>>> NOEDIT
>>>>> NOERROR-MAPS ESCAPE='%'
>>>>> EXPORT-TERMINALS=("LPGParsersym.xml","","")
>>>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGKWLexer"
>>>>> NOFIRST
>>>>> NOFOLLOW NOGLR NOGOTO-DEFAULT GRM-FILE="LPGKWLexer.gi"
>>>>> IMP-FILE="LPGKWLexerimp.xml"
>>>>>
>>>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>>>> LALR=1 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>>>> PACKAGE="org.eclipse.imp.lpg.parser" NOPARENT-SAVE
>>>>> NOPARSETABLE-INTERFACES
>>>>>
>>>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>>>> PRS-FILE="LPGKWLexerprs.xml"
>>>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>>>> NOSHIFT-DEFAULT SINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>>>> SUFFIX=""
>>>>> SYM-FILE="LPGKWLexersym.xml" TAB-FILE="LPGKWLexer.t" NOTABLE
>>>>> TEMPLATE="KeywordTemplateF.gi" TRACE=CONFLICTS NOVARIABLES
>>>>> NOVERBOSE
>>>>> NOVISITOR VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>>>
>>>>> LPGKWLexer.gi:0:0:0:0:0:0: Error: The template file KeywordTemplateF.gi
>>>>> could no
>>>>> t be read.
>>>>> LPGKWLexer.gi:12:5:12:28:358:381: Error: The include file
>>>>> KWLexerFoldedCaseMapF.
>>>>> gi could not be read.
>>>>>
>>>>> Options in effect for LPGLexer.gi:
>>>>>
>>>>> ACTION-BLOCK=("","/.","./")
>>>>>
>>>>> AST-DIRECTORY="" AST-TYPE="Ast" NOATTRIBUTES NOAUTOMATIC-AST
>>>>> NOBACKTRACK
>>>>>
>>>>> BYTE CONFLICTS DAT-DIRECTORY="" DAT-FILE="LPGLexerdcl.data"
>>>>> DCL-FILE="LPGLexerdcl.xml" NODEBUG DEF-FILE="LPGLexerdef.xml"
>>>>> NOEDIT
>>>>> NOERROR-MAPS ESCAPE='%'
>>>>> EXPORT-TERMINALS=("LPGParsersym.xml","","")
>>>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGLexer"
>>>>> FILTER="LPGKWLexer.gi" NOFIRST NOFOLLOW NOGLR NOGOTO-DEFAULT
>>>>> GRM-FILE="LPGLexer.gi" IMP-FILE="LPGLexerimp.xml"
>>>>>
>>>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>>>> LALR=15 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>>>> PACKAGE="org.eclipse.imp.lpg.parser" NOPARENT-SAVE
>>>>> NOPARSETABLE-INTERFACES
>>>>>
>>>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>>>> PRS-FILE="LPGLexerprs.xml"
>>>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>>>> NOSHIFT-DEFAULT SINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>>>> SUFFIX=""
>>>>> SYM-FILE="LPGLexersym.xml" TAB-FILE="LPGLexer.t" NOTABLE
>>>>> TEMPLATE="LexerTemplateF.gi" TRACE=CONFLICTS NOVARIABLES
>>>>> NOVERBOSE
>>>>> NOVISITOR VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>>>
>>>>>
>>>>> Options in effect for LPGParser.g:
>>>>>
>>>>> ACTION-BLOCK=("","/.","./")
>>>>>
>>>>> AST-DIRECTORY="" AST-TYPE="ASTNode" NOATTRIBUTES
>>>>> AUTOMATIC-AST=NESTED
>>>>> NOBACKTRACK BYTE CONFLICTS DAT-DIRECTORY=""
>>>>> DAT-FILE="LPGParserdcl.data"
>>>>>
>>>>> DCL-FILE="LPGParserdcl.xml" NODEBUG DEF-FILE="LPGParserdef.xml"
>>>>> NOEDIT
>>>>> NOERROR-MAPS ESCAPE='%'
>>>>> EXPORT-TERMINALS=("LPGParserexp.xml","","")
>>>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGParser"
>>>>> NOFIRST
>>>>> NOFOLLOW NOGLR NOGOTO-DEFAULT GRM-FILE="LPGParser.g"
>>>>> IMP-FILE="LPGParserimp.xml" IMPORT-TERMINALS="LPGLexer.gi"
>>>>>
>>>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>>>> LALR=6 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>>>> PACKAGE="org.eclipse.imp.lpg.parser" PARENT-SAVED
>>>>> NOPARSETABLE-INTERFACES
>>>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>>>> PRS-FILE="LPGParserprs.xml"
>>>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>>>> NOSHIFT-DEFAULT NOSINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>>>> SUFFIX=""
>>>>> SYM-FILE="LPGParsersym.xml" TAB-FILE="LPGParser.t" NOTABLE
>>>>> TEMPLATE="dtParserTemplateF.gi" TRACE=CONFLICTS VARIABLES
>>>>> NOVERBOSE
>>>>> VISITOR=PREORDER VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>>>
>>>>>
>>>>>
>>>>> the size of lpg-win32_X86.exe is 1224 Ko
>>>>> My include directory is the default param.
>>>>>
>>>>> Thanks
>>>>>
>>>>> Philippe
>>>>>
>>>
>
>
Re:[BUG] Build lpgparser in org.eclipse.imp.lpg.runtime failed [message #27741 is a reply to message #27317] Fri, 13 March 2009 06:05 Go to previous messageGo to next message
Defert Philippe is currently offline Defert Philippe
Messages: 62
Registered: July 2009
Member
Hi,

I searched and i found :-)

i'm under windows system and eclipse is under java.

the default generated includepath is in java syntax , the folder
separator is '/' but the lpg generator is win32 program and understand
only win32 folder separator AKA '\'

The FIX for win32 is switch java filepath syntax to win32 filepath
syntax of includepath before calling lpggenerator
or something like that

Philippe

Defert Philippe a écrit :
> it doesn't work for me,
> if i delete "lpgparser.java" and rebuild "lpgparser.g"
> the errors were generated and lpgparser.java wasn't generated and there
> occurs many errors in eclipse
>
> can you send me your lpg's includepath from your lpg's preference.
> mine is :
> .;..;${pluginResource:lpg.generator/templates/java};${plugin Resource:lpg.generator/include/java}
>
> Philippe
>
> jin.phd@gmail.com a écrit :
>> The files as mentioned works for me. it is possible that the lpg editor can
>> not provide the outline for some grammar files(maybe due to uncompleted
>> parsing), but should read them successfully. so your problem seems odd...)
>>
>> "Defert Philippe" <defert@bayesia.com>
>> ??????:gp7vkf$jqi$1@build.eclipse.org...
>>> I have no error in eclipse in errorLog, the problem seems to come in lpg
>>> runtime.
>>>
>>> Eclipse shows 2 problems in lpg code;
>>> The include file KWLexerFoldedCaseMapF.gi could not be read. LPGKWLexer.gi
>>> The template file KeywordTemplateF.gi could not be read. LPGKWLexer.gi
>>>
>>> Philippe
>>>
>>> jin.phd@gmail.com a écrit :
>>>> right, command line version is 2.0.15 (Feb 3 2009). Because the lpg
>>>> generator run in "external tools". command line or running in eclipse are
>>>> very much the same, if the settings are the same. How about your error
>>>> log?
>>>>
>>>> "Defert Philippe" <defert@bayesia.com>
>>>> ??????:gp67hn$7hn$1@build.eclipse.org...
>>>>> hi,
>>>>>
>>>>> I download the latest lpg runtime from his project website
>>>>> (lpg-win32_x86-2_0_16.exe) and the lpg command line version is : Version
>>>>> 2.0.15 (Feb 3 2009).
>>>>>
>>>>> it may be a start point ?
>>>>>
>>>>> Philippe
>>>>>
>>>>> Defert Philippe a écrit :
>>>>>> Hello,
>>>>>>
>>>>>> I have install the lastest version of IMP with lpg.runtime 2.0.16 on
>>>>>> eclipse ganymede SR2
>>>>>> The build (incremental or full) of lpgParser in
>>>>>> org.eclipse.imp.lpg.runtime failed in LPGKWLexer due his depencies
>>>>>>
>>>>>> i try to build it in commandline. The result is :
>>>>>>
>>>>>> lpg-win32_x86.exe -include-directory='.
>>>>>> ;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse/plu gins/lpg.generator_2
>>>>>> .0.16/templates/java/;/C:/Downloads/eclipse-jee-ganymede-SR2 -win32/eclipse/plugi
>>>>>> ns/lpg.generator_2.0.16/include/java/' LPGParser.g
>>>>>>
>>>>>> Options in effect for LPGKWLexer.gi:
>>>>>>
>>>>>> ACTION-BLOCK=("","/.","./")
>>>>>>
>>>>>> AST-DIRECTORY="" AST-TYPE="Ast" NOATTRIBUTES NOAUTOMATIC-AST
>>>>>> NOBACKTRACK
>>>>>>
>>>>>> BYTE CONFLICTS DAT-DIRECTORY="" DAT-FILE="LPGKWLexerdcl.data"
>>>>>> DCL-FILE="LPGKWLexerdcl.xml" NODEBUG DEF-FILE="LPGKWLexerdef.xml"
>>>>>> NOEDIT
>>>>>> NOERROR-MAPS ESCAPE='%'
>>>>>> EXPORT-TERMINALS=("LPGParsersym.xml","","")
>>>>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGKWLexer"
>>>>>> NOFIRST
>>>>>> NOFOLLOW NOGLR NOGOTO-DEFAULT GRM-FILE="LPGKWLexer.gi"
>>>>>> IMP-FILE="LPGKWLexerimp.xml"
>>>>>>
>>>>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>>>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>>>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>>>>> LALR=1 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>>>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>>>>> PACKAGE="org.eclipse.imp.lpg.parser" NOPARENT-SAVE
>>>>>> NOPARSETABLE-INTERFACES
>>>>>>
>>>>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>>>>> PRS-FILE="LPGKWLexerprs.xml"
>>>>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>>>>> NOSHIFT-DEFAULT SINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>>>>> SUFFIX=""
>>>>>> SYM-FILE="LPGKWLexersym.xml" TAB-FILE="LPGKWLexer.t" NOTABLE
>>>>>> TEMPLATE="KeywordTemplateF.gi" TRACE=CONFLICTS NOVARIABLES
>>>>>> NOVERBOSE
>>>>>> NOVISITOR VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>>>>
>>>>>> LPGKWLexer.gi:0:0:0:0:0:0: Error: The template file KeywordTemplateF.gi
>>>>>> could no
>>>>>> t be read.
>>>>>> LPGKWLexer.gi:12:5:12:28:358:381: Error: The include file
>>>>>> KWLexerFoldedCaseMapF.
>>>>>> gi could not be read.
>>>>>>
>>>>>> Options in effect for LPGLexer.gi:
>>>>>>
>>>>>> ACTION-BLOCK=("","/.","./")
>>>>>>
>>>>>> AST-DIRECTORY="" AST-TYPE="Ast" NOATTRIBUTES NOAUTOMATIC-AST
>>>>>> NOBACKTRACK
>>>>>>
>>>>>> BYTE CONFLICTS DAT-DIRECTORY="" DAT-FILE="LPGLexerdcl.data"
>>>>>> DCL-FILE="LPGLexerdcl.xml" NODEBUG DEF-FILE="LPGLexerdef.xml"
>>>>>> NOEDIT
>>>>>> NOERROR-MAPS ESCAPE='%'
>>>>>> EXPORT-TERMINALS=("LPGParsersym.xml","","")
>>>>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGLexer"
>>>>>> FILTER="LPGKWLexer.gi" NOFIRST NOFOLLOW NOGLR NOGOTO-DEFAULT
>>>>>> GRM-FILE="LPGLexer.gi" IMP-FILE="LPGLexerimp.xml"
>>>>>>
>>>>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>>>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>>>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>>>>> LALR=15 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>>>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>>>>> PACKAGE="org.eclipse.imp.lpg.parser" NOPARENT-SAVE
>>>>>> NOPARSETABLE-INTERFACES
>>>>>>
>>>>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>>>>> PRS-FILE="LPGLexerprs.xml"
>>>>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>>>>> NOSHIFT-DEFAULT SINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>>>>> SUFFIX=""
>>>>>> SYM-FILE="LPGLexersym.xml" TAB-FILE="LPGLexer.t" NOTABLE
>>>>>> TEMPLATE="LexerTemplateF.gi" TRACE=CONFLICTS NOVARIABLES
>>>>>> NOVERBOSE
>>>>>> NOVISITOR VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>>>>
>>>>>>
>>>>>> Options in effect for LPGParser.g:
>>>>>>
>>>>>> ACTION-BLOCK=("","/.","./")
>>>>>>
>>>>>> AST-DIRECTORY="" AST-TYPE="ASTNode" NOATTRIBUTES
>>>>>> AUTOMATIC-AST=NESTED
>>>>>> NOBACKTRACK BYTE CONFLICTS DAT-DIRECTORY=""
>>>>>> DAT-FILE="LPGParserdcl.data"
>>>>>>
>>>>>> DCL-FILE="LPGParserdcl.xml" NODEBUG DEF-FILE="LPGParserdef.xml"
>>>>>> NOEDIT
>>>>>> NOERROR-MAPS ESCAPE='%'
>>>>>> EXPORT-TERMINALS=("LPGParserexp.xml","","")
>>>>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGParser"
>>>>>> NOFIRST
>>>>>> NOFOLLOW NOGLR NOGOTO-DEFAULT GRM-FILE="LPGParser.g"
>>>>>> IMP-FILE="LPGParserimp.xml" IMPORT-TERMINALS="LPGLexer.gi"
>>>>>>
>>>>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>>>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>>>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>>>>> LALR=6 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>>>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>>>>> PACKAGE="org.eclipse.imp.lpg.parser" PARENT-SAVED
>>>>>> NOPARSETABLE-INTERFACES
>>>>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>>>>> PRS-FILE="LPGParserprs.xml"
>>>>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>>>>> NOSHIFT-DEFAULT NOSINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>>>>> SUFFIX=""
>>>>>> SYM-FILE="LPGParsersym.xml" TAB-FILE="LPGParser.t" NOTABLE
>>>>>> TEMPLATE="dtParserTemplateF.gi" TRACE=CONFLICTS VARIABLES
>>>>>> NOVERBOSE
>>>>>> VISITOR=PREORDER VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>>>>
>>>>>>
>>>>>>
>>>>>> the size of lpg-win32_X86.exe is 1224 Ko
>>>>>> My include directory is the default param.
>>>>>>
>>>>>> Thanks
>>>>>>
>>>>>> Philippe
>>>>>>
>>
Re: [BUG] Build lpgparser in org.eclipse.imp.lpg.runtime failed [message #27765 is a reply to message #27741] Fri, 13 March 2009 06:06 Go to previous messageGo to next message
Defert Philippe is currently offline Defert Philippe
Messages: 62
Registered: July 2009
Member
I 'm under winXP

Defert Philippe a écrit :
> Hi,
>
> I searched and i found :-)
>
> i'm under windows system and eclipse is under java.
>
> the default generated includepath is in java syntax , the folder
> separator is '/' but the lpg generator is win32 program and understand
> only win32 folder separator AKA '\'
>
> The FIX for win32 is switch java filepath syntax to win32 filepath
> syntax of includepath before calling lpggenerator
> or something like that
>
> Philippe
>
> Defert Philippe a écrit :
>> it doesn't work for me,
>> if i delete "lpgparser.java" and rebuild "lpgparser.g"
>> the errors were generated and lpgparser.java wasn't generated and there
>> occurs many errors in eclipse
>>
>> can you send me your lpg's includepath from your lpg's preference.
>> mine is :
>> .;..;${pluginResource:lpg.generator/templates/java};${plugin Resource:lpg.generator/include/java}
>>
>> Philippe
>>
>> jin.phd@gmail.com a écrit :
>>> The files as mentioned works for me. it is possible that the lpg editor can
>>> not provide the outline for some grammar files(maybe due to uncompleted
>>> parsing), but should read them successfully. so your problem seems odd...)
>>>
>>> "Defert Philippe" <defert@bayesia.com>
>>> ??????:gp7vkf$jqi$1@build.eclipse.org...
>>>> I have no error in eclipse in errorLog, the problem seems to come in lpg
>>>> runtime.
>>>>
>>>> Eclipse shows 2 problems in lpg code;
>>>> The include file KWLexerFoldedCaseMapF.gi could not be read. LPGKWLexer.gi
>>>> The template file KeywordTemplateF.gi could not be read. LPGKWLexer.gi
>>>>
>>>> Philippe
>>>>
>>>> jin.phd@gmail.com a écrit :
>>>>> right, command line version is 2.0.15 (Feb 3 2009). Because the lpg
>>>>> generator run in "external tools". command line or running in eclipse are
>>>>> very much the same, if the settings are the same. How about your error
>>>>> log?
>>>>>
>>>>> "Defert Philippe" <defert@bayesia.com>
>>>>> ??????:gp67hn$7hn$1@build.eclipse.org...
>>>>>> hi,
>>>>>>
>>>>>> I download the latest lpg runtime from his project website
>>>>>> (lpg-win32_x86-2_0_16.exe) and the lpg command line version is : Version
>>>>>> 2.0.15 (Feb 3 2009).
>>>>>>
>>>>>> it may be a start point ?
>>>>>>
>>>>>> Philippe
>>>>>>
>>>>>> Defert Philippe a écrit :
>>>>>>> Hello,
>>>>>>>
>>>>>>> I have install the lastest version of IMP with lpg.runtime 2.0.16 on
>>>>>>> eclipse ganymede SR2
>>>>>>> The build (incremental or full) of lpgParser in
>>>>>>> org.eclipse.imp.lpg.runtime failed in LPGKWLexer due his depencies
>>>>>>>
>>>>>>> i try to build it in commandline. The result is :
>>>>>>>
>>>>>>> lpg-win32_x86.exe -include-directory='.
>>>>>>> ;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse/plu gins/lpg.generator_2
>>>>>>> .0.16/templates/java/;/C:/Downloads/eclipse-jee-ganymede-SR2 -win32/eclipse/plugi
>>>>>>> ns/lpg.generator_2.0.16/include/java/' LPGParser.g
>>>>>>>
>>>>>>> Options in effect for LPGKWLexer.gi:
>>>>>>>
>>>>>>> ACTION-BLOCK=("","/.","./")
>>>>>>>
>>>>>>> AST-DIRECTORY="" AST-TYPE="Ast" NOATTRIBUTES NOAUTOMATIC-AST
>>>>>>> NOBACKTRACK
>>>>>>>
>>>>>>> BYTE CONFLICTS DAT-DIRECTORY="" DAT-FILE="LPGKWLexerdcl.data"
>>>>>>> DCL-FILE="LPGKWLexerdcl.xml" NODEBUG DEF-FILE="LPGKWLexerdef.xml"
>>>>>>> NOEDIT
>>>>>>> NOERROR-MAPS ESCAPE='%'
>>>>>>> EXPORT-TERMINALS=("LPGParsersym.xml","","")
>>>>>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGKWLexer"
>>>>>>> NOFIRST
>>>>>>> NOFOLLOW NOGLR NOGOTO-DEFAULT GRM-FILE="LPGKWLexer.gi"
>>>>>>> IMP-FILE="LPGKWLexerimp.xml"
>>>>>>>
>>>>>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>>>>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>>>>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>>>>>> LALR=1 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>>>>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>>>>>> PACKAGE="org.eclipse.imp.lpg.parser" NOPARENT-SAVE
>>>>>>> NOPARSETABLE-INTERFACES
>>>>>>>
>>>>>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>>>>>> PRS-FILE="LPGKWLexerprs.xml"
>>>>>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>>>>>> NOSHIFT-DEFAULT SINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>>>>>> SUFFIX=""
>>>>>>> SYM-FILE="LPGKWLexersym.xml" TAB-FILE="LPGKWLexer.t" NOTABLE
>>>>>>> TEMPLATE="KeywordTemplateF.gi" TRACE=CONFLICTS NOVARIABLES
>>>>>>> NOVERBOSE
>>>>>>> NOVISITOR VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>>>>>
>>>>>>> LPGKWLexer.gi:0:0:0:0:0:0: Error: The template file KeywordTemplateF.gi
>>>>>>> could no
>>>>>>> t be read.
>>>>>>> LPGKWLexer.gi:12:5:12:28:358:381: Error: The include file
>>>>>>> KWLexerFoldedCaseMapF.
>>>>>>> gi could not be read.
>>>>>>>
>>>>>>> Options in effect for LPGLexer.gi:
>>>>>>>
>>>>>>> ACTION-BLOCK=("","/.","./")
>>>>>>>
>>>>>>> AST-DIRECTORY="" AST-TYPE="Ast" NOATTRIBUTES NOAUTOMATIC-AST
>>>>>>> NOBACKTRACK
>>>>>>>
>>>>>>> BYTE CONFLICTS DAT-DIRECTORY="" DAT-FILE="LPGLexerdcl.data"
>>>>>>> DCL-FILE="LPGLexerdcl.xml" NODEBUG DEF-FILE="LPGLexerdef.xml"
>>>>>>> NOEDIT
>>>>>>> NOERROR-MAPS ESCAPE='%'
>>>>>>> EXPORT-TERMINALS=("LPGParsersym.xml","","")
>>>>>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGLexer"
>>>>>>> FILTER="LPGKWLexer.gi" NOFIRST NOFOLLOW NOGLR NOGOTO-DEFAULT
>>>>>>> GRM-FILE="LPGLexer.gi" IMP-FILE="LPGLexerimp.xml"
>>>>>>>
>>>>>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>>>>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>>>>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>>>>>> LALR=15 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>>>>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>>>>>> PACKAGE="org.eclipse.imp.lpg.parser" NOPARENT-SAVE
>>>>>>> NOPARSETABLE-INTERFACES
>>>>>>>
>>>>>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>>>>>> PRS-FILE="LPGLexerprs.xml"
>>>>>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>>>>>> NOSHIFT-DEFAULT SINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>>>>>> SUFFIX=""
>>>>>>> SYM-FILE="LPGLexersym.xml" TAB-FILE="LPGLexer.t" NOTABLE
>>>>>>> TEMPLATE="LexerTemplateF.gi" TRACE=CONFLICTS NOVARIABLES
>>>>>>> NOVERBOSE
>>>>>>> NOVISITOR VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>>>>>
>>>>>>>
>>>>>>> Options in effect for LPGParser.g:
>>>>>>>
>>>>>>> ACTION-BLOCK=("","/.","./")
>>>>>>>
>>>>>>> AST-DIRECTORY="" AST-TYPE="ASTNode" NOATTRIBUTES
>>>>>>> AUTOMATIC-AST=NESTED
>>>>>>> NOBACKTRACK BYTE CONFLICTS DAT-DIRECTORY=""
>>>>>>> DAT-FILE="LPGParserdcl.data"
>>>>>>>
>>>>>>> DCL-FILE="LPGParserdcl.xml" NODEBUG DEF-FILE="LPGParserdef.xml"
>>>>>>> NOEDIT
>>>>>>> NOERROR-MAPS ESCAPE='%'
>>>>>>> EXPORT-TERMINALS=("LPGParserexp.xml","","")
>>>>>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGParser"
>>>>>>> NOFIRST
>>>>>>> NOFOLLOW NOGLR NOGOTO-DEFAULT GRM-FILE="LPGParser.g"
>>>>>>> IMP-FILE="LPGParserimp.xml" IMPORT-TERMINALS="LPGLexer.gi"
>>>>>>>
>>>>>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>>>>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>>>>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>>>>>> LALR=6 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>>>>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>>>>>> PACKAGE="org.eclipse.imp.lpg.parser" PARENT-SAVED
>>>>>>> NOPARSETABLE-INTERFACES
>>>>>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>>>>>> PRS-FILE="LPGParserprs.xml"
>>>>>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>>>>>> NOSHIFT-DEFAULT NOSINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>>>>>> SUFFIX=""
>>>>>>> SYM-FILE="LPGParsersym.xml" TAB-FILE="LPGParser.t" NOTABLE
>>>>>>> TEMPLATE="dtParserTemplateF.gi" TRACE=CONFLICTS VARIABLES
>>>>>>> NOVERBOSE
>>>>>>> VISITOR=PREORDER VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> the size of lpg-win32_X86.exe is 1224 Ko
>>>>>>> My include directory is the default param.
>>>>>>>
>>>>>>> Thanks
>>>>>>>
>>>>>>> Philippe
>>>>>>>
Re: Re:[BUG] Build lpgparser in org.eclipse.imp.lpg.runtime failed [message #27804 is a reply to message #27741] Fri, 13 March 2009 11:32 Go to previous message
Jin Missing name is currently offline Jin Missing name
Messages: 100
Registered: July 2009
Senior Member
Defert, you are right! It is a bug. I first misunderstand your words. I
thoght
you were using the svn sources, and can not build the grammar files in the
sources. But I find the you are using installed imp right now. so I check
the runing imp application. I find the LPG builder can not work really. one
simple workaround is as your suggestion, we can tweak the
"perferences"->"LPG"-><right_path_here>. I open a bug[1] , and add a patch
to this bug. Another is using the patch.
The difference between "/" and "\" seem not important. as my test, "c:/aaa"
and "c:\aaa" both work for windows xp. The cruical thing is that the when
the PerferenceService convert the variable in eclipse such as
$pluginResource to "/C:/xxx/xxx", the first leading "/" makes whole things
broken.


[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=268550


"Defert Philippe" <defert@bayesia.com>
??????:gpdb59$rrs$1@build.eclipse.org...
> Hi,
>
> I searched and i found :-)
>
> i'm under windows system and eclipse is under java.
>
> the default generated includepath is in java syntax , the folder
> separator is '/' but the lpg generator is win32 program and understand
> only win32 folder separator AKA '\'
>
> The FIX for win32 is switch java filepath syntax to win32 filepath
> syntax of includepath before calling lpggenerator
> or something like that
>
> Philippe
>
> Defert Philippe a
Re: Build lpgparser in org.eclipse.imp.lpg.runtime failed [message #575219 is a reply to message #27127] Tue, 10 March 2009 13:20 Go to previous message
Defert Philippe is currently offline Defert Philippe
Messages: 62
Registered: July 2009
Member
hi,

I download the latest lpg runtime from his project website
(lpg-win32_x86-2_0_16.exe) and the lpg command line version is : Version
2.0.15 (Feb 3 2009).

it may be a start point ?

Philippe

Defert Philippe a écrit :
> Hello,
>
> I have install the lastest version of IMP with lpg.runtime 2.0.16 on
> eclipse ganymede SR2
> The build (incremental or full) of lpgParser in
> org.eclipse.imp.lpg.runtime failed in LPGKWLexer due his depencies
>
> i try to build it in commandline. The result is :
>
> lpg-win32_x86.exe -include-directory='.
> ;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse/plu gins/lpg.generator_2
> .0.16/templates/java/;/C:/Downloads/eclipse-jee-ganymede-SR2 -win32/eclipse/plugi
> ns/lpg.generator_2.0.16/include/java/' LPGParser.g
>
> Options in effect for LPGKWLexer.gi:
>
> ACTION-BLOCK=("","/.","./")
>
> AST-DIRECTORY="" AST-TYPE="Ast" NOATTRIBUTES NOAUTOMATIC-AST
> NOBACKTRACK
>
> BYTE CONFLICTS DAT-DIRECTORY="" DAT-FILE="LPGKWLexerdcl.data"
> DCL-FILE="LPGKWLexerdcl.xml" NODEBUG DEF-FILE="LPGKWLexerdef.xml"
> NOEDIT
> NOERROR-MAPS ESCAPE='%' EXPORT-TERMINALS=("LPGParsersym.xml","","")
> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGKWLexer" NOFIRST
> NOFOLLOW NOGLR NOGOTO-DEFAULT GRM-FILE="LPGKWLexer.gi"
> IMP-FILE="LPGKWLexerimp.xml"
>
> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
> LALR=1 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
> PACKAGE="org.eclipse.imp.lpg.parser" NOPARENT-SAVE
> NOPARSETABLE-INTERFACES
>
> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
> PRS-FILE="LPGKWLexerprs.xml"
> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
> NOSHIFT-DEFAULT SINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
> SUFFIX=""
> SYM-FILE="LPGKWLexersym.xml" TAB-FILE="LPGKWLexer.t" NOTABLE
> TEMPLATE="KeywordTemplateF.gi" TRACE=CONFLICTS NOVARIABLES NOVERBOSE
> NOVISITOR VISITOR-TYPE="Visitor" WARNINGS NOXREF
>
> LPGKWLexer.gi:0:0:0:0:0:0: Error: The template file KeywordTemplateF.gi
> could no
> t be read.
> LPGKWLexer.gi:12:5:12:28:358:381: Error: The include file
> KWLexerFoldedCaseMapF.
> gi could not be read.
>
> Options in effect for LPGLexer.gi:
>
> ACTION-BLOCK=("","/.","./")
>
> AST-DIRECTORY="" AST-TYPE="Ast" NOATTRIBUTES NOAUTOMATIC-AST
> NOBACKTRACK
>
> BYTE CONFLICTS DAT-DIRECTORY="" DAT-FILE="LPGLexerdcl.data"
> DCL-FILE="LPGLexerdcl.xml" NODEBUG DEF-FILE="LPGLexerdef.xml" NOEDIT
> NOERROR-MAPS ESCAPE='%' EXPORT-TERMINALS=("LPGParsersym.xml","","")
> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGLexer"
> FILTER="LPGKWLexer.gi" NOFIRST NOFOLLOW NOGLR NOGOTO-DEFAULT
> GRM-FILE="LPGLexer.gi" IMP-FILE="LPGLexerimp.xml"
>
> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
> LALR=15 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
> PACKAGE="org.eclipse.imp.lpg.parser" NOPARENT-SAVE
> NOPARSETABLE-INTERFACES
>
> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
> PRS-FILE="LPGLexerprs.xml"
> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
> NOSHIFT-DEFAULT SINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
> SUFFIX=""
> SYM-FILE="LPGLexersym.xml" TAB-FILE="LPGLexer.t" NOTABLE
> TEMPLATE="LexerTemplateF.gi" TRACE=CONFLICTS NOVARIABLES NOVERBOSE
> NOVISITOR VISITOR-TYPE="Visitor" WARNINGS NOXREF
>
>
> Options in effect for LPGParser.g:
>
> ACTION-BLOCK=("","/.","./")
>
> AST-DIRECTORY="" AST-TYPE="ASTNode" NOATTRIBUTES AUTOMATIC-AST=NESTED
> NOBACKTRACK BYTE CONFLICTS DAT-DIRECTORY=""
> DAT-FILE="LPGParserdcl.data"
>
> DCL-FILE="LPGParserdcl.xml" NODEBUG DEF-FILE="LPGParserdef.xml"
> NOEDIT
> NOERROR-MAPS ESCAPE='%' EXPORT-TERMINALS=("LPGParserexp.xml","","")
> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGParser" NOFIRST
> NOFOLLOW NOGLR NOGOTO-DEFAULT GRM-FILE="LPGParser.g"
> IMP-FILE="LPGParserimp.xml" IMPORT-TERMINALS="LPGLexer.gi"
>
> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
> LALR=6 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
> PACKAGE="org.eclipse.imp.lpg.parser" PARENT-SAVED
> NOPARSETABLE-INTERFACES
> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
> PRS-FILE="LPGParserprs.xml"
> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
> NOSHIFT-DEFAULT NOSINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
> SUFFIX=""
> SYM-FILE="LPGParsersym.xml" TAB-FILE="LPGParser.t" NOTABLE
> TEMPLATE="dtParserTemplateF.gi" TRACE=CONFLICTS VARIABLES NOVERBOSE
> VISITOR=PREORDER VISITOR-TYPE="Visitor" WARNINGS NOXREF
>
>
>
> the size of lpg-win32_X86.exe is 1224 Ko
> My include directory is the default param.
>
> Thanks
>
> Philippe
>
Re: Build lpgparser in org.eclipse.imp.lpg.runtime failed [message #575249 is a reply to message #27168] Tue, 10 March 2009 22:40 Go to previous message
Jin Missing name is currently offline Jin Missing name
Messages: 100
Registered: July 2009
Senior Member
right, command line version is 2.0.15 (Feb 3 2009). Because the lpg
generator run in "external tools". command line or running in eclipse are
very much the same, if the settings are the same. How about your error log?

"Defert Philippe" <defert@bayesia.com>
??????:gp67hn$7hn$1@build.eclipse.org...
> hi,
>
> I download the latest lpg runtime from his project website
> (lpg-win32_x86-2_0_16.exe) and the lpg command line version is : Version
> 2.0.15 (Feb 3 2009).
>
> it may be a start point ?
>
> Philippe
>
> Defert Philippe a
Re: Build lpgparser in org.eclipse.imp.lpg.runtime failed [message #575266 is a reply to message #27206] Wed, 11 March 2009 05:18 Go to previous message
Defert Philippe is currently offline Defert Philippe
Messages: 62
Registered: July 2009
Member
I have no error in eclipse in errorLog, the problem seems to come in lpg
runtime.

Eclipse shows 2 problems in lpg code;
The include file KWLexerFoldedCaseMapF.gi could not be read. LPGKWLexer.gi
The template file KeywordTemplateF.gi could not be read. LPGKWLexer.gi

Philippe

jin.phd@gmail.com a écrit :
> right, command line version is 2.0.15 (Feb 3 2009). Because the lpg
> generator run in "external tools". command line or running in eclipse are
> very much the same, if the settings are the same. How about your error log?
>
> "Defert Philippe" <defert@bayesia.com>
> ??????:gp67hn$7hn$1@build.eclipse.org...
>> hi,
>>
>> I download the latest lpg runtime from his project website
>> (lpg-win32_x86-2_0_16.exe) and the lpg command line version is : Version
>> 2.0.15 (Feb 3 2009).
>>
>> it may be a start point ?
>>
>> Philippe
>>
>> Defert Philippe a écrit :
>>> Hello,
>>>
>>> I have install the lastest version of IMP with lpg.runtime 2.0.16 on
>>> eclipse ganymede SR2
>>> The build (incremental or full) of lpgParser in
>>> org.eclipse.imp.lpg.runtime failed in LPGKWLexer due his depencies
>>>
>>> i try to build it in commandline. The result is :
>>>
>>> lpg-win32_x86.exe -include-directory='.
>>> ;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse/plu gins/lpg.generator_2
>>> .0.16/templates/java/;/C:/Downloads/eclipse-jee-ganymede-SR2 -win32/eclipse/plugi
>>> ns/lpg.generator_2.0.16/include/java/' LPGParser.g
>>>
>>> Options in effect for LPGKWLexer.gi:
>>>
>>> ACTION-BLOCK=("","/.","./")
>>>
>>> AST-DIRECTORY="" AST-TYPE="Ast" NOATTRIBUTES NOAUTOMATIC-AST
>>> NOBACKTRACK
>>>
>>> BYTE CONFLICTS DAT-DIRECTORY="" DAT-FILE="LPGKWLexerdcl.data"
>>> DCL-FILE="LPGKWLexerdcl.xml" NODEBUG DEF-FILE="LPGKWLexerdef.xml"
>>> NOEDIT
>>> NOERROR-MAPS ESCAPE='%' EXPORT-TERMINALS=("LPGParsersym.xml","","")
>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGKWLexer" NOFIRST
>>> NOFOLLOW NOGLR NOGOTO-DEFAULT GRM-FILE="LPGKWLexer.gi"
>>> IMP-FILE="LPGKWLexerimp.xml"
>>>
>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>> LALR=1 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>> PACKAGE="org.eclipse.imp.lpg.parser" NOPARENT-SAVE
>>> NOPARSETABLE-INTERFACES
>>>
>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>> PRS-FILE="LPGKWLexerprs.xml"
>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>> NOSHIFT-DEFAULT SINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>> SUFFIX=""
>>> SYM-FILE="LPGKWLexersym.xml" TAB-FILE="LPGKWLexer.t" NOTABLE
>>> TEMPLATE="KeywordTemplateF.gi" TRACE=CONFLICTS NOVARIABLES
>>> NOVERBOSE
>>> NOVISITOR VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>
>>> LPGKWLexer.gi:0:0:0:0:0:0: Error: The template file KeywordTemplateF.gi
>>> could no
>>> t be read.
>>> LPGKWLexer.gi:12:5:12:28:358:381: Error: The include file
>>> KWLexerFoldedCaseMapF.
>>> gi could not be read.
>>>
>>> Options in effect for LPGLexer.gi:
>>>
>>> ACTION-BLOCK=("","/.","./")
>>>
>>> AST-DIRECTORY="" AST-TYPE="Ast" NOATTRIBUTES NOAUTOMATIC-AST
>>> NOBACKTRACK
>>>
>>> BYTE CONFLICTS DAT-DIRECTORY="" DAT-FILE="LPGLexerdcl.data"
>>> DCL-FILE="LPGLexerdcl.xml" NODEBUG DEF-FILE="LPGLexerdef.xml"
>>> NOEDIT
>>> NOERROR-MAPS ESCAPE='%' EXPORT-TERMINALS=("LPGParsersym.xml","","")
>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGLexer"
>>> FILTER="LPGKWLexer.gi" NOFIRST NOFOLLOW NOGLR NOGOTO-DEFAULT
>>> GRM-FILE="LPGLexer.gi" IMP-FILE="LPGLexerimp.xml"
>>>
>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>> LALR=15 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>> PACKAGE="org.eclipse.imp.lpg.parser" NOPARENT-SAVE
>>> NOPARSETABLE-INTERFACES
>>>
>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>> PRS-FILE="LPGLexerprs.xml"
>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>> NOSHIFT-DEFAULT SINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>> SUFFIX=""
>>> SYM-FILE="LPGLexersym.xml" TAB-FILE="LPGLexer.t" NOTABLE
>>> TEMPLATE="LexerTemplateF.gi" TRACE=CONFLICTS NOVARIABLES NOVERBOSE
>>> NOVISITOR VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>
>>>
>>> Options in effect for LPGParser.g:
>>>
>>> ACTION-BLOCK=("","/.","./")
>>>
>>> AST-DIRECTORY="" AST-TYPE="ASTNode" NOATTRIBUTES
>>> AUTOMATIC-AST=NESTED
>>> NOBACKTRACK BYTE CONFLICTS DAT-DIRECTORY=""
>>> DAT-FILE="LPGParserdcl.data"
>>>
>>> DCL-FILE="LPGParserdcl.xml" NODEBUG DEF-FILE="LPGParserdef.xml"
>>> NOEDIT
>>> NOERROR-MAPS ESCAPE='%' EXPORT-TERMINALS=("LPGParserexp.xml","","")
>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGParser" NOFIRST
>>> NOFOLLOW NOGLR NOGOTO-DEFAULT GRM-FILE="LPGParser.g"
>>> IMP-FILE="LPGParserimp.xml" IMPORT-TERMINALS="LPGLexer.gi"
>>>
>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>> LALR=6 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>> PACKAGE="org.eclipse.imp.lpg.parser" PARENT-SAVED
>>> NOPARSETABLE-INTERFACES
>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>> PRS-FILE="LPGParserprs.xml"
>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>> NOSHIFT-DEFAULT NOSINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>> SUFFIX=""
>>> SYM-FILE="LPGParsersym.xml" TAB-FILE="LPGParser.t" NOTABLE
>>> TEMPLATE="dtParserTemplateF.gi" TRACE=CONFLICTS VARIABLES
>>> NOVERBOSE
>>> VISITOR=PREORDER VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>
>>>
>>>
>>> the size of lpg-win32_X86.exe is 1224 Ko
>>> My include directory is the default param.
>>>
>>> Thanks
>>>
>>> Philippe
>>>
>
>
Re: Build lpgparser in org.eclipse.imp.lpg.runtime failed [message #575280 is a reply to message #27245] Thu, 12 March 2009 10:12 Go to previous message
Jin Missing name is currently offline Jin Missing name
Messages: 100
Registered: July 2009
Senior Member
The files as mentioned works for me. it is possible that the lpg editor can
not provide the outline for some grammar files(maybe due to uncompleted
parsing), but should read them successfully. so your problem seems odd...)

"Defert Philippe" <defert@bayesia.com>
??????:gp7vkf$jqi$1@build.eclipse.org...
>I have no error in eclipse in errorLog, the problem seems to come in lpg
> runtime.
>
> Eclipse shows 2 problems in lpg code;
> The include file KWLexerFoldedCaseMapF.gi could not be read. LPGKWLexer.gi
> The template file KeywordTemplateF.gi could not be read. LPGKWLexer.gi
>
> Philippe
>
> jin.phd@gmail.com a
Re: Build lpgparser in org.eclipse.imp.lpg.runtime failed [message #575287 is a reply to message #27281] Thu, 12 March 2009 13:01 Go to previous message
Defert Philippe is currently offline Defert Philippe
Messages: 62
Registered: July 2009
Member
it doesn't work for me,
if i delete "lpgparser.java" and rebuild "lpgparser.g"
the errors were generated and lpgparser.java wasn't generated and there
occurs many errors in eclipse

can you send me your lpg's includepath from your lpg's preference.
mine is :
..;..;${pluginResource:lpg.generator/templates/java};${plugi nResource:lpg.generator/include/java}

Philippe

jin.phd@gmail.com a écrit :
> The files as mentioned works for me. it is possible that the lpg editor can
> not provide the outline for some grammar files(maybe due to uncompleted
> parsing), but should read them successfully. so your problem seems odd...)
>
> "Defert Philippe" <defert@bayesia.com>
> ??????:gp7vkf$jqi$1@build.eclipse.org...
>> I have no error in eclipse in errorLog, the problem seems to come in lpg
>> runtime.
>>
>> Eclipse shows 2 problems in lpg code;
>> The include file KWLexerFoldedCaseMapF.gi could not be read. LPGKWLexer.gi
>> The template file KeywordTemplateF.gi could not be read. LPGKWLexer.gi
>>
>> Philippe
>>
>> jin.phd@gmail.com a écrit :
>>> right, command line version is 2.0.15 (Feb 3 2009). Because the lpg
>>> generator run in "external tools". command line or running in eclipse are
>>> very much the same, if the settings are the same. How about your error
>>> log?
>>>
>>> "Defert Philippe" <defert@bayesia.com>
>>> ??????:gp67hn$7hn$1@build.eclipse.org...
>>>> hi,
>>>>
>>>> I download the latest lpg runtime from his project website
>>>> (lpg-win32_x86-2_0_16.exe) and the lpg command line version is : Version
>>>> 2.0.15 (Feb 3 2009).
>>>>
>>>> it may be a start point ?
>>>>
>>>> Philippe
>>>>
>>>> Defert Philippe a écrit :
>>>>> Hello,
>>>>>
>>>>> I have install the lastest version of IMP with lpg.runtime 2.0.16 on
>>>>> eclipse ganymede SR2
>>>>> The build (incremental or full) of lpgParser in
>>>>> org.eclipse.imp.lpg.runtime failed in LPGKWLexer due his depencies
>>>>>
>>>>> i try to build it in commandline. The result is :
>>>>>
>>>>> lpg-win32_x86.exe -include-directory='.
>>>>> ;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse/plu gins/lpg.generator_2
>>>>> .0.16/templates/java/;/C:/Downloads/eclipse-jee-ganymede-SR2 -win32/eclipse/plugi
>>>>> ns/lpg.generator_2.0.16/include/java/' LPGParser.g
>>>>>
>>>>> Options in effect for LPGKWLexer.gi:
>>>>>
>>>>> ACTION-BLOCK=("","/.","./")
>>>>>
>>>>> AST-DIRECTORY="" AST-TYPE="Ast" NOATTRIBUTES NOAUTOMATIC-AST
>>>>> NOBACKTRACK
>>>>>
>>>>> BYTE CONFLICTS DAT-DIRECTORY="" DAT-FILE="LPGKWLexerdcl.data"
>>>>> DCL-FILE="LPGKWLexerdcl.xml" NODEBUG DEF-FILE="LPGKWLexerdef.xml"
>>>>> NOEDIT
>>>>> NOERROR-MAPS ESCAPE='%'
>>>>> EXPORT-TERMINALS=("LPGParsersym.xml","","")
>>>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGKWLexer"
>>>>> NOFIRST
>>>>> NOFOLLOW NOGLR NOGOTO-DEFAULT GRM-FILE="LPGKWLexer.gi"
>>>>> IMP-FILE="LPGKWLexerimp.xml"
>>>>>
>>>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>>>> LALR=1 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>>>> PACKAGE="org.eclipse.imp.lpg.parser" NOPARENT-SAVE
>>>>> NOPARSETABLE-INTERFACES
>>>>>
>>>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>>>> PRS-FILE="LPGKWLexerprs.xml"
>>>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>>>> NOSHIFT-DEFAULT SINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>>>> SUFFIX=""
>>>>> SYM-FILE="LPGKWLexersym.xml" TAB-FILE="LPGKWLexer.t" NOTABLE
>>>>> TEMPLATE="KeywordTemplateF.gi" TRACE=CONFLICTS NOVARIABLES
>>>>> NOVERBOSE
>>>>> NOVISITOR VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>>>
>>>>> LPGKWLexer.gi:0:0:0:0:0:0: Error: The template file KeywordTemplateF.gi
>>>>> could no
>>>>> t be read.
>>>>> LPGKWLexer.gi:12:5:12:28:358:381: Error: The include file
>>>>> KWLexerFoldedCaseMapF.
>>>>> gi could not be read.
>>>>>
>>>>> Options in effect for LPGLexer.gi:
>>>>>
>>>>> ACTION-BLOCK=("","/.","./")
>>>>>
>>>>> AST-DIRECTORY="" AST-TYPE="Ast" NOATTRIBUTES NOAUTOMATIC-AST
>>>>> NOBACKTRACK
>>>>>
>>>>> BYTE CONFLICTS DAT-DIRECTORY="" DAT-FILE="LPGLexerdcl.data"
>>>>> DCL-FILE="LPGLexerdcl.xml" NODEBUG DEF-FILE="LPGLexerdef.xml"
>>>>> NOEDIT
>>>>> NOERROR-MAPS ESCAPE='%'
>>>>> EXPORT-TERMINALS=("LPGParsersym.xml","","")
>>>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGLexer"
>>>>> FILTER="LPGKWLexer.gi" NOFIRST NOFOLLOW NOGLR NOGOTO-DEFAULT
>>>>> GRM-FILE="LPGLexer.gi" IMP-FILE="LPGLexerimp.xml"
>>>>>
>>>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>>>> LALR=15 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>>>> PACKAGE="org.eclipse.imp.lpg.parser" NOPARENT-SAVE
>>>>> NOPARSETABLE-INTERFACES
>>>>>
>>>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>>>> PRS-FILE="LPGLexerprs.xml"
>>>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>>>> NOSHIFT-DEFAULT SINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>>>> SUFFIX=""
>>>>> SYM-FILE="LPGLexersym.xml" TAB-FILE="LPGLexer.t" NOTABLE
>>>>> TEMPLATE="LexerTemplateF.gi" TRACE=CONFLICTS NOVARIABLES
>>>>> NOVERBOSE
>>>>> NOVISITOR VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>>>
>>>>>
>>>>> Options in effect for LPGParser.g:
>>>>>
>>>>> ACTION-BLOCK=("","/.","./")
>>>>>
>>>>> AST-DIRECTORY="" AST-TYPE="ASTNode" NOATTRIBUTES
>>>>> AUTOMATIC-AST=NESTED
>>>>> NOBACKTRACK BYTE CONFLICTS DAT-DIRECTORY=""
>>>>> DAT-FILE="LPGParserdcl.data"
>>>>>
>>>>> DCL-FILE="LPGParserdcl.xml" NODEBUG DEF-FILE="LPGParserdef.xml"
>>>>> NOEDIT
>>>>> NOERROR-MAPS ESCAPE='%'
>>>>> EXPORT-TERMINALS=("LPGParserexp.xml","","")
>>>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGParser"
>>>>> NOFIRST
>>>>> NOFOLLOW NOGLR NOGOTO-DEFAULT GRM-FILE="LPGParser.g"
>>>>> IMP-FILE="LPGParserimp.xml" IMPORT-TERMINALS="LPGLexer.gi"
>>>>>
>>>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>>>> LALR=6 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>>>> PACKAGE="org.eclipse.imp.lpg.parser" PARENT-SAVED
>>>>> NOPARSETABLE-INTERFACES
>>>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>>>> PRS-FILE="LPGParserprs.xml"
>>>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>>>> NOSHIFT-DEFAULT NOSINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>>>> SUFFIX=""
>>>>> SYM-FILE="LPGParsersym.xml" TAB-FILE="LPGParser.t" NOTABLE
>>>>> TEMPLATE="dtParserTemplateF.gi" TRACE=CONFLICTS VARIABLES
>>>>> NOVERBOSE
>>>>> VISITOR=PREORDER VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>>>
>>>>>
>>>>>
>>>>> the size of lpg-win32_X86.exe is 1224 Ko
>>>>> My include directory is the default param.
>>>>>
>>>>> Thanks
>>>>>
>>>>> Philippe
>>>>>
>>>
>
>
Re:[BUG] Build lpgparser in org.eclipse.imp.lpg.runtime failed [message #575306 is a reply to message #27317] Fri, 13 March 2009 06:05 Go to previous message
Defert Philippe is currently offline Defert Philippe
Messages: 62
Registered: July 2009
Member
Hi,

I searched and i found :-)

i'm under windows system and eclipse is under java.

the default generated includepath is in java syntax , the folder
separator is '/' but the lpg generator is win32 program and understand
only win32 folder separator AKA '\'

The FIX for win32 is switch java filepath syntax to win32 filepath
syntax of includepath before calling lpggenerator
or something like that

Philippe

Defert Philippe a écrit :
> it doesn't work for me,
> if i delete "lpgparser.java" and rebuild "lpgparser.g"
> the errors were generated and lpgparser.java wasn't generated and there
> occurs many errors in eclipse
>
> can you send me your lpg's includepath from your lpg's preference.
> mine is :
> .;..;${pluginResource:lpg.generator/templates/java};${plugin Resource:lpg.generator/include/java}
>
> Philippe
>
> jin.phd@gmail.com a écrit :
>> The files as mentioned works for me. it is possible that the lpg editor can
>> not provide the outline for some grammar files(maybe due to uncompleted
>> parsing), but should read them successfully. so your problem seems odd...)
>>
>> "Defert Philippe" <defert@bayesia.com>
>> ??????:gp7vkf$jqi$1@build.eclipse.org...
>>> I have no error in eclipse in errorLog, the problem seems to come in lpg
>>> runtime.
>>>
>>> Eclipse shows 2 problems in lpg code;
>>> The include file KWLexerFoldedCaseMapF.gi could not be read. LPGKWLexer.gi
>>> The template file KeywordTemplateF.gi could not be read. LPGKWLexer.gi
>>>
>>> Philippe
>>>
>>> jin.phd@gmail.com a écrit :
>>>> right, command line version is 2.0.15 (Feb 3 2009). Because the lpg
>>>> generator run in "external tools". command line or running in eclipse are
>>>> very much the same, if the settings are the same. How about your error
>>>> log?
>>>>
>>>> "Defert Philippe" <defert@bayesia.com>
>>>> ??????:gp67hn$7hn$1@build.eclipse.org...
>>>>> hi,
>>>>>
>>>>> I download the latest lpg runtime from his project website
>>>>> (lpg-win32_x86-2_0_16.exe) and the lpg command line version is : Version
>>>>> 2.0.15 (Feb 3 2009).
>>>>>
>>>>> it may be a start point ?
>>>>>
>>>>> Philippe
>>>>>
>>>>> Defert Philippe a écrit :
>>>>>> Hello,
>>>>>>
>>>>>> I have install the lastest version of IMP with lpg.runtime 2.0.16 on
>>>>>> eclipse ganymede SR2
>>>>>> The build (incremental or full) of lpgParser in
>>>>>> org.eclipse.imp.lpg.runtime failed in LPGKWLexer due his depencies
>>>>>>
>>>>>> i try to build it in commandline. The result is :
>>>>>>
>>>>>> lpg-win32_x86.exe -include-directory='.
>>>>>> ;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse/plu gins/lpg.generator_2
>>>>>> .0.16/templates/java/;/C:/Downloads/eclipse-jee-ganymede-SR2 -win32/eclipse/plugi
>>>>>> ns/lpg.generator_2.0.16/include/java/' LPGParser.g
>>>>>>
>>>>>> Options in effect for LPGKWLexer.gi:
>>>>>>
>>>>>> ACTION-BLOCK=("","/.","./")
>>>>>>
>>>>>> AST-DIRECTORY="" AST-TYPE="Ast" NOATTRIBUTES NOAUTOMATIC-AST
>>>>>> NOBACKTRACK
>>>>>>
>>>>>> BYTE CONFLICTS DAT-DIRECTORY="" DAT-FILE="LPGKWLexerdcl.data"
>>>>>> DCL-FILE="LPGKWLexerdcl.xml" NODEBUG DEF-FILE="LPGKWLexerdef.xml"
>>>>>> NOEDIT
>>>>>> NOERROR-MAPS ESCAPE='%'
>>>>>> EXPORT-TERMINALS=("LPGParsersym.xml","","")
>>>>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGKWLexer"
>>>>>> NOFIRST
>>>>>> NOFOLLOW NOGLR NOGOTO-DEFAULT GRM-FILE="LPGKWLexer.gi"
>>>>>> IMP-FILE="LPGKWLexerimp.xml"
>>>>>>
>>>>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>>>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>>>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>>>>> LALR=1 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>>>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>>>>> PACKAGE="org.eclipse.imp.lpg.parser" NOPARENT-SAVE
>>>>>> NOPARSETABLE-INTERFACES
>>>>>>
>>>>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>>>>> PRS-FILE="LPGKWLexerprs.xml"
>>>>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>>>>> NOSHIFT-DEFAULT SINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>>>>> SUFFIX=""
>>>>>> SYM-FILE="LPGKWLexersym.xml" TAB-FILE="LPGKWLexer.t" NOTABLE
>>>>>> TEMPLATE="KeywordTemplateF.gi" TRACE=CONFLICTS NOVARIABLES
>>>>>> NOVERBOSE
>>>>>> NOVISITOR VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>>>>
>>>>>> LPGKWLexer.gi:0:0:0:0:0:0: Error: The template file KeywordTemplateF.gi
>>>>>> could no
>>>>>> t be read.
>>>>>> LPGKWLexer.gi:12:5:12:28:358:381: Error: The include file
>>>>>> KWLexerFoldedCaseMapF.
>>>>>> gi could not be read.
>>>>>>
>>>>>> Options in effect for LPGLexer.gi:
>>>>>>
>>>>>> ACTION-BLOCK=("","/.","./")
>>>>>>
>>>>>> AST-DIRECTORY="" AST-TYPE="Ast" NOATTRIBUTES NOAUTOMATIC-AST
>>>>>> NOBACKTRACK
>>>>>>
>>>>>> BYTE CONFLICTS DAT-DIRECTORY="" DAT-FILE="LPGLexerdcl.data"
>>>>>> DCL-FILE="LPGLexerdcl.xml" NODEBUG DEF-FILE="LPGLexerdef.xml"
>>>>>> NOEDIT
>>>>>> NOERROR-MAPS ESCAPE='%'
>>>>>> EXPORT-TERMINALS=("LPGParsersym.xml","","")
>>>>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGLexer"
>>>>>> FILTER="LPGKWLexer.gi" NOFIRST NOFOLLOW NOGLR NOGOTO-DEFAULT
>>>>>> GRM-FILE="LPGLexer.gi" IMP-FILE="LPGLexerimp.xml"
>>>>>>
>>>>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>>>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>>>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>>>>> LALR=15 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>>>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>>>>> PACKAGE="org.eclipse.imp.lpg.parser" NOPARENT-SAVE
>>>>>> NOPARSETABLE-INTERFACES
>>>>>>
>>>>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>>>>> PRS-FILE="LPGLexerprs.xml"
>>>>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>>>>> NOSHIFT-DEFAULT SINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>>>>> SUFFIX=""
>>>>>> SYM-FILE="LPGLexersym.xml" TAB-FILE="LPGLexer.t" NOTABLE
>>>>>> TEMPLATE="LexerTemplateF.gi" TRACE=CONFLICTS NOVARIABLES
>>>>>> NOVERBOSE
>>>>>> NOVISITOR VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>>>>
>>>>>>
>>>>>> Options in effect for LPGParser.g:
>>>>>>
>>>>>> ACTION-BLOCK=("","/.","./")
>>>>>>
>>>>>> AST-DIRECTORY="" AST-TYPE="ASTNode" NOATTRIBUTES
>>>>>> AUTOMATIC-AST=NESTED
>>>>>> NOBACKTRACK BYTE CONFLICTS DAT-DIRECTORY=""
>>>>>> DAT-FILE="LPGParserdcl.data"
>>>>>>
>>>>>> DCL-FILE="LPGParserdcl.xml" NODEBUG DEF-FILE="LPGParserdef.xml"
>>>>>> NOEDIT
>>>>>> NOERROR-MAPS ESCAPE='%'
>>>>>> EXPORT-TERMINALS=("LPGParserexp.xml","","")
>>>>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGParser"
>>>>>> NOFIRST
>>>>>> NOFOLLOW NOGLR NOGOTO-DEFAULT GRM-FILE="LPGParser.g"
>>>>>> IMP-FILE="LPGParserimp.xml" IMPORT-TERMINALS="LPGLexer.gi"
>>>>>>
>>>>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>>>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>>>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>>>>> LALR=6 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>>>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>>>>> PACKAGE="org.eclipse.imp.lpg.parser" PARENT-SAVED
>>>>>> NOPARSETABLE-INTERFACES
>>>>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>>>>> PRS-FILE="LPGParserprs.xml"
>>>>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>>>>> NOSHIFT-DEFAULT NOSINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>>>>> SUFFIX=""
>>>>>> SYM-FILE="LPGParsersym.xml" TAB-FILE="LPGParser.t" NOTABLE
>>>>>> TEMPLATE="dtParserTemplateF.gi" TRACE=CONFLICTS VARIABLES
>>>>>> NOVERBOSE
>>>>>> VISITOR=PREORDER VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>>>>
>>>>>>
>>>>>>
>>>>>> the size of lpg-win32_X86.exe is 1224 Ko
>>>>>> My include directory is the default param.
>>>>>>
>>>>>> Thanks
>>>>>>
>>>>>> Philippe
>>>>>>
>>
Re: [BUG] Build lpgparser in org.eclipse.imp.lpg.runtime failed [message #575327 is a reply to message #27741] Fri, 13 March 2009 06:06 Go to previous message
Defert Philippe is currently offline Defert Philippe
Messages: 62
Registered: July 2009
Member
I 'm under winXP

Defert Philippe a écrit :
> Hi,
>
> I searched and i found :-)
>
> i'm under windows system and eclipse is under java.
>
> the default generated includepath is in java syntax , the folder
> separator is '/' but the lpg generator is win32 program and understand
> only win32 folder separator AKA '\'
>
> The FIX for win32 is switch java filepath syntax to win32 filepath
> syntax of includepath before calling lpggenerator
> or something like that
>
> Philippe
>
> Defert Philippe a écrit :
>> it doesn't work for me,
>> if i delete "lpgparser.java" and rebuild "lpgparser.g"
>> the errors were generated and lpgparser.java wasn't generated and there
>> occurs many errors in eclipse
>>
>> can you send me your lpg's includepath from your lpg's preference.
>> mine is :
>> .;..;${pluginResource:lpg.generator/templates/java};${plugin Resource:lpg.generator/include/java}
>>
>> Philippe
>>
>> jin.phd@gmail.com a écrit :
>>> The files as mentioned works for me. it is possible that the lpg editor can
>>> not provide the outline for some grammar files(maybe due to uncompleted
>>> parsing), but should read them successfully. so your problem seems odd...)
>>>
>>> "Defert Philippe" <defert@bayesia.com>
>>> ??????:gp7vkf$jqi$1@build.eclipse.org...
>>>> I have no error in eclipse in errorLog, the problem seems to come in lpg
>>>> runtime.
>>>>
>>>> Eclipse shows 2 problems in lpg code;
>>>> The include file KWLexerFoldedCaseMapF.gi could not be read. LPGKWLexer.gi
>>>> The template file KeywordTemplateF.gi could not be read. LPGKWLexer.gi
>>>>
>>>> Philippe
>>>>
>>>> jin.phd@gmail.com a écrit :
>>>>> right, command line version is 2.0.15 (Feb 3 2009). Because the lpg
>>>>> generator run in "external tools". command line or running in eclipse are
>>>>> very much the same, if the settings are the same. How about your error
>>>>> log?
>>>>>
>>>>> "Defert Philippe" <defert@bayesia.com>
>>>>> ??????:gp67hn$7hn$1@build.eclipse.org...
>>>>>> hi,
>>>>>>
>>>>>> I download the latest lpg runtime from his project website
>>>>>> (lpg-win32_x86-2_0_16.exe) and the lpg command line version is : Version
>>>>>> 2.0.15 (Feb 3 2009).
>>>>>>
>>>>>> it may be a start point ?
>>>>>>
>>>>>> Philippe
>>>>>>
>>>>>> Defert Philippe a écrit :
>>>>>>> Hello,
>>>>>>>
>>>>>>> I have install the lastest version of IMP with lpg.runtime 2.0.16 on
>>>>>>> eclipse ganymede SR2
>>>>>>> The build (incremental or full) of lpgParser in
>>>>>>> org.eclipse.imp.lpg.runtime failed in LPGKWLexer due his depencies
>>>>>>>
>>>>>>> i try to build it in commandline. The result is :
>>>>>>>
>>>>>>> lpg-win32_x86.exe -include-directory='.
>>>>>>> ;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse/plu gins/lpg.generator_2
>>>>>>> .0.16/templates/java/;/C:/Downloads/eclipse-jee-ganymede-SR2 -win32/eclipse/plugi
>>>>>>> ns/lpg.generator_2.0.16/include/java/' LPGParser.g
>>>>>>>
>>>>>>> Options in effect for LPGKWLexer.gi:
>>>>>>>
>>>>>>> ACTION-BLOCK=("","/.","./")
>>>>>>>
>>>>>>> AST-DIRECTORY="" AST-TYPE="Ast" NOATTRIBUTES NOAUTOMATIC-AST
>>>>>>> NOBACKTRACK
>>>>>>>
>>>>>>> BYTE CONFLICTS DAT-DIRECTORY="" DAT-FILE="LPGKWLexerdcl.data"
>>>>>>> DCL-FILE="LPGKWLexerdcl.xml" NODEBUG DEF-FILE="LPGKWLexerdef.xml"
>>>>>>> NOEDIT
>>>>>>> NOERROR-MAPS ESCAPE='%'
>>>>>>> EXPORT-TERMINALS=("LPGParsersym.xml","","")
>>>>>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGKWLexer"
>>>>>>> NOFIRST
>>>>>>> NOFOLLOW NOGLR NOGOTO-DEFAULT GRM-FILE="LPGKWLexer.gi"
>>>>>>> IMP-FILE="LPGKWLexerimp.xml"
>>>>>>>
>>>>>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>>>>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>>>>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>>>>>> LALR=1 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>>>>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>>>>>> PACKAGE="org.eclipse.imp.lpg.parser" NOPARENT-SAVE
>>>>>>> NOPARSETABLE-INTERFACES
>>>>>>>
>>>>>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>>>>>> PRS-FILE="LPGKWLexerprs.xml"
>>>>>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>>>>>> NOSHIFT-DEFAULT SINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>>>>>> SUFFIX=""
>>>>>>> SYM-FILE="LPGKWLexersym.xml" TAB-FILE="LPGKWLexer.t" NOTABLE
>>>>>>> TEMPLATE="KeywordTemplateF.gi" TRACE=CONFLICTS NOVARIABLES
>>>>>>> NOVERBOSE
>>>>>>> NOVISITOR VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>>>>>
>>>>>>> LPGKWLexer.gi:0:0:0:0:0:0: Error: The template file KeywordTemplateF.gi
>>>>>>> could no
>>>>>>> t be read.
>>>>>>> LPGKWLexer.gi:12:5:12:28:358:381: Error: The include file
>>>>>>> KWLexerFoldedCaseMapF.
>>>>>>> gi could not be read.
>>>>>>>
>>>>>>> Options in effect for LPGLexer.gi:
>>>>>>>
>>>>>>> ACTION-BLOCK=("","/.","./")
>>>>>>>
>>>>>>> AST-DIRECTORY="" AST-TYPE="Ast" NOATTRIBUTES NOAUTOMATIC-AST
>>>>>>> NOBACKTRACK
>>>>>>>
>>>>>>> BYTE CONFLICTS DAT-DIRECTORY="" DAT-FILE="LPGLexerdcl.data"
>>>>>>> DCL-FILE="LPGLexerdcl.xml" NODEBUG DEF-FILE="LPGLexerdef.xml"
>>>>>>> NOEDIT
>>>>>>> NOERROR-MAPS ESCAPE='%'
>>>>>>> EXPORT-TERMINALS=("LPGParsersym.xml","","")
>>>>>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGLexer"
>>>>>>> FILTER="LPGKWLexer.gi" NOFIRST NOFOLLOW NOGLR NOGOTO-DEFAULT
>>>>>>> GRM-FILE="LPGLexer.gi" IMP-FILE="LPGLexerimp.xml"
>>>>>>>
>>>>>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>>>>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>>>>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>>>>>> LALR=15 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>>>>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>>>>>> PACKAGE="org.eclipse.imp.lpg.parser" NOPARENT-SAVE
>>>>>>> NOPARSETABLE-INTERFACES
>>>>>>>
>>>>>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>>>>>> PRS-FILE="LPGLexerprs.xml"
>>>>>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>>>>>> NOSHIFT-DEFAULT SINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>>>>>> SUFFIX=""
>>>>>>> SYM-FILE="LPGLexersym.xml" TAB-FILE="LPGLexer.t" NOTABLE
>>>>>>> TEMPLATE="LexerTemplateF.gi" TRACE=CONFLICTS NOVARIABLES
>>>>>>> NOVERBOSE
>>>>>>> NOVISITOR VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>>>>>
>>>>>>>
>>>>>>> Options in effect for LPGParser.g:
>>>>>>>
>>>>>>> ACTION-BLOCK=("","/.","./")
>>>>>>>
>>>>>>> AST-DIRECTORY="" AST-TYPE="ASTNode" NOATTRIBUTES
>>>>>>> AUTOMATIC-AST=NESTED
>>>>>>> NOBACKTRACK BYTE CONFLICTS DAT-DIRECTORY=""
>>>>>>> DAT-FILE="LPGParserdcl.data"
>>>>>>>
>>>>>>> DCL-FILE="LPGParserdcl.xml" NODEBUG DEF-FILE="LPGParserdef.xml"
>>>>>>> NOEDIT
>>>>>>> NOERROR-MAPS ESCAPE='%'
>>>>>>> EXPORT-TERMINALS=("LPGParserexp.xml","","")
>>>>>>> EXTENDS-PARSETABLE FACTORY="new " FILE-PREFIX="LPGParser"
>>>>>>> NOFIRST
>>>>>>> NOFOLLOW NOGLR NOGOTO-DEFAULT GRM-FILE="LPGParser.g"
>>>>>>> IMP-FILE="LPGParserimp.xml" IMPORT-TERMINALS="LPGLexer.gi"
>>>>>>>
>>>>>>> INCLUDE-DIRECTORY=".;..;/C:/Downloads/eclipse-jee-ganymede-SR2-win32/eclipse
>>>>>>> /plugins/lpg.generator_2.0.16/templates/java/;/C:/Downloads/ eclipse-jee-ganymede
>>>>>>> -SR2-win32/eclipse/plugins/lpg.generator_2.0.16/include/java / "
>>>>>>> LALR=6 LEGACY NOLIST MARGIN=0 MAX-CASES=1024 NAMES=OPTIMIZED
>>>>>>> NONT-CHECK OR_MARKER='|' OUT-DIRECTORY=""
>>>>>>> PACKAGE="org.eclipse.imp.lpg.parser" PARENT-SAVED
>>>>>>> NOPARSETABLE-INTERFACES
>>>>>>> PREFIX="" PRIORITY PROGRAMMING_LANGUAGE=XML
>>>>>>> PRS-FILE="LPGParserprs.xml"
>>>>>>> NOQUIET READ-REDUCE REMAP-TERMINALS NOSCOPES NOSERIALIZE
>>>>>>> NOSHIFT-DEFAULT NOSINGLE-PRODUCTIONS NOSOFT-KEYWORDS NOSTATES
>>>>>>> SUFFIX=""
>>>>>>> SYM-FILE="LPGParsersym.xml" TAB-FILE="LPGParser.t" NOTABLE
>>>>>>> TEMPLATE="dtParserTemplateF.gi" TRACE=CONFLICTS VARIABLES
>>>>>>> NOVERBOSE
>>>>>>> VISITOR=PREORDER VISITOR-TYPE="Visitor" WARNINGS NOXREF
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> the size of lpg-win32_X86.exe is 1224 Ko
>>>>>>> My include directory is the default param.
>>>>>>>
>>>>>>> Thanks
>>>>>>>
>>>>>>> Philippe
>>>>>>>
Re: Re:[BUG] Build lpgparser in org.eclipse.imp.lpg.runtime failed [message #575339 is a reply to message #27741] Fri, 13 March 2009 11:32 Go to previous message
Jin Missing name is currently offline Jin Missing name
Messages: 100
Registered: July 2009
Senior Member
Defert, you are right! It is a bug. I first misunderstand your words. I
thoght
you were using the svn sources, and can not build the grammar files in the
sources. But I find the you are using installed imp right now. so I check
the runing imp application. I find the LPG builder can not work really. one
simple workaround is as your suggestion, we can tweak the
"perferences"->"LPG"-><right_path_here>. I open a bug[1] , and add a patch
to this bug. Another is using the patch.
The difference between "/" and "\" seem not important. as my test, "c:/aaa"
and "c:\aaa" both work for windows xp. The cruical thing is that the when
the PerferenceService convert the variable in eclipse such as
$pluginResource to "/C:/xxx/xxx", the first leading "/" makes whole things
broken.


[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=268550


"Defert Philippe" <defert@bayesia.com>
??????:gpdb59$rrs$1@build.eclipse.org...
> Hi,
>
> I searched and i found :-)
>
> i'm under windows system and eclipse is under java.
>
> the default generated includepath is in java syntax , the folder
> separator is '/' but the lpg generator is win32 program and understand
> only win32 folder separator AKA '\'
>
> The FIX for win32 is switch java filepath syntax to win32 filepath
> syntax of includepath before calling lpggenerator
> or something like that
>
> Philippe
>
> Defert Philippe a
Previous Topic:Build lpgparser in org.eclipse.imp.lpg.runtime failed
Next Topic:Cannot find a solution satisfying the following requirements org.eclipse.ltk.core.refactoring
Goto Forum:
  


Current Time: Mon Jul 28 16:40:36 EDT 2014

Powered by FUDForum. Page generated in 0.04995 seconds