Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » OCL » An issue in EcoreEnvironment for extensibility
An issue in EcoreEnvironment for extensibility [message #26962] Thu, 07 June 2007 09:21 Go to next message
Eclipse UserFriend
Originally posted by: alu2526.etsii.ull.es

Hi Christian,

Im in the battle again ;)

I would be very pleased if in the constructor EcoreEnvironment (Registry,
Resource) the TypeResolver is created with a factoryMethod
(createTypeResolver(Resource)) in order to extend EcoreEnvironment and
TypeResolverImpl with my OMEnvironment and OMTypeResolver with a resource as
constructor's parameter.

Im persisting the generated types by the TypeResolver in the same resource
where i have my output OM Model, and I have had some problems. I have some
ideas about the reason, but i need to research more about them. I will post
you as soon as i find out the problem.
Re: An issue in EcoreEnvironment for extensibility [message #27121 is a reply to message #26962] Thu, 07 June 2007 13:33 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: cdamus.ca.ibm.com

Hi, Adolfo,

This sounds like a very sensible refactoring. Please raise an enhancement
request in bugzilla for it.

Cheers,

Christian

Adolfo S�chez-Barbudo Herrera wrote:

> Hi Christian,
>
> Im in the battle again ;)
>
> I would be very pleased if in the constructor EcoreEnvironment (Registry,
> Resource) the TypeResolver is created with a factoryMethod
> (createTypeResolver(Resource)) in order to extend EcoreEnvironment and
> TypeResolverImpl with my OMEnvironment and OMTypeResolver with a resource
> as constructor's parameter.
>
> Im persisting the generated types by the TypeResolver in the same resource
> where i have my output OM Model, and I have had some problems. I have some
> ideas about the reason, but i need to research more about them. I will
> post you as soon as i find out the problem.
Re: An issue in EcoreEnvironment for extensibility [message #27239 is a reply to message #27121] Thu, 07 June 2007 15:45 Go to previous message
Eclipse UserFriend
Originally posted by: alu2526.etsii.ull.es

Hi Christian,

Some comments

> This sounds like a very sensible refactoring. Please raise an enhancement
> request in bugzilla for it.

Sure it is ;)

Raised as https://bugs.eclipse.org/bugs/show_bug.cgi?id=191504

>> Im persisting the generated types by the TypeResolver in the same
>> resource
>> where i have my output OM Model, and I have had some problems. I have
>> some
>> ideas about the reason, but i need to research more about them. I will
>> post you as soon as i find out the problem.

It was my fault. I had not created the return type of a mapping operation
(which had not return value), and later an operationCallExp didnt work well.
I have successfully persisted all the collection types created during the
parsing in the same resource where i persist the output model ;)

Greetings !!!!
Adolfo
Previous Topic:emf validation examples
Next Topic:[Announce] MDT OCL 1.1.0 I200706071327 is available
Goto Forum:
  


Current Time: Thu Nov 27 11:13:13 GMT 2014

Powered by FUDForum. Page generated in 0.02747 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software