Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Riena » Host riena (OSGI) services on WebSphere
Host riena (OSGI) services on WebSphere [message #26694] Mon, 15 June 2009 08:10 Go to next message
Stefan Rehlig is currently offline Stefan Rehlig
Messages: 4
Registered: July 2009
Junior Member
Hello,

what steps do i have to follow to host some OSGI-services in an web
container like websphere, geronimo etc. an use them with riena
communication.

Is it possible?
Re: Host riena (OSGI) services on WebSphere [message #26735 is a reply to message #26694] Tue, 16 June 2009 08:14 Go to previous messageGo to next message
Stefan Rehlig is currently offline Stefan Rehlig
Messages: 4
Registered: July 2009
Junior Member
I found some information in this newsgroup on running the riena services
in a custom web container.

I set up a web application that exposes the bridge servlet
(org.eclipse.equinox.servletbridge.BridgeServlet). As the console tells
me, the osgi kernel is loaded (0 ACTIVE
org.eclipse.osgi_3.3.0.200704022148).

Now i want to run the services of org.eclipse.riena.sample.app.server.

Do i have to put the plugin-jars of app.server and its dependencies into
the plugins folder of the eclipse directory under WEB-INF?

What are the next steps?

Is there anyone who has some hints? Any comments are appreciated.

Thank you
Re: Host riena (OSGI) services on WebSphere [message #26814 is a reply to message #26735] Wed, 17 June 2009 08:00 Go to previous message
Christian Campo is currently offline Christian Campo
Messages: 590
Registered: July 2009
Senior Member
Stefan Rehlig schrieb:
> I found some information in this newsgroup on running the riena services
> in a custom web container.
>
> I set up a web application that exposes the bridge servlet
> (org.eclipse.equinox.servletbridge.BridgeServlet). As the console tells
> me, the osgi kernel is loaded (0 ACTIVE
> org.eclipse.osgi_3.3.0.200704022148).
>
> Now i want to run the services of org.eclipse.riena.sample.app.server.
>
> Do i have to put the plugin-jars of app.server and its dependencies into
> the plugins folder of the eclipse directory under WEB-INF?
>
> What are the next steps?
>
> Is there anyone who has some hints? Any comments are appreciated.
>
> Thank you
>
Right basically you have to follow to the general steps for the BridgetServlet on running an OSGi appservice in a WAR
file. And then take riena.app.server and all its dependencies into there and make sure they get started (maybe you need
a config.ini for that or you active the -console in the webcontainer for a start and start the riena.app.server manually)

That should do the trick....

christian campo
Re: Host riena (OSGI) services on WebSphere [message #582758 is a reply to message #26694] Tue, 16 June 2009 08:14 Go to previous message
Stefan Rehlig is currently offline Stefan Rehlig
Messages: 4
Registered: July 2009
Junior Member
I found some information in this newsgroup on running the riena services
in a custom web container.

I set up a web application that exposes the bridge servlet
(org.eclipse.equinox.servletbridge.BridgeServlet). As the console tells
me, the osgi kernel is loaded (0 ACTIVE
org.eclipse.osgi_3.3.0.200704022148).

Now i want to run the services of org.eclipse.riena.sample.app.server.

Do i have to put the plugin-jars of app.server and its dependencies into
the plugins folder of the eclipse directory under WEB-INF?

What are the next steps?

Is there anyone who has some hints? Any comments are appreciated.

Thank you
Re: Host riena (OSGI) services on WebSphere [message #582789 is a reply to message #26735] Wed, 17 June 2009 08:00 Go to previous message
Christian Campo is currently offline Christian Campo
Messages: 590
Registered: July 2009
Senior Member
Stefan Rehlig schrieb:
> I found some information in this newsgroup on running the riena services
> in a custom web container.
>
> I set up a web application that exposes the bridge servlet
> (org.eclipse.equinox.servletbridge.BridgeServlet). As the console tells
> me, the osgi kernel is loaded (0 ACTIVE
> org.eclipse.osgi_3.3.0.200704022148).
>
> Now i want to run the services of org.eclipse.riena.sample.app.server.
>
> Do i have to put the plugin-jars of app.server and its dependencies into
> the plugins folder of the eclipse directory under WEB-INF?
>
> What are the next steps?
>
> Is there anyone who has some hints? Any comments are appreciated.
>
> Thank you
>
Right basically you have to follow to the general steps for the BridgetServlet on running an OSGi appservice in a WAR
file. And then take riena.app.server and all its dependencies into there and make sure they get started (maybe you need
a config.ini for that or you active the -console in the webcontainer for a start and start the riena.app.server manually)

That should do the trick....

christian campo
Previous Topic:How to use IRemoteProgressMonitorRegistry?
Next Topic:Riena 1.1.0.0. Release
Goto Forum:
  


Current Time: Mon Apr 21 11:39:26 EDT 2014

Powered by FUDForum. Page generated in 0.01774 seconds