Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP - Mobile Tools for Java (MTJ) » Invalid jar problem
Invalid jar problem [message #26531] Wed, 18 February 2009 09:37 Go to next message
teknokrat is currently offline teknokrat
Messages: 73
Registered: July 2009
Member
I have built and packaged my midlet using MTJ. it works fine on the
emulator. I transfer the jar file to any phone via bluetooth and I get
an Invalid Jar error.

any help appreciated

cheers
Re: Invalid jar problem [message #26555 is a reply to message #26531] Wed, 18 February 2009 12:54 Go to previous messageGo to next message
Diego Madruga Sandin is currently offline Diego Madruga Sandin
Messages: 116
Registered: July 2009
Senior Member
Hi,

some devices have problems with the size of the jar, stipulating a mas jar
size constraint. Some others have problems with the number of MIDlets on a
Suite.

Most of this constraints are ignored by emulators, so you'll only discover
this when deploying to a real device.

Could you give us more info on what device you're using,the jar size,
number of MIDlets on the suite and some other info you'll find useful?

Diego
Re: Invalid jar problem [message #26675 is a reply to message #26555] Wed, 18 February 2009 14:05 Go to previous messageGo to next message
teknokrat is currently offline teknokrat
Messages: 73
Registered: July 2009
Member
Diego Madruga Sandin wrote:
> Hi,
>
> some devices have problems with the size of the jar, stipulating a mas
> jar size constraint. Some others have problems with the number of
> MIDlets on a Suite.
> Most of this constraints are ignored by emulators, so you'll only
> discover this when deploying to a real device.
>
> Could you give us more info on what device you're using,the jar size,
> number of MIDlets on the suite and some other info you'll find useful?
>
> Diego
>
>

Yes, in this case there was a problem with my manifest. Its fixed now.

cheers
Re: Invalid jar problem [message #26833 is a reply to message #26675] Wed, 18 February 2009 22:46 Go to previous message
Eclipse User
Originally posted by: news.s237965939.online.de

teknokrat wrote:
> Diego Madruga Sandin wrote:
>> Hi,
>>
>> some devices have problems with the size of the jar, stipulating a mas
>> jar size constraint. Some others have problems with the number of
>> MIDlets on a Suite.
>> Most of this constraints are ignored by emulators, so you'll only
>> discover this when deploying to a real device.
>>
>> Could you give us more info on what device you're using,the jar size,
>> number of MIDlets on the suite and some other info you'll find useful?
>>
>> Diego
>
> Yes, in this case there was a problem with my manifest. Its fixed now.

I had the same problem on my Sony/Ericsson K770i. Trying to install the
jar produced an "Operation failed" error message. I had a bug in the
manifest too which is also fixed now.

Hans
Re: Invalid jar problem [message #571176 is a reply to message #26531] Wed, 18 February 2009 12:54 Go to previous message
Diego Madruga Sandin is currently offline Diego Madruga Sandin
Messages: 116
Registered: July 2009
Senior Member
Hi,

some devices have problems with the size of the jar, stipulating a mas jar
size constraint. Some others have problems with the number of MIDlets on a
Suite.

Most of this constraints are ignored by emulators, so you'll only discover
this when deploying to a real device.

Could you give us more info on what device you're using,the jar size,
number of MIDlets on the suite and some other info you'll find useful?

Diego
Re: Invalid jar problem [message #571196 is a reply to message #26555] Wed, 18 February 2009 14:05 Go to previous message
teknokrat is currently offline teknokrat
Messages: 73
Registered: July 2009
Member
Diego Madruga Sandin wrote:
> Hi,
>
> some devices have problems with the size of the jar, stipulating a mas
> jar size constraint. Some others have problems with the number of
> MIDlets on a Suite.
> Most of this constraints are ignored by emulators, so you'll only
> discover this when deploying to a real device.
>
> Could you give us more info on what device you're using,the jar size,
> number of MIDlets on the suite and some other info you'll find useful?
>
> Diego
>
>

Yes, in this case there was a problem with my manifest. Its fixed now.

cheers
Re: Invalid jar problem [message #571330 is a reply to message #26675] Wed, 18 February 2009 22:46 Go to previous message
Eclipse User
Originally posted by: news.s237965939.online.de

teknokrat wrote:
> Diego Madruga Sandin wrote:
>> Hi,
>>
>> some devices have problems with the size of the jar, stipulating a mas
>> jar size constraint. Some others have problems with the number of
>> MIDlets on a Suite.
>> Most of this constraints are ignored by emulators, so you'll only
>> discover this when deploying to a real device.
>>
>> Could you give us more info on what device you're using,the jar size,
>> number of MIDlets on the suite and some other info you'll find useful?
>>
>> Diego
>
> Yes, in this case there was a problem with my manifest. Its fixed now.

I had the same problem on my Sony/Ericsson K770i. Trying to install the
jar produced an "Operation failed" error message. I had a bug in the
manifest too which is also fixed now.

Hans
Previous Topic:Using ProGuard as preverifier with MicroEmu?
Next Topic:Skinning & Version info
Goto Forum:
  


Current Time: Tue Sep 02 21:19:18 GMT 2014

Powered by FUDForum. Page generated in 0.01874 seconds