Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP - Real-Time Software Components (RTSC) » Using XDC with CCSv3.3
Using XDC with CCSv3.3 [message #2192] Wed, 22 April 2009 04:22 Go to next message
sgspecker is currently offline sgspecker
Messages: 8
Registered: July 2009
Junior Member
I've run into a problem installing the XDC tools for CCSv3.3. It appears
that when you install XDC v2.95, the proper hooks are put in place
allowing CCS to recognize and use XDC. If, on the other hand, you only
install another version of XDC (say XDC 3.10), XDC is not recognized by
CCS.

Looking in the release notes for XDC 3.10, it states that CCSv3.3 is
supported, but there are not any additional installation steps indicated.

Is there a procedure needed to get CCSv3.3 to recognize XDC? If so, can
someone point me to it; if not, can you help me document it.

Thanks,
Scott
Re: Using XDC with CCSv3.3 [message #2220 is a reply to message #2192] Wed, 22 April 2009 10:14 Go to previous messageGo to next message
Dave Russo is currently offline Dave Russo
Messages: 172
Registered: July 2009
Senior Member
sgspecker wrote:
> I've run into a problem installing the XDC tools for CCSv3.3. It appears
> that when you install XDC v2.95, the proper hooks are put in place
> allowing CCS to recognize and use XDC. If, on the other hand, you only
> install another version of XDC (say XDC 3.10), XDC is not recognized by
> CCS.
>
> Looking in the release notes for XDC 3.10, it states that CCSv3.3 is
> supported, but there are not any additional installation steps indicated.
>
> Is there a procedure needed to get CCSv3.3 to recognize XDC? If so, can
> someone point me to it; if not, can you help me document it.
Since you are installing XDCtools "by hand", you probably need to follow
the procedure described in "Network Installation":
http://rtsc.eclipse.org/docs-tip/XDCtools_Installation_Guide #About_Network_Installations.

Normally the XDCtools installer on Windows automatically makes some
registry modifications required by CCS 3.3. During a "network install"
(that allows a team to share a common XDCtools), each developer must
manually update their registry by following the steps outlined in
http://rtsc.eclipse.org/cdoc-tip/index.html#xdc/tools/config uro/ccs/package.html


>
> Thanks,
> Scott
>
Re: Using XDC with CCSv3.3 [message #2252 is a reply to message #2220] Wed, 22 April 2009 19:23 Go to previous messageGo to next message
sgspecker is currently offline sgspecker
Messages: 8
Registered: July 2009
Junior Member
> Since you are installing XDCtools "by hand", you probably need to follow
> the procedure described in "Network Installation ... Normally the XDCtools
> installer on Windows automatically makes some registry modifications
> required by CCS 3.3.

Thanks for the pointers to the Network Install instructions as well as
regserver reference. I'm guessing this will solve my problem.

In my case, though, I was actually installing XDC using the Windows .exe
setup file for 3.10.xx. Thus, it appears the correct registry mods may not
be getting implemented correctly. As I said, hopefully these instructions
will help me out, but it might be good to ensure the Windows installer
files are working as expected.

Thanks,
Scott
Re: Using XDC with CCSv3.3 [message #2341 is a reply to message #2252] Wed, 29 April 2009 12:08 Go to previous message
sgspecker is currently offline sgspecker
Messages: 8
Registered: July 2009
Junior Member
When I went back and tried this again, I realized I was using the "custom"
install option of the setup file. So, it appears whether you are using the
"network" (as you suspected) or "custom", neither seem to be registering
with CCS. When I chose "typical", the installer seemed to work correctly.

It seems to me that "custom" should have given me the option to register
or not, but I guess that's just what I've come to expect from custom-type
choices in installers.

Thanks for your help,
Scott
Previous Topic:RTSC targets tree started in RTSC source repository
Next Topic:How to wait on proxy module startup?
Goto Forum:
  


Current Time: Wed Aug 20 06:57:04 EDT 2014

Powered by FUDForum. Page generated in 0.01622 seconds