Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » JRE not compatible with workspace .class file compatibility
JRE not compatible with workspace .class file compatibility [message #256470] Thu, 15 May 2008 20:40 Go to next message
Eclipse UserFriend
Originally posted by: alfredo.ramos.networksolutions.com

I am loading up a project into Eclipse. I use jre1.5.0_09 - I don't have
any other JREs installed on my laptop. I can run the project fine from
command line, but when I try to run it from Eclipse by doing Run As->Open
Run Dialog and filling out the info... It says:

[JRE]: JRE not compatible with workspace .class file compatibility: 1.6

The odd part is that this works fine when run from command line. Any hint?

Thank you
Re: JRE not compatible with workspace .class file compatibility [message #256475 is a reply to message #256470] Thu, 15 May 2008 21:42 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: merks.ca.ibm.com

Alfredo,

If you look in Window->Preferences->Java->Installed JREs, is the one
you're expecting actually there? Were these .class files produced by
Eclipse? In Eclipse you'd want to set our source compatibility in the
preferences to be 1.5...


Alfredo wrote:
> I am loading up a project into Eclipse. I use jre1.5.0_09 - I don't
> have any other JREs installed on my laptop. I can run the project fine
> from command line, but when I try to run it from Eclipse by doing Run
> As->Open Run Dialog and filling out the info... It says:
>
> [JRE]: JRE not compatible with workspace .class file compatibility: 1.6
>
> The odd part is that this works fine when run from command line. Any
> hint?
>
> Thank you
>
Re: JRE not compatible with workspace .class file compatibility [message #256498 is a reply to message #256475] Fri, 16 May 2008 14:15 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: alfredo.ramos.networksolutions.com

I went to Window -> Preferences -> Java -> Installed JREs: the only JRE
listed there was jre1.5.0__09. That said, Under Java -> Compiler, the
"Compiler compliance level" was set to 6.0 and I switched it to 5.0 - that
got rid of the error message.

Thank you :)
Re: JRE not compatible with workspace .class file compatibility [message #257704 is a reply to message #256470] Thu, 05 June 2008 18:15 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: jaywalkersys.kkkkkk.com

Hi!

Go to Window > Preferences > Java > Compiler and change the "Compiler
compliance level" to 5.0 and try again...

Maybe your project workspace had been sailing over the Java 1.6 seas
before you started working, even in another station...

Good luck and be happy!

Silvio
Re: JRE not compatible with workspace .class file compatibility [message #892564 is a reply to message #256470] Thu, 28 June 2012 15:57 Go to previous message
ramukumar M is currently offline ramukumar MFriend
Messages: 7
Registered: June 2012
Junior Member
Basically You have installed two java versions in your machine.
and you have created the project with the version which is not default. So in the project properties, under JAVA compiler change the version to ur jdk version
This will solve your problem.

Let me know if you need more info
Previous Topic:Missing Build Path menu item in context menu
Next Topic:"Raw Type" Problem
Goto Forum:
  


Current Time: Mon Dec 22 03:36:12 GMT 2014

Powered by FUDForum. Page generated in 0.08835 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software