Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP - Mobile Tools for Java (MTJ) » Obfuscated version doesn't run
Obfuscated version doesn't run [message #24637] Thu, 01 January 2009 22:31 Go to next message
Eclipse User
Originally posted by: news.s237965939.online.de

I'm using ProGuard, but when I doubleclick the .jad file and press
"launch" the application terminates with these messages. Does anyone
know this problem and has a solution?

Running with storage root C:\Documents and
Settings\Hajue\j2mewtk\2.5.2\appdb\Hajue
Running with locale: German_Germany.1252
Running in the identified_third_party security domain
Error verifying method MobileGuitarMIDlet startApp()V
Approximate bytecode offset 0: Inconsistent or missing stackmap at target
Method............: 10233084
'com/sun/midp/midlet/MIDletState.createMIDlet (static)'

TIA,
Hans
Re: Obfuscated version doesn't run [message #24717 is a reply to message #24637] Thu, 01 January 2009 23:34 Go to previous messageGo to next message
Eclipse User
Originally posted by: news.s237965939.online.de

Hans-J. Ude wrote:
> I'm using ProGuard, but when I doubleclick the .jad file and press
> "launch" the application terminates with these messages. Does anyone
> know this problem and has a solution?
>
> Running with storage root C:\Documents and
> Settings\Hajue\j2mewtk\2.5.2\appdb\Hajue
> Running with locale: German_Germany.1252
> Running in the identified_third_party security domain
> Error verifying method MobileGuitarMIDlet startApp()V
> Approximate bytecode offset 0: Inconsistent or missing stackmap at target
> Method............: 10233084
> 'com/sun/midp/midlet/MIDletState.createMIDlet (static)'

I forgot to mention that if I load the obfuscated .jar into a
decompiler, it shows errors here and there. But not in startApp as
listed above.

Hans
Re: Obfuscated version doesn't run [message #24756 is a reply to message #24637] Fri, 02 January 2009 17:08 Go to previous messageGo to next message
Eclipse User
Originally posted by: news.s237965939.online.de

Hans-J. Ude wrote:
> I'm using ProGuard, but when I doubleclick the .jad file and press
> "launch" the application terminates with these messages. Does anyone
> know this problem and has a solution?

Sorry, my fault. There is no problem. In the deployed folder there are 3
files created. MyProgram.jad, MyProgram.jar and MyProgram_obf.jar.

Only when I edit the jad to refer to MyProgram_obf.jar I get that error.
I thought MyProgram.jar would be the unobfuscated package but it's
obfuscated too. Now I'm just wondering why two JARs are generated.

Hans
Re: Obfuscated version doesn't run [message #25062 is a reply to message #24756] Fri, 09 January 2009 01:08 Go to previous messageGo to next message
Eclipse User
Originally posted by: craigjunk.setera.org

MyProgram_obf.jar is the jar that is obfuscated, but not yet preverified
since being obfuscated. MyProgram.jar is both obfuscated and
preverified. Because obfuscation alters the JAR's code, it is necessary
to preverify the JAR file again.

In general, you should avoid playing too much with the JAD pointers to
the JAR files.

Craig

Hans-J. Ude wrote:
> Hans-J. Ude wrote:
>> I'm using ProGuard, but when I doubleclick the .jad file and press
>> "launch" the application terminates with these messages. Does anyone
>> know this problem and has a solution?
>
> Sorry, my fault. There is no problem. In the deployed folder there are 3
> files created. MyProgram.jad, MyProgram.jar and MyProgram_obf.jar.
>
> Only when I edit the jad to refer to MyProgram_obf.jar I get that error.
> I thought MyProgram.jar would be the unobfuscated package but it's
> obfuscated too. Now I'm just wondering why two JARs are generated.
>
> Hans
Re: Obfuscated version doesn't run [message #25102 is a reply to message #25062] Sat, 10 January 2009 18:22 Go to previous message
Eclipse User
Originally posted by: news.s237965939.online.de

Craig Setera wrote:
> MyProgram_obf.jar is the jar that is obfuscated, but not yet preverified
> since being obfuscated. MyProgram.jar is both obfuscated and
> preverified. Because obfuscation alters the JAR's code, it is necessary
> to preverify the JAR file again.
>
> In general, you should avoid playing too much with the JAD pointers to
> the JAR files.

Thanks for the info, Craig. It was very helpful for me since I'm still
learning all tat J2ME stuff. And thanks for the answer to my OTA
question in the other thread too.

Hans
Re: Obfuscated version doesn't run [message #569618 is a reply to message #24637] Thu, 01 January 2009 23:34 Go to previous message
Eclipse User
Originally posted by: news.s237965939.online.de

Hans-J. Ude wrote:
> I'm using ProGuard, but when I doubleclick the .jad file and press
> "launch" the application terminates with these messages. Does anyone
> know this problem and has a solution?
>
> Running with storage root C:\Documents and
> Settings\Hajue\j2mewtk\2.5.2\appdb\Hajue
> Running with locale: German_Germany.1252
> Running in the identified_third_party security domain
> Error verifying method MobileGuitarMIDlet startApp()V
> Approximate bytecode offset 0: Inconsistent or missing stackmap at target
> Method............: 10233084
> 'com/sun/midp/midlet/MIDletState.createMIDlet (static)'

I forgot to mention that if I load the obfuscated .jar into a
decompiler, it shows errors here and there. But not in startApp as
listed above.

Hans
Re: Obfuscated version doesn't run [message #569668 is a reply to message #24637] Fri, 02 January 2009 17:08 Go to previous message
Eclipse User
Originally posted by: news.s237965939.online.de

Hans-J. Ude wrote:
> I'm using ProGuard, but when I doubleclick the .jad file and press
> "launch" the application terminates with these messages. Does anyone
> know this problem and has a solution?

Sorry, my fault. There is no problem. In the deployed folder there are 3
files created. MyProgram.jad, MyProgram.jar and MyProgram_obf.jar.

Only when I edit the jad to refer to MyProgram_obf.jar I get that error.
I thought MyProgram.jar would be the unobfuscated package but it's
obfuscated too. Now I'm just wondering why two JARs are generated.

Hans
Re: Obfuscated version doesn't run [message #569857 is a reply to message #24756] Fri, 09 January 2009 01:08 Go to previous message
Craig Setera is currently offline Craig Setera
Messages: 54
Registered: July 2009
Member
MyProgram_obf.jar is the jar that is obfuscated, but not yet preverified
since being obfuscated. MyProgram.jar is both obfuscated and
preverified. Because obfuscation alters the JAR's code, it is necessary
to preverify the JAR file again.

In general, you should avoid playing too much with the JAD pointers to
the JAR files.

Craig

Hans-J. Ude wrote:
> Hans-J. Ude wrote:
>> I'm using ProGuard, but when I doubleclick the .jad file and press
>> "launch" the application terminates with these messages. Does anyone
>> know this problem and has a solution?
>
> Sorry, my fault. There is no problem. In the deployed folder there are 3
> files created. MyProgram.jad, MyProgram.jar and MyProgram_obf.jar.
>
> Only when I edit the jad to refer to MyProgram_obf.jar I get that error.
> I thought MyProgram.jar would be the unobfuscated package but it's
> obfuscated too. Now I'm just wondering why two JARs are generated.
>
> Hans
Re: Obfuscated version doesn't run [message #569887 is a reply to message #25062] Sat, 10 January 2009 18:22 Go to previous message
Eclipse User
Originally posted by: news.s237965939.online.de

Craig Setera wrote:
> MyProgram_obf.jar is the jar that is obfuscated, but not yet preverified
> since being obfuscated. MyProgram.jar is both obfuscated and
> preverified. Because obfuscation alters the JAR's code, it is necessary
> to preverify the JAR file again.
>
> In general, you should avoid playing too much with the JAD pointers to
> the JAR files.

Thanks for the info, Craig. It was very helpful for me since I'm still
learning all tat J2ME stuff. And thanks for the answer to my OTA
question in the other thread too.

Hans
Previous Topic:OTA server question
Next Topic:startApp threw an Exception
Goto Forum:
  


Current Time: Tue Sep 16 09:26:16 GMT 2014

Powered by FUDForum. Page generated in 0.02021 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software