Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IMP » incremental builder wizard failed
incremental builder wizard failed [message #24582] Thu, 16 October 2008 10:25 Go to next message
Defert Philippe is currently offline Defert Philippe
Messages: 62
Registered: July 2009
Member
Hello,

I use eclipse 3.4.1 and IMP meta-tooling 0.1.80

eclipse.buildId=M20080911-1700
java.version=1.6.0_03
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=fr_FR
Command-line arguments: -os win32 -ws win32 -arch x86


When i try to use incremental builder wizard , nothing done in wizard dialog

i have this error in log:

java.lang.Exception: Cannot find schema source for schema/builders.exsd
at
org.eclipse.imp.wizards.ExtensionPointWizardPage.<init>(ExtensionPointWizardPage.java:110)
at
org.eclipse.imp.wizards.ExtensionPointWizardPage.<init>(ExtensionPointWizardPage.java:65)
at
org.eclipse.imp.wizards.NewBuilderWizardPage.<init>(NewBuilderWizardPage.java:31)
at org.eclipse.imp.wizards.NewBuilder.addPages(NewBuilder.java: 42)
at
org.eclipse.jface.wizard.WizardSelectionPage.getNextPage(Wiz ardSelectionPage.java:113)
at
org.eclipse.ui.internal.dialogs.WorkbenchWizardSelectionPage .getNextPage(WorkbenchWizardSelectionPage.java:100)
at org.eclipse.jface.wizard.WizardDialog.nextPressed(WizardDial og.java:813)
at
org.eclipse.jface.wizard.WizardDialog.buttonPressed(WizardDi alog.java:369)
at org.eclipse.jface.dialogs.Dialog$2.widgetSelected(Dialog.jav a:624)
at
org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListe ner.java:228)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java :84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1003)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.ja va:3823)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3422)
at org.eclipse.jface.window.Window.runEventLoop(Window.java:825 )
at org.eclipse.jface.window.Window.open(Window.java:801)
at
org.eclipse.ui.internal.handlers.WizardHandler$New.executeHa ndler(WizardHandler.java:253)
at
org.eclipse.ui.internal.handlers.WizardHandler.execute(Wizar dHandler.java:273)
at
org.eclipse.ui.internal.handlers.HandlerProxy.execute(Handle rProxy.java:281)
at org.eclipse.core.commands.Command.executeWithChecks(Command. java:476)
at
org.eclipse.core.commands.ParameterizedCommand.executeWithCh ecks(ParameterizedCommand.java:508)
at
org.eclipse.ui.internal.handlers.HandlerService.executeComma nd(HandlerService.java:169)
at
org.eclipse.ui.internal.handlers.SlaveHandlerService.execute Command(SlaveHandlerService.java:247)
at
org.eclipse.ui.internal.actions.CommandAction.runWithEvent(C ommandAction.java:157)
at
org.eclipse.jface.action.ActionContributionItem.handleWidget Selection(ActionContributionItem.java:583)
at
org.eclipse.jface.action.ActionContributionItem.access$2(Act ionContributionItem.java:500)
at
org.eclipse.jface.action.ActionContributionItem$5.handleEven t(ActionContributionItem.java:411)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java :84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1003)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.ja va:3823)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3422)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:2382)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2346)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:21 98)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:493)
at
org.eclipse.core.databinding.observable.Realm.runWithDefault (Realm.java:288)
at
org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:488)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)
at
org.eclipse.ui.internal.ide.application.IDEApplication.start (IDEApplication.java:113)
at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:193)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:386)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 549)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)


Philippe
Re: incremental builder wizard failed [message #24668 is a reply to message #24582] Thu, 16 October 2008 14:21 Go to previous messageGo to next message
Eclipse User
Originally posted by: regenmacher.online.de

"Defert Philippe" <defert@bayesia.com> schrieb im Newsbeitrag
news:gd7ita$neg$1@build.eclipse.org...
> Hello,
> I use eclipse 3.4.1 and IMP meta-tooling 0.1.80
>
> When i try to use incremental builder wizard , nothing done in wizard
> dialog
> i have this error in log:
....
>
> Philippe

Current IMP doesn't work well with eclipse 3.4.x
IMP ( and incremental builder wizard dialog ) does work with eclipse 3.3
michael
Re: incremental builder wizard failed [message #24706 is a reply to message #24668] Fri, 17 October 2008 04:21 Go to previous messageGo to next message
Defert Philippe is currently offline Defert Philippe
Messages: 62
Registered: July 2009
Member
Michael Strothjohann a écrit :
>
> "Defert Philippe" <defert@bayesia.com> schrieb im Newsbeitrag
> news:gd7ita$neg$1@build.eclipse.org...
>> Hello,
>> I use eclipse 3.4.1 and IMP meta-tooling 0.1.80
>>
>> When i try to use incremental builder wizard , nothing done in wizard
>> dialog
>> i have this error in log:
> ...
>>
>> Philippe
>
> Current IMP doesn't work well with eclipse 3.4.x
> IMP ( and incremental builder wizard dialog ) does work with eclipse 3.3
> michael
>
>
i found a workaround . In org.eclipse.imp.metatooling_0.1.79.jar , i add
"builders.exsd" in "schema" folder, now it works fine under 3.4.X

Philippe
Re: incremental builder wizard failed [message #24783 is a reply to message #24706] Mon, 27 October 2008 12:14 Go to previous messageGo to next message
Robert M. Fuhrer is currently offline Robert M. Fuhrer
Messages: 294
Registered: July 2009
Senior Member
Hi there,

The problem is that Eclipse keeps on moving the various extension
point schemas to different locations from release to release. In
fact, oddly, there doesn't seem to be a consensus that the schemas
even ought to be distributed with non-source Eclipse releases,
which naturally causes problems for metatooling like IMP.

I could have sworn there was a bugzilla bug for this very issue,
but now I can't find it. :-(

Defert Philippe wrote:
> Michael Strothjohann a écrit :
>> "Defert Philippe" <defert@bayesia.com> schrieb im Newsbeitrag
>> news:gd7ita$neg$1@build.eclipse.org...
>>> Hello,
>>> I use eclipse 3.4.1 and IMP meta-tooling 0.1.80
>>>
>>> When i try to use incremental builder wizard , nothing done in wizard
>>> dialog
>>> i have this error in log:
>> ...
>>> Philippe
>> Current IMP doesn't work well with eclipse 3.4.x
>> IMP ( and incremental builder wizard dialog ) does work with eclipse 3.3
>> michael
>>
>>
> i found a workaround . In org.eclipse.imp.metatooling_0.1.79.jar , i add
> "builders.exsd" in "schema" folder, now it works fine under 3.4.X

--
Cheers,
-- Bob

--------------------------------
Robert M. Fuhrer
Research Staff Member
Programming Technologies Dept.
IBM T.J. Watson Research Center

IDE Meta-tooling Platform Project Lead (http://www.eclipse.org/imp)
X10: Productive High-Performance Parallel Programming (http://x10.sf.net)
Re: incremental builder wizard failed [message #25377 is a reply to message #24783] Wed, 12 November 2008 13:11 Go to previous message
Stan Sutton is currently offline Stan Sutton
Messages: 121
Registered: July 2009
Senior Member
I don't know whether we ever had a bugzilla bug, but this was certainly
a problem that we recognized. Our solution was to copy the
builders.exsd file into a schema folder in org.eclipse.imp.metatooling.
We did that locally, but evidently that folder/file didn't make it
into the release.

The workaround suggested by Philippe Defert is the solution that we
intend. We need to be sure that our build process includes that folder
and file in the release jar. I'll file a bugzilla report about that.

Stan

Robert M. Fuhrer wrote:
> Hi there,
>
> The problem is that Eclipse keeps on moving the various extension
> point schemas to different locations from release to release. In
> fact, oddly, there doesn't seem to be a consensus that the schemas
> even ought to be distributed with non-source Eclipse releases,
> which naturally causes problems for metatooling like IMP.
>
> I could have sworn there was a bugzilla bug for this very issue,
> but now I can't find it. :-(
>
> Defert Philippe wrote:
>> Michael Strothjohann a écrit :
>>> "Defert Philippe" <defert@bayesia.com> schrieb im Newsbeitrag
>>> news:gd7ita$neg$1@build.eclipse.org...
>>>> Hello,
>>>> I use eclipse 3.4.1 and IMP meta-tooling 0.1.80
>>>>
>>>> When i try to use incremental builder wizard , nothing done in wizard
>>>> dialog
>>>> i have this error in log:
>>> ...
>>>> Philippe
>>> Current IMP doesn't work well with eclipse 3.4.x
>>> IMP ( and incremental builder wizard dialog ) does work with eclipse 3.3
>>> michael
>>>
>>>
>> i found a workaround . In org.eclipse.imp.metatooling_0.1.79.jar , i add
>> "builders.exsd" in "schema" folder, now it works fine under 3.4.X
>
Re: incremental builder wizard failed [message #573598 is a reply to message #24582] Thu, 16 October 2008 14:21 Go to previous message
Michael Strothjohann is currently offline Michael Strothjohann
Messages: 52
Registered: July 2009
Member
"Defert Philippe" <defert@bayesia.com> schrieb im Newsbeitrag
news:gd7ita$neg$1@build.eclipse.org...
> Hello,
> I use eclipse 3.4.1 and IMP meta-tooling 0.1.80
>
> When i try to use incremental builder wizard , nothing done in wizard
> dialog
> i have this error in log:
....
>
> Philippe

Current IMP doesn't work well with eclipse 3.4.x
IMP ( and incremental builder wizard dialog ) does work with eclipse 3.3
michael
Re: incremental builder wizard failed [message #573620 is a reply to message #24668] Fri, 17 October 2008 04:21 Go to previous message
Defert Philippe is currently offline Defert Philippe
Messages: 62
Registered: July 2009
Member
Michael Strothjohann a écrit :
>
> "Defert Philippe" <defert@bayesia.com> schrieb im Newsbeitrag
> news:gd7ita$neg$1@build.eclipse.org...
>> Hello,
>> I use eclipse 3.4.1 and IMP meta-tooling 0.1.80
>>
>> When i try to use incremental builder wizard , nothing done in wizard
>> dialog
>> i have this error in log:
> ...
>>
>> Philippe
>
> Current IMP doesn't work well with eclipse 3.4.x
> IMP ( and incremental builder wizard dialog ) does work with eclipse 3.3
> michael
>
>
i found a workaround . In org.eclipse.imp.metatooling_0.1.79.jar , i add
"builders.exsd" in "schema" folder, now it works fine under 3.4.X

Philippe
Re: incremental builder wizard failed [message #573675 is a reply to message #24706] Mon, 27 October 2008 12:14 Go to previous message
Robert M. Fuhrer is currently offline Robert M. Fuhrer
Messages: 294
Registered: July 2009
Senior Member
Hi there,

The problem is that Eclipse keeps on moving the various extension
point schemas to different locations from release to release. In
fact, oddly, there doesn't seem to be a consensus that the schemas
even ought to be distributed with non-source Eclipse releases,
which naturally causes problems for metatooling like IMP.

I could have sworn there was a bugzilla bug for this very issue,
but now I can't find it. :-(

Defert Philippe wrote:
> Michael Strothjohann a écrit :
>> "Defert Philippe" <defert@bayesia.com> schrieb im Newsbeitrag
>> news:gd7ita$neg$1@build.eclipse.org...
>>> Hello,
>>> I use eclipse 3.4.1 and IMP meta-tooling 0.1.80
>>>
>>> When i try to use incremental builder wizard , nothing done in wizard
>>> dialog
>>> i have this error in log:
>> ...
>>> Philippe
>> Current IMP doesn't work well with eclipse 3.4.x
>> IMP ( and incremental builder wizard dialog ) does work with eclipse 3.3
>> michael
>>
>>
> i found a workaround . In org.eclipse.imp.metatooling_0.1.79.jar , i add
> "builders.exsd" in "schema" folder, now it works fine under 3.4.X

--
Cheers,
-- Bob

--------------------------------
Robert M. Fuhrer
Research Staff Member
Programming Technologies Dept.
IBM T.J. Watson Research Center

IDE Meta-tooling Platform Project Lead (http://www.eclipse.org/imp)
X10: Productive High-Performance Parallel Programming (http://x10.sf.net)
Re: incremental builder wizard failed [message #574091 is a reply to message #24783] Wed, 12 November 2008 13:11 Go to previous message
Stan Sutton is currently offline Stan Sutton
Messages: 121
Registered: July 2009
Senior Member
I don't know whether we ever had a bugzilla bug, but this was certainly
a problem that we recognized. Our solution was to copy the
builders.exsd file into a schema folder in org.eclipse.imp.metatooling.
We did that locally, but evidently that folder/file didn't make it
into the release.

The workaround suggested by Philippe Defert is the solution that we
intend. We need to be sure that our build process includes that folder
and file in the release jar. I'll file a bugzilla report about that.

Stan

Robert M. Fuhrer wrote:
> Hi there,
>
> The problem is that Eclipse keeps on moving the various extension
> point schemas to different locations from release to release. In
> fact, oddly, there doesn't seem to be a consensus that the schemas
> even ought to be distributed with non-source Eclipse releases,
> which naturally causes problems for metatooling like IMP.
>
> I could have sworn there was a bugzilla bug for this very issue,
> but now I can't find it. :-(
>
> Defert Philippe wrote:
>> Michael Strothjohann a écrit :
>>> "Defert Philippe" <defert@bayesia.com> schrieb im Newsbeitrag
>>> news:gd7ita$neg$1@build.eclipse.org...
>>>> Hello,
>>>> I use eclipse 3.4.1 and IMP meta-tooling 0.1.80
>>>>
>>>> When i try to use incremental builder wizard , nothing done in wizard
>>>> dialog
>>>> i have this error in log:
>>> ...
>>>> Philippe
>>> Current IMP doesn't work well with eclipse 3.4.x
>>> IMP ( and incremental builder wizard dialog ) does work with eclipse 3.3
>>> michael
>>>
>>>
>> i found a workaround . In org.eclipse.imp.metatooling_0.1.79.jar , i add
>> "builders.exsd" in "schema" folder, now it works fine under 3.4.X
>
Previous Topic:Status update
Next Topic:LPG question: how to add a method to generated code
Goto Forum:
  


Current Time: Wed Jul 30 03:17:14 EDT 2014

Powered by FUDForum. Page generated in 0.02857 seconds