Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Maven Integration (M2E) » Disable download from local repository?
Disable download from local repository? [message #24552] Mon, 30 March 2009 21:26 Go to next message
Eclipse User
Originally posted by: asd.asd.com

I have installed the maven eclipse plugin and the maven stand alone
application on a Vista 32 machine.

I have installed a few .jar files to my local repository using:

call mvn
install:install-file -DgroupId=birt-runtime -DartifactId=coreapi -Dversion=2.1.0
-Dpackaging=jar -Dfile=coreapi.jar
call mvn
install:install-file -DgroupId=birt-runtime -DartifactId=engineapi -Dversion=2.1.0
-Dpackaging=jar -Dfile=engineapi.jar
call mvn
install:install-file -DgroupId=birt-runtime -DartifactId=modelapi -Dversion=2.1.0
-Dpackaging=jar -Dfile=modelapi.jar
call mvn
install:install-file -DgroupId=com.ibm -DartifactId=icu -Dversion=3.8.1 -Dpackaging=jar
-Dfile=com.ibm.icu_3.8.1.v20080530.jar
call mvn
install:install-file -DgroupId=org.apache.commons -DartifactId=codec -Dversion=1.3.0
-Dpackaging=jar -Dfile=org.apache.commons.codec_1.3.0.v20080530-1600.jar
call mvn
install:install-file -DgroupId=birt-runtime -DartifactId=scriptapi -Dversion=2.1.0
-Dpackaging=jar -Dfile=scriptapi.jar
call mvn
install:install-file -DgroupId=birt-runtime -DartifactId=dteapi -Dversion=2.1.0
-Dpackaging=jar -Dfile=dteapi.jar
call mvn
install:install-file -DgroupId=birt-runtime -DartifactId=js -Dversion=2.1.0
-Dpackaging=jar -Dfile=js.jar


But each time i run "Maven test" these dependencies are "downloaded":

url = http://repo1.maven.org/maven2
Downloading:
http://repo1.maven.org/maven2/birt-runtime/engineapi/2.1.0/e ngineapi-2.1.0.pom
url = http://repo1.maven.org/maven2
Downloading:
http://repo1.maven.org/maven2/birt-runtime/coreapi/2.1.0/cor eapi-2.1.0.pom
url = http://repo1.maven.org/maven2
Downloading:
http://repo1.maven.org/maven2/birt-runtime/modelapi/2.1.0/mo delapi-2.1.0.pom
url = http://repo1.maven.org/maven2
Downloading: http://repo1.maven.org/maven2/com/ibm/icu/3.8.1/icu-3.8.1.po m
url = http://repo1.maven.org/maven2
Downloading:
http://repo1.maven.org/maven2/org/apache/commons/codec/1.3.0 /codec-1.3.0.pom
url = http://repo1.maven.org/maven2
Downloading:
http://repo1.maven.org/maven2/birt-runtime/js/2.1.0/js-2.1.0 .pom


It is beginning to take a pretty long time compared to actually executing
the test. Is there some way to disable this?
Re: Disable download from local repository? [message #24595 is a reply to message #24552] Mon, 30 March 2009 23:03 Go to previous messageGo to next message
Eclipse User
Originally posted by: igor.ifedorenko.com

It is not clear from your question if performance problem occurs when
you run maven test from cli or from m2e.

Assuming you see the problem in m2e, can you please check if pom.xml
files are present in the local repository for the JARs you've installed
with install:install-file? FYI, the problem sounds like
https://issues.sonatype.org/browse/MNGECLIPSE-523 although maven install
plugin is supposed to generate pom.xml in your case.

--
Regards,
Igor

JS wrote:
> I have installed the maven eclipse plugin and the maven stand alone
> application on a Vista 32 machine.
>
> I have installed a few .jar files to my local repository using:
>
> call mvn install:install-file -DgroupId=birt-runtime
> -DartifactId=coreapi -Dversion=2.1.0 -Dpackaging=jar -Dfile=coreapi.jar
> call mvn install:install-file -DgroupId=birt-runtime
> -DartifactId=engineapi -Dversion=2.1.0 -Dpackaging=jar -Dfile=engineapi.jar
> call mvn install:install-file -DgroupId=birt-runtime
> -DartifactId=modelapi -Dversion=2.1.0 -Dpackaging=jar -Dfile=modelapi.jar
> call mvn install:install-file -DgroupId=com.ibm -DartifactId=icu
> -Dversion=3.8.1 -Dpackaging=jar -Dfile=com.ibm.icu_3.8.1.v20080530.jar
> call mvn install:install-file -DgroupId=org.apache.commons
> -DartifactId=codec -Dversion=1.3.0 -Dpackaging=jar
> -Dfile=org.apache.commons.codec_1.3.0.v20080530-1600.jar
> call mvn install:install-file -DgroupId=birt-runtime
> -DartifactId=scriptapi -Dversion=2.1.0 -Dpackaging=jar -Dfile=scriptapi.jar
> call mvn install:install-file -DgroupId=birt-runtime -DartifactId=dteapi
> -Dversion=2.1.0 -Dpackaging=jar -Dfile=dteapi.jar
> call mvn install:install-file -DgroupId=birt-runtime -DartifactId=js
> -Dversion=2.1.0 -Dpackaging=jar -Dfile=js.jar
>
>
> But each time i run "Maven test" these dependencies are "downloaded":
>
> url = http://repo1.maven.org/maven2
> Downloading:
> http://repo1.maven.org/maven2/birt-runtime/engineapi/2.1.0/e ngineapi-2.1.0.pom
>
> url = http://repo1.maven.org/maven2
> Downloading:
> http://repo1.maven.org/maven2/birt-runtime/coreapi/2.1.0/cor eapi-2.1.0.pom
> url = http://repo1.maven.org/maven2
> Downloading:
> http://repo1.maven.org/maven2/birt-runtime/modelapi/2.1.0/mo delapi-2.1.0.pom
>
> url = http://repo1.maven.org/maven2
> Downloading: http://repo1.maven.org/maven2/com/ibm/icu/3.8.1/icu-3.8.1.po m
> url = http://repo1.maven.org/maven2
> Downloading:
> http://repo1.maven.org/maven2/org/apache/commons/codec/1.3.0 /codec-1.3.0.pom
>
> url = http://repo1.maven.org/maven2
> Downloading:
> http://repo1.maven.org/maven2/birt-runtime/js/2.1.0/js-2.1.0 .pom
>
>
> It is beginning to take a pretty long time compared to actually
> executing the test. Is there some way to disable this?
>
Re: Disable download from local repository? [message #24635 is a reply to message #24595] Tue, 31 March 2009 09:51 Go to previous messageGo to next message
Eclipse User
Originally posted by: asd.asd.com

I run the "Maven test" preset from eclipse (not from the commandline). In
eclipse its called Maven Integration not sure if this relates to m2e or
Maven Cli.

In each folder (of the manually installed jars) in the local repository
there is a file:

maven-metadata-local.xml

but thats it. There is no pom.xml file. But there is no pom.xml file in the
other folder which I did not install manually. Some of them have a *.pom
file though.




"Igor Fedorenko" <igor@ifedorenko.com> wrote in message
news:gqrj3u$ccn$1@build.eclipse.org...
> It is not clear from your question if performance problem occurs when you
> run maven test from cli or from m2e.
>
> Assuming you see the problem in m2e, can you please check if pom.xml files
> are present in the local repository for the JARs you've installed with
> install:install-file? FYI, the problem sounds like
> https://issues.sonatype.org/browse/MNGECLIPSE-523 although maven install
> plugin is supposed to generate pom.xml in your case.
>
> --
> Regards,
> Igor
>
> JS wrote:
>> I have installed the maven eclipse plugin and the maven stand alone
>> application on a Vista 32 machine.
>>
>> I have installed a few .jar files to my local repository using:
>>
>> call mvn
>> install:install-file -DgroupId=birt-runtime -DartifactId=coreapi -Dversion=2.1.0
>> -Dpackaging=jar -Dfile=coreapi.jar
>> call mvn
>> install:install-file -DgroupId=birt-runtime -DartifactId=engineapi -Dversion=2.1.0
>> -Dpackaging=jar -Dfile=engineapi.jar
>> call mvn
>> install:install-file -DgroupId=birt-runtime -DartifactId=modelapi -Dversion=2.1.0
>> -Dpackaging=jar -Dfile=modelapi.jar
>> call mvn
>> install:install-file -DgroupId=com.ibm -DartifactId=icu -Dversion=3.8.1 -Dpackaging=jar
>> -Dfile=com.ibm.icu_3.8.1.v20080530.jar
>> call mvn
>> install:install-file -DgroupId=org.apache.commons -DartifactId=codec -Dversion=1.3.0
>> -Dpackaging=jar -Dfile=org.apache.commons.codec_1.3.0.v20080530-1600.jar
>> call mvn
>> install:install-file -DgroupId=birt-runtime -DartifactId=scriptapi -Dversion=2.1.0
>> -Dpackaging=jar -Dfile=scriptapi.jar
>> call mvn
>> install:install-file -DgroupId=birt-runtime -DartifactId=dteapi -Dversion=2.1.0
>> -Dpackaging=jar -Dfile=dteapi.jar
>> call mvn
>> install:install-file -DgroupId=birt-runtime -DartifactId=js -Dversion=2.1.0
>> -Dpackaging=jar -Dfile=js.jar
>>
>>
>> But each time i run "Maven test" these dependencies are "downloaded":
>>
>> url = http://repo1.maven.org/maven2
>> Downloading:
>> http://repo1.maven.org/maven2/birt-runtime/engineapi/2.1.0/e ngineapi-2.1.0.pom
>> url = http://repo1.maven.org/maven2
>> Downloading:
>> http://repo1.maven.org/maven2/birt-runtime/coreapi/2.1.0/cor eapi-2.1.0.pom
>> url = http://repo1.maven.org/maven2
>> Downloading:
>> http://repo1.maven.org/maven2/birt-runtime/modelapi/2.1.0/mo delapi-2.1.0.pom
>> url = http://repo1.maven.org/maven2
>> Downloading:
>> http://repo1.maven.org/maven2/com/ibm/icu/3.8.1/icu-3.8.1.po m
>> url = http://repo1.maven.org/maven2
>> Downloading:
>> http://repo1.maven.org/maven2/org/apache/commons/codec/1.3.0 /codec-1.3.0.pom
>> url = http://repo1.maven.org/maven2
>> Downloading:
>> http://repo1.maven.org/maven2/birt-runtime/js/2.1.0/js-2.1.0 .pom
>>
>>
>> It is beginning to take a pretty long time compared to actually executing
>> the test. Is there some way to disable this?
>>
Re: Disable download from local repository? [message #24676 is a reply to message #24635] Wed, 01 April 2009 04:17 Go to previous messageGo to next message
Eclipse User
Originally posted by: igor.ifedorenko.com

If some pom.xml files are missing, then this is definitely
MNGECLIPSE-523. Try using

mvn install:install-file -DgeneratePom=true ...

to force pom.xml generation.

--
Regards,
Igor

JS wrote:
> I run the "Maven test" preset from eclipse (not from the commandline).
> In eclipse its called Maven Integration not sure if this relates to m2e
> or Maven Cli.
>
> In each folder (of the manually installed jars) in the local repository
> there is a file:
>
> maven-metadata-local.xml
>
> but thats it. There is no pom.xml file. But there is no pom.xml file in
> the other folder which I did not install manually. Some of them have a
> *.pom file though.
>
>
>
>
> "Igor Fedorenko" <igor@ifedorenko.com> wrote in message
> news:gqrj3u$ccn$1@build.eclipse.org...
>> It is not clear from your question if performance problem occurs when
>> you run maven test from cli or from m2e.
>>
>> Assuming you see the problem in m2e, can you please check if pom.xml
>> files are present in the local repository for the JARs you've
>> installed with install:install-file? FYI, the problem sounds like
>> https://issues.sonatype.org/browse/MNGECLIPSE-523 although maven
>> install plugin is supposed to generate pom.xml in your case.
>>
>> --
>> Regards,
>> Igor
>>
>> JS wrote:
>>> I have installed the maven eclipse plugin and the maven stand alone
>>> application on a Vista 32 machine.
>>>
>>> I have installed a few .jar files to my local repository using:
>>>
>>> call mvn install:install-file -DgroupId=birt-runtime
>>> -DartifactId=coreapi -Dversion=2.1.0 -Dpackaging=jar -Dfile=coreapi.jar
>>> call mvn install:install-file -DgroupId=birt-runtime
>>> -DartifactId=engineapi -Dversion=2.1.0 -Dpackaging=jar
>>> -Dfile=engineapi.jar
>>> call mvn install:install-file -DgroupId=birt-runtime
>>> -DartifactId=modelapi -Dversion=2.1.0 -Dpackaging=jar
>>> -Dfile=modelapi.jar
>>> call mvn install:install-file -DgroupId=com.ibm -DartifactId=icu
>>> -Dversion=3.8.1 -Dpackaging=jar -Dfile=com.ibm.icu_3.8.1.v20080530.jar
>>> call mvn install:install-file -DgroupId=org.apache.commons
>>> -DartifactId=codec -Dversion=1.3.0 -Dpackaging=jar
>>> -Dfile=org.apache.commons.codec_1.3.0.v20080530-1600.jar
>>> call mvn install:install-file -DgroupId=birt-runtime
>>> -DartifactId=scriptapi -Dversion=2.1.0 -Dpackaging=jar
>>> -Dfile=scriptapi.jar
>>> call mvn install:install-file -DgroupId=birt-runtime
>>> -DartifactId=dteapi -Dversion=2.1.0 -Dpackaging=jar -Dfile=dteapi.jar
>>> call mvn install:install-file -DgroupId=birt-runtime -DartifactId=js
>>> -Dversion=2.1.0 -Dpackaging=jar -Dfile=js.jar
>>>
>>>
>>> But each time i run "Maven test" these dependencies are "downloaded":
>>>
>>> url = http://repo1.maven.org/maven2
>>> Downloading:
>>> http://repo1.maven.org/maven2/birt-runtime/engineapi/2.1.0/e ngineapi-2.1.0.pom
>>> url = http://repo1.maven.org/maven2
>>> Downloading:
>>> http://repo1.maven.org/maven2/birt-runtime/coreapi/2.1.0/cor eapi-2.1.0.pom
>>>
>>> url = http://repo1.maven.org/maven2
>>> Downloading:
>>> http://repo1.maven.org/maven2/birt-runtime/modelapi/2.1.0/mo delapi-2.1.0.pom
>>> url = http://repo1.maven.org/maven2
>>> Downloading:
>>> http://repo1.maven.org/maven2/com/ibm/icu/3.8.1/icu-3.8.1.po m
>>> url = http://repo1.maven.org/maven2
>>> Downloading:
>>> http://repo1.maven.org/maven2/org/apache/commons/codec/1.3.0 /codec-1.3.0.pom
>>> url = http://repo1.maven.org/maven2
>>> Downloading:
>>> http://repo1.maven.org/maven2/birt-runtime/js/2.1.0/js-2.1.0 .pom
>>>
>>>
>>> It is beginning to take a pretty long time compared to actually
>>> executing the test. Is there some way to disable this?
>>>
>
Re: Disable download from local repository? [message #24716 is a reply to message #24676] Wed, 01 April 2009 07:32 Go to previous message
Eclipse User
Originally posted by: asd.asd.com

Thank you very much, that worked!

"Igor Fedorenko" <igor@ifedorenko.com> wrote in message
news:gqupru$r99$1@build.eclipse.org...
> If some pom.xml files are missing, then this is definitely MNGECLIPSE-523.
> Try using
>
> mvn install:install-file -DgeneratePom=true ...
>
> to force pom.xml generation.
>
> --
> Regards,
> Igor
>
> JS wrote:
>> I run the "Maven test" preset from eclipse (not from the commandline).
>> In eclipse its called Maven Integration not sure if this relates to m2e
>> or Maven Cli.
>>
>> In each folder (of the manually installed jars) in the local repository
>> there is a file:
>>
>> maven-metadata-local.xml
>>
>> but thats it. There is no pom.xml file. But there is no pom.xml file in
>> the other folder which I did not install manually. Some of them have a
>> *.pom file though.
>>
>>
>>
>>
>> "Igor Fedorenko" <igor@ifedorenko.com> wrote in message
>> news:gqrj3u$ccn$1@build.eclipse.org...
>>> It is not clear from your question if performance problem occurs when
>>> you run maven test from cli or from m2e.
>>>
>>> Assuming you see the problem in m2e, can you please check if pom.xml
>>> files are present in the local repository for the JARs you've installed
>>> with install:install-file? FYI, the problem sounds like
>>> https://issues.sonatype.org/browse/MNGECLIPSE-523 although maven install
>>> plugin is supposed to generate pom.xml in your case.
>>>
>>> --
>>> Regards,
>>> Igor
>>>
>>> JS wrote:
>>>> I have installed the maven eclipse plugin and the maven stand alone
>>>> application on a Vista 32 machine.
>>>>
>>>> I have installed a few .jar files to my local repository using:
>>>>
>>>> call mvn
>>>> install:install-file -DgroupId=birt-runtime -DartifactId=coreapi -Dversion=2.1.0
>>>> -Dpackaging=jar -Dfile=coreapi.jar
>>>> call mvn
>>>> install:install-file -DgroupId=birt-runtime -DartifactId=engineapi -Dversion=2.1.0
>>>> -Dpackaging=jar -Dfile=engineapi.jar
>>>> call mvn
>>>> install:install-file -DgroupId=birt-runtime -DartifactId=modelapi -Dversion=2.1.0
>>>> -Dpackaging=jar -Dfile=modelapi.jar
>>>> call mvn
>>>> install:install-file -DgroupId=com.ibm -DartifactId=icu -Dversion=3.8.1
>>>> -Dpackaging=jar -Dfile=com.ibm.icu_3.8.1.v20080530.jar
>>>> call mvn
>>>> install:install-file -DgroupId=org.apache.commons -DartifactId=codec -Dversion=1.3.0
>>>> -Dpackaging=jar -Dfile=org.apache.commons.codec_1.3.0.v20080530-1600.jar
>>>> call mvn
>>>> install:install-file -DgroupId=birt-runtime -DartifactId=scriptapi -Dversion=2.1.0
>>>> -Dpackaging=jar -Dfile=scriptapi.jar
>>>> call mvn
>>>> install:install-file -DgroupId=birt-runtime -DartifactId=dteapi -Dversion=2.1.0
>>>> -Dpackaging=jar -Dfile=dteapi.jar
>>>> call mvn
>>>> install:install-file -DgroupId=birt-runtime -DartifactId=js -Dversion=2.1.0
>>>> -Dpackaging=jar -Dfile=js.jar
>>>>
>>>>
>>>> But each time i run "Maven test" these dependencies are "downloaded":
>>>>
>>>> url = http://repo1.maven.org/maven2
>>>> Downloading:
>>>> http://repo1.maven.org/maven2/birt-runtime/engineapi/2.1.0/e ngineapi-2.1.0.pom
>>>> url = http://repo1.maven.org/maven2
>>>> Downloading:
>>>> http://repo1.maven.org/maven2/birt-runtime/coreapi/2.1.0/cor eapi-2.1.0.pom
>>>> url = http://repo1.maven.org/maven2
>>>> Downloading:
>>>> http://repo1.maven.org/maven2/birt-runtime/modelapi/2.1.0/mo delapi-2.1.0.pom
>>>> url = http://repo1.maven.org/maven2
>>>> Downloading:
>>>> http://repo1.maven.org/maven2/com/ibm/icu/3.8.1/icu-3.8.1.po m
>>>> url = http://repo1.maven.org/maven2
>>>> Downloading:
>>>> http://repo1.maven.org/maven2/org/apache/commons/codec/1.3.0 /codec-1.3.0.pom
>>>> url = http://repo1.maven.org/maven2
>>>> Downloading:
>>>> http://repo1.maven.org/maven2/birt-runtime/js/2.1.0/js-2.1.0 .pom
>>>>
>>>>
>>>> It is beginning to take a pretty long time compared to actually
>>>> executing the test. Is there some way to disable this?
>>>>
>>
Previous Topic:Can child modules be mutually dependent?
Next Topic:conflicts when installing m2eclipse
Goto Forum:
  


Current Time: Sat Oct 25 03:33:14 GMT 2014

Powered by FUDForum. Page generated in 0.01928 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software