Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP - Mobile Tools for Java (MTJ) » Installation problems on Linux/x64
Installation problems on Linux/x64 [message #24429] Tue, 30 December 2008 14:19 Go to next message
Elliot Lee is currently offline Elliot Lee
Messages: 4
Registered: July 2009
Junior Member
Hi,

I'm running Eclipse 3.4.1 on Fedora 10/x64, and trying to get MTJ 0.9.1
installed. The update manager installs the plugins just fine, but when I
restart eclipse and go to "preferences", there is no "Java ME" section in
the list.

I have tried installing both the 0.9.1 release, and the nightly build,
with no success. Are there any suggestions that might help me get this
working?

Thanks,
-- Elliot
Re: Installation problems on Linux/x64 [message #24470 is a reply to message #24429] Tue, 30 December 2008 19:37 Go to previous messageGo to next message
Gustavo de Paula is currently offline Gustavo de Paula
Messages: 118
Registered: July 2009
Senior Member
hi elliot,

we never tested mtj on this specific platform, but as far as there is no
reason of why it won't run.

are you able to see MTJ installable units on the "software updates /
installed software" menu? which IU can you see and what is their versions?
other option is to check if MTJ plugins are listed as installed on the
"About / Plugin details" menu

regards,
:)
gep

Elliot Lee wrote:

> Hi,

> I'm running Eclipse 3.4.1 on Fedora 10/x64, and trying to get MTJ 0.9.1
> installed. The update manager installs the plugins just fine, but when I
> restart eclipse and go to "preferences", there is no "Java ME" section in
> the list.

> I have tried installing both the 0.9.1 release, and the nightly build,
> with no success. Are there any suggestions that might help me get this
> working?

> Thanks,
> -- Elliot
Re: Installation problems on Linux/x64 [message #24511 is a reply to message #24470] Wed, 31 December 2008 12:24 Go to previous messageGo to next message
Elliot Lee is currently offline Elliot Lee
Messages: 4
Registered: July 2009
Junior Member
Hi Gustavo,

Thanks for your reply. After wiping my ~/.eclipse directory and
reinstalling the nightly build of MTJ, I checked in 'About ->
Configuration Details' and the following relevant plugins are listed:

org.eclipse.mtj.core (0.9.1.200812300802) "MTJ Core Plug-in (Incubation)"
[Installed]
org.eclipse.mtj.core.hooks (0.9.0.200812300802) "MTJ Core Hooks Plug-in
(Incubation)" [Starting]
org.eclipse.mtj.core.library (0.9.1.200812300802) "MTJ Library Plug-in
(Incubation)" [Installed]
org.eclipse.mtj.core.preverifier (0.9.0.200812300802) "MTJ Preverifier
Plug-in (Incubation)" [Starting]
org.eclipse.mtj.doc.user (0.9.0.200812300802) "MTJ User Documentation
Plug-in (Incubation)" [Resolved]
org.eclipse.mtj.jmunit (0.9.1.200812300802) "MTJ JMUnit support Plug-in
(Incubation)" [Installed]
org.eclipse.mtj.toolkit.microemu (0.9.1.200812300802) "MTJ Microemulator
Support Plug-in (Incubation)" [Installed]
org.eclipse.mtj.toolkit.mpowerplayer (0.9.1.200812300802) "MTJ
Mpowerplayer Support Plug-in (Incubation)" [Installed]
org.eclipse.mtj.toolkit.uei (0.9.1.200812300802) "MTJ Base UEI Support
Plug-in (Incubation)" [Installed]
org.eclipse.mtj.ui (0.9.1.200812300802) "MTJ UI Plug-in (Incubation)"
[Installed]

I'm not sure how to proceed from here. I doubt x86_64 is the problem. I do
wonder why the "Core Hooks" and "Core Preverifier" plugins are listed as
"Starting" instead of "Installed".

BTW, the version on a bunch of these is listed as 0.9.0.200812300802 in
the config details dialog, even though in About -> Features, the "Mobile
Tools..." features are listed as version 0.9.1.200812300802.

Take care,
-- Elliot
Re: Installation problems on Linux/x64 [message #24553 is a reply to message #24511] Wed, 31 December 2008 14:37 Go to previous messageGo to next message
Gustavo de Paula is currently offline Gustavo de Paula
Messages: 118
Registered: July 2009
Senior Member
hi elliot,

about the version, some of the plugins are still in 0.9.0 version since
they were not changed from 0.9.0 to 0.9.1 releases.

can you see the installable units on the "Help->Software
Updates->Installed Sofware" ?

can you see the menus to create MIDlet project? File->New
Project->JavaME->MIDletProject

it is strange that you can't see JavaME on the preferences pages. we
hanven't got any error report on that specific platform. i will be back to
office next week and i will try MTJ on fedora to see if there is any
issue. i'm using it right now on ubuntu with eclipse 3.4.1 and everything
works fine

:)
gep
Re: Installation problems on Linux/x64 [message #24911 is a reply to message #24511] Thu, 08 January 2009 20:03 Go to previous messageGo to next message
Eclipse User
Originally posted by: craigjunk.setera.org

Are there any errors in your workspace log that would tell more about
why the plugins don't appear to be correctly loading?

Elliot Lee wrote:
> Hi Gustavo,
>
> Thanks for your reply. After wiping my ~/.eclipse directory and
> reinstalling the nightly build of MTJ, I checked in 'About ->
> Configuration Details' and the following relevant plugins are listed:
>
> org.eclipse.mtj.core (0.9.1.200812300802) "MTJ Core Plug-in
> (Incubation)" [Installed]
> org.eclipse.mtj.core.hooks (0.9.0.200812300802) "MTJ Core Hooks Plug-in
> (Incubation)" [Starting]
> org.eclipse.mtj.core.library (0.9.1.200812300802) "MTJ Library Plug-in
> (Incubation)" [Installed]
> org.eclipse.mtj.core.preverifier (0.9.0.200812300802) "MTJ Preverifier
> Plug-in (Incubation)" [Starting]
> org.eclipse.mtj.doc.user (0.9.0.200812300802) "MTJ User Documentation
> Plug-in (Incubation)" [Resolved]
> org.eclipse.mtj.jmunit (0.9.1.200812300802) "MTJ JMUnit support Plug-in
> (Incubation)" [Installed]
> org.eclipse.mtj.toolkit.microemu (0.9.1.200812300802) "MTJ Microemulator
> Support Plug-in (Incubation)" [Installed]
> org.eclipse.mtj.toolkit.mpowerplayer (0.9.1.200812300802) "MTJ
> Mpowerplayer Support Plug-in (Incubation)" [Installed]
> org.eclipse.mtj.toolkit.uei (0.9.1.200812300802) "MTJ Base UEI Support
> Plug-in (Incubation)" [Installed]
> org.eclipse.mtj.ui (0.9.1.200812300802) "MTJ UI Plug-in (Incubation)"
> [Installed]
>
> I'm not sure how to proceed from here. I doubt x86_64 is the problem. I
> do wonder why the "Core Hooks" and "Core Preverifier" plugins are listed
> as "Starting" instead of "Installed".
>
> BTW, the version on a bunch of these is listed as 0.9.0.200812300802 in
> the config details dialog, even though in About -> Features, the "Mobile
> Tools..." features are listed as version 0.9.1.200812300802.
>
> Take care,
> -- Elliot
>
Re: Installation problems on Linux/x64 [message #551751 is a reply to message #24429] Mon, 09 August 2010 08:58 Go to previous messageGo to next message
No real name is currently offline No real name
Messages: 6
Registered: August 2010
Junior Member
I'm using Ubuntu 10.04 x64 and I've the same problem. The MTJ plugin is correctly installed, but there isn't "Java ME" in the preferences, and there isn't the possibility to create a "Java ME" project.
Could you help me?
Re: Installation problems on Linux/x64 [message #551753 is a reply to message #551751] Mon, 09 August 2010 09:06 Go to previous messageGo to next message
No real name is currently offline No real name
Messages: 6
Registered: August 2010
Junior Member
In Help -> Software Updates -> Manage configuration... there are the plugins, but their status is "The feature is not configured properly.".
Reasons:
No plug-in: "org.eclipse.mtj.pulsar.core" included at runtime.
No plug-in: "org.eclipse.mtj.pulsar.ui" included at runtime.
No plug-in: "org.eclipse.mtj.examples.jadextension" included at runtime.
No plug-in: "org.eclipse.mtj.examples.source" included at runtime.
No plug-in: "org.eclipse.mtj.example.library" included at runtime.
No plug-in: "org.eclipse.mtj.examples.toolkits" included at runtime.
No plug-in: "org.eclipse.mtj.examples.templates" included at runtime.
No plug-in: "org.eclipse.mtj.examples.toolkit.sdkprovidertestclamp" included at runtime.
No plug-in: "org.eclipse.mtj.examples.toolkit.sdkprovidertestclamp2" included at runtime.

And other..
Re: Installation problems on Linux/x64 [message #551766 is a reply to message #551753] Mon, 09 August 2010 09:44 Go to previous message
No real name is currently offline No real name
Messages: 6
Registered: August 2010
Junior Member
I've reinstalled the plugins, and now they are correctly installed without any error in the status.
But there isn't "Java ME" in the Preferences nor in the creation of a new project.
In the workspace there isn't any log. In the configuration the plugins are correctly listed, and the error log is empty.
Re: Installation problems on Linux/x64 [message #569394 is a reply to message #24429] Tue, 30 December 2008 19:37 Go to previous message
Gustavo de Paula is currently offline Gustavo de Paula
Messages: 118
Registered: July 2009
Senior Member
hi elliot,

we never tested mtj on this specific platform, but as far as there is no
reason of why it won't run.

are you able to see MTJ installable units on the "software updates /
installed software" menu? which IU can you see and what is their versions?
other option is to check if MTJ plugins are listed as installed on the
"About / Plugin details" menu

regards,
:)
gep

Elliot Lee wrote:

> Hi,

> I'm running Eclipse 3.4.1 on Fedora 10/x64, and trying to get MTJ 0.9.1
> installed. The update manager installs the plugins just fine, but when I
> restart eclipse and go to "preferences", there is no "Java ME" section in
> the list.

> I have tried installing both the 0.9.1 release, and the nightly build,
> with no success. Are there any suggestions that might help me get this
> working?

> Thanks,
> -- Elliot
Re: Installation problems on Linux/x64 [message #569408 is a reply to message #24470] Wed, 31 December 2008 12:24 Go to previous message
Elliot Lee is currently offline Elliot Lee
Messages: 4
Registered: July 2009
Junior Member
Hi Gustavo,

Thanks for your reply. After wiping my ~/.eclipse directory and
reinstalling the nightly build of MTJ, I checked in 'About ->
Configuration Details' and the following relevant plugins are listed:

org.eclipse.mtj.core (0.9.1.200812300802) "MTJ Core Plug-in (Incubation)"
[Installed]
org.eclipse.mtj.core.hooks (0.9.0.200812300802) "MTJ Core Hooks Plug-in
(Incubation)" [Starting]
org.eclipse.mtj.core.library (0.9.1.200812300802) "MTJ Library Plug-in
(Incubation)" [Installed]
org.eclipse.mtj.core.preverifier (0.9.0.200812300802) "MTJ Preverifier
Plug-in (Incubation)" [Starting]
org.eclipse.mtj.doc.user (0.9.0.200812300802) "MTJ User Documentation
Plug-in (Incubation)" [Resolved]
org.eclipse.mtj.jmunit (0.9.1.200812300802) "MTJ JMUnit support Plug-in
(Incubation)" [Installed]
org.eclipse.mtj.toolkit.microemu (0.9.1.200812300802) "MTJ Microemulator
Support Plug-in (Incubation)" [Installed]
org.eclipse.mtj.toolkit.mpowerplayer (0.9.1.200812300802) "MTJ
Mpowerplayer Support Plug-in (Incubation)" [Installed]
org.eclipse.mtj.toolkit.uei (0.9.1.200812300802) "MTJ Base UEI Support
Plug-in (Incubation)" [Installed]
org.eclipse.mtj.ui (0.9.1.200812300802) "MTJ UI Plug-in (Incubation)"
[Installed]

I'm not sure how to proceed from here. I doubt x86_64 is the problem. I do
wonder why the "Core Hooks" and "Core Preverifier" plugins are listed as
"Starting" instead of "Installed".

BTW, the version on a bunch of these is listed as 0.9.0.200812300802 in
the config details dialog, even though in About -> Features, the "Mobile
Tools..." features are listed as version 0.9.1.200812300802.

Take care,
-- Elliot
Re: Installation problems on Linux/x64 [message #569436 is a reply to message #24511] Wed, 31 December 2008 14:37 Go to previous message
Gustavo de Paula is currently offline Gustavo de Paula
Messages: 118
Registered: July 2009
Senior Member
hi elliot,

about the version, some of the plugins are still in 0.9.0 version since
they were not changed from 0.9.0 to 0.9.1 releases.

can you see the installable units on the "Help->Software
Updates->Installed Sofware" ?

can you see the menus to create MIDlet project? File->New
Project->JavaME->MIDletProject

it is strange that you can't see JavaME on the preferences pages. we
hanven't got any error report on that specific platform. i will be back to
office next week and i will try MTJ on fedora to see if there is any
issue. i'm using it right now on ubuntu with eclipse 3.4.1 and everything
works fine

:)
gep
Re: Installation problems on Linux/x64 [message #569810 is a reply to message #24511] Thu, 08 January 2009 20:03 Go to previous message
Craig Setera is currently offline Craig Setera
Messages: 54
Registered: July 2009
Member
Are there any errors in your workspace log that would tell more about
why the plugins don't appear to be correctly loading?

Elliot Lee wrote:
> Hi Gustavo,
>
> Thanks for your reply. After wiping my ~/.eclipse directory and
> reinstalling the nightly build of MTJ, I checked in 'About ->
> Configuration Details' and the following relevant plugins are listed:
>
> org.eclipse.mtj.core (0.9.1.200812300802) "MTJ Core Plug-in
> (Incubation)" [Installed]
> org.eclipse.mtj.core.hooks (0.9.0.200812300802) "MTJ Core Hooks Plug-in
> (Incubation)" [Starting]
> org.eclipse.mtj.core.library (0.9.1.200812300802) "MTJ Library Plug-in
> (Incubation)" [Installed]
> org.eclipse.mtj.core.preverifier (0.9.0.200812300802) "MTJ Preverifier
> Plug-in (Incubation)" [Starting]
> org.eclipse.mtj.doc.user (0.9.0.200812300802) "MTJ User Documentation
> Plug-in (Incubation)" [Resolved]
> org.eclipse.mtj.jmunit (0.9.1.200812300802) "MTJ JMUnit support Plug-in
> (Incubation)" [Installed]
> org.eclipse.mtj.toolkit.microemu (0.9.1.200812300802) "MTJ Microemulator
> Support Plug-in (Incubation)" [Installed]
> org.eclipse.mtj.toolkit.mpowerplayer (0.9.1.200812300802) "MTJ
> Mpowerplayer Support Plug-in (Incubation)" [Installed]
> org.eclipse.mtj.toolkit.uei (0.9.1.200812300802) "MTJ Base UEI Support
> Plug-in (Incubation)" [Installed]
> org.eclipse.mtj.ui (0.9.1.200812300802) "MTJ UI Plug-in (Incubation)"
> [Installed]
>
> I'm not sure how to proceed from here. I doubt x86_64 is the problem. I
> do wonder why the "Core Hooks" and "Core Preverifier" plugins are listed
> as "Starting" instead of "Installed".
>
> BTW, the version on a bunch of these is listed as 0.9.0.200812300802 in
> the config details dialog, even though in About -> Features, the "Mobile
> Tools..." features are listed as version 0.9.1.200812300802.
>
> Take care,
> -- Elliot
>
Re: Installation problems on Linux/x64 [message #581275 is a reply to message #24429] Mon, 09 August 2010 08:58 Go to previous message
No real name is currently offline No real name
Messages: 6
Registered: August 2010
Junior Member
I'm using Ubuntu 10.04 x64 and I've the same problem. The MTJ plugin is correctly installed, but there isn't "Java ME" in the preferences, and there isn't the possibility to create a "Java ME" project.
Could you help me?
Previous Topic:persistance
Next Topic:Re: Installation problems on Linux/x64
Goto Forum:
  


Current Time: Sun Apr 20 15:57:33 EDT 2014

Powered by FUDForum. Page generated in 0.13074 seconds