Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » GEF » Issue with editPart.setFocus(boolean) method?
Issue with editPart.setFocus(boolean) method? [message #247237] Thu, 12 February 2009 06:19 Go to next message
Madhu Samuel is currently offline Madhu Samuel
Messages: 199
Registered: July 2009
Senior Member
Hello Newsgroup,

Good Morning!

I have an issue with editPart.setFocus(boolean) method.

I am using the Eclipse 3.4, GEF 3.4 environment.

When I invoke the editPart.setFocus(true) I expect to see a dashed line
around my figure associated with the editPart. This dashed line denotes
that the focus is over it. But the dashed line does not appear.

As a workaround, the below code snippet gives me the dashed line.

editPart.setSelected(1);
editPart.setFocus(true);
editPart.setSelected(0);

That means, the focus is drawn correctly if I invoke the setFocus() after
the setSelected() method.

I even tried editPart.refresh() soon after invoking the setFocus(true),
but still it does not draw the dashed line.

But editPart.setFocus(true) works correctly in Eclipse 3.2, GEF 3.2.1
environment.

Gef committers,

Can you please check whether this is a bug or whether this is a problem
with the way I am using the setFocus().

If you feel that this is a bug, I will add this to the bugzilla.


Thanks,
Madhu


Re: Issue with editPart.setFocus(boolean) method? [message #247258 is a reply to message #247237] Thu, 12 February 2009 18:06 Go to previous message
Anthony Hunter is currently offline Anthony Hunter
Messages: 446
Registered: July 2009
Senior Member
Hi Madhu,

If you raise a Bugzilla with the snippet that works in GEF 3.2.1 and does
not work in GEF 3.4 we can check it out.

Cheers...
Anthony

"Madhu Samuel" <madhu.samuel@in.bosch.com> wrote in message
news:241d543b70a565dd412fe9a41af7eb1b$1@www.eclipse.org...
> Hello Newsgroup,
>
> Good Morning!
>
> I have an issue with editPart.setFocus(boolean) method.
> I am using the Eclipse 3.4, GEF 3.4 environment.
>
> When I invoke the editPart.setFocus(true) I expect to see a dashed line
> around my figure associated with the editPart. This dashed line denotes
> that the focus is over it. But the dashed line does not appear.
>
> As a workaround, the below code snippet gives me the dashed line.
> editPart.setSelected(1);
> editPart.setFocus(true);
> editPart.setSelected(0);
>
> That means, the focus is drawn correctly if I invoke the setFocus() after
> the setSelected() method.
>
> I even tried editPart.refresh() soon after invoking the setFocus(true),
> but still it does not draw the dashed line.
>
> But editPart.setFocus(true) works correctly in Eclipse 3.2, GEF 3.2.1
> environment.
>
> Gef committers,
> Can you please check whether this is a bug or whether this is a problem
> with the way I am using the setFocus().
>
> If you feel that this is a bug, I will add this to the bugzilla.
>
>
> Thanks,
> Madhu
>
Previous Topic:add border shape
Next Topic:[Announce] GEF 3.4.2RC2 is available
Goto Forum:
  


Current Time: Fri Oct 31 10:14:34 GMT 2014

Powered by FUDForum. Page generated in 0.02578 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software