Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » GEF » [Zest] Zest Layouts
[Zest] Zest Layouts [message #247218] Wed, 11 February 2009 11:47 Go to next message
as Missing name is currently offline as Missing name
Messages: 33
Registered: July 2009
Member
Hi Ian,

i have to display some dependencies with the help of
zest and the jgrapht library, i use the DirectedGraph
class from this library as an input to the GraphViewer
from zest.

At the moment i have a problem with layouts.

Just like in the org.eclipse.pde.visualization.dependency
example i use the CompositeLayoutAlgorithm which is
composed of the DirectedGraphLayoutAlgorithm and HorizontalShift.
Only HorizontalShift seems to be applied.

Could you please review the snippet on this location, its a
little example of my situation(you can import it as a project
and open the view with an action in the main tool bar) :

http://depositfiles.com/files/uax112e5c

What could be the reason for such a behaviour ?
What am i doing wrong ?

thank you for help
Re: [Zest] Zest Layouts [message #247284 is a reply to message #247218] Fri, 13 February 2009 16:46 Go to previous message
Eclipse User
Originally posted by: irbull.cs.uvic.ca

Yes, the one in Zest removes the horizontal placement. this is a bug
(We actually do this on purpose because the horizontal placement is
slow, I then manually place it myself).

Can you open a bug

cheers,
ian

Aleksey wrote:
> Hi Ian,
>
> i have to display some dependencies with the help of
> zest and the jgrapht library, i use the DirectedGraph
> class from this library as an input to the GraphViewer from zest.
>
> At the moment i have a problem with layouts.
>
> Just like in the org.eclipse.pde.visualization.dependency
> example i use the CompositeLayoutAlgorithm which is
> composed of the DirectedGraphLayoutAlgorithm and HorizontalShift.
> Only HorizontalShift seems to be applied.
>
> Could you please review the snippet on this location, its a little
> example of my situation(you can import it as a project
> and open the view with an action in the main tool bar) :
> http://depositfiles.com/files/uax112e5c
>
> What could be the reason for such a behaviour ?
> What am i doing wrong ?
>
> thank you for help
>
>
Previous Topic:[Zest] GraphConnection
Next Topic:[Zest] Graph not pretty
Goto Forum:
  


Current Time: Wed Sep 24 00:33:19 GMT 2014

Powered by FUDForum. Page generated in 0.01821 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software