Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Installed Facet Version problem(cannot install project facet XXX some version of this project facet is already installed)
Installed Facet Version problem [message #1397180] Wed, 09 July 2014 10:18 Go to next message
Rani NageshBabu is currently offline Rani NageshBabuFriend
Messages: 4
Registered: July 2014
Junior Member
Hi,

Installed my own facet project say version 1.0.0, name ABC
Delete this project (Do not delete its content)
Now create same faceted project with same name ABC and performFinish. Gives the following error message dialog.

One or more constraints have not been satisfied.
Cannot install project facet JavaScript 1.0. Some version of this project facet is already installed.
Cannot install project facet Mobile Application 1.0.0. Some version of this project facet is already installed.

On click of OK, the project gets installed but with incomplete model.

How can we handle this exception ?

Regards
Rani
Re: Installed Facet Version problem [message #1397384 is a reply to message #1397180] Wed, 09 July 2014 16:44 Go to previous messageGo to next message
Roberto Sanchez Herrera is currently offline Roberto Sanchez HerreraFriend
Messages: 32
Registered: January 2011
Member
Hi,
If you are using the new faceted project wizard, then this looks like a bug. If you try to do the same in other WTP wizards like Dynamic web project, the project name is validated, and you will see an error similar to this:

"A project already exists on the file system at this location: C:\ABC. Either use "Import Existing Projects into Workspace" to create a project at this location or delete the contents of C:\ABC from the file system."
Re: Installed Facet Version problem [message #1397756 is a reply to message #1397384] Thu, 10 July 2014 05:45 Go to previous messageGo to next message
Rani NageshBabu is currently offline Rani NageshBabuFriend
Messages: 4
Registered: July 2014
Junior Member
Yes, its faceted project wizard.
Re: Installed Facet Version problem [message #1398045 is a reply to message #1397756] Thu, 10 July 2014 14:20 Go to previous messageGo to next message
Roberto Sanchez Herrera is currently offline Roberto Sanchez HerreraFriend
Messages: 32
Registered: January 2011
Member
In that case, if you really think this is blocking you,I suggest to open a bug (https://bugs.eclipse.org/bugs/enter_bug.cgi?product=WTP%20Common%20Tools) against faceted project framework to validate the existence of the project.

Re: Installed Facet Version problem [message #1398093 is a reply to message #1398045] Thu, 10 July 2014 15:54 Go to previous message
Rani NageshBabu is currently offline Rani NageshBabuFriend
Messages: 4
Registered: July 2014
Junior Member
https://bugs.eclipse.org/bugs/show_bug.cgi?id=439362
Previous Topic:JSDT: impossible to use in an middle Java/JavaScript project
Next Topic:Is it possible to share server configurations?
Goto Forum:
  


Current Time: Tue Dec 23 02:23:28 GMT 2014

Powered by FUDForum. Page generated in 0.01783 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software