Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » GEF » Router problem
Router problem [message #244489] Tue, 22 July 2008 16:33 Go to next message
Eclipse User
Originally posted by: yassine.atter.anyware-tech.com

Hi,
I'm using Zest to create a graph with two types of nodes. I create my
own layout which extends a treelayoutalgorithm.
I have a little problem: the connections between nodes are curved. I
want to have horizontal connections. I think It will be fine if I use a
Manhattan Router but I don't know where??

thank'a in advance.
Re: Router problem [message #244562 is a reply to message #244489] Fri, 25 July 2008 12:42 Go to previous message
Eclipse User
Originally posted by: yassine.atter.anyware-tech.com

Atter Yassine a écrit :
> Hi,
> I'm using Zest to create a graph with two types of nodes. I create my
> own layout which extends a treelayoutalgorithm.
> I have a little problem: the connections between nodes are curved. I
> want to have horizontal connections. I think It will be fine if I use a
> Manhattan Router but I don't know where??
>
> thank'a in advance.


Hi again,
I have created my own router and of course my own route method (which
creates horizontal connections between two given points) and it works!!
In fact, there is also another "little" problem, I can't set the anchor
of my figures! Any idea?

Thank's.
Previous Topic:Toolbarproblem
Next Topic:SnapToGrid with odd grid spacing
Goto Forum:
  


Current Time: Fri Oct 31 08:03:13 GMT 2014

Powered by FUDForum. Page generated in 0.01713 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software