Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Getting javahl 1.4.5 to work on windows xp
Getting javahl 1.4.5 to work on windows xp [message #24010] Wed, 02 July 2008 20:43 Go to next message
Keith Fetterman is currently offline Keith Fetterman
Messages: 15
Registered: July 2009
Junior Member
I am trying to get JavaHL 1.4.5 to work on Windows XP with Subversive
0.7.1 and I keep getting the following error message when I try to
create a new repository location in the SVN Repository Perspective:

The system cannot find the file specified
svn: can't create tunnel: the system cannot find the file specified

I am using the svn+ssh: protocol to connect to the repository.

Do I need to install some external software that JavaHL needs to access?
I can't find any documentation that covers this.

I currently have following subversive and svn connectors installed in my
Eclipse 3.3.2:

JavaHL 1.4.5 Win32 Binaries 2.0.1
Native JavaHL 1.4.5 Implementation 2.0.1
Subversive SVN Connectors 2.0.1
SVN Team Provider 0.7.1
SVN Team Provider Localization 0.7.1

I am successfully connecting to the repository using Eclipe 3.3.2 on
Linux using JavaHL 1.4.4.

Any suggestions would really be appreciated.

Thanks,
Keith

ps. I have tried using SVNKit 1.1.7 on both Windows XP and Linux and I
have had no luck with it when using the svn+ssh protocol, which is why I
am now trying to get the JavaHL connector to work.
Re: Getting javahl 1.4.5 to work on windows xp [message #24102 is a reply to message #24010] Wed, 02 July 2008 23:13 Go to previous messageGo to next message
Werner Keil is currently offline Werner Keil
Messages: 1083
Registered: July 2009
Senior Member
I had a similar problem with JavaHL 1.4.5 on XP under Ganymede Final, too.

After Subversive gets looked up/installed via the Ganymede Update
Manager it still is missing the connector.

Once this is installed, any active SVN enabled Eclipse project trying to
sync with the SVN repository causes Eclipse to freeze or crash entirely !!!

This is the same for the other Win32 Native connector btw, so it sounds
like a problem similar to what is described below (I'm not using SSH
tunneling, but the same works on this Mac without a crash)

Werner


Keith Fetterman wrote:
> I am trying to get JavaHL 1.4.5 to work on Windows XP with Subversive
> 0.7.1 and I keep getting the following error message when I try to
> create a new repository location in the SVN Repository Perspective:
>
> The system cannot find the file specified
> svn: can't create tunnel: the system cannot find the file specified
>
> I am using the svn+ssh: protocol to connect to the repository.
>
> Do I need to install some external software that JavaHL needs to access?
> I can't find any documentation that covers this.
>
> I currently have following subversive and svn connectors installed in my
> Eclipse 3.3.2:
>
> JavaHL 1.4.5 Win32 Binaries 2.0.1
> Native JavaHL 1.4.5 Implementation 2.0.1
> Subversive SVN Connectors 2.0.1
> SVN Team Provider 0.7.1
> SVN Team Provider Localization 0.7.1
>
> I am successfully connecting to the repository using Eclipe 3.3.2 on
> Linux using JavaHL 1.4.4.
>
> Any suggestions would really be appreciated.
>
> Thanks,
> Keith
>
> ps. I have tried using SVNKit 1.1.7 on both Windows XP and Linux and I
> have had no luck with it when using the svn+ssh protocol, which is why I
> am now trying to get the JavaHL connector to work.
Re: Getting javahl 1.4.5 to work on windows xp [message #24107 is a reply to message #24010] Thu, 03 July 2008 03:31 Go to previous messageGo to next message
Keith Fetterman is currently offline Keith Fetterman
Messages: 15
Registered: July 2009
Junior Member
Do I need a separate svn client, like TortoiseSVN, installed on my
Windows XP to be able to use JavaHL 1.4.5?

Keith Fetterman wrote:
> I am trying to get JavaHL 1.4.5 to work on Windows XP with Subversive
> 0.7.1 and I keep getting the following error message when I try to
> create a new repository location in the SVN Repository Perspective:
>
> The system cannot find the file specified
> svn: can't create tunnel: the system cannot find the file specified
>
> I am using the svn+ssh: protocol to connect to the repository.
>
> Do I need to install some external software that JavaHL needs to access?
> I can't find any documentation that covers this.
>
> I currently have following subversive and svn connectors installed in my
> Eclipse 3.3.2:
>
> JavaHL 1.4.5 Win32 Binaries 2.0.1
> Native JavaHL 1.4.5 Implementation 2.0.1
> Subversive SVN Connectors 2.0.1
> SVN Team Provider 0.7.1
> SVN Team Provider Localization 0.7.1
>
> I am successfully connecting to the repository using Eclipe 3.3.2 on
> Linux using JavaHL 1.4.4.
>
> Any suggestions would really be appreciated.
>
> Thanks,
> Keith
>
> ps. I have tried using SVNKit 1.1.7 on both Windows XP and Linux and I
> have had no luck with it when using the svn+ssh protocol, which is why I
> am now trying to get the JavaHL connector to work.
Re: Getting javahl 1.4.5 to work on windows xp [message #24172 is a reply to message #24107] Thu, 03 July 2008 05:38 Go to previous message
Alexei Goncharov is currently offline Alexei Goncharov
Messages: 35
Registered: July 2009
Member
No, you don't need to install the separate client.
The problem seems to refer to wrong tunneling configuration for your
network.
The native client does not include svn+ssh support, so the tunnel should
be created and configured using some external tool (ex. PUTTY).

Keith Fetterman wrote:

> Do I need a separate svn client, like TortoiseSVN, installed on my
> Windows XP to be able to use JavaHL 1.4.5?

> Keith Fetterman wrote:
>> I am trying to get JavaHL 1.4.5 to work on Windows XP with Subversive
>> 0.7.1 and I keep getting the following error message when I try to
>> create a new repository location in the SVN Repository Perspective:
>>
>> The system cannot find the file specified
>> svn: can't create tunnel: the system cannot find the file specified
>>
>> I am using the svn+ssh: protocol to connect to the repository.
>>
>> Do I need to install some external software that JavaHL needs to access?
>> I can't find any documentation that covers this.
>>
>> I currently have following subversive and svn connectors installed in my
>> Eclipse 3.3.2:
>>
>> JavaHL 1.4.5 Win32 Binaries 2.0.1
>> Native JavaHL 1.4.5 Implementation 2.0.1
>> Subversive SVN Connectors 2.0.1
>> SVN Team Provider 0.7.1
>> SVN Team Provider Localization 0.7.1
>>
>> I am successfully connecting to the repository using Eclipe 3.3.2 on
>> Linux using JavaHL 1.4.4.
>>
>> Any suggestions would really be appreciated.
>>
>> Thanks,
>> Keith
>>
>> ps. I have tried using SVNKit 1.1.7 on both Windows XP and Linux and I
>> have had no luck with it when using the svn+ssh protocol, which is why I
>> am now trying to get the JavaHL connector to work.
Previous Topic:Ganymede Subversive - Compare/Replace with version from Repository
Next Topic:Why isn't merge finding any changes?
Goto Forum:
  


Current Time: Tue Jul 22 07:41:21 EDT 2014

Powered by FUDForum. Page generated in 0.28075 seconds