Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » "File name too long" in oomph.p2/cache
"File name too long" in oomph.p2/cache [message #1388241] Thu, 26 June 2014 06:56 Go to next message
Benjamin Schwertfeger is currently offline Benjamin SchwertfegerFriend
Messages: 49
Registered: July 2009
Member
Hello,
I have a very long URL (210 characters) in the target platform definition, which is because the repository is inside nexus and the unzip-plugin is used. Oomph tries to cache the artifacts but fails because the Mac OS X file system does not support the 330 character long path and file name.

Is there a way to disable the cache or change the format?

Thanks
Benjamin
Re: "File name too long" in oomph.p2/cache [message #1388249 is a reply to message #1388241] Thu, 26 June 2014 07:13 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 26278
Registered: July 2009
Senior Member
Benjamin,

We hadn't consider that limitation! Please open a bugzilla, preferably
with a URL illustrating the problem. We'll try to address that as soon
as possible.


On 26/06/2014 8:56 AM, Benjamin Schwertfeger wrote:
> Hello,
> I have a very long URL (210 characters) in the target platform
> definition, which is because the repository is inside nexus and the
> unzip-plugin is used. Oomph tries to cache the artifacts but fails
> because the Mac OS X file system does not support the 330 character
> long path and file name.
>
> Is there a way to disable the cache or change the format?
>
> Thanks
> Benjamin
Re: "File name too long" in oomph.p2/cache [message #1388250 is a reply to message #1388241] Thu, 26 June 2014 07:14 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 5586
Registered: July 2009
Senior Member
Hi Benjamin,

Please submit a bugzilla ( https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Oomph&component=Setup&version=1.0.0 ) so
that I can fix the problem.

Meanwhile you can disable the offline cache completely with the internal switch -Doomph.p2.disable.offline=true

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper


Am 26.06.2014 08:56, schrieb Benjamin Schwertfeger:
> Hello,
> I have a very long URL (210 characters) in the target platform definition, which is because the repository is inside
> nexus and the unzip-plugin is used. Oomph tries to cache the artifacts but fails because the Mac OS X file system does
> not support the 330 character long path and file name.
>
> Is there a way to disable the cache or change the format?
>
> Thanks
> Benjamin
Re: "File name too long" in oomph.p2/cache [message #1388269 is a reply to message #1388250] Thu, 26 June 2014 07:43 Go to previous message
Benjamin Schwertfeger is currently offline Benjamin SchwertfegerFriend
Messages: 49
Registered: July 2009
Member
Thanks, I have created https://bugs.eclipse.org/bugs/show_bug.cgi?id=438226.

Benjamin
Previous Topic:Target container doesn't include SWT native fragment
Next Topic:Import projects from Git repository into the workspace
Goto Forum:
  


Current Time: Thu Dec 18 07:34:30 GMT 2014

Powered by FUDForum. Page generated in 0.25217 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software