Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Version constraints in requirements for Targlet and P2
Version constraints in requirements for Targlet and P2 [message #1387178] Tue, 24 June 2014 16:27 Go to next message
Abel Hegedus is currently offline Abel Hegedus
Messages: 98
Registered: July 2009
Member
I am trying to create a setup that uses specific versions of given features (e.g. Xtext 2.4.2). However, after setting the precise version in the requirement in the setup model (copied from a target definition, e.g. 2.4.2.v201306120542), I get an exception during the execution of the Targlet task, that Xtext 2.6.1 and another feature that depends on Xtext 2.4 cannot be installed in the same time.

Am I using the version attribute incorrectly or this use case is not supported? I could not find any setup file that used the version attribute.

!ENTRY org.eclipse.equinox.p2.director 4 10054 2014-06-24 17:00:11.834
!MESSAGE Cannot complete the install because of a conflicting dependency.
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
!MESSAGE Software being installed: EMF-IncQuery SDK (Incubation) 0.7.2.201402181114 (org.eclipse.incquery.sdk.feature.source.feature.group 0.7.2.201402181114)
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
!MESSAGE Software being installed: Xtext SDK 2.6.1.v201406120726 (org.eclipse.xtext.sdk.feature.group 2.6.1.v201406120726)
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.834
!MESSAGE Only one of the following can be installed at once:
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
!MESSAGE Xbase Model 2.6.1.v201406120726 (org.eclipse.xtext.xbase 2.6.1.v201406120726)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
!MESSAGE Xbase Model 2.5.2.v201402120812 (org.eclipse.xtext.xbase 2.5.2.v201402120812)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
!MESSAGE Xbase Model 2.5.4.v201404100756 (org.eclipse.xtext.xbase 2.5.4.v201404100756)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
!MESSAGE Xbase Model 2.4.3.v201309030823 (org.eclipse.xtext.xbase 2.4.3.v201309030823)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
!MESSAGE Xbase Model 2.5.3.v201402240820 (org.eclipse.xtext.xbase 2.5.3.v201402240820)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
!MESSAGE Xbase Model 2.6.0.v201405210727 (org.eclipse.xtext.xbase 2.6.0.v201405210727)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
!MESSAGE Xbase Model 2.5.0.v201312110906 (org.eclipse.xtext.xbase 2.5.0.v201312110906)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
!MESSAGE Xbase Model 2.4.2.v201306120542 (org.eclipse.xtext.xbase 2.4.2.v201306120542)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
!MESSAGE Xbase Model 2.5.1.v201402030714 (org.eclipse.xtext.xbase 2.5.1.v201402030714)
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.835
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
!MESSAGE From: EMF-IncQuery SDK (Incubation) without Sources 0.7.2.201402181114 (org.eclipse.incquery.sdk.feature.feature.group 0.7.2.201402181114)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
!MESSAGE To: org.eclipse.incquery.tooling.ui [0.7.2.201402181114]
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.835
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
!MESSAGE From: EMF-IncQuery SDK (Incubation) 0.7.2.201402181114 (org.eclipse.incquery.sdk.feature.source.feature.group 0.7.2.201402181114)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
!MESSAGE To: org.eclipse.incquery.sdk.feature.feature.group [0.7.2.201402181114]
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.835
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
!MESSAGE From: IncQuery Tooling - User Interface (Incubation) 0.7.2.201402181114 (org.eclipse.incquery.tooling.ui 0.7.2.201402181114)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
!MESSAGE To: bundle org.eclipse.xtext.xbase [2.4.2,2.5.0)
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.835
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
!MESSAGE From: Xtext SDK 2.6.1.v201406120726 (org.eclipse.xtext.sdk.feature.group 2.6.1.v201406120726)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
!MESSAGE To: org.eclipse.xtext.xbase.feature.group [2.6.1.v201406120726]
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.835
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
!MESSAGE From: Xbase 2.6.1.v201406120726 (org.eclipse.xtext.xbase.feature.group 2.6.1.v201406120726)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
!MESSAGE To: org.eclipse.xtext.xbase [2.6.1.v201406120726]

!ENTRY org.eclipse.pde.core 4 0 2014-06-24 17:00:11.854
!MESSAGE Problems occurred while resolving the target contents
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 10054 2014-06-24 17:00:11.854
!MESSAGE Cannot complete the install because of a conflicting dependency.
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
!MESSAGE Software being installed: EMF-IncQuery SDK (Incubation) 0.7.2.201402181114 (org.eclipse.incquery.sdk.feature.source.feature.group 0.7.2.201402181114)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
!MESSAGE Software being installed: Xtext SDK 2.6.1.v201406120726 (org.eclipse.xtext.sdk.feature.group 2.6.1.v201406120726)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.854
!MESSAGE Only one of the following can be installed at once:
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
!MESSAGE Xbase Model 2.6.1.v201406120726 (org.eclipse.xtext.xbase 2.6.1.v201406120726)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
!MESSAGE Xbase Model 2.5.2.v201402120812 (org.eclipse.xtext.xbase 2.5.2.v201402120812)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
!MESSAGE Xbase Model 2.5.4.v201404100756 (org.eclipse.xtext.xbase 2.5.4.v201404100756)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
!MESSAGE Xbase Model 2.4.3.v201309030823 (org.eclipse.xtext.xbase 2.4.3.v201309030823)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
!MESSAGE Xbase Model 2.5.3.v201402240820 (org.eclipse.xtext.xbase 2.5.3.v201402240820)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
!MESSAGE Xbase Model 2.6.0.v201405210727 (org.eclipse.xtext.xbase 2.6.0.v201405210727)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
!MESSAGE Xbase Model 2.5.0.v201312110906 (org.eclipse.xtext.xbase 2.5.0.v201312110906)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
!MESSAGE Xbase Model 2.4.2.v201306120542 (org.eclipse.xtext.xbase 2.4.2.v201306120542)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
!MESSAGE Xbase Model 2.5.1.v201402030714 (org.eclipse.xtext.xbase 2.5.1.v201402030714)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.854
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
!MESSAGE From: EMF-IncQuery SDK (Incubation) without Sources 0.7.2.201402181114 (org.eclipse.incquery.sdk.feature.feature.group 0.7.2.201402181114)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
!MESSAGE To: org.eclipse.incquery.tooling.ui [0.7.2.201402181114]
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.854
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
!MESSAGE From: EMF-IncQuery SDK (Incubation) 0.7.2.201402181114 (org.eclipse.incquery.sdk.feature.source.feature.group 0.7.2.201402181114)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
!MESSAGE To: org.eclipse.incquery.sdk.feature.feature.group [0.7.2.201402181114]
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.854
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
!MESSAGE From: IncQuery Tooling - User Interface (Incubation) 0.7.2.201402181114 (org.eclipse.incquery.tooling.ui 0.7.2.201402181114)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
!MESSAGE To: bundle org.eclipse.xtext.xbase [2.4.2,2.5.0)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.854
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
!MESSAGE From: Xtext SDK 2.6.1.v201406120726 (org.eclipse.xtext.sdk.feature.group 2.6.1.v201406120726)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.855
!MESSAGE To: org.eclipse.xtext.xbase.feature.group [2.6.1.v201406120726]
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.855
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.855
!MESSAGE From: Xbase 2.6.1.v201406120726 (org.eclipse.xtext.xbase.feature.group 2.6.1.v201406120726)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.855
!MESSAGE To: org.eclipse.xtext.xbase [2.6.1.v201406120726]
Re: Version constraints in requirements for Targlet and P2 [message #1387183 is a reply to message #1387178] Tue, 24 June 2014 17:16 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26141
Registered: July 2009
Senior Member
Abel,

It's not clear which repos and which units you've listed in the task.
When you say an exact version number I hope/assume you mean a range
including 2.4.0 but excluding 2.5.0. Better would be to attach the *.setup.


On 24/06/2014 6:27 PM, Abel Hegedus wrote:
> I am trying to create a setup that uses specific versions of given
> features (e.g. Xtext 2.4.2). However, after setting the precise
> version in the requirement in the setup model (copied from a target
> definition, e.g. 2.4.2.v201306120542), I get an exception during the
> execution of the Targlet task, that Xtext 2.6.1 and another feature
> that depends on Xtext 2.4 cannot be installed in the same time.
>
> Am I using the version attribute incorrectly or this use case is not
> supported? I could not find any setup file that used the version
> attribute.
>
> !ENTRY org.eclipse.equinox.p2.director 4 10054 2014-06-24 17:00:11.834
> !MESSAGE Cannot complete the install because of a conflicting dependency.
> !SUBENTRY 1 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
> !MESSAGE Software being installed: EMF-IncQuery SDK (Incubation)
> 0.7.2.201402181114
> (org.eclipse.incquery.sdk.feature.source.feature.group
> 0.7.2.201402181114)
> !SUBENTRY 1 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
> !MESSAGE Software being installed: Xtext SDK 2.6.1.v201406120726
> (org.eclipse.xtext.sdk.feature.group 2.6.1.v201406120726)
> !SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.834
> !MESSAGE Only one of the following can be installed at once: !SUBENTRY
> 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
> !MESSAGE Xbase Model 2.6.1.v201406120726 (org.eclipse.xtext.xbase
> 2.6.1.v201406120726)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
> !MESSAGE Xbase Model 2.5.2.v201402120812 (org.eclipse.xtext.xbase
> 2.5.2.v201402120812)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
> !MESSAGE Xbase Model 2.5.4.v201404100756 (org.eclipse.xtext.xbase
> 2.5.4.v201404100756)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
> !MESSAGE Xbase Model 2.4.3.v201309030823 (org.eclipse.xtext.xbase
> 2.4.3.v201309030823)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
> !MESSAGE Xbase Model 2.5.3.v201402240820 (org.eclipse.xtext.xbase
> 2.5.3.v201402240820)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
> !MESSAGE Xbase Model 2.6.0.v201405210727 (org.eclipse.xtext.xbase
> 2.6.0.v201405210727)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
> !MESSAGE Xbase Model 2.5.0.v201312110906 (org.eclipse.xtext.xbase
> 2.5.0.v201312110906)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
> !MESSAGE Xbase Model 2.4.2.v201306120542 (org.eclipse.xtext.xbase
> 2.4.2.v201306120542)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
> !MESSAGE Xbase Model 2.5.1.v201402030714 (org.eclipse.xtext.xbase
> 2.5.1.v201402030714)
> !SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.835
> !MESSAGE Cannot satisfy dependency:
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
> !MESSAGE From: EMF-IncQuery SDK (Incubation) without Sources
> 0.7.2.201402181114 (org.eclipse.incquery.sdk.feature.feature.group
> 0.7.2.201402181114)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
> !MESSAGE To: org.eclipse.incquery.tooling.ui [0.7.2.201402181114]
> !SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.835
> !MESSAGE Cannot satisfy dependency:
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
> !MESSAGE From: EMF-IncQuery SDK (Incubation) 0.7.2.201402181114
> (org.eclipse.incquery.sdk.feature.source.feature.group
> 0.7.2.201402181114)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
> !MESSAGE To: org.eclipse.incquery.sdk.feature.feature.group
> [0.7.2.201402181114]
> !SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.835
> !MESSAGE Cannot satisfy dependency:
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
> !MESSAGE From: IncQuery Tooling - User Interface (Incubation)
> 0.7.2.201402181114 (org.eclipse.incquery.tooling.ui 0.7.2.201402181114)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
> !MESSAGE To: bundle org.eclipse.xtext.xbase [2.4.2,2.5.0)
> !SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.835
> !MESSAGE Cannot satisfy dependency:
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
> !MESSAGE From: Xtext SDK 2.6.1.v201406120726
> (org.eclipse.xtext.sdk.feature.group 2.6.1.v201406120726)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
> !MESSAGE To: org.eclipse.xtext.xbase.feature.group [2.6.1.v201406120726]
> !SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.835
> !MESSAGE Cannot satisfy dependency:
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
> !MESSAGE From: Xbase 2.6.1.v201406120726
> (org.eclipse.xtext.xbase.feature.group 2.6.1.v201406120726)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
> !MESSAGE To: org.eclipse.xtext.xbase [2.6.1.v201406120726]
>
> !ENTRY org.eclipse.pde.core 4 0 2014-06-24 17:00:11.854
> !MESSAGE Problems occurred while resolving the target contents
> !SUBENTRY 1 org.eclipse.equinox.p2.director 4 10054 2014-06-24
> 17:00:11.854
> !MESSAGE Cannot complete the install because of a conflicting dependency.
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE Software being installed: EMF-IncQuery SDK (Incubation)
> 0.7.2.201402181114
> (org.eclipse.incquery.sdk.feature.source.feature.group
> 0.7.2.201402181114)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE Software being installed: Xtext SDK 2.6.1.v201406120726
> (org.eclipse.xtext.sdk.feature.group 2.6.1.v201406120726)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.854
> !MESSAGE Only one of the following can be installed at once: !SUBENTRY
> 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE Xbase Model 2.6.1.v201406120726 (org.eclipse.xtext.xbase
> 2.6.1.v201406120726)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE Xbase Model 2.5.2.v201402120812 (org.eclipse.xtext.xbase
> 2.5.2.v201402120812)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE Xbase Model 2.5.4.v201404100756 (org.eclipse.xtext.xbase
> 2.5.4.v201404100756)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE Xbase Model 2.4.3.v201309030823 (org.eclipse.xtext.xbase
> 2.4.3.v201309030823)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE Xbase Model 2.5.3.v201402240820 (org.eclipse.xtext.xbase
> 2.5.3.v201402240820)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE Xbase Model 2.6.0.v201405210727 (org.eclipse.xtext.xbase
> 2.6.0.v201405210727)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE Xbase Model 2.5.0.v201312110906 (org.eclipse.xtext.xbase
> 2.5.0.v201312110906)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE Xbase Model 2.4.2.v201306120542 (org.eclipse.xtext.xbase
> 2.4.2.v201306120542)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE Xbase Model 2.5.1.v201402030714 (org.eclipse.xtext.xbase
> 2.5.1.v201402030714)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.854
> !MESSAGE Cannot satisfy dependency:
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE From: EMF-IncQuery SDK (Incubation) without Sources
> 0.7.2.201402181114 (org.eclipse.incquery.sdk.feature.feature.group
> 0.7.2.201402181114)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE To: org.eclipse.incquery.tooling.ui [0.7.2.201402181114]
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.854
> !MESSAGE Cannot satisfy dependency:
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE From: EMF-IncQuery SDK (Incubation) 0.7.2.201402181114
> (org.eclipse.incquery.sdk.feature.source.feature.group
> 0.7.2.201402181114)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE To: org.eclipse.incquery.sdk.feature.feature.group
> [0.7.2.201402181114]
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.854
> !MESSAGE Cannot satisfy dependency:
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE From: IncQuery Tooling - User Interface (Incubation)
> 0.7.2.201402181114 (org.eclipse.incquery.tooling.ui 0.7.2.201402181114)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE To: bundle org.eclipse.xtext.xbase [2.4.2,2.5.0)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.854
> !MESSAGE Cannot satisfy dependency:
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE From: Xtext SDK 2.6.1.v201406120726
> (org.eclipse.xtext.sdk.feature.group 2.6.1.v201406120726)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.855
> !MESSAGE To: org.eclipse.xtext.xbase.feature.group [2.6.1.v201406120726]
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.855
> !MESSAGE Cannot satisfy dependency:
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.855
> !MESSAGE From: Xbase 2.6.1.v201406120726
> (org.eclipse.xtext.xbase.feature.group 2.6.1.v201406120726)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.855
> !MESSAGE To: org.eclipse.xtext.xbase [2.6.1.v201406120726]
>
Re: Version constraints in requirements for Targlet and P2 [message #1387184 is a reply to message #1387178] Tue, 24 June 2014 17:31 Go to previous messageGo to next message
Eike Stepper is currently offline Eike Stepper
Messages: 5545
Registered: July 2009
Senior Member
Hi Abdel,

Comments below...

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper



Am 24.06.2014 18:27, schrieb Abel Hegedus:
> I am trying to create a setup that uses specific versions of given features (e.g. Xtext 2.4.2). However, after setting
> the precise version in the requirement in the setup model (copied from a target definition, e.g. 2.4.2.v201306120542),
Please note that the PDE target definition file format allows you to specifiy *installable units* with optional (exact)
*versions*, i.e., "x.y.z.q". No version or "0.0.0" means any version (so more of a version range).

In Oomph we generally use *requirement* with *version ranges*, which is generally more flexible. The format is typically
"[min-version,max-version)" and there are two special forms:

1) "0.0.0" is the omni version range
2) "[version-x,version-x]" is exactly version-x

So you should use the format 2, but keep in mind that you run into unsatisfiable queries more likely the smaller these
ranges are. Trying it out is often your best option ;-)

Note also that in Oomph models you cannot enter syntactically wrong version ranges without seeing the parse error in the
status line.

> I get an exception during the execution of the Targlet task, that Xtext 2.6.1 and another feature that depends on
> Xtext 2.4 cannot be installed in the same time.
>
> Am I using the version attribute incorrectly or this use case is not supported? I could not find any setup file that
> used the version attribute.
That's just because most targlets mostly point to the *own* source components and leave it to them to pull in the
required binary components. Source components have a specific version in the workspace so there's no need to specify
verion ranges for them in the targlets.

After reformatting this lovely error message the problem becomes more apparent:

Cannot complete the install because of a conflicting dependency.
Software being installed: EMF-IncQuery SDK (Incubation) 0.7.2.201402181114
(org.eclipse.incquery.sdk.feature.source.feature.group 0.7.2.201402181114)
Software being installed: Xtext SDK 2.6.1.v201406120726 (org.eclipse.xtext.sdk.feature.group 2.6.1.v201406120726)
Only one of the following can be installed at once:
Xbase Model 2.6.1.v201406120726 (org.eclipse.xtext.xbase 2.6.1.v201406120726)
Xbase Model 2.5.2.v201402120812 (org.eclipse.xtext.xbase 2.5.2.v201402120812)
Xbase Model 2.5.4.v201404100756 (org.eclipse.xtext.xbase 2.5.4.v201404100756)
Xbase Model 2.4.3.v201309030823 (org.eclipse.xtext.xbase 2.4.3.v201309030823)
Xbase Model 2.5.3.v201402240820 (org.eclipse.xtext.xbase 2.5.3.v201402240820)
Xbase Model 2.6.0.v201405210727 (org.eclipse.xtext.xbase 2.6.0.v201405210727)
Xbase Model 2.5.0.v201312110906 (org.eclipse.xtext.xbase 2.5.0.v201312110906)
Xbase Model 2.4.2.v201306120542 (org.eclipse.xtext.xbase 2.4.2.v201306120542)
Xbase Model 2.5.1.v201402030714 (org.eclipse.xtext.xbase 2.5.1.v201402030714)
Cannot satisfy dependency:
From: EMF-IncQuery SDK (Incubation) without Sources 0.7.2.201402181114
(org.eclipse.incquery.sdk.feature.feature.group 0.7.2.201402181114)
To: org.eclipse.incquery.tooling.ui [0.7.2.201402181114]
Cannot satisfy dependency:
From: EMF-IncQuery SDK (Incubation) 0.7.2.201402181114 (org.eclipse.incquery.sdk.feature.source.feature.group
0.7.2.201402181114)
To: org.eclipse.incquery.sdk.feature.feature.group [0.7.2.201402181114]
Cannot satisfy dependency:
From: IncQuery Tooling - User Interface (Incubation) 0.7.2.201402181114 (org.eclipse.incquery.tooling.ui
0.7.2.201402181114)
To: bundle _org.eclipse.xtext.xbase [2.4.2,2.5.0)_
Cannot satisfy dependency:
From: Xtext SDK 2.6.1.v201406120726 (org.eclipse.xtext.sdk.feature.group 2.6.1.v201406120726)
To: org.eclipse.xtext.xbase.feature.group [2.6.1.v201406120726]
Cannot satisfy dependency:
From: Xbase 2.6.1.v201406120726 (org.eclipse.xtext.xbase.feature.group 2.6.1.v201406120726)
To: _org.eclipse.xtext.xbase [2.6.1.v201406120726]_

Put simpler: The version of IncQuery you're using requires org.eclipse.xtext.xbase [2.4.2,2.5.0), which can not be
resolved together with your own requirement of org.eclipse.xtext.xbase [2.6.1.v201406120726]. You need to either find an
IncQuery version that uses a newer Xbase or use an older Xbase yourself.

> !ENTRY org.eclipse.equinox.p2.director 4 10054 2014-06-24 17:00:11.834
> !MESSAGE Cannot complete the install because of a conflicting dependency.
> !SUBENTRY 1 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
> !MESSAGE Software being installed: EMF-IncQuery SDK (Incubation) 0.7.2.201402181114
> (org.eclipse.incquery.sdk.feature.source.feature.group 0.7.2.201402181114)
> !SUBENTRY 1 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
> !MESSAGE Software being installed: Xtext SDK 2.6.1.v201406120726 (org.eclipse.xtext.sdk.feature.group
> 2.6.1.v201406120726)
> !SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.834
> !MESSAGE Only one of the following can be installed at once: !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0
> 2014-06-24 17:00:11.834
> !MESSAGE Xbase Model 2.6.1.v201406120726 (org.eclipse.xtext.xbase 2.6.1.v201406120726)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
> !MESSAGE Xbase Model 2.5.2.v201402120812 (org.eclipse.xtext.xbase 2.5.2.v201402120812)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
> !MESSAGE Xbase Model 2.5.4.v201404100756 (org.eclipse.xtext.xbase 2.5.4.v201404100756)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
> !MESSAGE Xbase Model 2.4.3.v201309030823 (org.eclipse.xtext.xbase 2.4.3.v201309030823)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
> !MESSAGE Xbase Model 2.5.3.v201402240820 (org.eclipse.xtext.xbase 2.5.3.v201402240820)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
> !MESSAGE Xbase Model 2.6.0.v201405210727 (org.eclipse.xtext.xbase 2.6.0.v201405210727)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
> !MESSAGE Xbase Model 2.5.0.v201312110906 (org.eclipse.xtext.xbase 2.5.0.v201312110906)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.834
> !MESSAGE Xbase Model 2.4.2.v201306120542 (org.eclipse.xtext.xbase 2.4.2.v201306120542)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
> !MESSAGE Xbase Model 2.5.1.v201402030714 (org.eclipse.xtext.xbase 2.5.1.v201402030714)
> !SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.835
> !MESSAGE Cannot satisfy dependency:
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
> !MESSAGE From: EMF-IncQuery SDK (Incubation) without Sources 0.7.2.201402181114
> (org.eclipse.incquery.sdk.feature.feature.group 0.7.2.201402181114)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
> !MESSAGE To: org.eclipse.incquery.tooling.ui [0.7.2.201402181114]
> !SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.835
> !MESSAGE Cannot satisfy dependency:
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
> !MESSAGE From: EMF-IncQuery SDK (Incubation) 0.7.2.201402181114 (org.eclipse.incquery.sdk.feature.source.feature.group
> 0.7.2.201402181114)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
> !MESSAGE To: org.eclipse.incquery.sdk.feature.feature.group [0.7.2.201402181114]
> !SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.835
> !MESSAGE Cannot satisfy dependency:
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
> !MESSAGE From: IncQuery Tooling - User Interface (Incubation) 0.7.2.201402181114 (org.eclipse.incquery.tooling.ui
> 0.7.2.201402181114)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
> !MESSAGE To: bundle org.eclipse.xtext.xbase [2.4.2,2.5.0)
> !SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.835
> !MESSAGE Cannot satisfy dependency:
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
> !MESSAGE From: Xtext SDK 2.6.1.v201406120726 (org.eclipse.xtext.sdk.feature.group 2.6.1.v201406120726)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
> !MESSAGE To: org.eclipse.xtext.xbase.feature.group [2.6.1.v201406120726]
> !SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.835
> !MESSAGE Cannot satisfy dependency:
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
> !MESSAGE From: Xbase 2.6.1.v201406120726 (org.eclipse.xtext.xbase.feature.group 2.6.1.v201406120726)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.835
> !MESSAGE To: org.eclipse.xtext.xbase [2.6.1.v201406120726]
>
> !ENTRY org.eclipse.pde.core 4 0 2014-06-24 17:00:11.854
> !MESSAGE Problems occurred while resolving the target contents
> !SUBENTRY 1 org.eclipse.equinox.p2.director 4 10054 2014-06-24 17:00:11.854
> !MESSAGE Cannot complete the install because of a conflicting dependency.
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE Software being installed: EMF-IncQuery SDK (Incubation) 0.7.2.201402181114
> (org.eclipse.incquery.sdk.feature.source.feature.group 0.7.2.201402181114)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE Software being installed: Xtext SDK 2.6.1.v201406120726 (org.eclipse.xtext.sdk.feature.group
> 2.6.1.v201406120726)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.854
> !MESSAGE Only one of the following can be installed at once: !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0
> 2014-06-24 17:00:11.854
> !MESSAGE Xbase Model 2.6.1.v201406120726 (org.eclipse.xtext.xbase 2.6.1.v201406120726)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE Xbase Model 2.5.2.v201402120812 (org.eclipse.xtext.xbase 2.5.2.v201402120812)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE Xbase Model 2.5.4.v201404100756 (org.eclipse.xtext.xbase 2.5.4.v201404100756)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE Xbase Model 2.4.3.v201309030823 (org.eclipse.xtext.xbase 2.4.3.v201309030823)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE Xbase Model 2.5.3.v201402240820 (org.eclipse.xtext.xbase 2.5.3.v201402240820)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE Xbase Model 2.6.0.v201405210727 (org.eclipse.xtext.xbase 2.6.0.v201405210727)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE Xbase Model 2.5.0.v201312110906 (org.eclipse.xtext.xbase 2.5.0.v201312110906)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE Xbase Model 2.4.2.v201306120542 (org.eclipse.xtext.xbase 2.4.2.v201306120542)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE Xbase Model 2.5.1.v201402030714 (org.eclipse.xtext.xbase 2.5.1.v201402030714)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.854
> !MESSAGE Cannot satisfy dependency:
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE From: EMF-IncQuery SDK (Incubation) without Sources 0.7.2.201402181114
> (org.eclipse.incquery.sdk.feature.feature.group 0.7.2.201402181114)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE To: org.eclipse.incquery.tooling.ui [0.7.2.201402181114]
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.854
> !MESSAGE Cannot satisfy dependency:
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE From: EMF-IncQuery SDK (Incubation) 0.7.2.201402181114 (org.eclipse.incquery.sdk.feature.source.feature.group
> 0.7.2.201402181114)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE To: org.eclipse.incquery.sdk.feature.feature.group [0.7.2.201402181114]
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.854
> !MESSAGE Cannot satisfy dependency:
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE From: IncQuery Tooling - User Interface (Incubation) 0.7.2.201402181114 (org.eclipse.incquery.tooling.ui
> 0.7.2.201402181114)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE To: bundle org.eclipse.xtext.xbase [2.4.2,2.5.0)
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.854
> !MESSAGE Cannot satisfy dependency:
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.854
> !MESSAGE From: Xtext SDK 2.6.1.v201406120726 (org.eclipse.xtext.sdk.feature.group 2.6.1.v201406120726)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.855
> !MESSAGE To: org.eclipse.xtext.xbase.feature.group [2.6.1.v201406120726]
> !SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2014-06-24 17:00:11.855
> !MESSAGE Cannot satisfy dependency:
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.855
> !MESSAGE From: Xbase 2.6.1.v201406120726 (org.eclipse.xtext.xbase.feature.group 2.6.1.v201406120726)
> !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2014-06-24 17:00:11.855
> !MESSAGE To: org.eclipse.xtext.xbase [2.6.1.v201406120726]
>
Re: Version constraints in requirements for Targlet and P2 [message #1387185 is a reply to message #1387183] Tue, 24 June 2014 17:38 Go to previous messageGo to next message
Abel Hegedus is currently offline Abel Hegedus
Messages: 98
Registered: July 2009
Member
Since the validation did not show errors, I used exact versions that are available from the repositories listed in the dependencies (as mentioned, I adopted a working .target file), See the attached setup.

Thanks for your help Ed and Eike, I'll try with the modifications you suggest.

Again, I saw that the validation doesn't allow incorrect ranges, but it doesn't complain on using a simple number. Should I file a bugzilla issue about that?

Edit: as you can see, I have no requirement towards Xbase 2.6.1, so that's not the cause, I imagine it uses "2.4.2..." as "[2.4.2,anything)".

[Updated on: Tue, 24 June 2014 17:46]

Report message to a moderator

Re: Version constraints in requirements for Targlet and P2 [message #1387186 is a reply to message #1387185] Tue, 24 June 2014 18:08 Go to previous messageGo to next message
Eike Stepper is currently offline Eike Stepper
Messages: 5545
Registered: July 2009
Senior Member
Am 24.06.2014 19:38, schrieb Abel Hegedus:
> Since the validation did not show errors, I used exact versions that are available from the repositories listed in the dependencies (as mentioned, I adopted a working .target file), See the attached setup.
>
> Thanks for your help Ed and Eike, I'll try with the modifications you suggest.
>
> Again, I saw that the validation doesn't allow incorrect ranges, but it doesn't complain on using a simple number. Should I file a bugzilla issue about that?
No, "x.y.z" is correctly interpreted by p2 (not by PDE!!) as "[x.y.z,max.max.max]", i.e. a version range with x.y.z as
lower bound and no upper bound. Tricky, eh? ;-)

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper
Re: Version constraints in requirements for Targlet and P2 [message #1387537 is a reply to message #1387186] Wed, 25 June 2014 08:16 Go to previous messageGo to next message
Abel Hegedus is currently offline Abel Hegedus
Messages: 98
Registered: July 2009
Member
I have updated my targlet and now it goes through the requirement and dependency calculation. However, I get an exception in the installation phase, do you have any idea what could go wrong? Thanks!

[09:50:17] Installing ch.qos.logback.classic
[09:50:17] An error was detected while performing the engine operation and the changes are being rolled back. See the log for details.
[09:50:17] ERROR: org.eclipse.pde.core code=0 Problems occurred while resolving the target contents
  at org.eclipse.oomph.targlets.internal.core.TargletContainer.forceUpdate(TargletContainer.java:573)
  at org.eclipse.oomph.setup.targlets.impl.TargletTaskImpl.perform(TargletTaskImpl.java:436)
  at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:2310)
  at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.access$0(SetupTaskPerformer.java:2283)
  at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil$1.run(SetupTaskPerformer.java:2916)
  at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2345)
  at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil.performNeededSetupTasks(SetupTaskPerformer.java:2910)
  at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil.access$0(SetupTaskPerformer.java:2908)
  at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:2274)
  at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:2258)
  at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:2200)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$7.run(ProgressPage.java:353)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9$1.run(ProgressPage.java:429)
  at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
  ERROR: org.eclipse.equinox.p2.engine code=4 An error occurred while installing the items
    ERROR: org.eclipse.equinox.p2.engine code=0 session context was:(profile=D__PhD_EclipseSpace_Oomph_transima-maintenance_ws-d434b8923c949ae5f286b714b28e5994b6e4abcd, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]ch.qos.logback.classic 1.0.7.v20121108-1250, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
    ERROR: org.eclipse.equinox.p2.engine code=0 
    java.lang.NullPointerException
      at org.eclipse.equinox.internal.frameworkadmin.equinox.EclipseLauncherParser.read(EclipseLauncherParser.java:67)
      at org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxManipulatorImpl.loadWithoutFwPersistentData(EquinoxManipulatorImpl.java:346)
      at org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxManipulatorImpl.load(EquinoxManipulatorImpl.java:319)
      at org.eclipse.equinox.internal.p2.touchpoint.eclipse.LazyManipulator.loadDelegate(LazyManipulator.java:55)
      at org.eclipse.equinox.internal.p2.touchpoint.eclipse.LazyManipulator.getConfigData(LazyManipulator.java:108)
      at org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction.installBundle(InstallBundleAction.java:75)
      at org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction.execute(InstallBundleAction.java:32)
      at org.eclipse.equinox.internal.p2.engine.ParameterizedProvisioningAction.execute(ParameterizedProvisioningAction.java:38)
      at org.eclipse.equinox.internal.p2.engine.Phase.mainPerform(Phase.java:183)
      at org.eclipse.equinox.internal.p2.engine.Phase.perform(Phase.java:95)
      at org.eclipse.equinox.internal.p2.engine.PhaseSet.perform(PhaseSet.java:47)
      at org.eclipse.equinox.internal.p2.engine.Engine.perform(Engine.java:75)
      at org.eclipse.equinox.internal.p2.engine.Engine.perform(Engine.java:44)
      at org.eclipse.equinox.internal.provisional.p2.director.PlanExecutionHelper.executePlan(PlanExecutionHelper.java:41)
      at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$3.commit(ProfileTransactionImpl.java:685)
      at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:325)
      at org.eclipse.oomph.targlets.internal.core.TargletContainer.updateProfile(TargletContainer.java:656)
      at org.eclipse.oomph.targlets.internal.core.TargletContainer.resolveUnits(TargletContainer.java:465)
      at org.eclipse.oomph.targlets.internal.core.TargletContainer.resolveBundles(TargletContainer.java:422)
      at org.eclipse.pde.internal.core.target.AbstractBundleContainer.resolve(AbstractBundleContainer.java:77)
      at org.eclipse.pde.internal.core.target.TargetDefinition.resolve(TargetDefinition.java:262)
      at org.eclipse.oomph.targlets.internal.core.TargletContainer.forceUpdate(TargletContainer.java:570)
      at org.eclipse.oomph.setup.targlets.impl.TargletTaskImpl.perform(TargletTaskImpl.java:436)
      at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:2310)
      at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.access$0(SetupTaskPerformer.java:2283)
      at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil$1.run(SetupTaskPerformer.java:2916)
      at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2345)
      at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil.performNeededSetupTasks(SetupTaskPerformer.java:2910)
      at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil.access$0(SetupTaskPerformer.java:2908)
      at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:2274)
      at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:2258)
      at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:2200)
      at org.eclipse.oomph.setup.ui.wizards.ProgressPage$7.run(ProgressPage.java:353)
      at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9$1.run(ProgressPage.java:429)
      at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)

[09:50:17] ERROR: org.eclipse.pde.core code=0 Problems occurred while resolving the target contents
  at org.eclipse.oomph.targlets.internal.core.TargletContainer.forceUpdate(TargletContainer.java:573)
  at org.eclipse.oomph.setup.targlets.impl.TargletTaskImpl.perform(TargletTaskImpl.java:436)
  at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:2310)
  at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.access$0(SetupTaskPerformer.java:2283)
  at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil$1.run(SetupTaskPerformer.java:2916)
  at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2345)
  at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil.performNeededSetupTasks(SetupTaskPerformer.java:2910)
  at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil.access$0(SetupTaskPerformer.java:2908)
  at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:2274)
  at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:2258)
  at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:2200)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$7.run(ProgressPage.java:353)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9$1.run(ProgressPage.java:429)
  at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
  ERROR: org.eclipse.equinox.p2.engine code=4 An error occurred while installing the items
    ERROR: org.eclipse.equinox.p2.engine code=0 session context was:(profile=D__PhD_EclipseSpace_Oomph_transima-maintenance_ws-d434b8923c949ae5f286b714b28e5994b6e4abcd, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]ch.qos.logback.classic 1.0.7.v20121108-1250, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
    ERROR: org.eclipse.equinox.p2.engine code=0 
    java.lang.NullPointerException
      at org.eclipse.equinox.internal.frameworkadmin.equinox.EclipseLauncherParser.read(EclipseLauncherParser.java:67)
      at org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxManipulatorImpl.loadWithoutFwPersistentData(EquinoxManipulatorImpl.java:346)
      at org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxManipulatorImpl.load(EquinoxManipulatorImpl.java:319)
      at org.eclipse.equinox.internal.p2.touchpoint.eclipse.LazyManipulator.loadDelegate(LazyManipulator.java:55)
      at org.eclipse.equinox.internal.p2.touchpoint.eclipse.LazyManipulator.getConfigData(LazyManipulator.java:108)
      at org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction.installBundle(InstallBundleAction.java:75)
      at org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction.execute(InstallBundleAction.java:32)
      at org.eclipse.equinox.internal.p2.engine.ParameterizedProvisioningAction.execute(ParameterizedProvisioningAction.java:38)
      at org.eclipse.equinox.internal.p2.engine.Phase.mainPerform(Phase.java:183)
      at org.eclipse.equinox.internal.p2.engine.Phase.perform(Phase.java:95)
      at org.eclipse.equinox.internal.p2.engine.PhaseSet.perform(PhaseSet.java:47)
      at org.eclipse.equinox.internal.p2.engine.Engine.perform(Engine.java:75)
      at org.eclipse.equinox.internal.p2.engine.Engine.perform(Engine.java:44)
      at org.eclipse.equinox.internal.provisional.p2.director.PlanExecutionHelper.executePlan(PlanExecutionHelper.java:41)
      at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$3.commit(ProfileTransactionImpl.java:685)
      at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:325)
      at org.eclipse.oomph.targlets.internal.core.TargletContainer.updateProfile(TargletContainer.java:656)
      at org.eclipse.oomph.targlets.internal.core.TargletContainer.resolveUnits(TargletContainer.java:465)
      at org.eclipse.oomph.targlets.internal.core.TargletContainer.resolveBundles(TargletContainer.java:422)
      at org.eclipse.pde.internal.core.target.AbstractBundleContainer.resolve(AbstractBundleContainer.java:77)
      at org.eclipse.pde.internal.core.target.TargetDefinition.resolve(TargetDefinition.java:262)
      at org.eclipse.oomph.targlets.internal.core.TargletContainer.forceUpdate(TargletContainer.java:570)
      at org.eclipse.oomph.setup.targlets.impl.TargletTaskImpl.perform(TargletTaskImpl.java:436)
      at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:2310)
      at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.access$0(SetupTaskPerformer.java:2283)
      at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil$1.run(SetupTaskPerformer.java:2916)
      at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2345)
      at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil.performNeededSetupTasks(SetupTaskPerformer.java:2910)
      at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil.access$0(SetupTaskPerformer.java:2908)
      at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:2274)
      at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:2258)
      at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:2200)
      at org.eclipse.oomph.setup.ui.wizards.ProgressPage$7.run(ProgressPage.java:353)
      at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9$1.run(ProgressPage.java:429)
      at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
Re: Version constraints in requirements for Targlet and P2 [message #1387579 is a reply to message #1387537] Wed, 25 June 2014 09:27 Go to previous messageGo to next message
Eike Stepper is currently offline Eike Stepper
Messages: 5545
Registered: July 2009
Senior Member
Hi Abdel,

I would like to reproduce the problem. Can you please submit a bugzilla and attach your model file or at least paste in
the markup of your targlet task?

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper


Am 25.06.2014 10:16, schrieb Abel Hegedus:
> I have updated my targlet and now it goes through the requirement and dependency calculation. However, I get an
> exception in the installation phase, do you have any idea what could go wrong? Thanks!
>
>
> [09:50:17] Installing ch.qos.logback.classic
> [09:50:17] An error was detected while performing the engine operation and the changes are being rolled back. See the
> log for details.
> [09:50:17] ERROR: org.eclipse.pde.core code=0 Problems occurred while resolving the target contents
> at org.eclipse.oomph.targlets.internal.core.TargletContainer.forceUpdate(TargletContainer.java:573)
> at org.eclipse.oomph.setup.targlets.impl.TargletTaskImpl.perform(TargletTaskImpl.java:436)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:2310)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.access$0(SetupTaskPerformer.java:2283)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil$1.run(SetupTaskPerformer.java:2916)
> at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2345)
> at
> org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil.performNeededSetupTasks(SetupTaskPerformer.java:2910)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil.access$0(SetupTaskPerformer.java:2908)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:2274)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:2258)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:2200)
> at org.eclipse.oomph.setup.ui.wizards.ProgressPage$7.run(ProgressPage.java:353)
> at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9$1.run(ProgressPage.java:429)
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
> ERROR: org.eclipse.equinox.p2.engine code=4 An error occurred while installing the items
> ERROR: org.eclipse.equinox.p2.engine code=0 session context
> was:(profile=D__PhD_EclipseSpace_Oomph_transima-maintenance_ws-d434b8923c949ae5f286b714b28e5994b6e4abcd,
> phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]ch.qos.logback.classic
> 1.0.7.v20121108-1250, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
> ERROR: org.eclipse.equinox.p2.engine code=0 java.lang.NullPointerException
> at org.eclipse.equinox.internal.frameworkadmin.equinox.EclipseLauncherParser.read(EclipseLauncherParser.java:67)
> at
> org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxManipulatorImpl.loadWithoutFwPersistentData(EquinoxManipulatorImpl.java:346)
> at org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxManipulatorImpl.load(EquinoxManipulatorImpl.java:319)
> at org.eclipse.equinox.internal.p2.touchpoint.eclipse.LazyManipulator.loadDelegate(LazyManipulator.java:55)
> at org.eclipse.equinox.internal.p2.touchpoint.eclipse.LazyManipulator.getConfigData(LazyManipulator.java:108)
> at
> org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction.installBundle(InstallBundleAction.java:75)
> at
> org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction.execute(InstallBundleAction.java:32)
> at
> org.eclipse.equinox.internal.p2.engine.ParameterizedProvisioningAction.execute(ParameterizedProvisioningAction.java:38)
> at org.eclipse.equinox.internal.p2.engine.Phase.mainPerform(Phase.java:183)
> at org.eclipse.equinox.internal.p2.engine.Phase.perform(Phase.java:95)
> at org.eclipse.equinox.internal.p2.engine.PhaseSet.perform(PhaseSet.java:47)
> at org.eclipse.equinox.internal.p2.engine.Engine.perform(Engine.java:75)
> at org.eclipse.equinox.internal.p2.engine.Engine.perform(Engine.java:44)
> at org.eclipse.equinox.internal.provisional.p2.director.PlanExecutionHelper.executePlan(PlanExecutionHelper.java:41)
> at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$3.commit(ProfileTransactionImpl.java:685)
> at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:325)
> at org.eclipse.oomph.targlets.internal.core.TargletContainer.updateProfile(TargletContainer.java:656)
> at org.eclipse.oomph.targlets.internal.core.TargletContainer.resolveUnits(TargletContainer.java:465)
> at org.eclipse.oomph.targlets.internal.core.TargletContainer.resolveBundles(TargletContainer.java:422)
> at org.eclipse.pde.internal.core.target.AbstractBundleContainer.resolve(AbstractBundleContainer.java:77)
> at org.eclipse.pde.internal.core.target.TargetDefinition.resolve(TargetDefinition.java:262)
> at org.eclipse.oomph.targlets.internal.core.TargletContainer.forceUpdate(TargletContainer.java:570)
> at org.eclipse.oomph.setup.targlets.impl.TargletTaskImpl.perform(TargletTaskImpl.java:436)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:2310)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.access$0(SetupTaskPerformer.java:2283)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil$1.run(SetupTaskPerformer.java:2916)
> at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2345)
> at
> org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil.performNeededSetupTasks(SetupTaskPerformer.java:2910)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil.access$0(SetupTaskPerformer.java:2908)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:2274)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:2258)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:2200)
> at org.eclipse.oomph.setup.ui.wizards.ProgressPage$7.run(ProgressPage.java:353)
> at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9$1.run(ProgressPage.java:429)
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
>
> [09:50:17] ERROR: org.eclipse.pde.core code=0 Problems occurred while resolving the target contents
> at org.eclipse.oomph.targlets.internal.core.TargletContainer.forceUpdate(TargletContainer.java:573)
> at org.eclipse.oomph.setup.targlets.impl.TargletTaskImpl.perform(TargletTaskImpl.java:436)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:2310)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.access$0(SetupTaskPerformer.java:2283)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil$1.run(SetupTaskPerformer.java:2916)
> at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2345)
> at
> org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil.performNeededSetupTasks(SetupTaskPerformer.java:2910)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil.access$0(SetupTaskPerformer.java:2908)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:2274)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:2258)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:2200)
> at org.eclipse.oomph.setup.ui.wizards.ProgressPage$7.run(ProgressPage.java:353)
> at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9$1.run(ProgressPage.java:429)
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
> ERROR: org.eclipse.equinox.p2.engine code=4 An error occurred while installing the items
> ERROR: org.eclipse.equinox.p2.engine code=0 session context
> was:(profile=D__PhD_EclipseSpace_Oomph_transima-maintenance_ws-d434b8923c949ae5f286b714b28e5994b6e4abcd,
> phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]ch.qos.logback.classic
> 1.0.7.v20121108-1250, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
> ERROR: org.eclipse.equinox.p2.engine code=0 java.lang.NullPointerException
> at org.eclipse.equinox.internal.frameworkadmin.equinox.EclipseLauncherParser.read(EclipseLauncherParser.java:67)
> at
> org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxManipulatorImpl.loadWithoutFwPersistentData(EquinoxManipulatorImpl.java:346)
> at org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxManipulatorImpl.load(EquinoxManipulatorImpl.java:319)
> at org.eclipse.equinox.internal.p2.touchpoint.eclipse.LazyManipulator.loadDelegate(LazyManipulator.java:55)
> at org.eclipse.equinox.internal.p2.touchpoint.eclipse.LazyManipulator.getConfigData(LazyManipulator.java:108)
> at
> org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction.installBundle(InstallBundleAction.java:75)
> at
> org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction.execute(InstallBundleAction.java:32)
> at
> org.eclipse.equinox.internal.p2.engine.ParameterizedProvisioningAction.execute(ParameterizedProvisioningAction.java:38)
> at org.eclipse.equinox.internal.p2.engine.Phase.mainPerform(Phase.java:183)
> at org.eclipse.equinox.internal.p2.engine.Phase.perform(Phase.java:95)
> at org.eclipse.equinox.internal.p2.engine.PhaseSet.perform(PhaseSet.java:47)
> at org.eclipse.equinox.internal.p2.engine.Engine.perform(Engine.java:75)
> at org.eclipse.equinox.internal.p2.engine.Engine.perform(Engine.java:44)
> at org.eclipse.equinox.internal.provisional.p2.director.PlanExecutionHelper.executePlan(PlanExecutionHelper.java:41)
> at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$3.commit(ProfileTransactionImpl.java:685)
> at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:325)
> at org.eclipse.oomph.targlets.internal.core.TargletContainer.updateProfile(TargletContainer.java:656)
> at org.eclipse.oomph.targlets.internal.core.TargletContainer.resolveUnits(TargletContainer.java:465)
> at org.eclipse.oomph.targlets.internal.core.TargletContainer.resolveBundles(TargletContainer.java:422)
> at org.eclipse.pde.internal.core.target.AbstractBundleContainer.resolve(AbstractBundleContainer.java:77)
> at org.eclipse.pde.internal.core.target.TargetDefinition.resolve(TargetDefinition.java:262)
> at org.eclipse.oomph.targlets.internal.core.TargletContainer.forceUpdate(TargletContainer.java:570)
> at org.eclipse.oomph.setup.targlets.impl.TargletTaskImpl.perform(TargletTaskImpl.java:436)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:2310)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.access$0(SetupTaskPerformer.java:2283)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil$1.run(SetupTaskPerformer.java:2916)
> at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2345)
> at
> org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil.performNeededSetupTasks(SetupTaskPerformer.java:2910)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer$WorkspaceUtil.access$0(SetupTaskPerformer.java:2908)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:2274)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:2258)
> at org.eclipse.oomph.internal.setup.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:2200)
> at org.eclipse.oomph.setup.ui.wizards.ProgressPage$7.run(ProgressPage.java:353)
> at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9$1.run(ProgressPage.java:429)
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
>
Re: Version constraints in requirements for Targlet and P2 [message #1387606 is a reply to message #1387579] Wed, 25 June 2014 10:15 Go to previous message
Abel Hegedus is currently offline Abel Hegedus
Messages: 98
Registered: July 2009
Member
Issue created in https://bugs.eclipse.org/bugs/show_bug.cgi?id=438141
Thanks for loooking into it!
Previous Topic:Error opening user.setup after removing installation
Next Topic:Target container doesn't include SWT native fragment
Goto Forum:
  


Current Time: Sun Oct 26 01:07:32 GMT 2014

Powered by FUDForum. Page generated in 0.02320 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software