Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Cannot preview the report: XPCOM error
Cannot preview the report: XPCOM error [message #1386338] Mon, 16 June 2014 18:01 Go to next message
Young Song is currently offline Young SongFriend
Messages: 1
Registered: June 2014
Junior Member
Hi,

I am fairly new to the BIRT project (just installed Eclipse/BIRT package last Friday) and was trying to go through tutorial.

I am going through similar phases of trial/error as described in this post.

I installed the Eclipse/BIRT in the following system spec:

- Linux Centos6.5
Kernel Linux 2.6.32-431.11.2.el6.x86_64

- Mozilla Firefox 24.5.0


Initially, when I tried to preview the report, I had an error saying

org.eclipse.swt.SWTError: No more handles [Could not detect registered
XULRunner to use]
at org.eclipse.swt.SWT.error(SWT.java:4423)...


So, went and try to fiddle with eclipse.ini and added the following line:

-Dorg.eclipse.swt.browser.XULRunnerPath=/home/ysong/bin/xulrunner

Now this is after when I installed the following version of xulrunner:

Mozilla XULRunner 17.0.10 - 20131029213213

When I tried previewing the report again, I now get a following error:

org.eclipse.swt.SWTError: XPCOM error 0x80004005
at org.eclipse.swt.browser.Mozilla.error(Mozilla.java:2714)
at org.eclipse.swt.browser.Mozilla.initXULRunner(Mozilla.java:2680)
at org.eclipse.swt.browser.Mozilla.create(Mozilla.java:686)
at org.eclipse.swt.browser.Browser.<init>(Browser.java:99)
at
org.eclipse.birt.report.designer.ui.preview.editors.ReportPreviewEditor.createMainBrowser(ReportPreviewEditor.java:297)
at ...


I have also went and changed some setting in Window->Preferences->Report Design->Preview to use external browsers.

At this point, I am not sure what else I need to do to get this thing work. Comments and advices here would be more than welcome.

Thank you,

Young


[Updated on: Mon, 16 June 2014 18:54]

Report message to a moderator

Re: Cannot preview the report: XPCOM error [message #1388934 is a reply to message #1386338] Fri, 27 June 2014 05:35 Go to previous message
Michael Williams is currently offline Michael WilliamsFriend
Messages: 1925
Registered: July 2009
Senior Member

Have you gotten this working? What's you Eclipse version? You might look at this to see that you get a compatible version of XULRunner: https://www.eclipse.org/swt/faq.php#browserlinux



Michael

Developer Evangelist, Silanis
Previous Topic:Column alias/name ignored
Next Topic:Decent example of embedding a report into an existing html page
Goto Forum:
  


Current Time: Mon May 21 01:12:13 GMT 2018

Powered by FUDForum. Page generated in 0.01811 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top