Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » Unable to create first entity in emtpy table
Unable to create first entity in emtpy table [message #1386063] Fri, 13 June 2014 09:57 Go to next message
Wilbert Alberts is currently offline Wilbert AlbertsFriend
Messages: 99
Registered: June 2010
Member
Hi,

This is probably a silly question.

The root element in my metamodel is Model and it contains Interface entities. I want to represent the Interface entities in a table (and add new ones). I added an InterfaceLine and CreateLine tools to the description.

However, I am unable to create the first interface. If my model already contains an interface (created by some other means), then that interface shows up and I can add additional ones by right clicking that interface and select the proper tool.

How or where should I create the tool that allows me to create an Interface in an otherwise empty model?

I attached a screenshot showing the organisation of VSP description.

Greetings,
Wilbert.
  • Attachment: s.png
    (Size: 14.82KB, Downloaded 17 times)
Re: Unable to create first entity in emtpy table [message #1386100 is a reply to message #1386063] Fri, 13 June 2014 12:30 Go to previous messageGo to next message
Laurent Redor is currently offline Laurent RedorFriend
Messages: 48
Registered: July 2009
Member
Hi,

Normally, you should have a create tool that appears in the toolbar.

I attached a simple example project.

Regards,

Laurent

Le 13/06/2014 11:57, Wilbert Alberts a écrit :
> Hi,
>
> This is probably a silly question.
>
> The root element in my metamodel is Model and it contains Interface entities. I want to represent the Interface entities in a table (and add new ones). I added an InterfaceLine and CreateLine tools to the description.
>
> However, I am unable to create the first interface. If my model already contains an interface (created by some other means), then that interface shows up and I can add additional ones by right clicking that interface and select the proper tool.
>
> How or where should I create the tool that allows me to create an Interface in an otherwise empty model?
>
> I attached a screenshot showing the organisation of VSP description.
>
> Greetings,
> Wilbert.
>
Re: Unable to create first entity in emtpy table [message #1386105 is a reply to message #1386100] Fri, 13 June 2014 12:38 Go to previous message
Wilbert Alberts is currently offline Wilbert AlbertsFriend
Messages: 99
Registered: June 2010
Member
Hi Laurent,

Indeed, the solution was too simple. I'm feeling ashamed now. *blush*

Thanks again!

Greetings,
Wilbert.
Previous Topic:What is wrong
Next Topic:Sirius for serialized ecore model
Goto Forum:
  


Current Time: Sat Dec 20 10:25:50 GMT 2014

Powered by FUDForum. Page generated in 0.03004 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software