Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Why is Eclipse deleting the CVS directories from my Git cloned repo?
Why is Eclipse deleting the CVS directories from my Git cloned repo? [message #1385738] Tue, 10 June 2014 20:25 Go to next message
Brian Johnson is currently offline Brian Johnson
Messages: 3
Registered: March 2013
Junior Member
I have a Git repo that still contains old CVS/ directories. When I create my local clone of this repo and create an Eclipse project pointing at my clone, Eclipse (Kepler SR2) shows all of the CVS/ directories as deleted. They also show up in the Unstaged Changes list on the Git perspective.

If I do a 'git status' on the command line it shows no modified files. I need those old CVS/ directories to still be there. So why is Eclipse doing this and how do I stop it?
Re: Why is Eclipse deleting the CVS directories from my Git cloned repo? [message #1385747 is a reply to message #1385738] Tue, 10 June 2014 21:52 Go to previous messageGo to next message
Robin Rosenberg is currently offline Robin Rosenberg
Messages: 330
Registered: July 2009
Senior Member
Brian Johnson skrev 2014-06-10 22.25:
> I have a Git repo that still contains old CVS/ directories. When I create my local clone of this repo and create an Eclipse project pointing at my clone, Eclipse (Kepler
> SR2) shows all of the CVS/ directories as deleted. They also show up in the Unstaged Changes list on the Git perspective.
>
> If I do a 'git status' on the command line it shows no modified files. I need those old CVS/ directories to still be there. So why is Eclipse doing this and how do I stop it?

I see no rational explanation for this behavior.

-- robin
Re: Why is Eclipse deleting the CVS directories from my Git cloned repo? [message #1385751 is a reply to message #1385738] Tue, 10 June 2014 23:07 Go to previous messageGo to next message
Brian Johnson is currently offline Brian Johnson
Messages: 3
Registered: March 2013
Junior Member
Quote:
I see no rational explanation for this behavior.

Are there any relevant logs that would help figure out what's going on?
Re: Why is Eclipse deleting the CVS directories from my Git cloned repo? [message #1385872 is a reply to message #1385751] Wed, 11 June 2014 20:28 Go to previous message
Robin Rosenberg is currently offline Robin Rosenberg
Messages: 330
Registered: July 2009
Senior Member
Brian Johnson skrev 2014-06-11 01.07:
> Quote:
>> I see no rational explanation for this behavior.
>
> Are there any relevant logs that would help figure out what's going on?

The only log is the workspace/.metdata/.log file, which essentially only
lists error messages. In this case it seems something "successfully" deleted
the CVS directories.

-- robin
Previous Topic:Programmatically find deleted resources that are not committed
Next Topic:EGit Commit Performance depends on Files in Workspace
Goto Forum:
  


Current Time: Tue Oct 21 07:19:31 GMT 2014

Powered by FUDForum. Page generated in 0.01695 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software