Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » Why is Eclipse deleting the CVS directories from my Git cloned repo?
Why is Eclipse deleting the CVS directories from my Git cloned repo? [message #1385738] Tue, 10 June 2014 20:25 Go to next message
Brian Johnson is currently offline Brian JohnsonFriend
Messages: 3
Registered: March 2013
Junior Member
I have a Git repo that still contains old CVS/ directories. When I create my local clone of this repo and create an Eclipse project pointing at my clone, Eclipse (Kepler SR2) shows all of the CVS/ directories as deleted. They also show up in the Unstaged Changes list on the Git perspective.

If I do a 'git status' on the command line it shows no modified files. I need those old CVS/ directories to still be there. So why is Eclipse doing this and how do I stop it?
Re: Why is Eclipse deleting the CVS directories from my Git cloned repo? [message #1385747 is a reply to message #1385738] Tue, 10 June 2014 21:52 Go to previous messageGo to next message
Robin Rosenberg is currently offline Robin RosenbergFriend
Messages: 332
Registered: July 2009
Senior Member
Brian Johnson skrev 2014-06-10 22.25:
> I have a Git repo that still contains old CVS/ directories. When I create my local clone of this repo and create an Eclipse project pointing at my clone, Eclipse (Kepler
> SR2) shows all of the CVS/ directories as deleted. They also show up in the Unstaged Changes list on the Git perspective.
>
> If I do a 'git status' on the command line it shows no modified files. I need those old CVS/ directories to still be there. So why is Eclipse doing this and how do I stop it?

I see no rational explanation for this behavior.

-- robin
Re: Why is Eclipse deleting the CVS directories from my Git cloned repo? [message #1385751 is a reply to message #1385738] Tue, 10 June 2014 23:07 Go to previous messageGo to next message
Brian Johnson is currently offline Brian JohnsonFriend
Messages: 3
Registered: March 2013
Junior Member
Quote:
I see no rational explanation for this behavior.

Are there any relevant logs that would help figure out what's going on?
Re: Why is Eclipse deleting the CVS directories from my Git cloned repo? [message #1385872 is a reply to message #1385751] Wed, 11 June 2014 20:28 Go to previous messageGo to next message
Robin Rosenberg is currently offline Robin RosenbergFriend
Messages: 332
Registered: July 2009
Senior Member
Brian Johnson skrev 2014-06-11 01.07:
> Quote:
>> I see no rational explanation for this behavior.
>
> Are there any relevant logs that would help figure out what's going on?

The only log is the workspace/.metdata/.log file, which essentially only
lists error messages. In this case it seems something "successfully" deleted
the CVS directories.

-- robin
Re: Why is Eclipse deleting the CVS directories from my Git cloned repo? [message #1705988 is a reply to message #1385872] Thu, 20 August 2015 17:41 Go to previous messageGo to next message
Sam Davis is currently offline Sam DavisFriend
Messages: 82
Registered: July 2012
Member
I am experiencing the same problem. The CVS files are still there on disk, and git status does not mention them, but they show up in the EGit staging view and commit dialog as deleted.
Re: Why is Eclipse deleting the CVS directories from my Git cloned repo? [message #1707682 is a reply to message #1705988] Tue, 08 September 2015 13:38 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 852
Registered: July 2009
Senior Member
Can you provide a small sample git repository containing CVS files to reproduce the problem ?
Re: Why is Eclipse deleting the CVS directories from my Git cloned repo? [message #1707714 is a reply to message #1707682] Tue, 08 September 2015 16:35 Go to previous messageGo to next message
Sam Davis is currently offline Sam DavisFriend
Messages: 82
Registered: July 2012
Member
Here you go:

* add the attached repository in the Git repositories view
* import the test project
* refresh the staging view
* the 4 files in the CVS folder appear as deleted

This only happens when the project has been imported. I wonder if there is some sort of resource filter for CVS files in Eclipse which prevents EGit from seeing them in the working directory, so it thinks they've been deleted.
  • Attachment: cvstest.zip
    (Size: 14.74KB, Downloaded 23 times)
Re: Why is Eclipse deleting the CVS directories from my Git cloned repo? [message #1709009 is a reply to message #1707714] Wed, 23 September 2015 09:47 Go to previous message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 852
Registered: July 2009
Senior Member
Thanks, I can reproduce the problem.

I filed bug
https://bugs.eclipse.org/bugs/show_bug.cgi?id=478148
to track it and pushed a fix for review
Previous Topic:Git Conflict issue
Next Topic:Eclipse and Egit : Remote Push is blocked
Goto Forum:
  


Current Time: Mon Aug 29 21:36:40 GMT 2016

Powered by FUDForum. Page generated in 0.01706 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software