Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Can we debug php code in eclipse helios???
Can we debug php code in eclipse helios??? [message #1385539] Mon, 09 June 2014 06:08 Go to next message
Megha Agarwal is currently offline Megha Agarwal
Messages: 1
Registered: June 2014
Junior Member
Sometimes when I make any changes in my PHP code, the site doesn't work properly or gets blocked.
Can we debug or track the cause of error in eclipse helios?? In other words, can we see which part of code is letting the website to get blocked??
Re: Can we debug php code in eclipse helios??? [message #1388425 is a reply to message #1385539] Thu, 26 June 2014 12:32 Go to previous messageGo to next message
Mike Bonhoff is currently offline Mike Bonhoff
Messages: 8
Registered: August 2013
Junior Member
Yes. It is possible but not easy to do. There are two debugging engines for php development on eclipse: Zend and xdebug.

And I hit your post when I was googling for an explanation how to do that again.

I think you have Eclipse (Helios) for PHP Developers. Next to the bug symbol there is an arrow. When you press it you can choose "Debug configurations". And there you could choose Server Debugger: XDebug. In the Name-field you can give a name to the kind of debugging-session so that you don't have to edit this mask again. In the File-field you - of course - specify which file you want to debug.

But - and here comes my problem - when I want to run it I get the error message:

Cannot run program my_program: CreateProcess error=193, %1 is no valid Win32-application.


I don't know yet what the problem is. I use a 64 bit os and the program is placed in programs (where the other 64 programs are also placed). I don't know if it is actually a 32 bit program which I installed (I don't know where to look about that, there is no such information in Help->About Eclipse.

Does anybody know what the problem might be?

Thanks!
Mike
Re: Can we debug php code in eclipse helios??? [message #1388443 is a reply to message #1388425] Thu, 26 June 2014 13:07 Go to previous message
Mike Bonhoff is currently offline Mike Bonhoff
Messages: 8
Registered: August 2013
Junior Member
I think I have found out what is the problem. Windows needs a php executable (which is unnecessary for the normal use of php programming because it is a scripting language and you use the xampp (apache etc.) to run it.

But in debugger mode you need that php.exe. You find it in xampp\php\php.exe. And you can specify this php.exe via Window->Preferences->PHP->PHP Executables by Adding this file as Executable path.

But now I have a different mistake after starting the debugging process (I use Zend now - by the way):
Error launching 'test_debugger'
The debug session could not be started. Please make sure that the debugger is properly configured as a php.ini directive.


In the php.ini (which is also in xampp\php) I commented in the line
zend_extension = "C:\xampp\php\ext\php_xdebug.dll"
under
[XDebug]
(there a 2 such lines but I think this is the right one). Now it still doesn't work even after restarting my apache web server. There is still the above mentioned mistake.
Previous Topic:Binding from ASt
Next Topic:DLTK problem - Syntax Error on double quotes !! Why ??
Goto Forum:
  


Current Time: Tue Sep 23 16:24:29 GMT 2014

Powered by FUDForum. Page generated in 0.02689 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software