Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Mime-types not set
Mime-types not set [message #1385431] Fri, 06 June 2014 07:43 Go to next message
rav rav is currently offline rav rav
Messages: 1
Registered: June 2014
Junior Member
Hi I am using Eclipse SVN. When committing from Team->Commit, I get the following error message although I have set the mime type in the config file (see attached)

Is there anything else I need to do?


svn: Commit blocked by pre-commit hook (exit code 1) with output:
/opt/svn/repositories/administration/hooks/check-mime-type.pl:

Project1/cleanup.json : svn:mime-type is not set


  • Attachment: config.txt
    (Size: 2.89KB, Downloaded 5 times)
Re: Mime-types not set [message #1402996 is a reply to message #1385431] Sat, 19 July 2014 11:44 Go to previous message
Alexander Gurov is currently offline Alexander Gurov
Messages: 85
Registered: July 2009
Member
Hi!

I've checked the file and the first thing to draw my attention was the name of the configuration file. In my case it is called simply 'config' and not 'config.txt'. So, it is possible that the file was completely ignored by the SVN client library.
So, in order to check if that is the case, you may try adding/committing resources using command line tool. If it works, then you may try JavaHL based connector and then SVN Kit connector in order to check if there is a difference or not.
Another way is to use plug-in's functionality:
Window->Preferences->Team->SVN->Properties Configuration->Automatic properties.
Previous Topic:wrong resource URL appears in label on imported projects
Next Topic:Checking out Large Reposotories
Goto Forum:
  


Current Time: Mon Jul 28 14:28:00 EDT 2014

Powered by FUDForum. Page generated in 0.06287 seconds