Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Product validation doesn't find the 2 lucene.core versions required
Product validation doesn't find the 2 lucene.core versions required [message #1385234] Thu, 05 June 2014 06:08
Al B is currently offline Al B
Messages: 129
Registered: July 2009
Senior Member
We are using Kepler 4.3; which include lucene.core 3.5. Unfortunately, the Lucene API radically changed in version 3.5. For instance, IndexReader, RAMDirectory, and others; were completely removed.

So our search code only works with Lucene 2.9.1 and migrating it to 3.5 will take some time and effort.

In the meantime, we are able to run/debug our RCP application by updating the Run Configuration with both versions of lucene.core (2.9.1 and 3.5). However, this doesn't work for the *.product file so when I try to "export" the product or build it with Buckminster, Eclipse complaints because it only selects the 3.5 version required by some Kepler plugins (e.g. org.eclipse.help.base). I even put explicit version numbers "2.9.1.v201101211721" for the required lucene.core plugin into my feature.xml, but it doesn't work either.

Has anyone figured out a workaround for this scenario?

TIA!
Previous Topic:Deploying fragment into Indigo based product
Next Topic:List vs JList
Goto Forum:
  


Current Time: Sat Nov 01 11:20:27 GMT 2014

Powered by FUDForum. Page generated in 0.10691 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software