Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Is there any way to make eclipse not install something that contains a plugin whose minimum Executio
Is there any way to make eclipse not install something that contains a plugin whose minimum Executio [message #1384702] Fri, 30 May 2014 10:31 Go to next message
Keith Chong is currently offline Keith Chong
Messages: 64
Registered: July 2009
Member
If I try and install a feature in an Unsupported Environment (e.g. only linux Operating System supported but I'm installing on windows), P2 blocks with nice error message "Cannot complete the install because some dependencies are not satisfiable...".

When I try installing a feature containing a plugin whose execution environment is not unsatisfied (e.g. Bundle-RequiredExecutionEnvironment: JavaSE-1.7 and eclipse running on Java 6), instead P2 let's the feature install go through, but the feature is disabled upon restart (Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))").

http://help.eclipse.org/kepler/topic/org.eclipse.pde.doc.user/guide/tools/editors/feature_editor/feature_editor.htm
http://help.eclipse.org/kepler/topic/org.eclipse.pde.doc.user/guide/tools/editors/manifest_editor/overview.htm?cp=4_3_2_0_0
Re: Is there any way to make eclipse not install something that contains a plugin whose minimum Exec [message #1385122 is a reply to message #1384702] Wed, 04 June 2014 09:02 Go to previous message
Thomas Watson is currently offline Thomas Watson
Messages: 425
Registered: July 2009
Senior Member
This is https://bugs.eclipse.org/bugs/show_bug.cgi?id=346174

It is a non-trivial problem that currently is not in a plan from the p2 team/community.
Previous Topic:How to run Java Applet in Kura OSGI framework?
Next Topic:Trying to get org.eclipse.ajdt.core.ant.AJDT_AjcCompilerAdapter to work
Goto Forum:
  


Current Time: Thu Aug 28 05:16:52 EDT 2014

Powered by FUDForum. Page generated in 0.02027 seconds