Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Why my added libraries are automatically removed from "Java Build Path" in Eclipse? (Build Path Libraries Issue)
Why my added libraries are automatically removed from "Java Build Path" in Eclipse? [message #1384524] Thu, 29 May 2014 07:52 Go to next message
Sana Shaikh is currently offline Sana ShaikhFriend
Messages: 7
Registered: May 2014
Junior Member
I am working on a Web Application;
I added libraries to my project via "Java Build Path" Application is running perfectly but when I made changes to my .jsp file and refreshed the the page on Browser;
the added libraries automatically removed.
Now how can fix it??? i am using apache-tomcat-7.0.37.
as every time I update my .jsp file or make any other changes I need to add the libraries again.
Any advice or suggestion would be highly appreciable. Thank you!
Re: Why my added libraries are automatically removed from "Java Build Path" in Eclipse? [message #1384603 is a reply to message #1384524] Thu, 29 May 2014 12:56 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 2360
Registered: July 2009
Senior Member
Moving this to the Web Tools forum.
Re: Why my added libraries are automatically removed from "Java Build Path" in Eclipse? [message #1384620 is a reply to message #1384603] Thu, 29 May 2014 15:54 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 2333
Registered: July 2009
Senior Member
Looks like it was also asked at http://stackoverflow.com/questions/23926925/why-my-added-libraries-are-automatically-removed-from-java-build-path-in-eclip?noredirect=1#comment36852228_23926925 .



---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: Why my added libraries are automatically removed from "Java Build Path" in Eclipse? [message #1384632 is a reply to message #1384620] Thu, 29 May 2014 19:07 Go to previous messageGo to next message
Sana Shaikh is currently offline Sana ShaikhFriend
Messages: 7
Registered: May 2014
Junior Member
Yes, I posted it there too; and if I m nt wrong u r the same Nitind.
Re: Why my added libraries are automatically removed from "Java Build Path" in Eclipse? [message #1384751 is a reply to message #1384632] Sat, 31 May 2014 09:16 Go to previous messageGo to next message
Sana Shaikh is currently offline Sana ShaikhFriend
Messages: 7
Registered: May 2014
Junior Member
Solution please???
Re: Why my added libraries are automatically removed from "Java Build Path" in Ecl [message #1384836 is a reply to message #1384751] Mon, 02 June 2014 12:55 Go to previous messageGo to next message
Larry Isaacs is currently offline Larry IsaacsFriend
Messages: 1310
Registered: July 2009
Senior Member
On 5/31/2014 5:16 AM, Sana Shaikh wrote:
> Solution please???
What is the contents of the .classpath file in your project. That might
provide some clues or provide help in determining the next questions to ask?

Cheers,
Larry
Re: Why my added libraries are automatically removed from "Java Build Path" in Ecl [message #1384909 is a reply to message #1384836] Tue, 03 June 2014 04:20 Go to previous messageGo to next message
Sana Shaikh is currently offline Sana ShaikhFriend
Messages: 7
Registered: May 2014
Junior Member
Well, .classpath file doe not contain anything odd, contents:
<classpath>
<classpathentry kind="src" path="src"/>
<classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
<classpathentry kind="lib" path="lib/mysql-connector-java-3.1.14-bin.jar"/>
<classpathentry kind="lib" path="lib/antlr-2.7.6.jar"/>
<classpathentry kind="lib" path="lib/commons-collections-3.1.jar"/>
<classpathentry kind="lib" path="lib/commons-logging-api-1.1.jar"/>
<classpathentry kind="lib" path="lib/ejb3-persistence.jar"/>
<classpathentry kind="lib" path="lib/hibernate3.jar"/>
<classpathentry kind="lib" path="lib/hibernate-annotations.jar"/>
<classpathentry kind="lib" path="lib/hibernate-commons-annotations.jar"/>
<classpathentry kind="lib" path="lib/hibernate-search.jar"/>
<classpathentry kind="lib" path="lib/javassist-3.4.GA.jar"/>
<classpathentry kind="lib" path="lib/jta.jar"/>
<classpathentry kind="lib" path="lib/log4j-1.2.15.jar"/>
<classpathentry kind="lib" path="lib/slf4j-api-1.5.0.jar"/>
<classpathentry kind="lib" path="lib/slf4j-log4j12-1.5.0.jar"/>
<classpathentry kind="lib" path="lib/spring.jar"/>
<classpathentry kind="output" path="bin"/>
</classpath>
Re: Why my added libraries are automatically removed from &quot;Java Build Path&quot; in Ecl [message #1384910 is a reply to message #1384836] Tue, 03 June 2014 04:23 Go to previous messageGo to next message
Sana Shaikh is currently offline Sana ShaikhFriend
Messages: 7
Registered: May 2014
Junior Member
Actually I tried many things,
recreated the server instance to check if there was problem wid a previous one...
tried modifying server specific settings too...
bt no effect.
I could nt figure out what's wrong..
There may be something wrong wid the IDE settings... bt What .. Who knowsss Sad
Re: Why my added libraries are automatically removed from &amp;quot;Java Build Path&amp;quot [message #1385010 is a reply to message #1384909] Tue, 03 June 2014 15:29 Go to previous messageGo to next message
Larry Isaacs is currently offline Larry IsaacsFriend
Messages: 1310
Registered: July 2009
Senior Member
On 6/3/2014 12:20 AM, Sana Shaikh wrote:
> Well, .classpath file doe not contain anything odd, contents:
> <classpath>
> <classpathentry kind="src" path="src"/>
> <classpathentry kind="con"
> path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
> <classpathentry kind="lib"
> path="lib/mysql-connector-java-3.1.14-bin.jar"/>
> <classpathentry kind="lib" path="lib/antlr-2.7.6.jar"/>
> <classpathentry kind="lib" path="lib/commons-collections-3.1.jar"/>
> <classpathentry kind="lib" path="lib/commons-logging-api-1.1.jar"/>
> <classpathentry kind="lib" path="lib/ejb3-persistence.jar"/>
> <classpathentry kind="lib" path="lib/hibernate3.jar"/>
> <classpathentry kind="lib" path="lib/hibernate-annotations.jar"/>
> <classpathentry kind="lib"
> path="lib/hibernate-commons-annotations.jar"/>
> <classpathentry kind="lib" path="lib/hibernate-search.jar"/>
> <classpathentry kind="lib" path="lib/javassist-3.4.GA.jar"/>
> <classpathentry kind="lib" path="lib/jta.jar"/>
> <classpathentry kind="lib" path="lib/log4j-1.2.15.jar"/>
> <classpathentry kind="lib" path="lib/slf4j-api-1.5.0.jar"/>
> <classpathentry kind="lib" path="lib/slf4j-log4j12-1.5.0.jar"/>
> <classpathentry kind="lib" path="lib/spring.jar"/>
> <classpathentry kind="output" path="bin"/>
> </classpath>
>

This file shows no evidence of being a Dynamic Web Project. If
something is removing entries, it doesn't appear to be Web Tools doing it.

Cheers,
Larry
Re: Why my added libraries are automatically removed from &amp;quot;Java Build Path&amp;quot [message #1385102 is a reply to message #1385010] Wed, 04 June 2014 11:07 Go to previous messageGo to next message
Sana Shaikh is currently offline Sana ShaikhFriend
Messages: 7
Registered: May 2014
Junior Member
yes;
May be its nt the Web Tools removing those libraries...
bt something is....
strange..
Re: Why my added libraries are automatically removed from &amp;amp;quot;Java Build Path&amp; [message #1385120 is a reply to message #1385102] Wed, 04 June 2014 12:57 Go to previous messageGo to next message
Larry Isaacs is currently offline Larry IsaacsFriend
Messages: 1310
Registered: July 2009
Senior Member
On 6/4/2014 7:07 AM, Sana Shaikh wrote:
> yes;
> May be its nt the Web Tools removing those libraries...
> bt something is....
> strange..
I don't know if I can help, but the next step would be to look in the
..project file to see if any of the natures or builders give a clue as to
what Eclipse plugins may be "messing" with the project.

Cheers,
Larry
Re: Why my added libraries are automatically removed from &amp;amp;quot;Java Build Path&amp; [message #1385215 is a reply to message #1385120] Thu, 05 June 2014 03:26 Go to previous message
Sana Shaikh is currently offline Sana ShaikhFriend
Messages: 7
Registered: May 2014
Junior Member
Well, Yes I am trying to detect what the prob is...let's see
will get the solution InshaALLAH.
Thanku so much for all.JazakALLAH
Previous Topic:error in creating JSF projrct
Next Topic:Ganymede JEE - Tomcat 6.0 Server Plugin
Goto Forum:
  


Current Time: Sun Nov 23 20:25:20 GMT 2014

Powered by FUDForum. Page generated in 0.01985 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software