Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » ATL » AM3 installation for ATL Version 3.x
AM3 installation for ATL Version 3.x [message #1383388] Mon, 26 May 2014 06:41 Go to next message
UmaShankar Subramani is currently offline UmaShankar Subramani
Messages: 118
Registered: December 2011
Location: SWEDEN
Senior Member
Hi all,


I need to install AM3 and I am using ATL version 3.x .

Is this the only way to install AM3(by checking it out from the SVN described in the following link)?

https://wiki.eclipse.org/index.php?title=AM3/How_Install_New_AM3_From_SVN

[Updated on: Mon, 26 May 2014 07:16]

Report message to a moderator

Re: AM3 installation for ATL Version 3.x [message #1383879 is a reply to message #1383388] Mon, 26 May 2014 11:58 Go to previous messageGo to next message
Hugo Bruneliere is currently offline Hugo Bruneliere
Messages: 603
Registered: July 2009
Senior Member
Hello,

The AM3 prototype has not been tested with the latest Eclipse/ATL versions.
It should normally work as before with them but it is not possible to guarantee it.

There are currently no binaries provided, so you have to build/export the AM3 plugins with the Eclipse/ATL versions you want to use.


------------------------------------------
Hugo Bruneliere - R&D Engineer
AtlanMod research team (Inria, EMN & LINA)
Ecole des Mines de Nantes
Nantes - France
------------------------------------------
Re: AM3 installation for ATL Version 3.x [message #1383884 is a reply to message #1383879] Mon, 26 May 2014 12:50 Go to previous messageGo to next message
UmaShankar Subramani is currently offline UmaShankar Subramani
Messages: 118
Registered: December 2011
Location: SWEDEN
Senior Member
Hi Hugo,
Thanks for the information.

Could you please tell me the version combination of ATL and AM3, which is supposed to work fine.


Because I tried the following tutorial.

https://wiki.eclipse.org/AM3/How_Install_New_AM3_From_SVN

But I cannot get ATL 2.1(development branch) from CVS, and I get "No Such Repository" error.

[Updated on: Mon, 26 May 2014 16:26]

Report message to a moderator

Re: AM3 installation for ATL Version 3.x [message #1383978 is a reply to message #1383884] Tue, 27 May 2014 11:49 Go to previous message
Hugo Bruneliere is currently offline Hugo Bruneliere
Messages: 603
Registered: July 2009
Senior Member
Hello,

ATL code is now hosted on Git.
You can get it from http://git.eclipse.org/c/mmt/org.eclipse.atl.git


------------------------------------------
Hugo Bruneliere - R&D Engineer
AtlanMod research team (Inria, EMN & LINA)
Ecole des Mines de Nantes
Nantes - France
------------------------------------------
Previous Topic:Mapping one object to multiple
Next Topic:Migration from ATL to EMFTVM
Goto Forum:
  


Current Time: Sat Aug 30 14:29:19 EDT 2014

Powered by FUDForum. Page generated in 0.12996 seconds