Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » WindowBuilder » JGoodies FormLayout - Which version is supported?(Which version of FormLayout is supported by WindowBuilder)
JGoodies FormLayout - Which version is supported? [message #1381025] Sun, 25 May 2014 10:47 Go to next message
Timo Rumland is currently offline Timo RumlandFriend
Messages: 5
Registered: July 2009
Junior Member
Hello,

I would like to get started with WindowBuilder (using Eclipse Kepler Service Release 1,
Build id: 20130919-0819) and the JGoodies FormLayout layout manager.

As I used FormLayout in the past in our project, I already got the JARs on the classpath, which are these:



  • jgoodies-forms-1.8.0.jar
  • jgoodies-common-1.8.0.jar


As you see, it is the latest version of JGoodies FormLayout.

When I now start building the GUI with WindowBuilder, it generates the following code:

// [...]
setLayout( new FormLayout(new ColumnSpec[] {
	com.jgoodies.forms.factories.FormFactory.RELATED_GAP_COLSPEC,
	com.jgoodies.forms.factories.FormFactory.DEFAULT_COLSPEC,
// [...]


With JGoodies FormLayout version 1.6, the class "FormFactory" has been renamed to "FormSpecs".


So, my question is - which version of JGoodies FormLayout does WindowBuilder support exactly?

Is support for the latest version planned?


Thanks a lot for your help!
Re: JGoodies FormLayout - Which version is supported? [message #1381342 is a reply to message #1381025] Sun, 25 May 2014 14:03 Go to previous messageGo to next message
Eric Clayberg is currently offline Eric ClaybergFriend
Messages: 886
Registered: July 2009
Location: Boston, MA
Senior Member
WindowBuilder ships with JGFL 1.3.0 (forms-1.3.0.jar).

We don't plan to update the support anytime soon, but would take a patch from someone who wants to update it.
Re: JGoodies FormLayout - Which version is supported? [message #1382003 is a reply to message #1381342] Sun, 25 May 2014 20:49 Go to previous messageGo to next message
Timo Rumland is currently offline Timo RumlandFriend
Messages: 5
Registered: July 2009
Junior Member
Thanks a lot for your answer.

Manuel Laggner offered a patch for JGoodies FormLayout 1.7.2 already here: https://bugs.eclipse.org/bugs/show_bug.cgi?id=387771#c2

Maybe this could be patched into a new release of WindowBuilder.
Re: JGoodies FormLayout - Which version is supported? [message #1411384 is a reply to message #1381025] Sat, 23 August 2014 06:13 Go to previous messageGo to next message
Markus Bollig is currently offline Markus BolligFriend
Messages: 0
Registered: August 2014
Location: Germany
I've created a patch that adds support for version 1.8.0 of the JGoodies FormLayout.
I would be very pleased if you could integrate the patch as soon as possible.

Kind regards

Markus
  • Attachment: patch.zip
    (Size: 535.63KB, Downloaded 33 times)
Re: JGoodies FormLayout - Which version is supported? [message #1411490 is a reply to message #1411384] Sat, 23 August 2014 13:37 Go to previous message
Eric Clayberg is currently offline Eric ClaybergFriend
Messages: 886
Registered: July 2009
Location: Boston, MA
Senior Member
Excellent! Thank you! We'll try to integrate this into the build soon.
Previous Topic:SWT Designer - DnD not working
Next Topic:WindowBuilder and EMF Databinding
Goto Forum:
  


Current Time: Sat Nov 29 02:56:32 GMT 2014

Powered by FUDForum. Page generated in 0.01648 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software