Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Incompatible JVM
Incompatible JVM [message #240461] Mon, 12 November 2007 22:24 Go to next message
Eclipse User
Originally posted by: flaflashr.yahoo.com

I already searched the FAQ and this topic is not covered. I am well
experienced in Linux, but not in Eclipse nor Java nor development
platforms.

My system is a Dell Latitude notebook running Kubuntu 7.1 Gutsy Gibbon

I installed eclipse-java-europa-fall2-linux-gtk.tar.gz into
/usr/local/eclipse/. I had previously installed
jdk-1_5_0_13-linux-i586.bin.

I have set $JAVA_HOME to /usr/local/jdk1.5.0_13 where I installed it.

When I try to start Eclipse, I get an error "Incompatible JVM - Version
1.4.2-02 of the JVM is not suitable for this product. Version 1.5 or
greater is required".

Where do I set this.

My next question is likely to be "how do I configure Apache-Tomcat so that
Eclipse invokes it?"

Thanks,

Jim
Re: Incompatible JVM [message #240472 is a reply to message #240461] Mon, 12 November 2007 22:48 Go to previous messageGo to next message
Eclipse User
Originally posted by: zx.us.ibm.com

Can you try passing -vm to Eclipse?

../eclipse -vm <location of 1.5 vm>

Cheers,

~ Chris
Re: Incompatible JVM [message #240476 is a reply to message #240461] Mon, 12 November 2007 23:33 Go to previous message
Paul A. Rubin is currently offline Paul A. Rubin
Messages: 188
Registered: July 2009
Senior Member
Fla wrote:
> I already searched the FAQ and this topic is not covered. I am well
> experienced in Linux, but not in Eclipse nor Java nor development
> platforms.
>
> My system is a Dell Latitude notebook running Kubuntu 7.1 Gutsy Gibbon
>
> I installed eclipse-java-europa-fall2-linux-gtk.tar.gz into
> /usr/local/eclipse/. I had previously installed
> jdk-1_5_0_13-linux-i586.bin.
>
> I have set $JAVA_HOME to /usr/local/jdk1.5.0_13 where I installed it.
>
> When I try to start Eclipse, I get an error "Incompatible JVM - Version
> 1.4.2-02 of the JVM is not suitable for this product. Version 1.5 or
> greater is required".
>
> Where do I set this.
>

As Chris A. noted, you can specify the JVM in the command that starts
Eclipse.

If you want to make the Sun JVM your default JVM (I did), you might try

sudo update-alternatives --config java

(and pick the Sun JVM). After I did that, I was able to start Eclipse
with just 'eclipse' and get the right JVM. There's a HOWTO at
http://ubuntuforums.org/showthread.php?t=76702.

/Paul
Previous Topic:Java project: linked source vs NTFS junction
Next Topic:cannot deploy with eclipse, auth cancel
Goto Forum:
  


Current Time: Wed Sep 17 05:51:34 GMT 2014

Powered by FUDForum. Page generated in 0.01752 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software