Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » ecore references
ecore references [message #1367252] Mon, 19 May 2014 18:04 Go to next message
Filipe Ramos is currently offline Filipe Ramos
Messages: 18
Registered: December 2013
Junior Member
Hi,

I've a ecore model with one EClass that contains a reference to another EClass. That reference has a lower bound of 0 and a upper bound of -1.

I generated the model code, but there's no code created for me to set the references, only for get them... Why is that?

Thanks...
Re: ecore references [message #1367288 is a reply to message #1367252] Mon, 19 May 2014 18:20 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4097
Registered: July 2009
Senior Member
Hi

For collections you do getXXX().add(y)

Regards

Ed Willink

On 19/05/2014 19:04, Filipe Ramos wrote:
> Hi,
>
> I've a ecore model with one EClass that contains a reference to
> another EClass. That reference has a lower bound of 0 and a upper
> bound of -1.
>
> I generated the model code, but there's no code created for me to set
> the references, only for get them... Why is that?
>
> Thanks...
Re: ecore references [message #1369361 is a reply to message #1367288] Tue, 20 May 2014 14:51 Go to previous message
Filipe Ramos is currently offline Filipe Ramos
Messages: 18
Registered: December 2013
Junior Member
Thanks! Razz
Previous Topic:Run CDO Server in Web
Next Topic:[CDO/Hibernate]Import data from XMI files to an existing repository - Unresolved proxy
Goto Forum:
  


Current Time: Fri Oct 24 13:44:03 GMT 2014

Powered by FUDForum. Page generated in 0.17575 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software