Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Why isn't merge finding any changes?
Why isn't merge finding any changes? [message #23189] Tue, 01 July 2008 23:30 Go to next message
No real name is currently offline No real nameFriend
Messages: 25
Registered: July 2009
Junior Member
I've just updated to Eclipse 3.4 on Linux and updated the plugins to 2.0.1.

When I try to merge a branch with the trunk, I get no differences. I
have confirmed that there are differences by checking out the trunk and
branch into separate directories and doing a diff -r.

In the preferences for SVN connector, I choose "SVN kit (SVNKit 1.2.0
development (http://svnkit.com/) r4310)".

I use a svn hosting company for the repository and they are using SVN
1.4. Locally I have v1.4.6 of the svn client commandline utilities.

I also deleted project (without deleting the files) and recreated the
project.

What am I doing wrong?
Re: Why isn't merge finding any changes? [message #23416 is a reply to message #23189] Wed, 02 July 2008 12:55 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: alexander.gurov.polarion.org

Hello Chris,


First of all, please note that SVN Kit 1.2.0 connector is SVN 1.5
compatible one. So, it silently converts working copy from SVN 1.4
compatible into SVN 1.5 compatible format. This mean that SVN 1.4.6 client
which you are installed locally will not work with these working copies
(at least with converted parts).

The second moment is merging itself. Did you specified correctly start and
stop revisions (by default both points to HEAD and this revision range
always contains no changes)?
Re: Why isn't merge finding any changes? [message #24104 is a reply to message #23416] Thu, 03 July 2008 06:10 Go to previous messageGo to next message
No real name is currently offline No real nameFriend
Messages: 25
Registered: July 2009
Junior Member
Alexander Gurov wrote:
> First of all, please note that SVN Kit 1.2.0 connector is SVN 1.5
> compatible one. So, it silently converts working copy from SVN 1.4
> compatible into SVN 1.5 compatible format. This mean that SVN 1.4.6
> client which you are installed locally will not work with these working
> copies (at least with converted parts).

Are svn 1.5 client utilities backward compatible with 1.4 repository server?

> The second moment is merging itself. Did you specified correctly start
> and stop revisions (by default both points to HEAD and this revision
> range always contains no changes)?

Now that I look at it more closely, I didn't.

This was because it wasn't clear that right-clicking on the project head
and select Team->Merge... would not automatically use the url of the
right-clicked project as one the sources to merge with. And that the
dialog defaults to 'simple', but I incorrectly assumed the url I was
selected would be use to merge with the working copy and not with it's self.

I'd suggest you eliminate the 'simple' option and auto-fill one of the
source url's with the url of the selected working copy.

However, I'm still having issues. One of my sub-directory is not being
compared. There are ~600 files in it and there are 29 files that are
different. Why isn't it merging on this one directory. I'm choosing the
root of the trunk and root of the branch.
Re: Why isn't merge finding any changes? [message #24206 is a reply to message #24104] Thu, 03 July 2008 09:47 Go to previous message
Alexei Goncharov is currently offline Alexei GoncharovFriend
Messages: 35
Registered: July 2009
Member
> Are svn 1.5 client utilities backward compatible with 1.4 repository server?

Yes, they are. But some client functionality, which depends on server (ex.
Merge Tracking) - the server specific features list can be found on
http://subversion.tigris.org/svn_1.5_releasenotes.html .

> Now that I look at it more closely, I didn't.

> This was because it wasn't clear that right-clicking on the project head
> and select Team->Merge... would not automatically use the url of the
> right-clicked project as one the sources to merge with. And that the
> dialog defaults to 'simple', but I incorrectly assumed the url I was
> selected would be use to merge with the working copy and not with it's self.

> I'd suggest you eliminate the 'simple' option and auto-fill one of the
> source url's with the url of the selected working copy.

> However, I'm still having issues. One of my sub-directory is not being
> compared. There are ~600 files in it and there are 29 files that are
> different. Why isn't it merging on this one directory. I'm choosing the
> root of the trunk and root of the branch.

The fact is that Simple and Advance modes are not just 'easy and hard',
but absolutely different merge modes.

The simple mode should be used to merge the changes from one source to a
working copy, and advance is for merging changes from different sources -
please read SVN book for details on merging.
Previous Topic:Getting javahl 1.4.5 to work on windows xp
Next Topic:Folder 'Compare With' feature
Goto Forum:
  


Current Time: Mon Nov 24 04:00:13 GMT 2014

Powered by FUDForum. Page generated in 0.05094 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software