Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Linux System Trace Statistical Agent in 2005071281519
Linux System Trace Statistical Agent in 2005071281519 [message #23163] Thu, 21 July 2005 13:55 Go to next message
Troy Poppe is currently offline Troy Poppe
Messages: 9
Registered: July 2009
Junior Member
I'm trying to create a Statistical configuration item that would monitor the
"Linux System Trace" that would be attached to the RAServer running on my
linux box. However, when I try to profile this item I get a "IWAT6062E
Could not create trace agent on RAC", with the following details:

org.eclipse.hyades.internal.execution.local.control.NoSuchAp plicationException
BUNDLE_NAME ..........org.eclipse.hyades.perfmon
BUNDLE_LOCATION ..........update@plugins/org.eclipse.hyades.perfmon_4.0.0/
BUNDLE_ID ..........748
BUNDLE ..........update@plugins/org.eclipse.hyades.perfmon_4.0.0/ [748]
org.eclipse.hyades.internal.execution.local.control.NoSuchAp plicationException
at
org.eclipse.hyades.internal.execution.local.control.ProcessI mpl.launch(ProcessImpl.java:192)
at
org.eclipse.hyades.perfmon.common.internal.CommonModuleTrace $Init.run(CommonModuleTrace.java:317)
at
org.eclipse.hyades.perfmon.common.internal.CommonModuleTrace .run(CommonModuleTrace.java:128)
at
org.eclipse.hyades.perfmon.common.internal.CommonModuleTrace LaunchJob.run(CommonModuleTraceLaunchJob.java:39)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:76)

In the plugins directory for the RAC, I have the following:

drwxrwxr-x 2 tpo tpo 4096 2005-07-19 14:51
org.apache.jakarta_commons_logging_1.0.3
-rw-rw-r-- 1 tpo tpo 453884 2005-07-18 13:36
org.eclipse.core.runtime_3.1.0.jar
-rw-rw-r-- 1 tpo tpo 137063 2005-07-18 13:36
org.eclipse.emf.common_2.1.0.jar
-rw-rw-r-- 1 tpo tpo 639778 2005-07-18 13:36
org.eclipse.emf.ecore_2.1.0.jar
-rw-rw-r-- 1 tpo tpo 144460 2005-07-18 13:36
org.eclipse.emf.ecore.xmi_2.1.0.jar
drwxrwxr-x 3 tpo tpo 4096 2005-07-19 14:51
org.eclipse.hyades.execution_4.0.0
drwxrwxr-x 4 tpo tpo 4096 2005-07-19 14:51
org.eclipse.hyades.logging.adapter_4.0.0
drwxrwxr-x 5 tpo tpo 4096 2005-07-19 14:51
org.eclipse.hyades.logging.core_4.0.0
drwxrwxr-x 5 tpo tpo 4096 2005-07-19 14:51
org.eclipse.hyades.logging.parsers_4.0.0
drwxrwxr-x 7 tpo tpo 4096 2005-07-19 14:51
org.eclipse.hyades.perfmon.agents_4.0.0
drwxrwxr-x 5 tpo tpo 4096 2005-07-19 14:51
org.eclipse.hyades.perfmon.linux
drwxrwxr-x 4 tpo tpo 4096 2005-07-19 14:51
org.eclipse.hyades.test.core_4.0.0
drwxrwxr-x 4 tpo tpo 4096 2005-07-19 14:51
org.eclipse.hyades.test.tools.core_4.0.0
drwxrwxr-x 3 tpo tpo 4096 2005-07-19 14:51
org.eclipse.tptp.platform.collection.framework_4.0.0
drwxrwxr-x 3 tpo tpo 4096 2005-07-19 14:52
org.eclipse.tptp.platform.models_4.0.0
drwxrwxr-x 3 tpo tpo 4096 2005-07-19 14:52 org.junit_3.8.1

Does the NoSuchApplicationException indicate a problem in my Eclipse
configuration? or with the RAC? Am I missing something?

Thanks.

Troy
Re: Linux System Trace Statistical Agent in 2005071281519 [message #23200 is a reply to message #23163] Thu, 21 July 2005 14:48 Go to previous message
Troy Poppe is currently offline Troy Poppe
Messages: 9
Registered: July 2009
Junior Member
As it turns out, the LinuxAgent executable wasn't marked as executable...
chmod'ing it made it work...

T


"Troy Poppe" <troy.poppe@eia.doe.gov> wrote in message
news:dbo9ga$jll$1@news.eclipse.org...
> I'm trying to create a Statistical configuration item that would monitor
> the "Linux System Trace" that would be attached to the RAServer running on
> my linux box. However, when I try to profile this item I get a "IWAT6062E
> Could not create trace agent on RAC", with the following details:
>
> org.eclipse.hyades.internal.execution.local.control.NoSuchAp plicationException
> BUNDLE_NAME ..........org.eclipse.hyades.perfmon
> BUNDLE_LOCATION
> ..........update@plugins/org.eclipse.hyades.perfmon_4.0.0/
> BUNDLE_ID ..........748
> BUNDLE ..........update@plugins/org.eclipse.hyades.perfmon_4.0.0/ [748]
>
> org.eclipse.hyades.internal.execution.local.control.NoSuchAp plicationException
> at
> org.eclipse.hyades.internal.execution.local.control.ProcessI mpl.launch(ProcessImpl.java:192)
> at
> org.eclipse.hyades.perfmon.common.internal.CommonModuleTrace $Init.run(CommonModuleTrace.java:317)
> at
> org.eclipse.hyades.perfmon.common.internal.CommonModuleTrace .run(CommonModuleTrace.java:128)
> at
> org.eclipse.hyades.perfmon.common.internal.CommonModuleTrace LaunchJob.run(CommonModuleTraceLaunchJob.java:39)
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:76)
>
> In the plugins directory for the RAC, I have the following:
>
> drwxrwxr-x 2 tpo tpo 4096 2005-07-19 14:51
> org.apache.jakarta_commons_logging_1.0.3
> -rw-rw-r-- 1 tpo tpo 453884 2005-07-18 13:36
> org.eclipse.core.runtime_3.1.0.jar
> -rw-rw-r-- 1 tpo tpo 137063 2005-07-18 13:36
> org.eclipse.emf.common_2.1.0.jar
> -rw-rw-r-- 1 tpo tpo 639778 2005-07-18 13:36
> org.eclipse.emf.ecore_2.1.0.jar
> -rw-rw-r-- 1 tpo tpo 144460 2005-07-18 13:36
> org.eclipse.emf.ecore.xmi_2.1.0.jar
> drwxrwxr-x 3 tpo tpo 4096 2005-07-19 14:51
> org.eclipse.hyades.execution_4.0.0
> drwxrwxr-x 4 tpo tpo 4096 2005-07-19 14:51
> org.eclipse.hyades.logging.adapter_4.0.0
> drwxrwxr-x 5 tpo tpo 4096 2005-07-19 14:51
> org.eclipse.hyades.logging.core_4.0.0
> drwxrwxr-x 5 tpo tpo 4096 2005-07-19 14:51
> org.eclipse.hyades.logging.parsers_4.0.0
> drwxrwxr-x 7 tpo tpo 4096 2005-07-19 14:51
> org.eclipse.hyades.perfmon.agents_4.0.0
> drwxrwxr-x 5 tpo tpo 4096 2005-07-19 14:51
> org.eclipse.hyades.perfmon.linux
> drwxrwxr-x 4 tpo tpo 4096 2005-07-19 14:51
> org.eclipse.hyades.test.core_4.0.0
> drwxrwxr-x 4 tpo tpo 4096 2005-07-19 14:51
> org.eclipse.hyades.test.tools.core_4.0.0
> drwxrwxr-x 3 tpo tpo 4096 2005-07-19 14:51
> org.eclipse.tptp.platform.collection.framework_4.0.0
> drwxrwxr-x 3 tpo tpo 4096 2005-07-19 14:52
> org.eclipse.tptp.platform.models_4.0.0
> drwxrwxr-x 3 tpo tpo 4096 2005-07-19 14:52 org.junit_3.8.1
>
> Does the NoSuchApplicationException indicate a problem in my Eclipse
> configuration? or with the RAC? Am I missing something?
>
> Thanks.
>
> Troy
>
Previous Topic:How can I export UML2 and execution flow figures?
Next Topic:Java.exe crash when profiling J2EE app in JBoss 4 with TPTP 4.0-200507181519
Goto Forum:
  


Current Time: Tue Oct 21 21:49:51 GMT 2014

Powered by FUDForum. Page generated in 0.01915 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software