Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Maven Integration (M2E) » Import multi-module project from Bazaar SCM
Import multi-module project from Bazaar SCM [message #23156] Fri, 20 March 2009 12:44 Go to next message
Eclipse User
Originally posted by: jonathan.magma.ca

I have just setup a new Eclipse 3.5M6 installation with a new workspace,
installed the required and optional prerequisites for M2Eclipse and then
installed M2Eclipse 0.9.7.200902090947 without problems.

The first operation I tried to perform was to import a multi-module
project from a Bazaar SCM. About half way through the import (3 modules
imported) I got an internal error report with the following details:

An internal error occurred during: "Importing Maven projects".
Attempted to beginRule:
MultiRule[P/bzr-eclipse,P/.org.eclipse.jdt.core.external.fol ders], does
not match outer scope rule:
org.maven.ide.eclipse.internal.project.SchedulingRule@5e20dc10

The complete error log contained the following:

!SESSION 2009-03-19 22:07:37.932
-----------------------------------------------
eclipse.buildId=I20090313-0100
java.version=1.6.0_12
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_CA
Command-line arguments: -os linux -ws gtk -arch x86_64 -clean

!ENTRY org.eclipse.ui.workbench 2 0 2009-03-19 22:07:57.358
!MESSAGE A handler conflict occurred. This may disable some commands.
!SUBENTRY 1 org.eclipse.ui.workbench 2 0 2009-03-19 22:07:57.358
!MESSAGE Conflict for
'AUTOGEN:::org.eclipse.jst.jee.ui.CreateDeploymentFilesActio n/createDeploymentFiles':
HandlerActivation(commandId=AUTOGEN:::org.eclipse.jst.jee.ui .CreateDeploymentFilesAction/createDeploymentFiles,
handler=ActionDelegateHandlerProxy(null,org.eclipse.jst.jee. ui.internal.CreateDeploymentFilesActionDelegate),
expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@dc737be),sourcePriority=16384)
HandlerActivation(commandId=AUTOGEN:::org.eclipse.jst.jee.ui .CreateDeploymentFilesAction/createDeploymentFiles,
handler=ActionDelegateHandlerProxy(null,org.eclipse.jst.jee. ui.internal.CreateDeploymentFilesActionDelegate),
expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@dc737be),sourcePriority=16384)
!SESSION 2009-03-19 22:10:32.206
-----------------------------------------------
eclipse.buildId=I20090313-0100
java.version=1.6.0_12
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_CA
Command-line arguments: -os linux -ws gtk -arch x86_64 -clean

!ENTRY org.eclipse.ui.workbench 2 0 2009-03-19 22:10:50.225
!MESSAGE A handler conflict occurred. This may disable some commands.
!SUBENTRY 1 org.eclipse.ui.workbench 2 0 2009-03-19 22:10:50.225
!MESSAGE Conflict for
'AUTOGEN:::org.eclipse.jst.jee.ui.CreateDeploymentFilesActio n/createDeploymentFiles':
HandlerActivation(commandId=AUTOGEN:::org.eclipse.jst.jee.ui .CreateDeploymentFilesAction/createDeploymentFiles,
handler=ActionDelegateHandlerProxy(null,org.eclipse.jst.jee. ui.internal.CreateDeploymentFilesActionDelegate),
expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@5b8099a),sourcePriority=16384)
HandlerActivation(commandId=AUTOGEN:::org.eclipse.jst.jee.ui .CreateDeploymentFilesAction/createDeploymentFiles,
handler=ActionDelegateHandlerProxy(null,org.eclipse.jst.jee. ui.internal.CreateDeploymentFilesActionDelegate),
expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@5b8099a),sourcePriority=16384)

!ENTRY org.eclipse.osgi 2 1 2009-03-19 22:21:45.518
!MESSAGE NLS unused message:
ValidationMessageFactory_DefaultElSeverityDisplayName in:
org.eclipse.jst.jsf.ui.internal.validation.messages

!ENTRY org.eclipse.osgi 2 1 2009-03-19 22:21:45.519
!MESSAGE NLS unused message:
ValidationMessageFactory_DefaultTypeComparatorDisplayName in:
org.eclipse.jst.jsf.ui.internal.validation.messages
!SESSION 2009-03-19 22:28:02.337
-----------------------------------------------
eclipse.buildId=I20090313-0100
java.version=1.6.0_12
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_CA
Command-line arguments: -os linux -ws gtk -arch x86_64 -clean

!ENTRY org.eclipse.ui.workbench 2 0 2009-03-19 22:28:27.768
!MESSAGE A handler conflict occurred. This may disable some commands.
!SUBENTRY 1 org.eclipse.ui.workbench 2 0 2009-03-19 22:28:27.768
!MESSAGE Conflict for
'AUTOGEN:::org.eclipse.jst.jee.ui.CreateDeploymentFilesActio n/createDeploymentFiles':
HandlerActivation(commandId=AUTOGEN:::org.eclipse.jst.jee.ui .CreateDeploymentFilesAction/createDeploymentFiles,
handler=ActionDelegateHandlerProxy(null,org.eclipse.jst.jee. ui.internal.CreateDeploymentFilesActionDelegate),
expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@527a9c0f),sourcePriority=16384)
HandlerActivation(commandId=AUTOGEN:::org.eclipse.jst.jee.ui .CreateDeploymentFilesAction/createDeploymentFiles,
handler=ActionDelegateHandlerProxy(null,org.eclipse.jst.jee. ui.internal.CreateDeploymentFilesActionDelegate),
expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@527a9c0f),sourcePriority=16384)

!ENTRY org.eclipse.equinox.p2.metadata.repository 4 1000 2009-03-19
22:28:32.730
!MESSAGE No repository found at
file:/home/jonathan/Downloads/Eclipse/eclipse-3.5M6-mk2/conf iguration/org.eclipse.osgi/bundles/138/data/listener_1925729 951/.
!SESSION 2009-03-19 22:35:32.122
-----------------------------------------------
eclipse.buildId=I20090313-0100
java.version=1.6.0_12
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_CA
Command-line arguments: -os linux -ws gtk -arch x86_64 -clean

!ENTRY org.eclipse.ui.workbench 2 0 2009-03-19 22:35:50.118
!MESSAGE A handler conflict occurred. This may disable some commands.
!SUBENTRY 1 org.eclipse.ui.workbench 2 0 2009-03-19 22:35:50.118
!MESSAGE Conflict for
'AUTOGEN:::org.eclipse.jst.jee.ui.CreateDeploymentFilesActio n/createDeploymentFiles':
HandlerActivation(commandId=AUTOGEN:::org.eclipse.jst.jee.ui .CreateDeploymentFilesAction/createDeploymentFiles,
handler=ActionDelegateHandlerProxy(null,org.eclipse.jst.jee. ui.internal.CreateDeploymentFilesActionDelegate),
expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@7656acfa),sourcePriority=16384)
HandlerActivation(commandId=AUTOGEN:::org.eclipse.jst.jee.ui .CreateDeploymentFilesAction/createDeploymentFiles,
handler=ActionDelegateHandlerProxy(null,org.eclipse.jst.jee. ui.internal.CreateDeploymentFilesActionDelegate),
expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@7656acfa),sourcePriority=16384)
!SESSION 2009-03-20 08:24:33.315
-----------------------------------------------
eclipse.buildId=I20090313-0100
java.version=1.6.0_12
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_CA
Command-line arguments: -os linux -ws gtk -arch x86_64 -clean

!ENTRY org.eclipse.ui.workbench 2 0 2009-03-20 08:25:06.572
!MESSAGE A handler conflict occurred. This may disable some commands.
!SUBENTRY 1 org.eclipse.ui.workbench 2 0 2009-03-20 08:25:06.572
!MESSAGE Conflict for
'AUTOGEN:::org.eclipse.jst.jee.ui.CreateDeploymentFilesActio n/createDeploymentFiles':
HandlerActivation(commandId=AUTOGEN:::org.eclipse.jst.jee.ui .CreateDeploymentFilesAction/createDeploymentFiles,
handler=ActionDelegateHandlerProxy(null,org.eclipse.jst.jee. ui.internal.CreateDeploymentFilesActionDelegate),
expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@12f53870),sourcePriority=16384)
HandlerActivation(commandId=AUTOGEN:::org.eclipse.jst.jee.ui .CreateDeploymentFilesAction/createDeploymentFiles,
handler=ActionDelegateHandlerProxy(null,org.eclipse.jst.jee. ui.internal.CreateDeploymentFilesActionDelegate),
expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@12f53870),sourcePriority=16384)

!ENTRY org.eclipse.core.jobs 4 2 2009-03-20 08:48:47.481
!MESSAGE An internal error occurred during: "Importing Maven projects".
!STACK 0
java.lang.IllegalArgumentException: Attempted to beginRule:
MultiRule[P/bzr-eclipse,P/.org.eclipse.jdt.core.external.fol ders], does
not match outer scope rule:
org.maven.ide.eclipse.internal.project.SchedulingRule@2c478134
at org.eclipse.core.runtime.Assert.isLegal(Assert.java:63)
at org.eclipse.core.internal.jobs.ThreadJob.illegalPush(ThreadJ ob.java:122)
at org.eclipse.core.internal.jobs.ThreadJob.push(ThreadJob.java :232)
at org.eclipse.core.internal.jobs.ImplicitJobs.begin(ImplicitJo bs.java:80)
at org.eclipse.core.internal.jobs.JobManager.beginRule(JobManag er.java:232)
at
org.eclipse.core.internal.resources.WorkManager.checkIn(Work Manager.java:117)
at
org.eclipse.core.internal.resources.Workspace.prepareOperati on(Workspace.java:1747)
at org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1795)
at
org.eclipse.jdt.internal.core.JavaModelOperation.runOperatio n(JavaModelOperation.java:793)
at
org.eclipse.jdt.internal.core.JavaProject.setRawClasspath(Ja vaProject.java:2836)
at
org.eclipse.jdt.internal.core.JavaProject.setRawClasspath(Ja vaProject.java:2867)
at
org.maven.ide.eclipse.jdt.internal.JavaProjectConfigurator.a ddMavenClasspathContainer(JavaProjectConfigurator.java:586)
at
org.maven.ide.eclipse.jdt.internal.JavaProjectConfigurator.c onfigure(JavaProjectConfigurator.java:90)
at
org.maven.ide.eclipse.internal.project.ProjectConfigurationM anager.updateProjectConfiguration(ProjectConfigurationManage r.java:292)
at
org.maven.ide.eclipse.internal.project.ProjectConfigurationM anager.configureNewMavenProject(ProjectConfigurationManager. java:215)
at
org.maven.ide.eclipse.internal.project.ProjectConfigurationM anager.importProjects(ProjectConfigurationManager.java:154)
at
org.maven.ide.eclipse.wizards.MavenProjectCheckoutJob$Checko utJobChangeListener$3.runInWorkspace(MavenProjectCheckoutJob .java:224)
at
org.eclipse.core.internal.resources.InternalWorkspaceJob.run (InternalWorkspaceJob.java:38)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

The project being imported is under active development so it is quite
likely that there are either questionable or possibly downright wrong
entries in the POM's. Right now I am looking for initial suggestions for
trouble-shooting as well as an initial assessment as to whether an issue
should be raised. I am willing to help in any way necessary to resolve
this issue. Just let me know what I should be doing. I have a reasonable
knowledge of Eclipse including some plug-in development a few years ago
but I am completely new to Maven.

Thanks

Jonathan Gossage
Re: Import multi-module project from Bazaar SCM [message #23195 is a reply to message #23156] Fri, 20 March 2009 17:56 Go to previous message
Eugene Kuleshov is currently offline Eugene Kuleshov
Messages: 505
Registered: July 2009
Senior Member
Jonathan,

This is a known issue in m2eclipse when it is running on Eclipse 3.5
(not really related to Bazaar). Please use Eclipse 3.4.x until it is
fixed (hopefully in 0.9.8 build).

Thanks

Eugene


Jonathan Gossage wrote:
> I have just setup a new Eclipse 3.5M6 installation with a new workspace,
> installed the required and optional prerequisites for M2Eclipse and then
> installed M2Eclipse 0.9.7.200902090947 without problems.
>
> The first operation I tried to perform was to import a multi-module
> project from a Bazaar SCM. About half way through the import (3 modules
> imported) I got an internal error report with the following details:
>
> An internal error occurred during: "Importing Maven projects".
> Attempted to beginRule:
> MultiRule[P/bzr-eclipse,P/.org.eclipse.jdt.core.external.fol ders], does
> not match outer scope rule:
> org.maven.ide.eclipse.internal.project.SchedulingRule@5e20dc10
>
> The complete error log contained the following:
>
> !SESSION 2009-03-19 22:07:37.932
> -----------------------------------------------
> eclipse.buildId=I20090313-0100
> java.version=1.6.0_12
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_CA
> Command-line arguments: -os linux -ws gtk -arch x86_64 -clean
>
> !ENTRY org.eclipse.ui.workbench 2 0 2009-03-19 22:07:57.358
> !MESSAGE A handler conflict occurred. This may disable some commands.
> !SUBENTRY 1 org.eclipse.ui.workbench 2 0 2009-03-19 22:07:57.358
> !MESSAGE Conflict for
> 'AUTOGEN:::org.eclipse.jst.jee.ui.CreateDeploymentFilesActio n/createDeploymentFiles':
> HandlerActivation(commandId=AUTOGEN:::org.eclipse.jst.jee.ui .CreateDeploymentFilesAction/createDeploymentFiles,
> handler=ActionDelegateHandlerProxy(null,org.eclipse.jst.jee. ui.internal.CreateDeploymentFilesActionDelegate),
> expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@dc737be),sourcePriority=16384)
> HandlerActivation(commandId=AUTOGEN:::org.eclipse.jst.jee.ui .CreateDeploymentFilesAction/createDeploymentFiles,
> handler=ActionDelegateHandlerProxy(null,org.eclipse.jst.jee. ui.internal.CreateDeploymentFilesActionDelegate),
> expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@dc737be),sourcePriority=16384)
> !SESSION 2009-03-19 22:10:32.206
> -----------------------------------------------
> eclipse.buildId=I20090313-0100
> java.version=1.6.0_12
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_CA
> Command-line arguments: -os linux -ws gtk -arch x86_64 -clean
>
> !ENTRY org.eclipse.ui.workbench 2 0 2009-03-19 22:10:50.225
> !MESSAGE A handler conflict occurred. This may disable some commands.
> !SUBENTRY 1 org.eclipse.ui.workbench 2 0 2009-03-19 22:10:50.225
> !MESSAGE Conflict for
> 'AUTOGEN:::org.eclipse.jst.jee.ui.CreateDeploymentFilesActio n/createDeploymentFiles':
> HandlerActivation(commandId=AUTOGEN:::org.eclipse.jst.jee.ui .CreateDeploymentFilesAction/createDeploymentFiles,
> handler=ActionDelegateHandlerProxy(null,org.eclipse.jst.jee. ui.internal.CreateDeploymentFilesActionDelegate),
> expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@5b8099a),sourcePriority=16384)
> HandlerActivation(commandId=AUTOGEN:::org.eclipse.jst.jee.ui .CreateDeploymentFilesAction/createDeploymentFiles,
> handler=ActionDelegateHandlerProxy(null,org.eclipse.jst.jee. ui.internal.CreateDeploymentFilesActionDelegate),
> expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@5b8099a),sourcePriority=16384)
>
> !ENTRY org.eclipse.osgi 2 1 2009-03-19 22:21:45.518
> !MESSAGE NLS unused message:
> ValidationMessageFactory_DefaultElSeverityDisplayName in:
> org.eclipse.jst.jsf.ui.internal.validation.messages
>
> !ENTRY org.eclipse.osgi 2 1 2009-03-19 22:21:45.519
> !MESSAGE NLS unused message:
> ValidationMessageFactory_DefaultTypeComparatorDisplayName in:
> org.eclipse.jst.jsf.ui.internal.validation.messages
> !SESSION 2009-03-19 22:28:02.337
> -----------------------------------------------
> eclipse.buildId=I20090313-0100
> java.version=1.6.0_12
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_CA
> Command-line arguments: -os linux -ws gtk -arch x86_64 -clean
>
> !ENTRY org.eclipse.ui.workbench 2 0 2009-03-19 22:28:27.768
> !MESSAGE A handler conflict occurred. This may disable some commands.
> !SUBENTRY 1 org.eclipse.ui.workbench 2 0 2009-03-19 22:28:27.768
> !MESSAGE Conflict for
> 'AUTOGEN:::org.eclipse.jst.jee.ui.CreateDeploymentFilesActio n/createDeploymentFiles':
> HandlerActivation(commandId=AUTOGEN:::org.eclipse.jst.jee.ui .CreateDeploymentFilesAction/createDeploymentFiles,
> handler=ActionDelegateHandlerProxy(null,org.eclipse.jst.jee. ui.internal.CreateDeploymentFilesActionDelegate),
> expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@527a9c0f),sourcePriority=16384)
> HandlerActivation(commandId=AUTOGEN:::org.eclipse.jst.jee.ui .CreateDeploymentFilesAction/createDeploymentFiles,
> handler=ActionDelegateHandlerProxy(null,org.eclipse.jst.jee. ui.internal.CreateDeploymentFilesActionDelegate),
> expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@527a9c0f),sourcePriority=16384)
>
> !ENTRY org.eclipse.equinox.p2.metadata.repository 4 1000 2009-03-19
> 22:28:32.730
> !MESSAGE No repository found at
> file:/home/jonathan/Downloads/Eclipse/eclipse-3.5M6-mk2/conf iguration/org.eclipse.osgi/bundles/138/data/listener_1925729 951/.
> !SESSION 2009-03-19 22:35:32.122
> -----------------------------------------------
> eclipse.buildId=I20090313-0100
> java.version=1.6.0_12
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_CA
> Command-line arguments: -os linux -ws gtk -arch x86_64 -clean
>
> !ENTRY org.eclipse.ui.workbench 2 0 2009-03-19 22:35:50.118
> !MESSAGE A handler conflict occurred. This may disable some commands.
> !SUBENTRY 1 org.eclipse.ui.workbench 2 0 2009-03-19 22:35:50.118
> !MESSAGE Conflict for
> 'AUTOGEN:::org.eclipse.jst.jee.ui.CreateDeploymentFilesActio n/createDeploymentFiles':
> HandlerActivation(commandId=AUTOGEN:::org.eclipse.jst.jee.ui .CreateDeploymentFilesAction/createDeploymentFiles,
> handler=ActionDelegateHandlerProxy(null,org.eclipse.jst.jee. ui.internal.CreateDeploymentFilesActionDelegate),
> expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@7656acfa),sourcePriority=16384)
> HandlerActivation(commandId=AUTOGEN:::org.eclipse.jst.jee.ui .CreateDeploymentFilesAction/createDeploymentFiles,
> handler=ActionDelegateHandlerProxy(null,org.eclipse.jst.jee. ui.internal.CreateDeploymentFilesActionDelegate),
> expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@7656acfa),sourcePriority=16384)
> !SESSION 2009-03-20 08:24:33.315
> -----------------------------------------------
> eclipse.buildId=I20090313-0100
> java.version=1.6.0_12
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_CA
> Command-line arguments: -os linux -ws gtk -arch x86_64 -clean
>
> !ENTRY org.eclipse.ui.workbench 2 0 2009-03-20 08:25:06.572
> !MESSAGE A handler conflict occurred. This may disable some commands.
> !SUBENTRY 1 org.eclipse.ui.workbench 2 0 2009-03-20 08:25:06.572
> !MESSAGE Conflict for
> 'AUTOGEN:::org.eclipse.jst.jee.ui.CreateDeploymentFilesActio n/createDeploymentFiles':
> HandlerActivation(commandId=AUTOGEN:::org.eclipse.jst.jee.ui .CreateDeploymentFilesAction/createDeploymentFiles,
> handler=ActionDelegateHandlerProxy(null,org.eclipse.jst.jee. ui.internal.CreateDeploymentFilesActionDelegate),
> expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@12f53870),sourcePriority=16384)
> HandlerActivation(commandId=AUTOGEN:::org.eclipse.jst.jee.ui .CreateDeploymentFilesAction/createDeploymentFiles,
> handler=ActionDelegateHandlerProxy(null,org.eclipse.jst.jee. ui.internal.CreateDeploymentFilesActionDelegate),
> expression=WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@12f53870),sourcePriority=16384)
>
> !ENTRY org.eclipse.core.jobs 4 2 2009-03-20 08:48:47.481
> !MESSAGE An internal error occurred during: "Importing Maven projects".
> !STACK 0
> java.lang.IllegalArgumentException: Attempted to beginRule:
> MultiRule[P/bzr-eclipse,P/.org.eclipse.jdt.core.external.fol ders], does
> not match outer scope rule:
> org.maven.ide.eclipse.internal.project.SchedulingRule@2c478134
> at org.eclipse.core.runtime.Assert.isLegal(Assert.java:63)
> at org.eclipse.core.internal.jobs.ThreadJob.illegalPush(ThreadJ ob.java:122)
> at org.eclipse.core.internal.jobs.ThreadJob.push(ThreadJob.java :232)
> at org.eclipse.core.internal.jobs.ImplicitJobs.begin(ImplicitJo bs.java:80)
> at org.eclipse.core.internal.jobs.JobManager.beginRule(JobManag er.java:232)
> at
> org.eclipse.core.internal.resources.WorkManager.checkIn(Work Manager.java:117)
> at
> org.eclipse.core.internal.resources.Workspace.prepareOperati on(Workspace.java:1747)
> at org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1795)
> at
> org.eclipse.jdt.internal.core.JavaModelOperation.runOperatio n(JavaModelOperation.java:793)
> at
> org.eclipse.jdt.internal.core.JavaProject.setRawClasspath(Ja vaProject.java:2836)
> at
> org.eclipse.jdt.internal.core.JavaProject.setRawClasspath(Ja vaProject.java:2867)
> at
> org.maven.ide.eclipse.jdt.internal.JavaProjectConfigurator.a ddMavenClasspathContainer(JavaProjectConfigurator.java:586)
> at
> org.maven.ide.eclipse.jdt.internal.JavaProjectConfigurator.c onfigure(JavaProjectConfigurator.java:90)
> at
> org.maven.ide.eclipse.internal.project.ProjectConfigurationM anager.updateProjectConfiguration(ProjectConfigurationManage r.java:292)
> at
> org.maven.ide.eclipse.internal.project.ProjectConfigurationM anager.configureNewMavenProject(ProjectConfigurationManager. java:215)
> at
> org.maven.ide.eclipse.internal.project.ProjectConfigurationM anager.importProjects(ProjectConfigurationManager.java:154)
> at
> org.maven.ide.eclipse.wizards.MavenProjectCheckoutJob$Checko utJobChangeListener$3.runInWorkspace(MavenProjectCheckoutJob .java:224)
> at
> org.eclipse.core.internal.resources.InternalWorkspaceJob.run (InternalWorkspaceJob.java:38)
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
>
> The project being imported is under active development so it is quite
> likely that there are either questionable or possibly downright wrong
> entries in the POM's. Right now I am looking for initial suggestions for
> trouble-shooting as well as an initial assessment as to whether an issue
> should be raised. I am willing to help in any way necessary to resolve
> this issue. Just let me know what I should be doing. I have a reasonable
> knowledge of Eclipse including some plug-in development a few years ago
> but I am completely new to Maven.
>
> Thanks
>
> Jonathan Gossage
>
Previous Topic:[tycho] mvn package and NullPointerException
Next Topic:Add maven dependency?
Goto Forum:
  


Current Time: Mon Sep 01 03:47:35 EDT 2014

Powered by FUDForum. Page generated in 0.01825 seconds