Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Eclipse Galileo and Apache CXF
Eclipse Galileo and Apache CXF [message #234138] Fri, 24 July 2009 15:28 Go to next message
Andre Ribeiro is currently offline Andre Ribeiro
Messages: 58
Registered: July 2009
Member
Hi all,

I had an application developed using the Eclipse Ganymede. This
application has a web service implemented using Apache CXF and run
without problems.
Recently, we migrated it to Eclipse Galileo and the web service stoped
working. It doesn’t raise any error or exception and apparently runs
without problem. However, the services are not created. Is there someone
with the same problem?

The code used to create de web service is:

JaxWsServerFactoryBean svrFactory = new JaxWsServerFactoryBean();

svrFactory.setServiceClass(Position.class);

svrFactory.setAddress(address);

svrFactory.setServiceBean(implementor);

svrFactory.getInInterceptors().add(new PremfireInterceptor());

svrFactory.create();

The log is:

C:\Program
Files\Java\eclipse-rcp-galileo\plugins\org.eclipse.equinox.l auncher_1.0.200.v20090520.jar

24/Jul/2009 16:15:29
org.apache.cxf.service.factory.ReflectionServiceFactoryBean
buildServiceFromClass

INFO: Creating Service {http://server.position /}PositionService from
class position.server.Position

24/Jul/2009 16:15:29 org.apache.cxf.endpoint.ServerImpl initDestination

INFO: Setting the server's publish address to be
http://localhost:9000/position

24/Jul/2009 16:15:30 org.mortbay.log.Slf4jLog info

INFO: Logging to org.slf4j.impl.JDK14LoggerAdapter(org.mortbay.log) via
org.mortbay.log.Slf4jLog

24/Jul/2009 16:15:30 org.mortbay.log.Slf4jLog info

INFO: jetty-6.1.16

24/Jul/2009 16:15:30 org.mortbay.log.Slf4jLog info

INFO: Started SelectChannelConnector@0.0.0.0:9000

The server is available and the WSDL is returned
(http://localhost:9000/position?wsdl) but the services are not present
in the wsdl.


Any help is very welcomed!

Much Thanks!!
Re: Eclipse Galileo and Apache CXF [message #467841 is a reply to message #234138] Mon, 03 August 2009 06:41 Go to previous messageGo to next message
David Williams is currently offline David Williams
Messages: 176
Registered: July 2009
Senior Member
André Ribeiro wrote:
> Hi all,
>
> I had an application developed using the Eclipse Ganymede. This
> application has a web service implemented using Apache CXF and run
> without problems.
> Recently, we migrated it to Eclipse Galileo and the web service stoped
> working.
Just to sanity check, how did you migrate to Galileo? Did you get the
latest stuff from our webtools/updates site? I ask only because the CXF
tools are not included in the JEE IDE all-in-one download and I was just
wondering if that caused some issues.

But, otherwise, you'll have to wait for the webservices experts to respond.
Re: Eclipse Galileo and Apache CXF [message #468292 is a reply to message #234138] Tue, 04 August 2009 21:21 Go to previous message
Shane Clarke is currently offline Shane Clarke
Messages: 67
Registered: July 2009
Member
Hi André,

I've tested a similar example in both Ganymede and Galileo that uses
JAXWSFactoryBeans and interceptors and it runs fine and the service is
present in the WSDL.

I was using the java_first_jaxws_factory_bean example from a CXF 2.2.1
install samples directory. That sample can be found in any CXF 2.2
download onwards.

Could you try that sample if you get a chance to see if you get a WSDL
with a service?

Thanks,
Shane
Previous Topic:Eclipse3.4 propertysheetpage | HtmlEditor
Next Topic:http://www.w3.org/TR/html401/strict.dtd fails Validate?
Goto Forum:
  


Current Time: Wed Sep 17 21:50:44 GMT 2014

Powered by FUDForum. Page generated in 0.01882 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software