Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » can't add apache 6.0.18 server runtime
can't add apache 6.0.18 server runtime [message #233256] Thu, 02 July 2009 22:58 Go to next message
Tom H is currently offline Tom H
Messages: 136
Registered: July 2009
Senior Member
Hi,

I am running eclipse 3.4 with apache tomcat 6.0.18 from the fedora 11
repos, and I'm pretty much stuck with that due to company policy.

I am trying to add a Tomcat server runtime, and I am trying to select
the tomcat base directory /use/share/tomcat6, however I am getting the
following error;

The Tomcat installation directory is not valid. It is missing expected
file or folder lib/servlet-api.jar (alternate name [servletapi6].jar).

None of the tomcat6 packages that are shipped with f11 actually contain
either of those files;
[tomh@localhost ~]$ rpm -qa | grep tomcat6 | xargs rpm -ql | grep
servlet | grep jar
/usr/share/java/tomcat6/tomcat6-servlet-2.5-api-6.0.18.jar
/usr/share/java/tomcat6-servlet-2.5-api-6.0.18.jar
/usr/share/java/tomcat6-servlet-2.5-api.jar

It looks like the fedora11 packaged tomcat6 does not have the expected
file structure that the tomcat server adapter is expecting.

Any ideas on what I am doing wrong?

Thanks,

Tom
Re: can't add apache 6.0.18 server runtime [message #233325 is a reply to message #233256] Mon, 06 July 2009 10:38 Go to previous message
Larry Isaacs is currently offline Larry Isaacs
Messages: 1305
Registered: July 2009
Senior Member
Tom H wrote:
> Hi,
>
> I am running eclipse 3.4 with apache tomcat 6.0.18 from the fedora 11
> repos, and I'm pretty much stuck with that due to company policy.
>
> I am trying to add a Tomcat server runtime, and I am trying to select
> the tomcat base directory /use/share/tomcat6, however I am getting the
> following error;
>
> The Tomcat installation directory is not valid. It is missing expected
> file or folder lib/servlet-api.jar (alternate name [servletapi6].jar).
>
> None of the tomcat6 packages that are shipped with f11 actually contain
> either of those files;
> [tomh@localhost ~]$ rpm -qa | grep tomcat6 | xargs rpm -ql | grep
> servlet | grep jar
> /usr/share/java/tomcat6/tomcat6-servlet-2.5-api-6.0.18.jar
> /usr/share/java/tomcat6-servlet-2.5-api-6.0.18.jar
> /usr/share/java/tomcat6-servlet-2.5-api.jar
>
> It looks like the fedora11 packaged tomcat6 does not have the expected
> file structure that the tomcat server adapter is expecting.
>
> Any ideas on what I am doing wrong?
>
> Thanks,
>
> Tom
>
>

This is mentioned in the Tomcat FAQ [1]. If you aren't able to download
a binary version of Tomcat 6.0.18 from the Apache site, then you can use
the following workaround.

Add the following system property to end of the eclipse.ini file or to
the startup arguments for your Eclipse.

-Dorg.eclipse.jst.server.tomcat.core.verify60install=lib/jas per-el.jar,lib/servlet-api.jar|[servletapi6].jar,bin/bootstr ap.jar,conf,webapps

The value shown duplicates what WTP Tomcat support is using to validate
the Tomcat6 installation. The "lib/servlet-api.jar|[servletapi6].jar"
means it expects to find "lib/servlet-api.jar" or
"lib/[servletapi6].jar". Obviously those that created the Tomcat
package changed some things from prior packages. Check in the "lib"
folder to see what the link is to tomcat6-servlet-2.5-api-6.0.18.jar and
update that "file spec" in the setting. Update any other "file specs"
that also fails.

If you can tell me what the new links are, I'll see about adding them to
the list.

Cheers,
Larry

[1]
http://wiki.eclipse.org/WTP_Tomcat_FAQ#Why_won.27t_the_New_S erver_Runtime_dialog_recognize_my_Linux_installed_version_of _Tomcat.3F
Previous Topic:XML Schema Editor says the type from an XML-Catalog-Referenced schema is invalid
Next Topic:Ganamede, Galileo, and Tomcat 6
Goto Forum:
  


Current Time: Wed Aug 27 05:17:08 EDT 2014

Powered by FUDForum. Page generated in 0.02852 seconds