Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » can't install from update site
can't install from update site [message #233224] Thu, 02 July 2009 17:49 Go to next message
Tom H is currently offline Tom HFriend
Messages: 136
Registered: July 2009
Senior Member
Hi,

If I try to install the Web developer tools from the WTP update site, I
get the following error; and ideas on that?


Cannot complete the request. See the details.
Unsatisfied dependency: [org.eclipse.wst.server.discovery 1.0.0.v20090602]
requiredCapability: osgi.bundle/org.eclipse.equinox.p2.repository/1.0.0
Cannot find a solution where both "bundle org.eclipse.wst.xml.ui
[1.1.0,1.2.0)" and "bundle org.eclipse.wst.xml.ui [1.0.400,1.1.0)" are
satisfied.
Unsatisfied dependency: [org.eclipse.wst.server.discovery 1.0.0.v20090602]
requiredCapability: osgi.bundle/org.eclipse.equinox.p2.repository/1.0.0
Cannot find a solution where both "bundle org.eclipse.wst.wsdl
[1.2.0,1.3.0)" and "bundle org.eclipse.wst.wsdl [1.1.0,1.2.0)" are
satisfied.
Cannot find a solution where both "bundle org.eclipse.wst.xml.ui
[1.1.0,1.2.0)" and "bundle org.eclipse.wst.xml.ui [1.0.400,1.1.0)" are
satisfied.
Cannot find a solution where both "bundle org.eclipse.wst.wsdl
[1.2.0,1.3.0)" and "bundle org.eclipse.wst.wsdl [1.1.0,1.2.0)" are
satisfied.
Cannot find a solution where both "bundle org.eclipse.wst.xml.ui
[1.1.0,1.2.0)" and "bundle org.eclipse.wst.xml.ui [1.0.400,1.1.0)" are
satisfied.
Unsatisfied dependency: [org.eclipse.wst.ws 1.1.3.v200902042200]
requiredCapability: osgi.bundle/org.eclipse.wst.wsdl/[1.1.0,1.2.0)
Unsatisfied dependency: [org.eclipse.wst.jsdt.web.ui
1.0.200.v200904230847] requiredCapability:
osgi.bundle/org.eclipse.wst.xml.ui/[1.1.0,1.2.0)
Unsatisfied dependency: [org.eclipse.wst.ws.parser 1.0.202.v200805140300]
requiredCapability: osgi.bundle/org.eclipse.wst.wsdl/[1.1.0,1.2.0)
Unsatisfied dependency: [org.eclipse.wst.server_ui.feature.feature.group
3.1.0.v200901260254-7B3DLAtJZNyxfIUbDVOO4256] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.server.discovery/[ 1.0.0.v20090602,1.0.0.v20090602]
Unsatisfied dependency: [org.eclipse.wst.server_ui.feature.feature.group
3.1.0.v200901260254-7B3DLAtJZNyxfIUbDVOO4256] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.server.ui/[1.1.102 .v20090515,1.1.102.v20090515]
Unsatisfied dependency: [org.eclipse.wst.server.ui 1.1.102.v20090515]
requiredCapability:
osgi.bundle/org.eclipse.wst.server.discovery/[1.0.0,2.0.0)
Unsatisfied dependency: [org.eclipse.wst.xml_ui.feature.feature.group
3.1.0.v200905240756-7H6FMVDxtkM-5OgPGKK4xQocS5AL] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.xml.ui/[1.1.0.v200 905242047,1.1.0.v200905242047]
Unsatisfied dependency: [org.eclipse.wst.web_ui.feature.feature.group
3.1.0.v200905242131-7R77FShEVw2xUGpF1LiNxdVAELXy] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.server_ui.feature. feature.group/[3.1.0.v200901260254-7B3DLAtJZNyxfIUbDVOO4256, 3.1.0.v200901260254-7B3DLAtJZNyxfIUbDVOO4256]
Unsatisfied dependency: [org.eclipse.wst.web_ui.feature.feature.group
3.1.0.v200905242131-7R77FShEVw2xUGpF1LiNxdVAELXy] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.jsdt.web.ui/[1.0.2 00.v200904230847,1.0.200.v200904230847]
Unsatisfied dependency: [org.eclipse.wst.web_ui.feature.feature.group
3.1.0.v200905242131-7R77FShEVw2xUGpF1LiNxdVAELXy] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.xml_ui.feature.fea ture.group/[3.1.0.v200905240756-7H6FMVDxtkM-5OgPGKK4xQocS5AL ,3.1.0.v200905240756-7H6FMVDxtkM-5OgPGKK4xQocS5AL]
Unsatisfied dependency: [org.eclipse.wst.web_ui.feature.feature.group
3.1.0.v200905242131-7R77FShEVw2xUGpF1LiNxdVAELXy] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.ws_ui.feature.feat ure.group/[3.1.0.v200903020650-7I6FPlEtEnGxSBtv6tT6hoOXcS3b, 3.1.0.v200903020650-7I6FPlEtEnGxSBtv6tT6hoOXcS3b]
Unsatisfied dependency: [org.eclipse.wst.server.discovery 1.0.0.v20090602]
requiredCapability: osgi.bundle/org.eclipse.equinox.p2.repository/1.0.0
Unsatisfied dependency: [org.eclipse.wst.ws_ui.feature.feature.group
3.1.0.v200903020650-7I6FPlEtEnGxSBtv6tT6hoOXcS3b] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.xml_ui.feature.fea ture.group/[3.1.0.v200905240756-7H6FMVDxtkM-5OgPGKK4xQocS5AL ,3.1.0.v200905240756-7H6FMVDxtkM-5OgPGKK4xQocS5AL]



Thanks,

Tom
Re: can't install from update site [message #233249 is a reply to message #233224] Thu, 02 July 2009 20:47 Go to previous message
Eclipse UserFriend
Originally posted by: eclipse-news.rizzoweb.com

Tom H wrote:
> Hi,
>
> If I try to install the Web developer tools from the WTP update site, I
> get the following error; and ideas on that?

What version of Eclipse are you trying to install into? What version of
WTP are you trying to install? Did you check that the two are compatible
(eg, that you're not trying to install the latest WTP into an older
Eclipse like 3.4)?

Hope this helps,
Eric


> Cannot complete the request. See the details.
> Unsatisfied dependency: [org.eclipse.wst.server.discovery
> 1.0.0.v20090602] requiredCapability:
> osgi.bundle/org.eclipse.equinox.p2.repository/1.0.0
> Cannot find a solution where both "bundle org.eclipse.wst.xml.ui
> [1.1.0,1.2.0)" and "bundle org.eclipse.wst.xml.ui [1.0.400,1.1.0)" are
> satisfied.
> Unsatisfied dependency: [org.eclipse.wst.server.discovery
> 1.0.0.v20090602] requiredCapability:
> osgi.bundle/org.eclipse.equinox.p2.repository/1.0.0
> Cannot find a solution where both "bundle org.eclipse.wst.wsdl
> [1.2.0,1.3.0)" and "bundle org.eclipse.wst.wsdl [1.1.0,1.2.0)" are
> satisfied.
> Cannot find a solution where both "bundle org.eclipse.wst.xml.ui
> [1.1.0,1.2.0)" and "bundle org.eclipse.wst.xml.ui [1.0.400,1.1.0)" are
> satisfied.
> Cannot find a solution where both "bundle org.eclipse.wst.wsdl
> [1.2.0,1.3.0)" and "bundle org.eclipse.wst.wsdl [1.1.0,1.2.0)" are
> satisfied.
> Cannot find a solution where both "bundle org.eclipse.wst.xml.ui
> [1.1.0,1.2.0)" and "bundle org.eclipse.wst.xml.ui [1.0.400,1.1.0)" are
> satisfied.
> Unsatisfied dependency: [org.eclipse.wst.ws 1.1.3.v200902042200]
> requiredCapability: osgi.bundle/org.eclipse.wst.wsdl/[1.1.0,1.2.0)
> Unsatisfied dependency: [org.eclipse.wst.jsdt.web.ui
> 1.0.200.v200904230847] requiredCapability:
> osgi.bundle/org.eclipse.wst.xml.ui/[1.1.0,1.2.0)
> Unsatisfied dependency: [org.eclipse.wst.ws.parser
> 1.0.202.v200805140300] requiredCapability:
> osgi.bundle/org.eclipse.wst.wsdl/[1.1.0,1.2.0)
> Unsatisfied dependency: [org.eclipse.wst.server_ui.feature.feature.group
> 3.1.0.v200901260254-7B3DLAtJZNyxfIUbDVOO4256] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.wst.server.discovery/[ 1.0.0.v20090602,1.0.0.v20090602]
>
> Unsatisfied dependency: [org.eclipse.wst.server_ui.feature.feature.group
> 3.1.0.v200901260254-7B3DLAtJZNyxfIUbDVOO4256] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.wst.server.ui/[1.1.102 .v20090515,1.1.102.v20090515]
>
> Unsatisfied dependency: [org.eclipse.wst.server.ui 1.1.102.v20090515]
> requiredCapability:
> osgi.bundle/org.eclipse.wst.server.discovery/[1.0.0,2.0.0)
> Unsatisfied dependency: [org.eclipse.wst.xml_ui.feature.feature.group
> 3.1.0.v200905240756-7H6FMVDxtkM-5OgPGKK4xQocS5AL] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.wst.xml.ui/[1.1.0.v200 905242047,1.1.0.v200905242047]
>
> Unsatisfied dependency: [org.eclipse.wst.web_ui.feature.feature.group
> 3.1.0.v200905242131-7R77FShEVw2xUGpF1LiNxdVAELXy] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.wst.server_ui.feature. feature.group/[3.1.0.v200901260254-7B3DLAtJZNyxfIUbDVOO4256, 3.1.0.v200901260254-7B3DLAtJZNyxfIUbDVOO4256]
>
> Unsatisfied dependency: [org.eclipse.wst.web_ui.feature.feature.group
> 3.1.0.v200905242131-7R77FShEVw2xUGpF1LiNxdVAELXy] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.wst.jsdt.web.ui/[1.0.2 00.v200904230847,1.0.200.v200904230847]
>
> Unsatisfied dependency: [org.eclipse.wst.web_ui.feature.feature.group
> 3.1.0.v200905242131-7R77FShEVw2xUGpF1LiNxdVAELXy] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.wst.xml_ui.feature.fea ture.group/[3.1.0.v200905240756-7H6FMVDxtkM-5OgPGKK4xQocS5AL ,3.1.0.v200905240756-7H6FMVDxtkM-5OgPGKK4xQocS5AL]
>
> Unsatisfied dependency: [org.eclipse.wst.web_ui.feature.feature.group
> 3.1.0.v200905242131-7R77FShEVw2xUGpF1LiNxdVAELXy] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.wst.ws_ui.feature.feat ure.group/[3.1.0.v200903020650-7I6FPlEtEnGxSBtv6tT6hoOXcS3b, 3.1.0.v200903020650-7I6FPlEtEnGxSBtv6tT6hoOXcS3b]
>
> Unsatisfied dependency: [org.eclipse.wst.server.discovery
> 1.0.0.v20090602] requiredCapability:
> osgi.bundle/org.eclipse.equinox.p2.repository/1.0.0
> Unsatisfied dependency: [org.eclipse.wst.ws_ui.feature.feature.group
> 3.1.0.v200903020650-7I6FPlEtEnGxSBtv6tT6hoOXcS3b] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.wst.xml_ui.feature.fea ture.group/[3.1.0.v200905240756-7H6FMVDxtkM-5OgPGKK4xQocS5AL ,3.1.0.v200905240756-7H6FMVDxtkM-5OgPGKK4xQocS5AL]
>
>
>
>
> Thanks,
>
> Tom
>
Previous Topic:help with editorConfiguration
Next Topic:Eclipse JUnit Plug-in Test
Goto Forum:
  


Current Time: Fri Dec 19 22:50:00 GMT 2014

Powered by FUDForum. Page generated in 0.01864 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software