Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » XML Schema Editor says the type from an XML-Catalog-Referenced schema is invalid
XML Schema Editor says the type from an XML-Catalog-Referenced schema is invalid [message #233137] Tue, 30 June 2009 11:20 Go to next message
Istvan is currently offline Istvan
Messages: 15
Registered: July 2009
Junior Member
Hello!

I have an XSD (called Test) in a jar somewhere on my disk. Targetnamespace
of the XSD is "test".
I add it to XML Catalog with this key:
"specialprefix:testjar/test/test.xsd". Key type is schemalocation.

I also have an XSD (called Importer) in my eclipse workspace and I import to
it the xsd mentioned before.
Schemalocation of the import is "specialprefix:testjar/test/test.xsd", as it
is set in the Catalog.
xmlns prefix is set to "test" in the xsd:schema tag.

After doing this, when I create a new element in Importer and press CTRL +
Space in the type attribute of it, I can see the types defined by Test (in a
"test: ..." form). This is OK.
But when I save Importer it says that the type is invalid.

So it seems the content assist mechanism resolves XML Catalog entries but
the element/type validation mechanism does not.

Is it a bug? Is it may be reported to bugzilla?


Thanks,
Istvan
Re: XML Schema Editor says the type from an XML-Catalog-Referenced schema is invalid [message #233153 is a reply to message #233137] Wed, 01 July 2009 03:16 Go to previous messageGo to next message
Eclipse User
Originally posted by: valentinbaciu.hotmail.com

Hi Istvan, perhaps you can attach a simple example project with your schema
and the jar? If they are proprietary attach some mocked up sample schemas
instead. If you are contributing to the user catalog, export it and attach
it here. If you are contributing to the sytem catalog using the catalog
extension point please attach that extension. We'll try to help once we
understand your scenario better.

Regards, Valentin

"Istvan" <acereg@citromail.hu> wrote in message
news:h2dagn$uku$1@build.eclipse.org...
> Hello!
>
> I have an XSD (called Test) in a jar somewhere on my disk. Targetnamespace
> of the XSD is "test".
> I add it to XML Catalog with this key:
> "specialprefix:testjar/test/test.xsd". Key type is schemalocation.
>
> I also have an XSD (called Importer) in my eclipse workspace and I import
> to it the xsd mentioned before.
> Schemalocation of the import is "specialprefix:testjar/test/test.xsd", as
> it is set in the Catalog.
> xmlns prefix is set to "test" in the xsd:schema tag.
>
> After doing this, when I create a new element in Importer and press CTRL +
> Space in the type attribute of it, I can see the types defined by Test (in
> a "test: ..." form). This is OK.
> But when I save Importer it says that the type is invalid.
>
> So it seems the content assist mechanism resolves XML Catalog entries but
> the element/type validation mechanism does not.
>
> Is it a bug? Is it may be reported to bugzilla?
>
>
> Thanks,
> Istvan
Re: XML Schema Editor says the type from an XML-Catalog-Referenced schema is invalid [message #233161 is a reply to message #233153] Wed, 01 July 2009 06:12 Go to previous messageGo to next message
Istvan is currently offline Istvan
Messages: 15
Registered: July 2009
Junior Member
This is a multi-part message in MIME format.

------=_NextPart_000_00C7_01C9FA45.34A907B0
Content-Type: text/plain;
format=flowed;
charset="iso-8859-1";
reply-type=response
Content-Transfer-Encoding: 7bit

Hello,

Sorry if my description was not so clear.
The concrete problem was solved, but a strange "thing" still exists.
I attached a zip file, the comments in testimport.xsd describe the
situation.

thanks,

Istvan

"Valentin" <valentinbaciu@hotmail.com> wrote in message
news:h2f2h5$ppm$1@build.eclipse.org...
> Hi Istvan, perhaps you can attach a simple example project with your
> schema and the jar? If they are proprietary attach some mocked up sample
> schemas instead. If you are contributing to the user catalog, export it
> and attach it here. If you are contributing to the sytem catalog using the
> catalog extension point please attach that extension. We'll try to help
> once we understand your scenario better.
>
> Regards, Valentin
>
> "Istvan" <acereg@citromail.hu> wrote in message
> news:h2dagn$uku$1@build.eclipse.org...
>> Hello!
>>
>> I have an XSD (called Test) in a jar somewhere on my disk.
>> Targetnamespace of the XSD is "test".
>> I add it to XML Catalog with this key:
>> "specialprefix:testjar/test/test.xsd". Key type is schemalocation.
>>
>> I also have an XSD (called Importer) in my eclipse workspace and I import
>> to it the xsd mentioned before.
>> Schemalocation of the import is "specialprefix:testjar/test/test.xsd", as
>> it is set in the Catalog.
>> xmlns prefix is set to "test" in the xsd:schema tag.
>>
>> After doing this, when I create a new element in Importer and press CTRL
>> + Space in the type attribute of it, I can see the types defined by Test
>> (in a "test: ..." form). This is OK.
>> But when I save Importer it says that the type is invalid.
>>
>> So it seems the content assist mechanism resolves XML Catalog entries but
>> the element/type validation mechanism does not.
>>
>> Is it a bug? Is it may be reported to bugzilla?
>>
>>
>> Thanks,
>> Istvan
>
>

------=_NextPart_000_00C7_01C9FA45.34A907B0
Content-Type: application/x-zip-compressed;
name="xsd_xmlcatalog_test.zip"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
filename="xsd_xmlcatalog_test.zip"

UEsDBAoAAAAAAAVX4Tor0Cce4gIAAOICAAAIAAAAdGVzdC5qYXJQSwMEFAAC AAAAo1PhOgAAAAAA
AAAAAAAAAAkAAABNRVRBLUlORi9QSwMEFAACAAgA9FbhOhIpELUsAAAANgAA ABQAAABNRVRBLUlO
Ri9NQU5JRkVTVC5NRvNNzMtMSy0u0Q1LLSrOzM+zUjDUM+DlcsxDEnEsSEzO SFUAigElzfRMebkA
UEsDBBQAAgAAAIpT4ToAAAAAAAAAAAAAAAAFAAAAdGVzdC9QSwMEFAACAAgA W1ThOopkBqwSAQAA
GQIAAA0AAAB0ZXN0L3Rlc3QueHNkdZFdS8MwFIavFfwPIfc2nXohY9luVBho EazgbdYds0CT1OT0
w39v2mR0U4Te9OU8z3kPWW0GXZMOnFfWcLrIckrAVHavjOT0vXy6vqeb9dXl avD7pa8OoAVB4SRg
ITT4RlTAKYJHSoLI+LOfZYA4PSA2S8b6vs/628w6yW7yfME+Xp7fJh8N+ovw TSugBg0GiQl2Tsvg
eozJNBVnKqubGobyu4EpjKmHrzY0T9G5zcEnp6/bomj1DhxlCWN/uBj9WhDD 5Pq/7OwnGEhOzcm2
I+LVqB7NiUpD83Uu3OxUheE9yE74MDKmxpoCpEDVwdYgyCMSGbQo6gclFXrS iboN0F26MpY/kc4X
zV1iw5ROj7L+AVBLAQIUABQAAgAAAKNT4ToAAAAAAAAAAAAAAAAJAAAAAAAA AAAAMAAAAAAAAABN
RVRBLUlORi9QSwECFAAUAAIACAD0VuE6EikQtSwAAAA2AAAAFAAAAAAAAAAA ACAAAAAnAAAATUVU
QS1JTkYvTUFOSUZFU1QuTUZQSwECFAAUAAIAAACKU+E6AAAAAAAAAAAAAAAA BQAAAAAAAAAAADAA
AACFAAAAdGVzdC9QSwECFAAUAAIACABbVOE6imQGrBIBAAAZAgAADQAAAAAA AAAAACAAAACoAAAA
dGVzdC90ZXN0LnhzZFBLBQYAAAAABAAEAOcAAADlAQAAAABQSwMEFAAAAAgA KmDhOlffm6hKAgAA
TQQAAA4AAAB0ZXN0aW1wb3J0LnhzZIWUTU/cMBCGz0HiPww+gbpJoL1UFgtq QZVWhR5gUXvg4nVm
s6aJnXqcDfn3jB0+26qVstnEM/PMOzN2jk/v2wa26Mk4OxdHxaEAtNpVxtZz cbP8kn8Upye7O8f3
VEnSG2wVBOVrDN9Ui9QpjXMRkIJpO+eDAMZZ+suSZMBcbELoZFkOw1AMHwrn 6/L94eFR+ePy4jqx
BezuZJN/JEwcwfl5OUmYmGDfJhcwSbtwWoVUCHWojWoSpbhTvowP6VYwRpQn EbiX5/y33CD8zx8M
AWEAY4G1wpkKqnE1BA5du6ZxA7cLBjVK5vH1pENmkXD7hInhzIa1aRDOJa+3 3e2LB5s49uZqIQEg
y/hVRk95Lsvo+UoSm/beKuTArzjCcuxQZs+jgfg0mWSW/btGdoM8f2z11Jnv G7SwgM4jEZwtry7g
HVwnLhcSaw+cjrdDPYM0Bmn7doU+dUttlWnUqsFiasknW4F1A+MIcZaisTLB eagcEpsCkBrpN5BW
NlpWCKzBNVusCthfhJggEpSlAT0EB+0Iv/q457jpYAIMzv+kWXwyE1zBqq8P HsV87tMoXe+5OHeH
OiSeZyL/yLXImYllDWnxldikMb57XLPJaqymLvypdMaJhk0ctQ6+4dZNIxFJ Gm8b/9xCAfuJwVLd
OmLTTtHOBrQhV0SGQt7w7aCA5Ya9BkVQocYumC0mVPvU50s1rqJi9uJLq56Y thrBxfpAG6/7loJi
4RQj0sSno4UNtpwvna25WKSDhn6papFEzt9Mpkwb5bh8+SzwwgNQSwECFAAK AAAAAAAFV+E6K9An
HuICAADiAgAACAAAAAAAAAAAACAAAAAAAAAAdGVzdC5qYXJQSwECFAAUAAAA CAAqYOE6V9+bqEoC
AABNBAAADgAAAAAAAAABACAAAAAIAwAAdGVzdGltcG9ydC54c2RQSwUGAAAA AAIAAgByAAAAfgUA
AAAA

------=_NextPart_000_00C7_01C9FA45.34A907B0--
Re: XML Schema Editor says the type from an XML-Catalog-Referenced schema is invalid [message #233169 is a reply to message #233161] Wed, 01 July 2009 11:03 Go to previous messageGo to next message
Wini Mark is currently offline Wini Mark
Messages: 5
Registered: July 2009
Junior Member
Hi Istvan,
I download your zip (xsd_xmlcatalog_test.zip) but it seems the file is
corrupted. There is no testimport.xsd file. Could you please attach your
project again so we can try to reproduce?

Thanks,
Wini
Re: XML Schema Editor says the type from an XML-Catalog-Referenced schema is invalid [message #233208 is a reply to message #233169] Thu, 02 July 2009 08:16 Go to previous messageGo to next message
Istvan is currently offline Istvan
Messages: 15
Registered: July 2009
Junior Member
This is a multi-part message in MIME format.

------=_NextPart_000_002D_01C9FB1F.AC385260
Content-Type: text/plain;
format=flowed;
charset="ISO-8859-15";
reply-type=response
Content-Transfer-Encoding: 7bit

Hello,

I attached a newly created zip.
(I downloaded the previous file from the newsgroup, it is not the same as
the one that is in my Sent folder of my email client. The file from the
newsgroup contains only the content of the jar that was added to the zip.
Strange...)

Thanks in advance,
Istvan

The
"Wini Mark" <wmmark@ca.ibm.com> wrote in message
news:bfdb3042db65f268e526cf80462bc889$1@www.eclipse.org...
> Hi Istvan,
> I download your zip (xsd_xmlcatalog_test.zip) but it seems the file is
> corrupted. There is no testimport.xsd file. Could you please attach your
> project again so we can try to reproduce?
> Thanks,
> Wini
>

------=_NextPart_000_002D_01C9FB1F.AC385260
Content-Type: application/x-zip-compressed;
name="xsd_xmlcatalog_test.zip"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
filename="xsd_xmlcatalog_test.zip"

UEsDBAoAAAAAAAVX4Tor0Cce4gIAAOICAAAIAAAAdGVzdC5qYXJQSwMEFAAC AAAAo1PhOgAAAAAA
AAAAAAAAAAkAAABNRVRBLUlORi9QSwMEFAACAAgA9FbhOhIpELUsAAAANgAA ABQAAABNRVRBLUlO
Ri9NQU5JRkVTVC5NRvNNzMtMSy0u0Q1LLSrOzM+zUjDUM+DlcsxDEnEsSEzO SFUAigElzfRMebkA
UEsDBBQAAgAAAIpT4ToAAAAAAAAAAAAAAAAFAAAAdGVzdC9QSwMEFAACAAgA W1ThOopkBqwSAQAA
GQIAAA0AAAB0ZXN0L3Rlc3QueHNkdZFdS8MwFIavFfwPIfc2nXohY9luVBho EazgbdYds0CT1OT0
w39v2mR0U4Te9OU8z3kPWW0GXZMOnFfWcLrIckrAVHavjOT0vXy6vqeb9dXl avD7pa8OoAVB4SRg
ITT4RlTAKYJHSoLI+LOfZYA4PSA2S8b6vs/628w6yW7yfME+Xp7fJh8N+ovw TSugBg0GiQl2Tsvg
eozJNBVnKqubGobyu4EpjKmHrzY0T9G5zcEnp6/bomj1DhxlCWN/uBj9WhDD 5Pq/7OwnGEhOzcm2
I+LVqB7NiUpD83Uu3OxUheE9yE74MDKmxpoCpEDVwdYgyCMSGbQo6gclFXrS iboN0F26MpY/kc4X
zV1iw5ROj7L+AVBLAQIUABQAAgAAAKNT4ToAAAAAAAAAAAAAAAAJAAAAAAAA AAAAMAAAAAAAAABN
RVRBLUlORi9QSwECFAAUAAIACAD0VuE6EikQtSwAAAA2AAAAFAAAAAAAAAAA ACAAAAAnAAAATUVU
QS1JTkYvTUFOSUZFU1QuTUZQSwECFAAUAAIAAACKU+E6AAAAAAAAAAAAAAAA BQAAAAAAAAAAADAA
AACFAAAAdGVzdC9QSwECFAAUAAIACABbVOE6imQGrBIBAAAZAgAADQAAAAAA AAAAACAAAACoAAAA
dGVzdC90ZXN0LnhzZFBLBQYAAAAABAAEAOcAAADlAQAAAABQSwMEFAAAAAgA KmDhOlffm6hKAgAA
TQQAAA4AAAB0ZXN0aW1wb3J0LnhzZIWUTU/cMBCGz0HiPww+gbpJoL1UFgtq QZVWhR5gUXvg4nVm
s6aJnXqcDfn3jB0+26qVstnEM/PMOzN2jk/v2wa26Mk4OxdHxaEAtNpVxtZz cbP8kn8Upye7O8f3
VEnSG2wVBOVrDN9Ui9QpjXMRkIJpO+eDAMZZ+suSZMBcbELoZFkOw1AMHwrn 6/L94eFR+ePy4jqx
BezuZJN/JEwcwfl5OUmYmGDfJhcwSbtwWoVUCHWojWoSpbhTvowP6VYwRpQn EbiX5/y33CD8zx8M
AWEAY4G1wpkKqnE1BA5du6ZxA7cLBjVK5vH1pENmkXD7hInhzIa1aRDOJa+3 3e2LB5s49uZqIQEg
y/hVRk95Lsvo+UoSm/beKuTArzjCcuxQZs+jgfg0mWSW/btGdoM8f2z11Jnv G7SwgM4jEZwtry7g
HVwnLhcSaw+cjrdDPYM0Bmn7doU+dUttlWnUqsFiasknW4F1A+MIcZaisTLB eagcEpsCkBrpN5BW
NlpWCKzBNVusCthfhJggEpSlAT0EB+0Iv/q457jpYAIMzv+kWXwyE1zBqq8P HsV87tMoXe+5OHeH
OiSeZyL/yLXImYllDWnxldikMb57XLPJaqymLvypdMaJhk0ctQ6+4dZNIxFJ Gm8b/9xCAfuJwVLd
OmLTTtHOBrQhV0SGQt7w7aCA5Ya9BkVQocYumC0mVPvU50s1rqJi9uJLq56Y thrBxfpAG6/7loJi
4RQj0sSno4UNtpwvna25WKSDhn6papFEzt9Mpkwb5bh8+SzwwgNQSwECFAAK AAAAAAAFV+E6K9An
HuICAADiAgAACAAAAAAAAAAAACAAAAAAAAAAdGVzdC5qYXJQSwECFAAUAAAA CAAqYOE6V9+bqEoC
AABNBAAADgAAAAAAAAABACAAAAAIAwAAdGVzdGltcG9ydC54c2RQSwUGAAAA AAIAAgByAAAAfgUA
AAAA

------=_NextPart_000_002D_01C9FB1F.AC385260--
Re: XML Schema Editor says the type from an XML-Catalog-Referenced schema is invalid [message #233279 is a reply to message #233208] Fri, 03 July 2009 15:12 Go to previous message
Wini Mark is currently offline Wini Mark
Messages: 5
Registered: July 2009
Junior Member
Hi Istvan,
I download your new zip file and it's still doesn't have the
testimport.xsd. Is there something that I have missed?
Thanks,
Wini
Previous Topic:Eclipse JUnit Plug-in Test
Next Topic:can't add apache 6.0.18 server runtime
Goto Forum:
  


Current Time: Sat Aug 02 00:54:22 EDT 2014

Powered by FUDForum. Page generated in 0.02281 seconds