Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » one or more required items could not be found
one or more required items could not be found [message #232951] Thu, 25 June 2009 17:15 Go to next message
Jay Sprenkle is currently offline Jay SprenkleFriend
Messages: 4
Registered: July 2009
Junior Member
Good afternoon,

I'm a newbie to Eclipse. I'm trying to install the xml tools in the latest
Galileo CDT release (via the built in Eclipse software update). Can anyone
explain what I've done to get the following?


Cannot complete the install because one or more required items could not
be found.
Software being installed: Eclipse XML Editors and Tools
3.1.0.v200905240756-7H6FMVDxtkM-5OgPGKK4xQocS5AL
(org.eclipse.wst.xml_ui.feature.feature.group
3.1.0.v200905240756-7H6FMVDxtkM-5OgPGKK4xQocS5AL)
Missing requirement: Structured Text Model 1.1.400.v200905141750
(org.eclipse.wst.sse.core 1.1.400.v200905141750) requires 'bundle
org.eclipse.emf.common [2.4.0,3.0.0)' but it could not be found
Cannot satisfy dependency:
From: SSE DTD Source Editor 1.0.400.v200904300717
(org.eclipse.wst.dtd.ui 1.0.400.v200904300717)
To: bundle org.eclipse.wst.xml.ui [1.0.400,1.2.0)
Cannot satisfy dependency:
From: Eclipse XML Editors and Tools 1.1.0.v200905242047
(org.eclipse.wst.xml.ui 1.1.0.v200905242047)
To: bundle org.eclipse.wst.sse.core [1.1.300,1.2.0)
Cannot satisfy dependency:
From: Eclipse XML Editors and Tools
3.1.0.v200905240756-7H6FMVDxtkM-5OgPGKK4xQocS5AL
(org.eclipse.wst.xml_ui.feature.feature.group
3.1.0.v200905240756-7H6FMVDxtkM-5OgPGKK4xQocS5AL)
To: org.eclipse.wst.dtd.ui [1.0.400.v200904300717]
Re: one or more required items could not be found [message #232967 is a reply to message #232951] Thu, 25 June 2009 17:31 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: david_williams.linux.vnet.ibm.com

Jay Sprenkle wrote:
> I'm a newbie to Eclipse. I'm trying to install the xml tools in the
> latest Galileo CDT release (via the built in Eclipse software update).
> Can anyone explain what I've done to get the following?
>
> [...]
I just tried installing XML on top of CDT and it worked ok. It might
have been some temporarily unavailable servers (with them being a little
overloaded, the first few days after release). If you continue to have
trouble, you'll have to give more details on exactly what you did.
Here's what I did:

Installed CDT package from
http://www.eclipse.org/downloads/

Started Eclipse (I used a fresh workspace, and while that's not strictly
required, it is usually easier while you are setting up).

Went to "install new software", picked the Galileo discovery site, and
picked "Eclipse XML Editors and Tools".

And, eventually, it completed and asked me to restart.

Hope that helps
Re: one or more required items could not be found [message #232974 is a reply to message #232967] Thu, 25 June 2009 17:44 Go to previous messageGo to next message
Jay Sprenkle is currently offline Jay SprenkleFriend
Messages: 4
Registered: July 2009
Junior Member
Woo hoo!

I guess the web tools repository isn't as up to date as the Galileo
repository. Changing the source of the update got me past the error.
Re: one or more required items could not be found [message #232982 is a reply to message #232974] Thu, 25 June 2009 18:39 Go to previous message
Eclipse UserFriend
Originally posted by: david_williams.linux.vnet.ibm.com

Jay Sprenkle wrote:
> Woo hoo!
>
> I guess the web tools repository isn't as up to date as the Galileo
> repository. Changing the source of the update got me past the error.
Ah, I see. The webtools site is up to date (it better be!) but it
doesn't have pre-reqs.

I see this in your original message:
requires 'bundle org.eclipse.emf.common [2.4.0,3.0.0)' but it could not
be found

So, just for reference, if people try to use the Web Tools update site
directly, to get something that is not on the Galileo site (e.g. source)
then they can use web tool update site, but then also leave the galileo
site 'enabled' and there's a check box to "Contact all update sties
during install to find required software" ... so then it would get xml
from webtools, and "find" emf on galileo site.

HTH
Previous Topic:Geronimo 2.1 doesn't work with WTP 3.1
Next Topic:JST Server Adapters twice in Galielo Site
Goto Forum:
  


Current Time: Sun Nov 23 19:07:38 GMT 2014

Powered by FUDForum. Page generated in 0.01657 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software