Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » EJB 2.1 support
EJB 2.1 support [message #232718] Thu, 18 June 2009 12:52
sombriks  is currently offline sombriks
Messages: 6
Registered: July 2009
Junior Member
don't know if it's the correct group, please redirect me if it's misplaced.

Actually i'm trying to build a "Portable J2EE application", i.e. able to
run flawlessly on Glassfish, Geronimo, Websphere, JBoss, etc. and in order
to do that i need at least to build the AS independent part (ejb's without
stubs and xml's) using just default tools.

right now the support for that is like broken using a regular 3.4 J2EE
edition installation; it creates the ear project, when it creates the ejb
project it also creates the ejbclient projetc and ear libraries get
updated;

but if i use ejb 2.1 it fails to find the ejb project on some wizards.

I would like to know if someone already find that kind of problem and also
what do i need to build and maybe do some modifications on that behavior.
I think that at least ejb-jar.xml could be correctly populated, so only
the server dependent configs would be pending; i want to be less dependent
on 3rd party and non-mainstream plugins, and i know that even createeing
those articafts the problem still since i'll need integration with the
server runtime, but create correctly those artifacts even for older
versions of J2EE would help many of us which have to maintain old J2EE
apps.
Previous Topic:Simple Question - Adding popup menu to SSE
Next Topic:galileo - javascript outline does not display object members
Goto Forum:
  


Current Time: Sat Nov 01 10:36:52 GMT 2014

Powered by FUDForum. Page generated in 0.01713 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software