Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Lua Development Tools » Build failure(I don't understand how to build)
Build failure [message #1342179] Thu, 08 May 2014 20:53 Go to next message
Fabio Tiozzo is currently offline Fabio Tiozzo
Messages: 18
Registered: December 2013
Junior Member
I followed forum instructions to build (this lonk : https://wiki.eclipse.org/Koneki/LDT/Developer_Area/Building_LDT_from_source)
but don't work anything.
I downloaded the git - run mvn (version 3.2.1) but I received an error after few seconds:

E:\org.eclipse.koneki.ldt>set JAVA_HOME=C:\Program Files\Java\jre7

E:\org.eclipse.koneki.ldt>E:\eclipse\apache-maven-3.2.1\bin\mvn clean package -P build-product
[INFO] Scanning for projects...
---------------------------------------------------
constituent[0]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/aether-api-0.9.0.M2.jar
constituent[1]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/aether-connector-wagon-0.9.0.M2.jar
constituent[2]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/aether-impl-0.9.0.M2.jar
constituent[3]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/aether-spi-0.9.0.M2.jar
constituent[4]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/aether-util-0.9.0.M2.jar
constituent[5]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/aopalliance-1.0.jar
constituent[6]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/cdi-api-1.0.jar
constituent[7]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/commons-cli-1.2.jar
constituent[8]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/commons-io-2.2.jar
constituent[9]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/commons-lang-2.6.jar
constituent[10]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/guava-14.0.1.jar
constituent[11]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/javax.inject-1.jar
constituent[12]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/jsoup-1.7.2.jar
constituent[13]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/jsr250-api-1.0.jar
constituent[14]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/maven-aether-provider-3.2.1.jar
constituent[15]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/maven-artifact-3.2.1.jar
constituent[16]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/maven-compat-3.2.1.jar
constituent[17]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/maven-core-3.2.1.jar
constituent[18]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/maven-embedder-3.2.1.jar
constituent[19]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/maven-model-3.2.1.jar
constituent[20]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/maven-model-builder-3.2.1.jar
constituent[21]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/maven-plugin-api-3.2.1.jar
constituent[22]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/maven-repository-metadata-3.2.1.jar
constituent[23]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/maven-settings-3.2.1.jar
constituent[24]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/maven-settings-builder-3.2.1.jar
constituent[25]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/org.eclipse.sisu.inject-0.0.0.M5.jar
constituent[26]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/org.eclipse.sisu.plexus-0.0.0.M5.jar
constituent[27]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/plexus-cipher-1.7.jar
constituent[28]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/plexus-component-annotations-1.5.5.jar
constituent[29]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/plexus-interpolation-1.19.jar
constituent[30]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/plexus-sec-dispatcher-1.3.jar
constituent[31]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/plexus-utils-3.0.17.jar
constituent[32]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/sisu-guice-3.1.3-no_aop.jar
constituent[33]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/slf4j-api-1.7.5.jar
constituent[34]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/slf4j-simple-1.7.5.jar
constituent[35]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/wagon-file-2.6.jar
constituent[36]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/wagon-http-2.6-shaded.jar
constituent[37]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/wagon-http-shared-2.6.jar
constituent[38]: file:/E:/eclipse/apache-maven-3.2.1/bin/../lib/wagon-provider-api-2.6.jar
constituent[39]: file:/E:/eclipse/apache-maven-3.2.1/bin/../conf/logging/
---------------------------------------------------
After this lines I received
'Exception in thread "main" java.lang.NoSuchMethodError: org.apache.maven.execution.MavenSession.getRepositorySession()Lorg/sonatype/aether/RepositorySystemSession;.....

Why? I not have modified anything.... Sad
I followed this guide...

Please help me with an example or pdf guide...

Thanks
Fabio
Re: Build failure [message #1343174 is a reply to message #1342179] Fri, 09 May 2014 07:02 Go to previous messageGo to next message
Marc Aubry is currently offline Marc Aubry
Messages: 83
Registered: August 2012
Member
Hi Fabio,

I am not on Windows anymore, but do you have modified your PATH environment variable as explained here : http://maven.apache.org/download.cgi#Windows ?

If you have done so, if your folder E:\org.eclipse.koneki.ldt contains LDT source code, you may be able to run the simple command "E:\org.eclipse.koneki.ldt>mvn clean package -P build-product" without specifying the path to maven binary.

I hope this begging to help, I will looking forward to check if our build is compatible with maven v3.2 (I still use 3.0 currently).

Marc
Re: Build failure [message #1344167 is a reply to message #1343174] Fri, 09 May 2014 16:49 Go to previous messageGo to next message
Kevin KIN-FOO is currently offline Kevin KIN-FOO
Messages: 50
Registered: January 2010
Member
Hi Fabio,

I am using maven 3.2 as well.
We are unable to build so far due to tycho version.
Currently we are using 0.15 on master, but 0.20 works better with maven 3.2.
Why isn't it upgraded yet?

  • Eclipse's continuous integration uses maven 3.1
  • We want to stabilize everything before delivery

You can:

  • Downgrade to maven 3.1
  • Edit root pom.xml and set tycho-version to 0.20

We will set it all straight when Luna will be out.

Kevin
Re: Build failure [message #1350681 is a reply to message #1344167] Mon, 12 May 2014 19:35 Go to previous messageGo to next message
Fabio Tiozzo is currently offline Fabio Tiozzo
Messages: 18
Registered: December 2013
Junior Member
Hi, thanks for suggestions, but nothing happens.
I have continuosly error during compile....
A simple question: why the project needs more files from http repositories?
How to create the master project offline mode?
I create a project using import menu..but for me is wrong...
Please help me. I love Koneki but I need to change something.
Regards
Re: Build failure [message #1356841 is a reply to message #1350681] Thu, 15 May 2014 08:42 Go to previous messageGo to next message
Marc Aubry is currently offline Marc Aubry
Messages: 83
Registered: August 2012
Member
Sorry, for late responses it seems there is a problem with forum email notification.

You still have the same error ? if yes, us can you provide us your root pom.xml ?

From the LDT git repository, you will have all the LDT sources, but you need to compile them against the Eclipse platform which are store on eclipse server. It's the same for Maven plugins we use to build which are downloaded from maven repositories.
In the case of maven have already download all the stuff once in the local repository, you can try to run maven with the -o option for offline mode, but if something is missing the build will fail.

Just for information, what did you want to change in Koneki ? functional feedback is always appreciated.

Marc
Re: Build failure [message #1356968 is a reply to message #1356841] Thu, 15 May 2014 09:51 Go to previous messageGo to next message
Fabio Tiozzo is currently offline Fabio Tiozzo
Messages: 18
Registered: December 2013
Junior Member
Hi Marc
I don't understand (I'm newbie in Eclipse plugin) but when I load the sources from git and I start mvn I receive the errors.

I need change some keywords (because I have a custom lua compiler) otherwise DTLK stop the parsing and in Outline I not have the function list / class browser.
Is possible to disable this ?

Thanks a lot for your patience

Fabio
Re: Build failure [message #1359813 is a reply to message #1356968] Fri, 16 May 2014 14:15 Go to previous messageGo to next message
Marc Aubry is currently offline Marc Aubry
Messages: 83
Registered: August 2012
Member
Sorry, i am a bit lost in your explanations

Can you re-copy paste here the error you get ?
And also the version on tycho and maven ou use to get that error?

I have fixed a build issue yesterday, don't forget to update your git repository.

About the keyword you want to change, it's a bit complex because you should also modify lua grammar define in the sub project metalua.

Marc

Re: Build failure [message #1401905 is a reply to message #1342179] Wed, 16 July 2014 08:27 Go to previous messageGo to next message
Fabio Tiozzo is currently offline Fabio Tiozzo
Messages: 18
Registered: December 2013
Junior Member
Hi
is possible to have a zip folder with the sources 'ready to compile'?
For me is impossible to create the development tool.
Do you have a complete guide (pdf or html with pictures and explanations)?
Please help me Crying or Very Sad

Thanks a lot

Fabio
Re: Build failure [message #1403087 is a reply to message #1401905] Mon, 21 July 2014 09:52 Go to previous messageGo to next message
Simon Bernard is currently offline Simon Bernard
Messages: 287
Registered: July 2009
Senior Member
I think Kevin pointed the problem.
Did you try his suggestions ?
Downgrade to maven 3.1
OR
Edit root pom.xml and set tycho-version to 0.20
Re: Build failure [message #1403700 is a reply to message #1403087] Fri, 25 July 2014 12:47 Go to previous message
Fabio Tiozzo is currently offline Fabio Tiozzo
Messages: 18
Registered: December 2013
Junior Member
Ok. change tyco to 0.20 and now works.
Thanks

But my original question was how to insert new keywords in Koneki.
I have a cnc controller that accept a lua special version language that have some keywords c-style like define, ifdef, switch case and some other.
How insert them in Koneki?
Which files need to changed?
No need to compile or debug with koneki..only for editing (advanced editing.. Wink
Thanks again
Previous Topic:Some scripts got 'This file probably contains a syntax error' after upgrading from 1.1 to 1.2
Next Topic:Unable to Launch
Goto Forum:
  


Current Time: Fri Oct 31 07:05:13 GMT 2014

Powered by FUDForum. Page generated in 0.03101 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software