Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » XML Design page change lost when prompted for checkou
XML Design page change lost when prompted for checkou [message #231108] Wed, 06 May 2009 18:54 Go to next message
John Palof is currently offline John PalofFriend
Messages: 16
Registered: July 2009
Junior Member
If I attempt to alter an SCM controlled xml file through the Design tab of
the XML Editor, I briefly see my change appear in the editor and the file
marked as dirty. The SCM system kicks in and prompts me to check out.
Upon confirming the checkout dialog, the change is reverted and the file
is no longer marked as dirty. Note: Making a change through the
Properties view suffers from the same problem.

If I retry the scenario above but attempt the change in the Source tab of
the XML Editor, it works as expected: I don't see my change appear in the
editor; the SCM system kicks in and prompts me to check out; upon
confirming the checkout dialog the change is made to the file and it is
marked as dirty.

I could not find a bug on this issue but it appears to be in at least 3.3
and 3.4. Is this expected behavor or a known issue?

PS: I am using P4WSAD (Perforce)

Thank you,
John
Re: XML Design page change lost when prompted for checkou [message #231116 is a reply to message #231108] Wed, 06 May 2009 21:47 Go to previous messageGo to next message
Nick Sandonato is currently offline Nick SandonatoFriend
Messages: 126
Registered: July 2009
Senior Member
Hi John,

Your scenario is mentioned in
https://bugs.eclipse.org/bugs/show_bug.cgi?id=231026#c1 under the 2nd of
the two outstanding issues.

I do not think your issue is being actively tracked, however. It might
be worth opening a bug.

-Nick


John Palof wrote:
> If I attempt to alter an SCM controlled xml file through the Design tab
> of the XML Editor, I briefly see my change appear in the editor and the
> file marked as dirty. The SCM system kicks in and prompts me to check
> out. Upon confirming the checkout dialog, the change is reverted and
> the file is no longer marked as dirty. Note: Making a change through
> the Properties view suffers from the same problem.
>
> If I retry the scenario above but attempt the change in the Source tab
> of the XML Editor, it works as expected: I don't see my change appear
> in the editor; the SCM system kicks in and prompts me to check out; upon
> confirming the checkout dialog the change is made to the file and it is
> marked as dirty.
>
> I could not find a bug on this issue but it appears to be in at least
> 3.3 and 3.4. Is this expected behavor or a known issue?
>
> PS: I am using P4WSAD (Perforce)
>
> Thank you,
> John
>
Re: XML Design page change lost when prompted for checkou [message #231124 is a reply to message #231116] Thu, 07 May 2009 14:25 Go to previous message
John Palof is currently offline John PalofFriend
Messages: 16
Registered: July 2009
Junior Member
Thank you for finding the defect. As you suggested I opened a new defect
to track this: https://bugs.eclipse.org/bugs/show_bug.cgi?id=275305
Previous Topic:Generic External Server says shutdown failed before stop script has returned
Next Topic:Problem from Web browser
Goto Forum:
  


Current Time: Mon Dec 22 08:34:29 GMT 2014

Powered by FUDForum. Page generated in 0.02233 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software