Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » GEF » Connection Performance
Connection Performance [message #230746] Fri, 16 February 2007 00:46 Go to next message
Adam Cabler is currently offline Adam Cabler
Messages: 113
Registered: July 2009
Senior Member
I have a grid with about 4000 connections. After creating all of these
connections scrolling gets really choppy when using the Thumbnail
viewer. Scrolling with the mouse or scroll bars works fine. Now, I
would expect this because all of the connections get redrawn when using
the thumbnail view. However, this still happens when I hide the
Connection Layer (and therefore the connections), so I don't know why it
should still be so slow.

I would really appreciate help with this.

thanks,
adam
Re: Connection Performance [message #231150 is a reply to message #230746] Tue, 27 February 2007 22:43 Go to previous message
Adam Cabler is currently offline Adam Cabler
Messages: 113
Registered: July 2009
Senior Member
https://bugs.eclipse.org/bugs/show_bug.cgi?id=175758


AdamC wrote:
> I have a grid with about 4000 connections. After creating all of these
> connections scrolling gets really choppy when using the Thumbnail
> viewer. Scrolling with the mouse or scroll bars works fine. Now, I
> would expect this because all of the connections get redrawn when using
> the thumbnail view. However, this still happens when I hide the
> Connection Layer (and therefore the connections), so I don't know why it
> should still be so slow.
>
> I would really appreciate help with this.
>
> thanks,
> adam
Previous Topic:3.3 Planned Changes?
Next Topic:Refresh problem in broswer when I use swt applet (embedded GEF GraphicalViewer)
Goto Forum:
  


Current Time: Tue Oct 21 18:38:07 GMT 2014

Powered by FUDForum. Page generated in 0.03888 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software