Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » UTF-8 Char are not displaying in TableViewer SWT(UTF-8 Char are not displaying in TableViewer SWT)
UTF-8 Char are not displaying in TableViewer SWT [message #1338911] Wed, 07 May 2014 08:31 Go to next message
sumit singh is currently offline sumit singh
Messages: 129
Registered: October 2012
Location: Bangalore
Senior Member

I created TableViewer in that I'm setting table item text as following.

item.setText(0, String.valueOf((char) 255));


After running the program there is nothing displaying for above.

If I create Text or StyledText and set that value then I'm getting `ΓΏ`

StyledText styledText = new StyledText(shell, SWT.BORDER);
styledText.setText("Hello " + String.valueOf((char) 255));



I tried to set `StyledCellLabelProvider` but still no value is showing for
String.valueOf((char) 255) 


I tried to run the application with -Dfile.encoding=utf-8 option but no help.

What I'm missing here?, why table not displaying UTF-8 char

[Updated on: Wed, 07 May 2014 08:34]

Report message to a moderator

Re: UTF-8 Char are not displaying in TableViewer SWT [message #1384667 is a reply to message #1338911] Fri, 30 May 2014 03:28 Go to previous message
Niraj Modi is currently offline Niraj Modi
Messages: 12
Registered: November 2013
Junior Member
Hi Sumit,
This works for me on Win7. Can you share a running code sample to reproduce this issue at our end ?
Previous Topic:Progressbar is frozen with syncExec
Next Topic:Border of table
Goto Forum:
  


Current Time: Fri Aug 01 00:02:42 EDT 2014

Powered by FUDForum. Page generated in 0.03483 seconds