Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Installation Problem Eclipse e4 Tools Bridge for 3.x(Installation of Eclipse e4 Tools Bridge for 3.x for Eclipse 4.3.2 failes)
Installation Problem Eclipse e4 Tools Bridge for 3.x [message #1338414] Wed, 07 May 2014 07:47 Go to next message
Stefan Weiser is currently offline Stefan Weiser
Messages: 38
Registered: February 2012
Member
Hello,

I try to install the e4 tools bridge for 3.x into the new Eclipse 4.3.2, but I always fail with the following problem:
Cannot complete the install because of a conflicting dependency.
  Software being installed: Eclipse e4 Tools Bridge for 3.x (Incubation) 0.14.0.v20130620-0935 (org.eclipse.e4.tools.e3x.bridge.feature.feature.group 0.14.0.v20130620-0935)
  Software currently installed: Eclipse for RCP and RAP Developers 2.0.2.20140224-0000 (epp.package.rcp 2.0.2.20140224-0000)
  Only one of the following can be installed at once: 
    Eclipse UI Application Services 1.0.1.v20130909-1436 (org.eclipse.e4.ui.services 1.0.1.v20130909-1436)
    Eclipse UI Application Services 1.0.0.v20130515-1857 (org.eclipse.e4.ui.services 1.0.0.v20130515-1857)
    Eclipse UI Application Services 1.1.0.v20140328-1925 (org.eclipse.e4.ui.services 1.1.0.v20140328-1925)
    Eclipse UI Application Services 1.0.1.v20131118-1940 (org.eclipse.e4.ui.services 1.0.1.v20131118-1940)
  Cannot satisfy dependency:
    From: Eclipse for RCP and RAP Developers 2.0.2.20140224-0000 (epp.package.rcp 2.0.2.20140224-0000)
    To: org.eclipse.epp.package.rcp.feature.feature.group [2.0.2.20140224-0000]
  Cannot satisfy dependency:
    From: Eclipse e4 Rich Client Platform 1.2.2.v20140206-1358 (org.eclipse.e4.rcp.feature.group 1.2.2.v20140206-1358)
    To: org.eclipse.e4.ui.services [1.0.1.v20131118-1940]
  Cannot satisfy dependency:
    From: Eclipse e4 Tools Bridge for 3.x (Incubation) 0.14.0.v20130620-0935 (org.eclipse.e4.tools.e3x.bridge.feature.feature.group 0.14.0.v20130620-0935)
    To: org.eclipse.e4.ui.services [1.0.0.v20130515-1857]
  Cannot satisfy dependency:
    From: EPP RCP/RAP Feature 2.0.2.20140224-0000 (org.eclipse.epp.package.rcp.feature.feature.group 2.0.2.20140224-0000)
    To: org.eclipse.platform.feature.group [4.3.2.v20140221-1852]
  Cannot satisfy dependency:
    From: Eclipse Platform 4.3.2.v20140221-1852 (org.eclipse.platform.feature.group 4.3.2.v20140221-1852)
    To: org.eclipse.rcp.feature.group [4.3.2.v20140221-1700]
  Cannot satisfy dependency:
    From: Eclipse RCP 4.3.2.v20140221-1700 (org.eclipse.rcp.feature.group 4.3.2.v20140221-1700)
    To: org.eclipse.e4.rcp.feature.group [1.2.2.v20140206-1358]


It seems that there is a conflict with the version of org.eclipse.e4.ui.services, but I don't know how to solve this problem. I tried different versions of the e4-tools, but always had the same problem (e.g. http://download.eclipse.org/e4/downloads/drops/R-0.14-201306242200/repository/). I also tried to directly copy the plugin parallel to the existing version, but it doesn't change anything.

Do I use the wrong update-site or is there another problem I did not identify? I hope someone can help me.

Edit: I now checked the update-site http://download.eclipse.org/e4/updates/0.15/ with the same result. I also still have the problem with the current available version of Eclipse provided as download.

[Updated on: Wed, 07 May 2014 08:55]

Report message to a moderator

Re: Installation Problem Eclipse e4 Tools Bridge for 3.x [message #1343517 is a reply to message #1338414] Fri, 09 May 2014 10:22 Go to previous message
Stefan Weiser is currently offline Stefan Weiser
Messages: 38
Registered: February 2012
Member
As nobody seem to have an answer for my problem, I switched back to an old Eclipse 4.3.1. There the compatibility bridget works fine. When I migrated all staff to the new e4-model, I will switch to the newest version.

I hope this problem is solved after a while, because I don't like to switch the Eclipse depending on the task I'm working on.
Smile
Previous Topic:Injecting selected project into view
Next Topic:dynamic PopupMenu on Part
Goto Forum:
  


Current Time: Tue Sep 16 19:50:07 GMT 2014

Powered by FUDForum. Page generated in 0.02385 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software