Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Facet version not detected correctly
Facet version not detected correctly [message #229874] Tue, 31 March 2009 00:16
Debajit Adhikary is currently offline Debajit Adhikary
Messages: 8
Registered: July 2009
Junior Member
It appears for some reason that the facet version is not detected
correctly for library providers.

I have the following extension points in open source Galileo (All they do
is enable different sets of JSF libs to appear (for JSF 1.1 and 1.2)):


<!-- JSF 1.2 downloadable library provider -->
<extension
point=" org.eclipse.jst.common.project.facet.core.downloadableLibrar ies ">
<import-definitions path="jsf-1.2-downloadable-libraries.xml">
<enablement>
<with variable="requestingProjectFacet">
<test
property="org.eclipse.wst.common.project.facet.core.projectFacet "
value="jst.jsf:1.2" forcePluginActivation="true"/>
</with>
</enablement>
</import-definitions>
</extension>


<!-- JSF 1.1 downloadable library provider -->
<extension
point=" org.eclipse.jst.common.project.facet.core.downloadableLibrar ies ">
<import-definitions path="jsf-1.1-downloadable-libraries.xml">
<enablement>
<with variable="requestingProjectFacet">
<test
property="org.eclipse.wst.common.project.facet.core.projectFacet "
value="jst.jsf:1.1" forcePluginActivation="true"/>
</with>
</enablement>
</import-definitions>
</extension>


Now, on running this, only the JSF 1.1 libs show up (in the Downloadable
libs window) regardless of whether JSF 1.1 or JSF 1.2 is selected.

Any pointers on what might be going wrong here?
Previous Topic:WSDL XSD and XML Catalog
Next Topic:Upgrade to 3.4.1 - Run on server no longer launches initial page
Goto Forum:
  


Current Time: Wed Sep 24 02:26:44 GMT 2014

Powered by FUDForum. Page generated in 0.02565 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software