Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Babel » Illegal token characters in babel fragment names
Illegal token characters in babel fragment names [message #22413] Thu, 23 October 2008 16:45 Go to next message
Eclipse UserFriend
Originally posted by: sf.tragwerk-software.de

Hi !

First let me thank you all for the great work on tranlation / tools
already been done.

I recently updated to the new language packs (German).
I noticed a change in the names of the fragments.

The old pattern was *.nl_de
which is now *.nl-de
So the underscore changed to minus.

Unfortunattely the minus is an illegal value for fragment tokens.
When I manually add NL-fragments to a Feature of my RCP-application, I
recieve warnings like this from PDE:

Illegal value 'org.eclipse.ant.core.nl-de' for attribute 'id'. Legal
token characters are "a-z", "A-Z", "0-9", "_". Tokens must be
separated by "." feature.xml

Furthermore I have to change my runtime configuration which is annoying.


Is it a bug or a feature ?
Would it be possible to switch back to the traditional naming convention ?

Sebastian
Re: Illegal token characters in babel fragment names [message #22500 is a reply to message #22413] Fri, 24 October 2008 22:52 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: atoulme.intalio.com

Hi Sebastian,

sounds like a bug to me. Can you open a bugzilla entry, and give the
link here ?

Thanks,

Antoine

Sebastian Fuchs wrote:
> Hi !
>
> First let me thank you all for the great work on tranlation / tools
> already been done.
>
> I recently updated to the new language packs (German).
> I noticed a change in the names of the fragments.
>
> The old pattern was *.nl_de
> which is now *.nl-de
> So the underscore changed to minus.
>
> Unfortunattely the minus is an illegal value for fragment tokens.
> When I manually add NL-fragments to a Feature of my RCP-application, I
> recieve warnings like this from PDE:
>
> Illegal value 'org.eclipse.ant.core.nl-de' for attribute 'id'. Legal
> token characters are "a-z", "A-Z", "0-9", "_". Tokens must be separated
> by "." feature.xml
>
> Furthermore I have to change my runtime configuration which is annoying.
>
>
> Is it a bug or a feature ?
> Would it be possible to switch back to the traditional naming convention ?
>
> Sebastian
Re: Illegal token characters in babel fragment names [message #22544 is a reply to message #22500] Mon, 27 October 2008 08:49 Go to previous message
Eclipse UserFriend
Originally posted by: sf.tragwerk-software.de

opened bug #252140

https://bugs.eclipse.org/bugs/show_bug.cgi?id=252140
Re: Illegal token characters in babel fragment names [message #575413 is a reply to message #22413] Fri, 24 October 2008 22:52 Go to previous message
Eclipse UserFriend
Originally posted by: atoulme.intalio.com

Hi Sebastian,

sounds like a bug to me. Can you open a bugzilla entry, and give the
link here ?

Thanks,

Antoine

Sebastian Fuchs wrote:
> Hi !
>
> First let me thank you all for the great work on tranlation / tools
> already been done.
>
> I recently updated to the new language packs (German).
> I noticed a change in the names of the fragments.
>
> The old pattern was *.nl_de
> which is now *.nl-de
> So the underscore changed to minus.
>
> Unfortunattely the minus is an illegal value for fragment tokens.
> When I manually add NL-fragments to a Feature of my RCP-application, I
> recieve warnings like this from PDE:
>
> Illegal value 'org.eclipse.ant.core.nl-de' for attribute 'id'. Legal
> token characters are "a-z", "A-Z", "0-9", "_". Tokens must be separated
> by "." feature.xml
>
> Furthermore I have to change my runtime configuration which is annoying.
>
>
> Is it a bug or a feature ?
> Would it be possible to switch back to the traditional naming convention ?
>
> Sebastian
Re: Illegal token characters in babel fragment names [message #575431 is a reply to message #22500] Mon, 27 October 2008 08:49 Go to previous message
Sebastian Fuchs is currently offline Sebastian FuchsFriend
Messages: 94
Registered: July 2009
Member
opened bug #252140

https://bugs.eclipse.org/bugs/show_bug.cgi?id=252140
Previous Topic:Illegal token characters in babel fragment names
Next Topic:Re: how to internationalize a product-file
Goto Forum:
  


Current Time: Fri Dec 19 15:56:47 GMT 2014

Powered by FUDForum. Page generated in 0.02277 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software