Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Can't start jboss from Eclipse Ganymede
Can't start jboss from Eclipse Ganymede [message #228881] Fri, 13 March 2009 06:02 Go to next message
Heiner is currently offline Heiner
Messages: 2
Registered: July 2009
Junior Member
Dear all,

I'm using Eclipse3.4.2, JBoss 5.0.1 GA, JBoss Tools and try to start the
app server from eclipse. The log is fine at the beginning (extract):

10:28:28,593 INFO [JMXKernel] Legacy JMX core initialized
10:28:32,140 INFO [ProfileServiceImpl] Loading profile: default from:
org.jboss.system.server.profileservice.repository.Serializab leDeploymentRepository @161cd25(root=C:\Java\Tools\jboss-5.0.1.GA\server,
key=org.jboss.profileservice.spi.ProfileKey@143b82c3[domain=default,server=default,name=default])
10:28:32,140 INFO [ProfileImpl] Using
repository: org.jboss.system.server.profileservice.repository.Serializab leDeploymentRepository @161cd25(root=C:\Java\Tools\jboss-5.0.1.GA\server,
key=org.jboss.profileservice.spi.ProfileKey@143b82c3[domain=default,server=default,name=default])
10:28:32,140 INFO [ProfileServiceImpl] Loaded profile:
ProfileImpl@165547d{key=org.jboss.profileservice.spi.ProfileKey@143b82c3[domain=default,server=default,name=default]}
10:28:48,203 INFO [WebService] Using RMI server codebase:
http://localhost:8083/

Then classloader errors occur:

DEPLOYMENTS IN ERROR:
Deployment "RarModuleJSR77Deployer" is in error due to the following
reason(s): java.lang.NoClassDefFoundError:
org/jboss/resource/metadata/ConnectorMetaData
Deployment
" vfsfile:/C:/Java/Tools/jboss-5.0.1.GA/server/default/deploye rs/jboss-jca.deployer/ "
is in error due to the following reason(s):
java.lang.UnsupportedClassVersionError: Bad version number in .class file
Deployment "JCAResourceJSR77Deployer" is in error due to the following
reason(s): java.lang.NoClassDefFoundError:
org/jboss/resource/metadata/mcf/ManagedConnectionFactoryDepl oymentGroup

Starting jboss directly also works fine. Has anyone an idea about the
problem ? Any help is appreciated. Thanks.
Re: Can't start jboss from Eclipse Ganymede [message #228891 is a reply to message #228881] Fri, 13 March 2009 09:59 Go to previous messageGo to next message
Eclipse User
Originally posted by: wknauf_NO_._INSIDE_hg-online.de

Hi,

what is the Java version for your JBoss? It seems that you picked JBoss 5.0.1GA
for JDK 1.6 (there are two different downloads available at jboss!), but you try
to run it on 1.5?
At least this message points to it: "java.lang.UnsupportedClassVersionError: Bad
version number in .class file".

If your JBoss has the correct version, there is maybe some JAR included in
"jboss-jca.deployer", which is compiled against java 1.6?

Best regards

Wolfgang

Ralph schrieb:
> Dear all,
>
> Then classloader errors occur:
> DEPLOYMENTS IN ERROR:
> Deployment "RarModuleJSR77Deployer" is in error due to the following
> reason(s): java.lang.NoClassDefFoundError:
> org/jboss/resource/metadata/ConnectorMetaData
> Deployment
> " vfsfile:/C:/Java/Tools/jboss-5.0.1.GA/server/default/deploye rs/jboss-jca.deployer/ "
> is in error due to the following reason(s):
> java.lang.UnsupportedClassVersionError: Bad version number in .class file
> Deployment "JCAResourceJSR77Deployer" is in error due to the following
> reason(s): java.lang.NoClassDefFoundError:
> org/jboss/resource/metadata/mcf/ManagedConnectionFactoryDepl oymentGroup
>
> Starting jboss directly also works fine. Has anyone an idea about the
> problem ? Any help is appreciated. Thanks.
>
>
Re: Can't start jboss from Eclipse Ganymede [message #228908 is a reply to message #228891] Fri, 13 March 2009 11:26 Go to previous message
Heiner is currently offline Heiner
Messages: 2
Registered: July 2009
Junior Member
Hi Wolfgang,

you're right: I used jre 1.5 instead of jre 1.6. Now jboss starts without
problems.

Thanks so much !
Previous Topic:which method is called when select "START" from server's context menu?
Next Topic:Latest Stable Build Required (M5 preferred)
Goto Forum:
  


Current Time: Sat Apr 19 09:03:12 EDT 2014

Powered by FUDForum. Page generated in 0.01657 seconds