Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Epsilon » Problem Running Transformations
Problem Running Transformations [message #22347] Mon, 13 July 2009 15:23 Go to next message
Marcellus Castro is currently offline Marcellus Castro
Messages: 10
Registered: July 2009
Junior Member
Hi,

IŽm trying to run the examples but, always I get the same problem.

Any help will be appreciates.

Thanks,


java.lang.NullPointerException
at
org.antlr.runtime.CommonTokenStream.fillBuffer(CommonTokenSt ream.java:95)
at org.antlr.runtime.CommonTokenStream.LT(CommonTokenStream.jav a:238)
at
org.eclipse.epsilon.eol.AbstractModule.invokeMainRule(Abstra ctModule.java:182)
at org.eclipse.epsilon.eol.AbstractModule.parse(AbstractModule. java:142)
at
org.eclipse.epsilon.evl.dt.launching.EvlLaunchConfigurationD elegate.launch(EvlLaunchConfigurationDelegate.java:49)
at
org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:853)
at
org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:703)
at
org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(D ebugUIPlugin.java:866)
at
org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlu gin.java:1069)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
Re: Problem Running Transformations [message #22431 is a reply to message #22347] Mon, 13 July 2009 15:46 Go to previous messageGo to next message
Dimitrios Kolovos is currently offline Dimitrios Kolovos
Messages: 1776
Registered: July 2009
Senior Member
Hi Marcellus,

This happens when the program specified in the source tab of the launch
configuration does not exist. My guess is that you have imported/checked
out the examples but with different project names. You can either
re-import them using their default names, or update the launch
configurations accordingly.

In any case, it should fail more gracefully than throwing an exception,
so I'll open a new bug report to keep track of this.

Cheers,
Dimitris

Marcellus Castro wrote:
> Hi,
>
> IŽm trying to run the examples but, always I get the same problem.
>
> Any help will be appreciates.
>
> Thanks,
>
>
> java.lang.NullPointerException
> at
> org.antlr.runtime.CommonTokenStream.fillBuffer(CommonTokenSt ream.java:95)
> at org.antlr.runtime.CommonTokenStream.LT(CommonTokenStream.jav a:238)
> at
> org.eclipse.epsilon.eol.AbstractModule.invokeMainRule(Abstra ctModule.java:182)
>
> at
> org.eclipse.epsilon.eol.AbstractModule.parse(AbstractModule. java:142)
> at
> org.eclipse.epsilon.evl.dt.launching.EvlLaunchConfigurationD elegate.launch(EvlLaunchConfigurationDelegate.java:49)
>
> at
> org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:853)
>
> at
> org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:703)
>
> at
> org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(D ebugUIPlugin.java:866)
>
> at
> org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlu gin.java:1069)
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
>
Re: Problem Running Transformations [message #22475 is a reply to message #22431] Mon, 13 July 2009 16:25 Go to previous messageGo to next message
Marcellus Castro is currently offline Marcellus Castro
Messages: 10
Registered: July 2009
Junior Member
Hi Dimitris, Thx for the answer!

I believe that the is not that. The configuration is correct but the
problem still is occurring.
Re: Problem Running Transformations [message #22519 is a reply to message #22475] Mon, 13 July 2009 16:29 Go to previous messageGo to next message
Dimitrios Kolovos is currently offline Dimitrios Kolovos
Messages: 1776
Registered: July 2009
Senior Member
Hi Marcellus,

Which example is that? Have you checked it out from the SVN or
downloaded a .zip file?

Cheers,
Dimitris

Marcellus Castro wrote:
> Hi Dimitris, Thx for the answer!
>
> I believe that the is not that. The configuration is correct but the
> problem still is occurring.
>
>
Re: Problem Running Transformations [message #22563 is a reply to message #22519] Mon, 13 July 2009 16:46 Go to previous messageGo to next message
Marcellus Castro is currently offline Marcellus Castro
Messages: 10
Registered: July 2009
Junior Member
It's the validateoo example. I can run the validation only if I create a
ant task for it.

Cheers
Re: Problem Running Transformations [message #22607 is a reply to message #22563] Mon, 13 July 2009 17:10 Go to previous message
Dimitrios Kolovos is currently offline Dimitrios Kolovos
Messages: 1776
Registered: July 2009
Senior Member
Hi Marcellus,

I can't seem to be able to reproduce this... I checked out the example
and the org.eclipse.epsilon.examples.metamodels project, registered
OO.ecore, right-clicked ValaidateOO.launch and clicked Run As ->
ValidateOO and it ran as expected. I'm starting to run low on ideas on
what may be wrong...

Cheers,
Dimitris

Marcellus Castro wrote:
> It's the validateoo example. I can run the validation only if I create a
> ant task for it.
>
> Cheers
>
Re: Problem Running Transformations [message #570584 is a reply to message #22347] Mon, 13 July 2009 15:46 Go to previous message
Dimitrios Kolovos is currently offline Dimitrios Kolovos
Messages: 1776
Registered: July 2009
Senior Member
Hi Marcellus,

This happens when the program specified in the source tab of the launch
configuration does not exist. My guess is that you have imported/checked
out the examples but with different project names. You can either
re-import them using their default names, or update the launch
configurations accordingly.

In any case, it should fail more gracefully than throwing an exception,
so I'll open a new bug report to keep track of this.

Cheers,
Dimitris

Marcellus Castro wrote:
> Hi,
>
> IŽm trying to run the examples but, always I get the same problem.
>
> Any help will be appreciates.
>
> Thanks,
>
>
> java.lang.NullPointerException
> at
> org.antlr.runtime.CommonTokenStream.fillBuffer(CommonTokenSt ream.java:95)
> at org.antlr.runtime.CommonTokenStream.LT(CommonTokenStream.jav a:238)
> at
> org.eclipse.epsilon.eol.AbstractModule.invokeMainRule(Abstra ctModule.java:182)
>
> at
> org.eclipse.epsilon.eol.AbstractModule.parse(AbstractModule. java:142)
> at
> org.eclipse.epsilon.evl.dt.launching.EvlLaunchConfigurationD elegate.launch(EvlLaunchConfigurationDelegate.java:49)
>
> at
> org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:853)
>
> at
> org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:703)
>
> at
> org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(D ebugUIPlugin.java:866)
>
> at
> org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlu gin.java:1069)
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
>
Re: Problem Running Transformations [message #570609 is a reply to message #22431] Mon, 13 July 2009 16:25 Go to previous message
Marcellus Castro is currently offline Marcellus Castro
Messages: 10
Registered: July 2009
Junior Member
Hi Dimitris, Thx for the answer!

I believe that the is not that. The configuration is correct but the
problem still is occurring.
Re: Problem Running Transformations [message #570631 is a reply to message #22475] Mon, 13 July 2009 16:29 Go to previous message
Dimitrios Kolovos is currently offline Dimitrios Kolovos
Messages: 1776
Registered: July 2009
Senior Member
Hi Marcellus,

Which example is that? Have you checked it out from the SVN or
downloaded a .zip file?

Cheers,
Dimitris

Marcellus Castro wrote:
> Hi Dimitris, Thx for the answer!
>
> I believe that the is not that. The configuration is correct but the
> problem still is occurring.
>
>
Re: Problem Running Transformations [message #570647 is a reply to message #22519] Mon, 13 July 2009 16:46 Go to previous message
Marcellus Castro is currently offline Marcellus Castro
Messages: 10
Registered: July 2009
Junior Member
It's the validateoo example. I can run the validation only if I create a
ant task for it.

Cheers
Re: Problem Running Transformations [message #570671 is a reply to message #22563] Mon, 13 July 2009 17:10 Go to previous message
Dimitrios Kolovos is currently offline Dimitrios Kolovos
Messages: 1776
Registered: July 2009
Senior Member
Hi Marcellus,

I can't seem to be able to reproduce this... I checked out the example
and the org.eclipse.epsilon.examples.metamodels project, registered
OO.ecore, right-clicked ValaidateOO.launch and clicked Run As ->
ValidateOO and it ran as expected. I'm starting to run low on ideas on
what may be wrong...

Cheers,
Dimitris

Marcellus Castro wrote:
> It's the validateoo example. I can run the validation only if I create a
> ant task for it.
>
> Cheers
>
Previous Topic:Problem Running Transformations
Next Topic:Euginia: Synchronize GMF Gen Model produce an Error
Goto Forum:
  


Current Time: Thu Jul 31 05:32:02 EDT 2014

Powered by FUDForum. Page generated in 0.01717 seconds