Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » XML validation problem
XML validation problem [message #228500] Mon, 02 March 2009 10:39 Go to next message
Michiel van Wezel is currently offline Michiel van Wezel
Messages: 8
Registered: July 2009
Junior Member
Dear all,

Does eclipse use a local cache of XML schema files?

I created an XML DTD and XSD file which i placed somewhere on the
internet. Then i created a local XML file and validated that against the
remote XSD. Worked fine.

Then, i changed the remote XSD and displayed it in my webbrowser to
certify it was correctly changed remotely.

PROBLEM: eclipse does not incorporate the new changes in the XSD and keep
validating XML files against the *old* XSD. So, i suspect the old XSD is
cached somewhere.

How can i tell eclipse to use the latest XSD?

Thanks

Mike
Re: XML validation problem [message #228508 is a reply to message #228500] Mon, 02 March 2009 12:38 Go to previous messageGo to next message
Eclipse User
Originally posted by: valentinbaciu.hotmail.com

You are right, WTP does cache schemas. You can see the cached schemas and
clear the local cache by going to Window->Preferences->General->Network
Connections->Cache.
It seems we could do a better job to refresh the cache when the remote
resource changes.

Hope this helps, Valentin

"Michiel van Wezel" <michielvanwezel@michielvanwezel.com> wrote in message
news:e25d192a199f46b147a0977085f1613a$1@www.eclipse.org...
> Dear all,
>
> Does eclipse use a local cache of XML schema files?
>
> I created an XML DTD and XSD file which i placed somewhere on the
> internet. Then i created a local XML file and validated that against the
> remote XSD. Worked fine.
> Then, i changed the remote XSD and displayed it in my webbrowser to
> certify it was correctly changed remotely.
> PROBLEM: eclipse does not incorporate the new changes in the XSD and keep
> validating XML files against the *old* XSD. So, i suspect the old XSD is
> cached somewhere.
>
> How can i tell eclipse to use the latest XSD?
>
> Thanks
>
> Mike
>
Re: XML validation problem [message #228516 is a reply to message #228508] Mon, 02 March 2009 13:11 Go to previous message
Michiel van Wezel is currently offline Michiel van Wezel
Messages: 8
Registered: July 2009
Junior Member
Thanks Valentin,
Removing the xsd from the cache worked fine!
Mike
Previous Topic:Re: What is this means?
Next Topic:Password protect 3.4.1 infocenter
Goto Forum:
  


Current Time: Sat Oct 25 03:32:40 GMT 2014

Powered by FUDForum. Page generated in 0.02358 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software