Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » GEF » restore diagram problem
restore diagram problem [message #228052] Thu, 14 December 2006 03:49 Go to next message
Eclipse User
Originally posted by: Sferzah.yandex.ru

i save my diagram to RDB.
to open saved diagram i full restore diagrammodel and set it as input to
my editor

workbenchWindow.getActivePage().openEditor(input, MyEditor.EDITOR_ID,
true);

some elements on diagram need to perform refreshVisual() method, how
(where) i can do that?
Re: restore diagram problem [message #228126 is a reply to message #228052] Fri, 15 December 2006 19:40 Go to previous messageGo to next message
Alex Boyko is currently offline Alex Boyko
Messages: 200
Registered: July 2009
Senior Member
Hi Alexey,

When you open up the editor and #setContents() is called root edit part
creates children for itself. Edit part factory creates edit parts for
model elements which are read from the digram resource file. As soon as
edit part is created it's refreshed and edit part's visuals are refreshed
too. So, this should be done automatically - you'll have to debug
AbstarctEditPart#refreshChildren to find out what the problem is.

Cheers,

Alex
Re: restore diagram problem [message #228199 is a reply to message #228126] Mon, 18 December 2006 01:41 Go to previous message
Eclipse User
Originally posted by: Sferzah.yandex.ru

yes you are right, thank you! it was my bug really.
Previous Topic:How to change (Target)Anchor dynamicly?
Next Topic:painting Figure
Goto Forum:
  


Current Time: Tue Jul 22 15:49:31 EDT 2014

Powered by FUDForum. Page generated in 0.02011 seconds